Browse Source

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@12386 ec354946-7b23-47d6-9f5a-488ba84defc7
tomop 2 years ago
parent
commit
df4e8b2ea4

+ 8 - 6
e/epiphany/epiphany-vl.spec

@@ -8,11 +8,13 @@ Summary: GNOME web browser based on WebKit
 Summary(ja): WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
 Name: epiphany
 Version: 3.30.5
-Release: 2%{?_dist_release}
-License: GPL
+Release: 3%{?_dist_release}
 Group: Applications/Internet
-URL: http://www.gnome.org/projects/epiphany/
+Vendor: Project Vine
+Distribution: Vine Linux
 
+License: GPL
+URL: http://www.gnome.org/projects/epiphany/
 %define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
 Source0: https://ftp.gnome.org/pub/GNOME/sources/epiphany/%{shortver}/%{name}-%{version}.tar.xz
 
@@ -49,9 +51,6 @@ BuildRequires: yelp-tools
 
 Obsoletes: %{name}-devel < 3.10.0
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
 %description
 epiphany is a simple GNOME web browser based on the WebKit rendering
 engine
@@ -113,6 +112,9 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-3
+- rebuilt with icu-67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-2
 - rebuilt with icu-66.
 

+ 7 - 6
e/evolution-data-server/evolution-data-server-vl.spec

@@ -30,10 +30,12 @@ Summary: Backend data server for evolution
 Summary(ja): Evolution バックエンドデータサーバ
 Name: evolution-data-server
 Version: 3.30.5
-Release: 2%{?_dist_release}
+Release: 3%{?_dist_release}
 Group: System Environment/Libraries
-License: LGPL
+Vendor: Project Vine
+Distribution: Vine Linux
 
+License: LGPL
 URL: http://www.gnome.org/projects/evolution/
 %define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
 Source0: https://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/%{shortver}/%{name}-%{version}.tar.xz
@@ -97,10 +99,6 @@ BuildRequires: krb5-devel
 #define krb5dir `pwd`/krb5-fakeprefix
 %endif
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
-
 %description
 The evolution-data-server package provides a unified backend for 
 programs that work with contacts, tasks, and calendar information.
@@ -352,6 +350,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
 %{_datadir}/vala/vapi/camel-1.2.vapi
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-3
+- rebuilt with icu-67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-2
 - rebuilt with icu-66.
 

+ 8 - 6
h/harfbuzz/harfbuzz-vl.spec

@@ -3,11 +3,13 @@
 Summary:	Text shaping library
 Name:		harfbuzz
 Version:	2.6.4
-Release:	1%{?_dist_release}
-License:	MIT
+Release:	2%{?_dist_release}
 Group:		System Environment/Libraries 
-URL:		http://www.freedesktop.org/wiki/Software/HarfBuzz
+Vendor:		Project Vine
+Distribution:	Vine Linux
 
+License:	MIT
+URL:		http://www.freedesktop.org/wiki/Software/HarfBuzz
 Source0:	https://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.xz
 
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
@@ -16,9 +18,6 @@ BuildRequires:	cairo-devel
 BuildRequires:	freetype2-devel
 BuildRequires:	libicu-devel
 
-Vendor:		Project Vine
-Distribution:	Vine Linux
-
 
 %description
 HarfBuzz is an OpenType text shaping engine.
@@ -159,6 +158,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.4-2
+- built with icu-67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.4-1
 - new upstream release.
 - built with icu-66.

+ 35 - 19
i/icu/icu-vl.spec

@@ -1,33 +1,34 @@
 %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
 
-%define sover 66
+%define sover 67
 %define minorver 1
 
-Summary: International Components for Unicode
-Summary(ja): ユニコード用国際化コンポーネント
-Name: icu
-Version: %{sover}.%{minorver}
-Release: 1%{?_dist_release}
-Group:   Development/Tools
-License: MIT
-URL:     http://icu-project.org/
-
-Source0: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
-Source1: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-root
-BuildRequires: gcc-c++
-BuildRequires: unzip perl 
-Requires: libicu%{sover} = %{version}-%{release}
+Summary:        International Components for Unicode
+Summary(ja):    ユニコード用国際化コンポーネント
+Name:           icu
+Version:        %{sover}.%{minorver}
+Release:        1%{?_dist_release}
+Group:          Development/Tools
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
+License:        MIT
+URL:            http://icu-project.org/
 
-Vendor: Project Vine
-Distribution: Vine Linux
+Source0:        https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
+Source1:        https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-root
+BuildRequires:  gcc-c++
+BuildRequires:  unzip perl 
+Requires:       libicu%{sover} = %{version}-%{release}
 
 %description
 ICU is a C++ and C library that provides robust and full-featured Unicode
 support. This package contains the Unicode character database and derived
 properties, along with converters and time zones data.
 
+
 %package -n libicu%{sover}
 Summary: International Components for Unicode (library)
 Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
@@ -39,6 +40,7 @@ ICU is a C++ and C library that provides robust and full-featured Unicode
 support. This package contains the runtime libraries for ICU. It does not
 contain any of the data files needed at runtime.
 
+
 %package -n libicu-devel
 Summary: Header files, libraries and development documentation for libicu
 Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
@@ -50,6 +52,7 @@ This package contains the header files, static libraries for %{name}.
 If you like to develop programs using %{name}, you will need to install 
 %{name}-devel.
 
+
 %package -n libicu-doc
 Summary: Documentation for International Components for Unicode
 Summary(ja): ユニコード用国際化コンポーネントのドキュメント
@@ -59,6 +62,7 @@ Requires: libicu%{sover} = %{version}-%{release}
 %description -n libicu-doc
 This package contains the development documentation for %{name}. 
 
+
 # compat32
 %if %{build_compat32}
 %package -n compat32-libicu%{sover}
@@ -74,6 +78,9 @@ contain any of the data files needed at runtime.
 %endif
 
 
+%debug_package
+
+
 %prep
 %setup -q -n icu
 
@@ -85,6 +92,7 @@ pushd docs
 unzip %{SOURCE1}
 popd
 
+
 %build
 cd source
 export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
@@ -92,6 +100,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
 %configure --disable-static --with-data-packaging=library --disable-samples 
 make %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 make -C source install DESTDIR=$RPM_BUILD_ROOT
@@ -103,13 +112,16 @@ chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
 make %{?_smp_mflags} -C source check
 %endif
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %post -n libicu%{sover} -p /sbin/ldconfig
 
 %postun -n libicu%{sover} -p /sbin/ldconfig
 
+
 %files
 %defattr(-, root, root, 0755)
 %license LICENSE
@@ -156,7 +168,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/*.so.*
 %endif
 
+
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 67.1-1
+- updated to 67.1.
+
 * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 66.1-1
 - updated to 66.1.
 

+ 4 - 3
lib/libv/libvisio/libvisio-vl.spec

@@ -2,17 +2,15 @@
 
 Name: libvisio
 Version: 0.1.7
-Release: 2%{?_dist_release}
+Release: 3%{?_dist_release}
 Summary: A library for import of Microsoft Visio diagrams
 Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
 Group: System Environment/Libraries
-
 Vendor: Project Vine
 Distribution: Vine Linux
 
 License: MPLv2.0
 URL: http://wiki.documentfoundation.org/DLP/Libraries/libvisio
-
 Source: http://dev-www.libreoffice.org/src/%{name}/%{name}-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -132,6 +130,9 @@ rm -rf %{buildroot}
 %{_mandir}/man1/vss2xhtml.1*
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-3
+- rebuilt with icu-67.
+
 * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-2
 - rebuilt with icu-66.
 

+ 4 - 1
p/php74/php74-vl.spec

@@ -52,7 +52,7 @@ Name: php%{majorver}
 Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
 Summary(ja): HTML 埋め込み型スクリプト言語 PHP
 Version: 7.4.5
-Release: 1%{_dist_release}%{?with_systemd:.systemd}
+Release: 2%{_dist_release}%{?with_systemd:.systemd}
 Conflicts: php5 < 5.6.11
 
 Vendor: Project Vine
@@ -1051,6 +1051,9 @@ rm -f files.*
 
 #======================================================================
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4.5-2
+- rebuilt with icu67.
+
 * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4.5-1
 - new upstream release.
 - added systemd support (disabled as default).

+ 63 - 25
p/postfix/postfix-vl.spec

@@ -1,5 +1,4 @@
-#%define build_mysql %{?_with_mysql:1}%{!?_with_mysql:0}
-#%define build_pgsql %{?_with_pgsql:1}%{!?_with_pgsql:0}
+%bcond_with systemd
 
 %define _unpackaged_files_terminate_build 1
 
@@ -30,26 +29,28 @@
 %define postfix_readme_dir      %{postfix_doc_dir}/README_FILES
 
 
-%define origversion 3.5.0
-
-Summary:   Postfix Mail Transport Agent
-Summary(ja):   Postfix メールトランスポートエージェント
-Name:      postfix
-Version:   %{origversion}
-Release:   1%{?_dist_release}
-URL:       http://www.postfix.org/
-License:   Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
-Group:     System Environment/Daemons
-
-Source0:   http://mirror.postfix.jp/postfix-release/official/%{name}-%{version}.tar.gz
-Source1:   postfix.aliases
-Source2:   postfix.cron
-Source3:   postfix.init
-
-Patch0:    postfix-2.9.1-vine.patch
+Summary:        Postfix Mail Transport Agent
+Summary(ja):    Postfix メールトランスポートエージェント
+Name:           postfix
+Version:        3.5.1
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
+Group:          System Environment/Daemons
+Vendor:         Project Vine
+Distribution:   Vine Linux
+Packager:       daisuke
+
+URL:            http://www.postfix.org/
+License:        Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
+Source0:        http://mirror.postfix.jp/postfix-release/official/%{name}-%{version}.tar.gz
+Source1:        postfix.aliases
+Source2:        postfix.cron
+Source3:        postfix.init
+Source4:        postfix.service
+Source5:        postfix-prestart.sh
+Patch0:         postfix-2.9.1-vine.patch
 
 # patches 200-299 are imported from rh/fedora
-Patch200: postfix-3.2.0-large-fs.patch
+Patch200:       postfix-3.2.0-large-fs.patch
 
 # patches 300-399 are imported from ubuntu
 # none
@@ -63,6 +64,13 @@ BuildRequires: openldap-devel, openssl-devel
 BuildRequires: libicu-devel, pcre-devel
 BuildRequires: libnsl2-devel
 
+%if %{with systemd}
+%{?systemd_requires}
+%else
+Requires(post): chkconfig
+Requires(preun): chkconfig
+%endif
+
 %if "%{_dist_release}" >= "vl7"
 BuildRequires: libdb-devel >= 5.3
 Requires(post): libdb
@@ -95,10 +103,6 @@ Requires:    pam
 Obsoletes: postfix-beta
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: daisuke
-
 
 %description
 Postfix aims to be an alternative to the widely-used sendmail
@@ -298,7 +302,16 @@ done
 
 install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/postfix/aliases
 install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/postfix
+
+%if %{with systemd}
+# Systemd
+mkdir -p %{buildroot}%{_unitdir}
+mkdir -p %{buildroot}%{_libexecdir}/postfix
+install -m 644 %{SOURCE4} %{buildroot}%{_unitdir}
+install -m 755 %{SOURCE5} %{buildroot}%{_libexecdir}/postfix/postfix-prestart.sh
+%else
 install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/postfix
+%endif
 
 ln -sf postfix/aliases $RPM_BUILD_ROOT%{_sysconfdir}/aliases
 ln -sf postfix/aliases.db $RPM_BUILD_ROOT%{_sysconfdir}/aliases.db
@@ -363,7 +376,11 @@ exit 0
   sample_directory=%{postfix_sample_dir} \
   readme_directory=%{postfix_readme_dir} &> /dev/null
 
+%if %{with systemd}
+%systemd_post %{name}.service
+%else
 /sbin/chkconfig --add postfix
+%endif
 if [ ! -f %{_sysconfdir}/postfix/aliases.db ]; then
   %{_sbindir}/postalias %{_sysconfdir}/postfix/aliases
 fi
@@ -376,16 +393,23 @@ fi
 
 
 %preun
-if [ $1 -eq 0 ]; then
+%if %{with systemd}
+%systemd_preun %{name}.service
+%else
+if [ $1 -eq 0 -o -x /bin/systemctl ]; then
    if [ -f %{_var}/lock/subsys/postfix -a -f %{_sysconfdir}/rc.d/init.d/postfix ]; then
       %{_sysconfdir}/rc.d/init.d/postfix stop
    fi
    /sbin/chkconfig --del postfix
 fi
+%endif
 
 
 %postun
 /sbin/ldconfig
+%if %{with systemd}
+%systemd_postun_with_restart %{name}.service
+%else
 if [ -f %{_var}/lock/subsys/postfix ]; then
    if [ $1 -eq 0 ]; then
         rm -rf %{_var}/lock/subsys/postfix
@@ -393,6 +417,7 @@ if [ -f %{_var}/lock/subsys/postfix ]; then
         %{_sysconfdir}/rc.d/init.d/postfix restart
    fi
 fi
+%endif
 
 %triggerpostun -- postfix < 3.1.0
 if [ -f %{_var}/lock/subsys/postfix ]; then
@@ -438,7 +463,13 @@ rm -rf $RPM_BUILD_ROOT
 %config %{_sysconfdir}/postfix/postfix-files
 %config %{_sysconfdir}/postfix/post-install
 %config %{_sysconfdir}/postfix/postfix-script
+%if %{with systemd}
+%{_unitdir}/postfix.service
+%{_libexecdir}/postfix/postfix-prestart.sh
+%else
 %config %{_sysconfdir}/rc.d/init.d/postfix
+%endif
+
 %{_bindir}/*
 %dir %{_libdir}/postfix
 %{_libdir}/postfix/*
@@ -525,6 +556,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/postfix/postfix-files.d/pcre
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.1-2
+- rebuilt with icu67.
+
+* Tue Apr 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.1-1
+- new upstream release.
+- added systemd support (disabled as default).
+
 * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.0-1
 - new upstream release.
 - dropped Patch300: fixed in upstream.

+ 34 - 28
q/qt5-qtbase/qt5-qtbase-vl.spec

@@ -67,88 +67,88 @@ BuildRequires: systemd-devel
 %global qt5_minorver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
 #global qt5_patchlevel 1
 
-Summary: Qt5 - QtBase components
-Name:    qt5-qtbase
-Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
-Release: 1%{?_dist_release}%{?with_systemd:.systemd}
+Summary:        Qt5 - QtBase components
+Name:           qt5-qtbase
+Version:        %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
+Vendor:         Project Vine
+Distribution:   Vine Linux
 
 # See LGPL_EXCEPTIONS.txt, for exception details
-License: LGPLv2 with exceptions or GPLv3 with exceptions
-Url: https://qt-project.org/
+License:        LGPLv2 with exceptions or GPLv3 with exceptions
+Url:            https://qt-project.org/
 
-Vendor: Project Vine
-Distribution: Vine Linux
 
-Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
+Source0:        https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
 
 # https://bugzilla.redhat.com/show_bug.cgi?id=1227295
-Source1: qtlogging.ini
+Source1:        qtlogging.ini
 
 # header file to workaround multilib issue
 # https://bugzilla.redhat.com/show_bug.cgi?id=1036956
-Source5: qconfig-multilib.h
+Source5:        qconfig-multilib.h
 
 # xinitrc script to check for OpenGL 1 only drivers and automatically set
 # QT_XCB_FORCE_SOFTWARE_OPENGL for them
-Source6: 10-qt5-check-opengl2.sh
+Source6:        10-qt5-check-opengl2.sh
 
 # macros
-Source10: macros.qt5-qtbase
+Source10:       macros.qt5-qtbase
 
 # support multilib optflags
-Patch2: qtbase-multilib_optflags.patch
+Patch2:         qtbase-multilib_optflags.patch
 
 # fix QTBUG-35459 (too low entityCharacterLimit=1024 for CVE-2013-4549)
-Patch4: qtbase-opensource-src-5.3.2-QTBUG-35459.patch
+Patch4:         qtbase-opensource-src-5.3.2-QTBUG-35459.patch
 
 # borrowed from opensuse
 # track private api via properly versioned symbols
 # downside: binaries produced with these differently-versioned symbols are no longer
 # compatible with qt-project.org's Qt binary releases.
-Patch8: tell-the-truth-about-private-api.patch
+Patch8:         tell-the-truth-about-private-api.patch
 
 # upstreamable patches
 # namespace QT_VERSION_CHECK to workaround major/minor being pre-defined (#1396755)
-Patch50: qtbase-opensource-src-5.8.0-QT_VERSION_CHECK.patch
+Patch50:        qtbase-opensource-src-5.8.0-QT_VERSION_CHECK.patch
 
 # 1381828 - Broken window scaling for some QT5 applications (#1381828)
 # This patch moves the threshold for 2x scaling from the DPI of 144 to 192,
 # the same value GNOME uses. It's not a complete solution...
-Patch51: qtbase-hidpi_scale_at_192.patch
+Patch51:        qtbase-hidpi_scale_at_192.patch
 
 # 1. Workaround moc/multilib issues
 # https://bugzilla.redhat.com/show_bug.cgi?id=1290020
 # https://bugreports.qt.io/browse/QTBUG-49972
 # 2. Workaround sysmacros.h (pre)defining major/minor a breaking stuff
-Patch52: qtbase-opensource-src-5.7.1-moc_macros.patch
+Patch52:        qtbase-opensource-src-5.7.1-moc_macros.patch
 
 # CMake generates wrong -isystem /usr/include compilations flags with Qt5::Gui
 # https://bugzilla.redhat.com/1704474
-Patch53: qtbase-everywhere-src-5.12.1-qt5gui_cmake_isystem_includes.patch
+Patch53:        qtbase-everywhere-src-5.12.1-qt5gui_cmake_isystem_includes.patch
 
 # respect QMAKE_LFLAGS_RELEASE when building qmake
-Patch54: qtbase-qmake_LFLAGS.patch
+Patch54:        qtbase-qmake_LFLAGS.patch
 
 # drop -O3 and make -O2 by default
-Patch61: qt5-qtbase-cxxflag.patch
+Patch61:        qt5-qtbase-cxxflag.patch
 
 # support firebird version 3.x
-Patch64: qt5-qtbase-5.12.1-firebird.patch
+Patch64:        qt5-qtbase-5.12.1-firebird.patch
 
 # fix for new mariadb
-Patch65: qtbase-opensource-src-5.9.0-mysql.patch
+Patch65:        qtbase-opensource-src-5.9.0-mysql.patch
 
 # use categorized logging for xcb log entries
 # https://bugreports.qt.io/browse/QTBUG-55167
 # https://bugzilla.redhat.com/show_bug.cgi?id=1497564
-Patch67: https://bugreports.qt.io/secure/attachment/66353/xcberror_filter.patch
+Patch67:        https://bugreports.qt.io/secure/attachment/66353/xcberror_filter.patch
 
 # python3
-Patch68: qtbase-everywhere-src-5.11.1-python3.patch
+Patch68:        qtbase-everywhere-src-5.11.1-python3.patch
 
 # https://fedoraproject.org/wiki/Changes/Qt_Wayland_By_Default_On_Gnome
 # https://bugzilla.redhat.com/show_bug.cgi?id=1732129
-Patch80: qtbase-use-wayland-on-gnome.patch
+Patch80:        qtbase-use-wayland-on-gnome.patch
 
 # macros, be mindful to keep sync'd with macros.qt5-base
 %define _qt5 %{name}
@@ -213,7 +213,7 @@ BuildRequires: pkgconfig(glesv2)
 %global sqlite -system-sqlite
 BuildRequires: pkgconfig(sqlite3) >= 3.7
 %global harfbuzz -system-harfbuzz
-BuildRequires: pkgconfig(harfbuzz) >= 0.9.42
+BuildRequires: harfbuzz-devel >= 2.6.4-2
 BuildRequires: pkgconfig(icu-i18n)
 BuildRequires: pkgconfig(libpcre2-posix) >= 10.20
 BuildRequires: pkgconfig(libpcre) >= 8.0
@@ -352,6 +352,9 @@ Requires: glx-utils
 Qt5 libraries used for drawing widgets and OpenGL items.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
 
@@ -1036,6 +1039,9 @@ fi
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
+- rebuilt with icu-67.
+
 * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
 - new upstream release.
 - dropped Patch1000: fixed in upstream.

+ 7 - 1
q/qt5-qtlocation/qt5-qtlocation-vl.spec

@@ -21,7 +21,7 @@
 Summary: Qt5 - Location component
 Name:    qt5-%{qt_module}
 Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 
 # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
 License: LGPLv2 with exceptions or GPLv3 with exceptions
@@ -87,6 +87,9 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
 %{summary}.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
 %patch0 -p1 -b .gcc10
@@ -180,6 +183,9 @@ popd
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
+- rebuilt with icu-67.
+
 * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
 - new upstream release.
 

+ 4 - 1
q/qt5-qtwebengine/qt5-qtwebengine-vl.spec

@@ -41,7 +41,7 @@
 Summary: Qt5 - QtWebEngine components
 Name:    qt5-qtwebengine
 Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 
 # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
 # See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
@@ -588,6 +588,9 @@ sed -i -e "s|%{version} \${_Qt5WebEngine|%{lesser_version} \${_Qt5WebEngine|" \
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-2
+- rebuilt with icu-67.
+
 * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
 - new upstream release.
 - built with libevent-2.1.11.

+ 8 - 8
s/samba/samba-vl.spec

@@ -3,7 +3,7 @@
 
 %define samba_version 4.12.1
 #define rc_number rc4
-%define samba_release 1
+%define samba_release 2
 
 %define doc_version 4.12.0
 %define api_version 4.0
@@ -39,8 +39,11 @@ Summary(ja): Samba スイート
 Name: samba
 Version: %{samba_version}
 Release: %{samba_release}%{?rc_suffix}%{?_dist_release}%{?with_systemd:.systemd}
-License: GPLv3+
 Group: System Environment/Daemons
+Vendor: Project Vine
+Distribution: Vine Linux
+
+License: GPLv3+
 URL: http://www.samba.org/
 
 %define samba_includedir   %{_includedir}/samba-%{api_version}
@@ -157,12 +160,6 @@ BuildConflicts: compat32-libuuid-devel.32bit
 # Working around perl dependency problem from docs
 #define __perl_requires %{SOURCE999}
 
-
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: tomop
-
-
 %description
 Samba is the standard Windows interoperability suite of programs
 for Linux and Unix.
@@ -1823,6 +1820,9 @@ fi
 %endif
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.12.1-2
+- rebuilt with icu-67.
+
 * Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.12.1-1
 - new upstream release.
 - added systemd support (disabled as default).

+ 6 - 5
t/tracker-miners/tracker-miners-vl.spec

@@ -4,9 +4,9 @@
 %global with_libcue 1
 %global with_rss 0
 
-%global tracker_version 2.2.0
+%global tracker_version 2.3.4
 
-%global systemd_units tracker-extract.service tracker-miner-fs.service tracker-miner-rss.service tracker-writeback.service
+%global systemd_units tracker-extract.service tracker-miner-fs.service %{?_with_rss:tracker-miner-rss.service} tracker-writeback.service
 
 # Exclude private libraries from autogenerated provides and requires
 %global __provides_exclude_from ^%{_libdir}/tracker-miners-2.0/
@@ -14,17 +14,15 @@
 
 Name:           tracker-miners
 Version:        2.3.3
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}%{?with_systemd:.systemd}
 Summary:        Tracker miners and metadata extractors
 Group:          Applications/Services
-
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
 # libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
 License:        GPLv2+ and LGPLv2+
 URL:            https://wiki.gnome.org/Projects/Tracker
-
 %define         shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
 Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 
@@ -153,6 +151,9 @@ fi
 %endif
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-2
+- rebuilt with icu-67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-1
 - new upstream release.
 

+ 41 - 8
t/tracker/tracker-vl.spec

@@ -1,16 +1,20 @@
+%bcond_with systemd
+
 %define _unpackaged_files_terminate_build 1
 
 Summary: An object database, tag/metadata database, search tool and indexer
 Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
 Name: tracker
-Version: 2.2.2
-Release: 3%{?_dist_release}
-License: GPL
+Version: 2.3.4
+Release: 1%{?_dist_release}%{?with_systemd:.systemd}
 Group: Applications/System
-URL: http://www.gnome.org/projects/tracker/
+Vendor: Project Vine
+Distribution: Vine Linux
 
+License: GPL
+URL: https://gnome.pages.gitlab.gnome.org/tracker/
 %define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
-Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
+Source0: https://download.gnome.org/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires:  meson
@@ -28,15 +32,19 @@ BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(sqlite3)
 BuildRequires:  libuuid-devel
+%if %{with systemd}
+BuildRequires:  systemd
+%endif
+%if %{with systemd}
+%global systemd_units tracker-store.service
+%{?systemd_requires}
+%endif
 
 Obsoletes: %{name}-libs < 2.0.0
 Obsoletes: %{name}-search-tool < 2.0.0
 Provides: %{name}-libs = %{version}-%{release}
 Provides: %{name}-search-tool = %{version}-%{release}
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
 %description
 Tracker is a powerful desktop-neutral first class object database,
 tag/metadata database, search tool and indexer. 
@@ -79,6 +87,9 @@ This package contains documentation for tracker.
 %build
 %meson \
 	-Dstemmer=disabled \
+%if %{with systemd}
+	-Dsystemd_user_services=%{_userunitdir} \
+%endif
 	-Ddocs=true
 
 %meson_build
@@ -93,18 +104,30 @@ rm -rf %{buildroot}%{_datadir}/tracker-tests
 
 %find_lang %{name}
 
+%if !%{with systemd}
 rm -rf %{buildroot}/usr/lib/systemd
+%endif
+
 
 %clean
 rm -rf %{buildroot}
 
+
 %post
 /sbin/ldconfig
 touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
+%if %{with systemd}
+%systemd_user_post %{systemd_units}
+%endif
 
 %posttrans
 gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
 glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
+
+%if %{with systemd}
+%preun
+%systemd_user_preun %{systemd_units}
+%endif
   
 %postun
 /sbin/ldconfig
@@ -113,6 +136,9 @@ if [ $1 -eq 0 ] ; then
     gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
     glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
 fi
+%if %{with systemd}
+%systemd_user_postun_with_restart %{systemd_units}
+%endif
 
 
 %files -f %{name}.lang
@@ -135,6 +161,9 @@ fi
 %dir %{_datadir}/bash-completion/completions
 %{_datadir}/bash-completion/completions/tracker
 %{_datadir}/glib-2.0/schemas/*
+%if %{with systemd}
+%{_userunitdir}/tracker-store.service
+%endif
 
 %files devel
 %defattr(-, root, root, -)
@@ -156,6 +185,10 @@ fi
 
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
+- new upstream release.
+- built with icu-67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-3
 - rebuilt with icu-66.
 

+ 8 - 5
w/webkitgtk4/webkitgtk4-vl.spec

@@ -8,16 +8,15 @@
         cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
 
 Name:           webkitgtk4
-Version:        2.28.0
-Release:        2%{?_dist_release}
+Version:        2.28.1
+Release:        1%{?_dist_release}
 Summary:        GTK+ Web content engine library
-
-License:        LGPLv2
 Group:          System Environment/Libraries
-URL:            http://www.webkitgtk.org/
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
+License:        LGPLv2
+URL:            http://www.webkitgtk.org/
 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
 
 %if %{with clang}
@@ -220,6 +219,10 @@ DESTDIR=%{buildroot} ninja -C %{_target_platform} install
 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
+- new upstream release.
+- rebuilt with libicu67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
 - rebuilt with libicu66.
 

+ 7 - 2
x/xfsprogs/xfsprogs-vl.spec

@@ -1,12 +1,12 @@
 Summary:	Utilities for managing the XFS filesystem
 Summary(ja):	XFS ファイルシステムを管理するためのユーティリティ
 Name:		xfsprogs
-Version:	5.5.0
+Version:	5.6.0
 Release:        1%{?_dist_release}
 Group:		System Environment/Base
-
 Vendor:         Project Vine
 Distribution:   Vine Linux
+
 # Licensing based on generic "GNU GENERAL PUBLIC LICENSE"
 # in source, with no mention of version.
 # doc/COPYING file specifies what is GPL and what is LGPL
@@ -14,6 +14,7 @@ Distribution:   Vine Linux
 License:	GPL+ and LGPLv2+
 URL:		http://xfs.org/
 Source0:	https://mirrors.edge.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.xz
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:	libtool, gettext
 BuildRequires:	libattr-devel
@@ -108,6 +109,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/*
 
 %changelog
+* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.6.0-1
+- new upstream release.
+- built with icu67.
+
 * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.0-1
 - new upstream release.
 - built with icu66.