tracker-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459
  1. %bcond_with systemd
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: An object database, tag/metadata database, search tool and indexer
  4. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  5. Name: tracker
  6. Version: 2.3.4
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: Applications/System
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPL
  12. URL: https://gnome.pages.gitlab.gnome.org/tracker/
  13. %define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
  14. Source0: https://download.gnome.org/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: meson
  17. BuildRequires: graphviz
  18. BuildRequires: gtk-doc
  19. BuildRequires: intltool
  20. BuildRequires: libappstream-glib
  21. BuildRequires: vala
  22. BuildRequires: pkgconfig(gobject-introspection-1.0)
  23. BuildRequires: pkgconfig(icu-i18n)
  24. BuildRequires: pkgconfig(icu-uc)
  25. BuildRequires: pkgconfig(json-glib-1.0)
  26. BuildRequires: pkgconfig(libnm)
  27. BuildRequires: pkgconfig(libsoup-2.4)
  28. BuildRequires: pkgconfig(libxml-2.0)
  29. BuildRequires: pkgconfig(sqlite3)
  30. BuildRequires: libuuid-devel
  31. %if %{with systemd}
  32. BuildRequires: systemd
  33. %endif
  34. %if %{with systemd}
  35. %global systemd_units tracker-store.service
  36. %{?systemd_requires}
  37. %endif
  38. Obsoletes: %{name}-libs < 2.0.0
  39. Obsoletes: %{name}-search-tool < 2.0.0
  40. Provides: %{name}-libs = %{version}-%{release}
  41. Provides: %{name}-search-tool = %{version}-%{release}
  42. %description
  43. Tracker is a powerful desktop-neutral first class object database,
  44. tag/metadata database, search tool and indexer.
  45. It consists of a common object database that allows entities to have an
  46. almost infinte number of properties, metadata (both embedded/harvested as
  47. well as user definable), a comprehensive database of keywords/tags and
  48. links to other entities.
  49. It provides additional features for file based objects including context
  50. linking and audit trails for a file object.
  51. It has the ability to index, store, harvest metadata. retrieve and search
  52. all types of files and other first class objects
  53. %package devel
  54. Summary: Headers for developing programs that will use %{name}
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. %description devel
  58. This package contains the static libraries and header files needed for
  59. developing with tracker
  60. %package docs
  61. Summary: Documentation for tracker
  62. Group: Documentation
  63. Obsoletes: %{name}-doc < 0.15.0
  64. Provides: %{name}-doc = 0.15.0
  65. BuildArch: noarch
  66. %description docs
  67. This package contains documentation for tracker.
  68. %prep
  69. %setup -q
  70. %build
  71. %meson \
  72. -Dstemmer=disabled \
  73. %if %{with systemd}
  74. -Dsystemd_user_services=%{_userunitdir} \
  75. %endif
  76. -Ddocs=true
  77. %meson_build
  78. %install
  79. rm -rf %{buildroot}
  80. export LANG=ja_JP.UTF-8
  81. %meson_install
  82. rm -rf %{buildroot}%{_datadir}/tracker-tests
  83. %find_lang %{name}
  84. %if !%{with systemd}
  85. rm -rf %{buildroot}/usr/lib/systemd
  86. %endif
  87. %clean
  88. rm -rf %{buildroot}
  89. %post
  90. /sbin/ldconfig
  91. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  92. %if %{with systemd}
  93. %systemd_user_post %{systemd_units}
  94. %endif
  95. %posttrans
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  97. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  98. %if %{with systemd}
  99. %preun
  100. %systemd_user_preun %{systemd_units}
  101. %endif
  102. %postun
  103. /sbin/ldconfig
  104. if [ $1 -eq 0 ] ; then
  105. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  106. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  107. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  108. fi
  109. %if %{with systemd}
  110. %systemd_user_postun_with_restart %{systemd_units}
  111. %endif
  112. %files -f %{name}.lang
  113. %defattr(-, root, root, -)
  114. %license COPYING
  115. %doc AUTHORS NEWS README.md
  116. %{_bindir}/tracker
  117. %{_libexecdir}/tracker-store
  118. %{_datadir}/tracker/
  119. %{_datadir}/dbus-1/services/org.freedesktop.Tracker1.service
  120. %{_libdir}/libtracker*-2.0.so.*
  121. %{_libdir}/tracker-2.0/
  122. %dir %{_libdir}/girepository-1.0
  123. %{_libdir}/girepository-1.0/Tracker-2.0.typelib
  124. %{_libdir}/girepository-1.0/TrackerControl-2.0.typelib
  125. %{_libdir}/girepository-1.0/TrackerMiner-2.0.typelib
  126. %{_mandir}/*/tracker*.gz
  127. %config(noreplace) %{_sysconfdir}/xdg/autostart/tracker-store.desktop
  128. %dir %{_datadir}/bash-completion
  129. %dir %{_datadir}/bash-completion/completions
  130. %{_datadir}/bash-completion/completions/tracker
  131. %{_datadir}/glib-2.0/schemas/*
  132. %if %{with systemd}
  133. %{_userunitdir}/tracker-store.service
  134. %endif
  135. %files devel
  136. %defattr(-, root, root, -)
  137. %{_includedir}/tracker-2.0/
  138. %{_libdir}/*.so
  139. %{_libdir}/pkgconfig/*.pc
  140. %dir %{_datadir}/vala
  141. %dir %{_datadir}/vala/vapi
  142. %{_datadir}/vala/vapi/*
  143. %dir %{_datadir}/gir-1.0
  144. %{_datadir}/gir-1.0/*
  145. %files docs
  146. %defattr(-, root, root, -)
  147. %{_datadir}/gtk-doc/html/libtracker-control
  148. %{_datadir}/gtk-doc/html/libtracker-miner
  149. %{_datadir}/gtk-doc/html/libtracker-sparql
  150. %{_datadir}/gtk-doc/html/ontology/
  151. %changelog
  152. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  153. - new upstream release.
  154. - built with icu-67.
  155. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-3
  156. - rebuilt with icu-66.
  157. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-2
  158. - rebuilt with icu-65.
  159. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-1
  160. - new upstream release.
  161. - dropped Patch0.
  162. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  163. - new upstream release.
  164. - dropped all patches.
  165. - added Patch0.
  166. - dropped subpackages "libs" and "search-tool".
  167. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
  168. - new upstream release.
  169. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  170. - new upstream release
  171. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  172. - new upstream release
  173. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
  174. - new upstream release
  175. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  176. - new upstream release
  177. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
  178. - remove *.la files
  179. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  180. - new upstream release
  181. - add BuildRequires: libmediaart-devel, libvorbis-devel, flac-devel
  182. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.5-1
  183. - new upstream release
  184. * Sun Nov 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  185. - new upstream release
  186. - add Patch1 (tracker-1.2.3-revert-error_message.patch)
  187. * Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  188. - rebuild with upower-0.99.1
  189. * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  190. - new upstream release
  191. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  192. - new upstream release
  193. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-3
  194. - rebuild with poppler-0.26.2
  195. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
  196. - rebuild with libarchive-3.1.2
  197. * Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
  198. - new upstream release
  199. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  200. - rebuild with poppler-0.24.5
  201. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  202. - new upstream release
  203. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-2
  204. - rebuild with VineSeed environment
  205. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-1
  206. - new upstream release
  207. * Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.3-1
  208. - new upstream release
  209. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-2
  210. - rebuild with icu-51.2
  211. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-1
  212. - new upstream release
  213. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  214. - new upstream release
  215. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  216. - new upstream release
  217. - remove BuildRequires: gnome-panel-devel, gnome-applets
  218. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  219. - add BuildRequires: libjpeg-turbo-devel, giflib-devel, libtiff-devel, exempi-devel, enca-devel, taglib-devel, libgxps-devel
  220. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  221. - change to %%{name}-docs subpackage from %%{name}-docs
  222. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.5-1
  223. - new upstream release
  224. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.4-1
  225. - new upstream release
  226. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.3-1
  227. - new upstream release
  228. * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-2
  229. - create -libs subpackage
  230. - add BuildRequires: firefox, thunderbird
  231. * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  232. - new upstream release
  233. * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  234. - new upstream release
  235. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  236. - new upstream release
  237. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
  238. - new upstream release
  239. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
  240. - new upstream release
  241. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
  242. - new upstream release
  243. - create %%{name}-doc sub package
  244. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
  245. - new upstream release
  246. - add Patch0 (tracker-0.12.3-sched.patch)
  247. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
  248. - new upstream release
  249. - add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
  250. - drop Patch0
  251. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
  252. - new upstream release
  253. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
  254. - new upstream release
  255. * Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
  256. - new upstream release
  257. - add BuildRequires: libicu-devel
  258. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
  259. - new upstream release
  260. - add Patch0 (tracker-0.8.18-tracker_spawn.patch)
  261. - delete Patch1
  262. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
  263. - rebuilt with poppler-0.16.3
  264. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
  265. - rebuild with poppler-0.14.2
  266. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
  267. - new upstream release
  268. - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
  269. - add configure option (--enable-tracker-search-bar)
  270. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  271. - new upstream release
  272. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  273. - new upstream release
  274. - fix URL of Source0
  275. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  276. - new upstream release
  277. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  278. - new upstream release
  279. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  280. - new upstream release
  281. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  282. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  283. - new upstream release
  284. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  285. - new upstream release
  286. - add BuildRequires: upower-devel, gnome-applets
  287. - change BuildRequires: dbus-glib -> dbus-glib-devel
  288. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  289. - new upstream release
  290. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  291. - fix BuildRequires: gmime-devel >= 2.4
  292. - add configure option (--enable-tracker-search-tool)
  293. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  294. - new upstream release
  295. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  296. - rebuild with poppler-0.10.2
  297. - spec in UTF-8
  298. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  299. - new upstream release
  300. - update Patch1
  301. - drop Patch10 (no more necessary)
  302. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  303. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  304. - apply new versioning policy
  305. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  306. - new upstream release
  307. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  308. - add Patch10 to fix selecting video-extractor
  309. - use external video extractor(totem) instead of gstreamer/xine
  310. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  311. - initial build for Vine Linux
  312. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  313. - Ship both autostart desktop files in the main package (BZ #233323)
  314. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  315. - Package the deskbar plugin properly (BZ #228308)
  316. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  317. - Split out tracker-search-tool sub-packages, for the GUI facility
  318. - Add proper requires for the -devel subpackage
  319. - Deal with the rpmlint complaints on rpath
  320. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  321. - Update to 0.5.4
  322. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  323. - Update to 0.5.3
  324. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  325. - Apply patch on Makefile.am instead of Makefile.in
  326. - Add libtool to BR
  327. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  328. - Update to 0.5.2
  329. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  330. - Update to new version
  331. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  332. - Have the devel subpackage require pkgconfig
  333. - Make the description field not have more than 76 characters on a line
  334. - Fix up the RPM group
  335. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  336. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  337. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  338. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  339. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  340. - Add autostart desktop file.
  341. - Edit the package description as suggested in review
  342. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  343. - More cleaups to the spec file.
  344. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  345. - Add needed BRs
  346. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  347. - Initial packaging for Fedora Extras