tracker-miners-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265
  1. %bcond_with systemd
  2. %global with_enca 1
  3. %global with_libcue 1
  4. %global with_rss 0
  5. %global tracker_version 2.3.4
  6. %global systemd_units tracker-extract.service tracker-miner-fs.service %{?_with_rss:tracker-miner-rss.service} tracker-writeback.service
  7. # Exclude private libraries from autogenerated provides and requires
  8. %global __provides_exclude_from ^%{_libdir}/tracker-miners-2.0/
  9. %global __requires_exclude ^(libtracker-extract\.so|libtracker-miners-common\.so|libextract-.*\.so|libwriteback-.*\.so)
  10. Name: tracker-miners
  11. Version: 2.3.3
  12. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  13. Summary: Tracker miners and metadata extractors
  14. Group: Applications/Services
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. # libtracker-extract is LGPLv2+; the miners are a mix of GPLv2+ and LGPLv2+ code
  18. License: GPLv2+ and LGPLv2+
  19. URL: https://wiki.gnome.org/Projects/Tracker
  20. %define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
  21. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  22. BuildRequires: gcc
  23. BuildRequires: giflib-devel
  24. BuildRequires: intltool
  25. BuildRequires: meson
  26. %if %{with systemd}
  27. BuildRequires: systemd
  28. %endif
  29. BuildRequires: pkgconfig(dbus-1)
  30. %if 0%{?with_enca}
  31. BuildRequires: pkgconfig(enca)
  32. %endif
  33. BuildRequires: pkgconfig(exempi-2.0)
  34. BuildRequires: flac-devel
  35. BuildRequires: pkgconfig(gexiv2)
  36. BuildRequires: pkgconfig(gstreamer-1.0)
  37. BuildRequires: pkgconfig(gstreamer-pbutils-1.0)
  38. BuildRequires: pkgconfig(gstreamer-tag-1.0)
  39. BuildRequires: pkgconfig(icu-i18n)
  40. BuildRequires: pkgconfig(icu-uc)
  41. %if 0%{?with_libcue}
  42. BuildRequires: pkgconfig(libcue)
  43. %endif
  44. BuildRequires: pkgconfig(libexif)
  45. %if 0%{?with_rss}
  46. BuildRequires: pkgconfig(libgrss)
  47. %endif
  48. BuildRequires: pkgconfig(libgsf-1)
  49. BuildRequires: pkgconfig(libgxps)
  50. #BuildRequires: pkgconfig(libiptcdata)
  51. BuildRequires: pkgconfig(libjpeg)
  52. #BuildRequires: pkgconfig(libosinfo-1.0)
  53. BuildRequires: pkgconfig(libpng)
  54. BuildRequires: pkgconfig(libseccomp)
  55. BuildRequires: pkgconfig(libtiff-4)
  56. BuildRequires: pkgconfig(libxml-2.0)
  57. BuildRequires: pkgconfig(poppler-glib)
  58. BuildRequires: pkgconfig(taglib_c)
  59. BuildRequires: pkgconfig(totem-plparser)
  60. BuildRequires: pkgconfig(tracker-sparql-2.0)
  61. BuildRequires: pkgconfig(upower-glib)
  62. BuildRequires: pkgconfig(vorbisfile)
  63. BuildRequires: pkgconfig(zlib)
  64. %if %{with systemd}
  65. %{?systemd_requires}
  66. %endif
  67. Requires(post,postun): desktop-file-utils
  68. Requires: tracker%{?_isa} >= %{tracker_version}
  69. # tracker-miners was split out from tracker in 1.99.2
  70. Obsoletes: tracker < 1.99.2
  71. Conflicts: tracker < 1.99.2
  72. %description
  73. Tracker is a powerful desktop-neutral first class object database,
  74. tag/metadata database and search tool.
  75. This package contains various miners and metadata extractors for tracker.
  76. %prep
  77. %autosetup -p1
  78. %build
  79. # Disable the functional tests for now, they use python bytecodes.
  80. %meson \
  81. -Dfunctional_tests=false \
  82. -Diptc=disabled \
  83. -Diso=disabled \
  84. -Dminer_rss=false \
  85. %if %{with systemd}
  86. -Dsystemd_user_services=%{_userunitdir}
  87. %endif
  88. %{nil}
  89. %meson_build
  90. %install
  91. %meson_install
  92. rm -rf %{buildroot}%{_datadir}/tracker-tests
  93. %find_lang %{name}
  94. %post
  95. %if %{with systemd}
  96. %systemd_user_post %{systemd_units}
  97. %endif
  98. if [ $1 -eq 1 ]; then
  99. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  100. update-desktop-database -q > /dev/null || :
  101. fi
  102. %if %{with systemd}
  103. %preun
  104. %systemd_user_preun %{systemd_units}
  105. %endif
  106. %postun
  107. %if %{with systemd}
  108. %systemd_user_postun_with_restart %{systemd_units}
  109. %endif
  110. if [ $1 -eq 0 ]; then
  111. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  112. update-desktop-database -q > /dev/null || :
  113. fi
  114. %files -f %{name}.lang
  115. %license COPYING
  116. %doc AUTHORS NEWS README.md
  117. %{_libdir}/tracker-miners-2.0/
  118. %{_libexecdir}/tracker*
  119. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  120. %{_datadir}/glib-2.0/schemas/*
  121. %{_datadir}/tracker/
  122. %{_datadir}/tracker-miners/
  123. %{_mandir}/man1/tracker-*.1*
  124. %config(noreplace) %{_sysconfdir}/xdg/autostart/tracker*.desktop
  125. %if %{with systemd}
  126. %{_userunitdir}/tracker*.service
  127. %endif
  128. %changelog
  129. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-2
  130. - rebuilt with icu-67.
  131. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.3-1
  132. - new upstream release.
  133. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1
  134. - initial build for Vine Linux.
  135. - new upstream release.
  136. * Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 2.3.0-1
  137. - Update to 2.3.0
  138. * Fri Sep 06 2019 Nikola Forró <nforro@redhat.com> - 2.2.99.1-2
  139. - Rebuilt for exempi 2.5.1
  140. * Fri Sep 06 2019 Kalev Lember <klember@redhat.com> - 2.2.99.1-1
  141. - Update to 2.2.99.1
  142. * Mon Aug 12 2019 Kalev Lember <klember@redhat.com> - 2.2.99.0-1
  143. - Update to 2.2.99.0
  144. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.2-2
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  146. * Fri May 03 2019 David King <amigadave@amigadave.com> - 2.2.2-1
  147. - Update to 2.2.2
  148. * Fri Mar 08 2019 Kalev Lember <klember@redhat.com> - 2.2.1-1
  149. - Update to 2.2.1
  150. * Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-3
  151. - Exclude private libraries from autogenerated provides and requires
  152. * Thu Feb 21 2019 Kalev Lember <klember@redhat.com> - 2.2.0-2
  153. - Fix the package to be installable again
  154. * Wed Feb 20 2019 Kalev Lember <klember@redhat.com> - 2.2.0-1
  155. - Update to 2.2.0
  156. - Switch to the meson build system
  157. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  159. * Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 2.1.5-3
  160. - Rebuild for ICU 63
  161. * Mon Jan 21 2019 Kevin Fenzi <kevin@scrye.com> - 2.1.5-2
  162. - Rebuild to drop libiptcdata deps
  163. * Fri Sep 28 2018 Kalev Lember <klember@redhat.com> - 2.1.5-1
  164. - Update to 2.1.5
  165. * Wed Sep 05 2018 Kalev Lember <klember@redhat.com> - 2.1.4-2
  166. - Rebuilt with fixed vala
  167. * Tue Sep 04 2018 Kalev Lember <klember@redhat.com> - 2.1.4-1
  168. - Update to 2.1.4
  169. * Mon Sep 03 2018 Kalev Lember <klember@redhat.com> - 2.1.3-1
  170. - Update to 2.1.3
  171. * Sun Aug 19 2018 Kalev Lember <klember@redhat.com> - 2.1.1-1
  172. - Update to 2.1.1
  173. * Wed Jul 25 2018 Kalev Lember <klember@redhat.com> - 2.1.0-1
  174. - Update to 2.1.0
  175. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.5-3
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  177. * Tue Jul 10 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.5-2
  178. - Rebuild for ICU 62
  179. * Tue Jun 26 2018 Kalev Lember <klember@redhat.com> - 2.0.5-1
  180. - Update to 2.0.5
  181. * Mon Apr 30 2018 Pete Walter <pwalter@fedoraproject.org> - 2.0.4-4
  182. - Rebuild for ICU 61.1
  183. * Sun Feb 11 2018 Sandro Mani <manisandro@gmail.com> - 2.0.4-3
  184. - Rebuild (giflib)
  185. * Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 2.0.4-2
  186. - Rebuild to really enable the RAW extractor
  187. * Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 2.0.4-1
  188. - Update to 2.0.4
  189. - Enable new gexiv2 based RAW extractor
  190. * Thu Nov 30 2017 Pete Walter <pwalter@fedoraproject.org> - 2.0.3-2
  191. - Rebuild for ICU 60.1
  192. * Tue Nov 21 2017 Kalev Lember <klember@redhat.com> - 2.0.3-1
  193. - Update to 2.0.3
  194. * Fri Oct 06 2017 Kalev Lember <klember@redhat.com> - 2.0.2-1
  195. - Update to 2.0.2
  196. * Tue Sep 19 2017 Kalev Lember <klember@redhat.com> - 2.0.0-3
  197. - Backport a fix for a crash when processing virtual elements (#1488707)
  198. * Fri Sep 15 2017 Kalev Lember <klember@redhat.com> - 2.0.0-2
  199. - Package review fixes (#1491725):
  200. - Pass --disable-mp3 to use the generic gstreamer extractor
  201. - Disable libstemmer support to match the previous behaviour
  202. - Fix removing .so symlinks for private libraries
  203. - Remove ldconfig rpm scripts as we don't install any shared libraries
  204. - Correct license tag and add comment explaining mixed source licensing
  205. * Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 2.0.0-1
  206. - Initial Fedora packaging