webkitgtk4-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340
  1. %bcond_with clang
  2. ## NOTE: Lots of files in various subdirectories have the same name (such as
  3. ## "LICENSE") so this short macro allows us to distinguish them by using their
  4. ## directory names (from the source tree) as prefixes for the files.
  5. %global add_to_license_files() \
  6. mkdir -p _license_files ; \
  7. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  8. Name: webkitgtk4
  9. Version: 2.28.1
  10. Release: 1%{?_dist_release}
  11. Summary: GTK+ Web content engine library
  12. Group: System Environment/Libraries
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. License: LGPLv2
  16. URL: http://www.webkitgtk.org/
  17. Source0: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  18. %if %{with clang}
  19. BuildRequires: clang
  20. BuildRequires: lld
  21. %endif
  22. BuildRequires: at-spi2-core-devel
  23. BuildRequires: bison
  24. BuildRequires: bubblewrap
  25. BuildRequires: cairo-devel
  26. BuildRequires: cmake
  27. BuildRequires: enchant-devel
  28. BuildRequires: flex
  29. BuildRequires: fontconfig-devel
  30. BuildRequires: freetype-devel
  31. BuildRequires: geoclue2-devel
  32. BuildRequires: gettext
  33. BuildRequires: glib2-devel
  34. BuildRequires: gobject-introspection-devel
  35. BuildRequires: gperf
  36. BuildRequires: gstreamer1-devel
  37. BuildRequires: gstreamer1-plugins-base-devel
  38. BuildRequires: gtk2-devel
  39. BuildRequires: gtk3-devel
  40. BuildRequires: harfbuzz-icu-devel
  41. BuildRequires: libicu-devel
  42. BuildRequires: libjpeg-turbo-devel
  43. BuildRequires: libpng-devel
  44. BuildRequires: libseccomp-devel
  45. BuildRequires: libsecret-devel
  46. BuildRequires: libsoup-devel
  47. BuildRequires: libwebp-devel
  48. BuildRequires: libxslt-devel
  49. BuildRequires: libXt-devel
  50. BuildRequires: ninja
  51. BuildRequires: mesa-libGL-devel
  52. BuildRequires: pcre-devel
  53. BuildRequires: python3-devel
  54. BuildRequires: ruby
  55. BuildRequires: sqlite3-devel
  56. BuildRequires: libnotify-devel
  57. BuildRequires: hyphen-devel
  58. BuildRequires: woff2-devel
  59. BuildRequires: xdg-dbus-proxy
  60. Requires: geoclue2
  61. # for sandbox
  62. Requires: bubblewrap
  63. Requires: xdg-dbus-proxy
  64. # Require the jsc subpackage
  65. Requires: %{name}-jsc = %{version}-%{release}
  66. # Obsolete libwebkit2gtk from the webkitgtk3 package
  67. Obsoletes: libwebkit2gtk < 2.4.5-3
  68. Provides: libwebkit2gtk = %{version}-%{release}
  69. # Filter out provides for private libraries
  70. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  71. %description
  72. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  73. GTK+ platform.
  74. This package contains WebKitGTK+ for GTK+ 3.
  75. %package devel
  76. Summary: Development files for %{name}
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: %{name}-jsc-devel = %{version}-%{release}
  80. %description devel
  81. The %{name}-devel package contains libraries, build data, and header
  82. files for developing applications that use %{name}.
  83. %package jsc
  84. Summary: JavaScript engine from %{name}
  85. Group: System Environment/Libraries
  86. %description jsc
  87. This package contains JavaScript engine from %{name}.
  88. %package jsc-devel
  89. Summary: Development files for JavaScript engine from %{name}
  90. Group: Development/Libraries
  91. Requires: %{name}-jsc = %{version}-%{release}
  92. %description jsc-devel
  93. The %{name}-jsc-devel package contains libraries, build data, and header
  94. files for developing applications that use JavaScript engine from %{name}.
  95. %prep
  96. %setup -q -n webkitgtk-%{version}
  97. # Remove bundled libraries
  98. rm -rf Source/ThirdParty/leveldb/
  99. rm -rf Source/ThirdParty/gtest/
  100. rm -rf Source/ThirdParty/qunit/
  101. %build
  102. # binutils-2.23 doesn't support "reduce-memory-overheads"
  103. # Use linker flags to reduce memory consumption
  104. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  105. %if %{with clang}
  106. %ifnarch x86_64
  107. %define cflags_add --rtlib=compiler-rt
  108. %endif
  109. %global optflags %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
  110. %else
  111. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  112. %endif
  113. mkdir -p %{_target_platform}
  114. pushd %{_target_platform}
  115. %if %{with clang}
  116. export CC=clang
  117. export CXX=clang++
  118. export LD=ld.lld
  119. %endif
  120. %cmake \
  121. -GNinja \
  122. %if %{with clang}
  123. -DCOMPILER_IS_CLANG=ON \
  124. -DCMAKE_CXX_COMPILER=clang++ \
  125. %endif
  126. -DPORT=GTK \
  127. -DCMAKE_BUILD_TYPE=Release \
  128. -DENABLE_JIT=OFF \
  129. -DENABLE_LLINT_C_LOOP=ON \
  130. -DUSE_GSTREAMER_GL=OFF \
  131. -DUSE_OPENJPEG=OFF \
  132. -DENABLE_GTKDOC=OFF \
  133. ..
  134. popd
  135. ninja -C %{_target_platform}
  136. %install
  137. DESTDIR=%{buildroot} ninja -C %{_target_platform} install
  138. %find_lang WebKit2GTK-4.0
  139. # Finally, copy over and rename various files for %%license inclusion
  140. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  141. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  142. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  143. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  144. %add_to_license_files Source/WebCore/icu/LICENSE
  145. %add_to_license_files Source/WebCore/LICENSE-APPLE
  146. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  147. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  148. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  149. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  150. %add_to_license_files Source/WTF/icu/LICENSE
  151. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  152. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  153. %post -p /sbin/ldconfig
  154. %postun -p /sbin/ldconfig
  155. %post jsc -p /sbin/ldconfig
  156. %postun jsc -p /sbin/ldconfig
  157. %files -f WebKit2GTK-4.0.lang
  158. %license _license_files/*
  159. %{_libdir}/libwebkit2gtk-4.0.so.*
  160. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  161. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  162. %{_libdir}/webkit2gtk-4.0/
  163. %{_libexecdir}/webkit2gtk-4.0/*
  164. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  165. %{_bindir}/WebKitWebDriver
  166. %files jsc
  167. %license _license_files/*JavaScriptCore*
  168. %dir %{_libexecdir}/webkit2gtk-4.0/
  169. %{_libexecdir}/webkit2gtk-4.0/jsc
  170. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  171. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  172. %files devel
  173. %{_includedir}/webkitgtk-4.0/*
  174. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  175. %{_libdir}/libwebkit2gtk-4.0.so
  176. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  177. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  178. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  179. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  180. %files jsc-devel
  181. %dir %{_includedir}/webkitgtk-4.0
  182. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  183. %{_libdir}/libjavascriptcoregtk-4.0.so
  184. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  185. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  186. %changelog
  187. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
  188. - new upstream release.
  189. - rebuilt with libicu67.
  190. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
  191. - rebuilt with libicu66.
  192. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
  193. - new upstream release.
  194. - dropped Patch1: fixed in upstream.
  195. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
  196. - new upstream release.
  197. - built with icu-65.
  198. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
  199. - new upstream release.
  200. - switched build-system to ninja.
  201. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
  202. - new upstream release.
  203. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
  204. - new upstream release.
  205. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  206. - new upstream release.
  207. - added subpackages webkitgtk4-jsc{,-devel}.
  208. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  209. - new upstream release.
  210. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  211. - rebuilt with new toolchain.
  212. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  213. - new upstream release
  214. (including security fix for CVE-2016-1856,1857)
  215. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  216. - new upstream release
  217. - remove Patch0
  218. - add BuildRequires: libnotify-devel, hyphen-devel
  219. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  220. - rebuild with gnutls-3.4.7
  221. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  222. - rebuild with icu-56.1
  223. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  224. - new upstream release
  225. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  226. - new upstream release
  227. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  228. - new upstream release
  229. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  230. - new upstream release
  231. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  232. - new upstream release
  233. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  234. - new upstream release
  235. - update Patch0
  236. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  237. - new upstream release
  238. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  239. - add Group tag
  240. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  241. - new upstream release
  242. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  243. - new upstream release
  244. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  245. - initial build for Vine Linux
  246. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  247. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  248. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  249. - Update to 2.6.0
  250. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  251. - Update to 2.5.90
  252. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  253. - Obsolete libwebkit2gtk from the webkitgtk3 package
  254. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  255. - rebuild for ICU 53.1
  256. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  257. - Add support for secondary arches
  258. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  259. - Add webkitgtk-2.5.3-toggle-buttons.patch
  260. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  261. - More package review fixes (#1131284)
  262. - Correct the license tag to read LGPLv2
  263. - Filter out provides for private libraries
  264. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  265. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  266. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  267. - Update to 2.5.3
  268. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  269. - Initial Fedora packaging, based on the webkitgtk3 package