elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global nocheck true
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  5. Name: elfutils
  6. Version: 0.183
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: bzip2
  19. BuildRequires: bzip2-devel
  20. BuildRequires: flex >= 2.5.4a
  21. BuildRequires: gcc >= 9.0.0
  22. BuildRequires: gettext
  23. BuildRequires: libzstd-devel
  24. BuildRequires: m4
  25. BuildRequires: xz-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: zstd
  28. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  29. BuildRequires: glibc-headers >= 2.3.4-11
  30. %define _gnu %{nil}
  31. %define _program_prefix eu-
  32. %description
  33. Elfutils is a collection of utilities, including ld (a linker),
  34. nm (for listing symbols from object files), size (for listing the
  35. section sizes of an object or archive file), strip (for discarding
  36. symbols), readelf (to see the raw ELF file structures), and elflint
  37. (to check for well-formed ELF files).
  38. %package libs
  39. Summary: Libraries to handle compiled objects
  40. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  41. License: GPLv2+ or LGPLv3+
  42. Group: system
  43. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  44. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  45. Conflicts: elfutils < %{version}-%{release}
  46. Conflicts: elfutils > %{version}-%{release}
  47. Conflicts: elfutils-devel < %{version}-%{release}
  48. Conflicts: elfutils-devel > %{version}-%{release}
  49. %description libs
  50. The elfutils-libs package contains libraries which implement DWARF, ELF,
  51. and machine-specific ELF handling. These libraries are used by the programs
  52. in the elfutils package. The elfutils-devel package enables building
  53. other programs using these libraries.
  54. %package devel
  55. Summary: Development libraries to handle compiled objects
  56. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  57. License: GPLv2+ or LGPLv3+
  58. Group: programming
  59. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  60. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  61. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  62. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  63. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  64. %description devel
  65. The elfutils-devel package contains the libraries to create
  66. applications for handling compiled objects. libebl provides some
  67. higher-level ELF access functionality. libdw provides access to
  68. the DWARF debugging information. libasm provides a programmable
  69. assembler interface.
  70. %package devel-static
  71. Summary: Static archives to handle compiled objects
  72. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  73. License: GPLv2+ or LGPLv3+
  74. Group: programming
  75. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  76. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  77. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  78. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  79. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  80. %description devel-static
  81. The elfutils-devel-static package contains the static archives
  82. with the code to handle compiled objects.
  83. %package libelf
  84. Summary: Library to read and write ELF files
  85. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  86. License: GPLv2+ or LGPLv3+
  87. Group: system
  88. Provides: libelf = %{version}-%{release}
  89. Obsoletes: libelf <= 0.8.2-2
  90. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  91. Conflicts: elfutils < %{version}-%{release}
  92. Conflicts: elfutils > %{version}-%{release}
  93. Conflicts: elfutils-libs < %{version}-%{release}
  94. Conflicts: elfutils-libs > %{version}-%{release}
  95. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  96. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  97. %description libelf
  98. The elfutils-libelf package provides a DSO which allows reading and
  99. writing ELF files on a high level. Third party programs depend on
  100. this package to read internals of ELF files. The programs of the
  101. elfutils package use it also to generate new ELF files.
  102. %package libelf-devel
  103. Summary: Development support for libelf
  104. Summary(ja): libelf の開発用ライブラリ
  105. License: GPLv2+ or LGPLv3+
  106. Group: programming
  107. Provides: libelf-devel = %{version}-%{release}
  108. Obsoletes: libelf-devel <= 0.8.2-2
  109. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  110. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  111. Conflicts: libelf-devel < %{version}-%{release}
  112. %description libelf-devel
  113. The elfutils-libelf-devel package contains the libraries to create
  114. applications for handling compiled objects. libelf allows you to
  115. access the internals of the ELF object file format, so you can see the
  116. different sections of an ELF file.
  117. %package libelf-devel-static
  118. Summary: Static archive of libelf
  119. Summary(ja): libelf の静的ライブラリ
  120. License: GPLv2+ or LGPLv3+
  121. Group: programming
  122. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  123. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  124. %description libelf-devel-static
  125. The elfutils-libelf-static package contains the static archive
  126. for libelf.
  127. # compat32
  128. %package -n compat32-%{name}-libelf
  129. Summary: Library to read and write ELF files
  130. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  131. License: GPLv2+ or LGPLv3+
  132. Group: system
  133. Provides: compat32-libelf = %{version}-%{release}
  134. %description -n compat32-%{name}-libelf
  135. The elfutils-libelf package provides a DSO which allows reading and
  136. writing ELF files on a high level. Third party programs depend on
  137. this package to read internals of ELF files. The programs of the
  138. elfutils package use it also to generate new ELF files.
  139. %debug_package
  140. %prep
  141. %setup -q
  142. autoreconf -f -v -i
  143. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  144. %build
  145. # Remove -Wall from default flags. The makefiles enable enough warnings
  146. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  147. # the makefiles disable some specific warnings for specific code.
  148. # But add -Wformat explicitly for use with -Werror=format-security which
  149. # doesn't work without -Wformat (enabled by -Wall).
  150. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  151. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  152. %configure \
  153. CFLAGS="$RPM_OPT_FLAGS -fexceptions" \
  154. --disable-debuginfod \
  155. --disable-libdebuginfod
  156. make -s %{?_smp_mflags}
  157. %install
  158. rm -rf ${RPM_BUILD_ROOT}
  159. make -s install DESTDIR=${RPM_BUILD_ROOT}
  160. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  161. %find_lang %{name}
  162. # XXX Nuke unpackaged files
  163. { cd ${RPM_BUILD_ROOT}
  164. rm -f .%{_bindir}/eu-ld
  165. }
  166. %check
  167. make -s check || (cat tests/test-suite.log; %{nocheck})
  168. %clean
  169. rm -rf ${RPM_BUILD_ROOT}
  170. %post libs -p /sbin/ldconfig
  171. %postun libs -p /sbin/ldconfig
  172. %post libelf -p /sbin/ldconfig
  173. %postun libelf -p /sbin/ldconfig
  174. %post -n compat32-%{name}-libelf -p /sbin/ldconfig
  175. %postun -n compat32-%{name}-libelf -p /sbin/ldconfig
  176. %files -f %{name}.lang
  177. %defattr(-,root,root)
  178. %doc README TODO
  179. %{_bindir}/eu-addr2line
  180. %{_bindir}/eu-ar
  181. %{_bindir}/eu-elfclassify
  182. %{_bindir}/eu-elfcmp
  183. %{_bindir}/eu-elflint
  184. %{_bindir}/eu-findtextrel
  185. %{_bindir}/eu-nm
  186. %{_bindir}/eu-objdump
  187. %{_bindir}/eu-ranlib
  188. %{_bindir}/eu-readelf
  189. %{_bindir}/eu-size
  190. %{_bindir}/eu-stack
  191. %{_bindir}/eu-strings
  192. %{_bindir}/eu-strip
  193. #%{_bindir}/eu-ld
  194. %{_bindir}/eu-unstrip
  195. %{_bindir}/eu-make-debug-archive
  196. %{_bindir}/eu-elfcompress
  197. %{_mandir}/man1/eu-*
  198. %files libs
  199. %defattr(-,root,root)
  200. %{_libdir}/libasm-%{version}.so
  201. %{_libdir}/libasm.so.*
  202. %{_libdir}/libdw-%{version}.so
  203. %{_libdir}/libdw.so.*
  204. %files devel
  205. %defattr(-,root,root)
  206. %{_includedir}/dwarf.h
  207. %dir %{_includedir}/elfutils
  208. %{_includedir}/elfutils/elf-knowledge.h
  209. %{_includedir}/elfutils/known-dwarf.h
  210. %{_includedir}/elfutils/libasm.h
  211. %{_includedir}/elfutils/libdw.h
  212. %{_includedir}/elfutils/libdwelf.h
  213. %{_includedir}/elfutils/libdwfl.h
  214. %{_includedir}/elfutils/version.h
  215. %{_libdir}/libasm.so
  216. %{_libdir}/libdw.so
  217. %{_libdir}/pkgconfig/libdw.pc
  218. %files devel-static
  219. %defattr(-,root,root)
  220. %{_libdir}/libasm.a
  221. %{_libdir}/libdw.a
  222. %files libelf
  223. %defattr(-,root,root)
  224. %{_libdir}/libelf-%{version}.so
  225. %{_libdir}/libelf.so.*
  226. %files libelf-devel
  227. %defattr(-,root,root)
  228. %{_includedir}/libelf.h
  229. %{_includedir}/gelf.h
  230. %{_includedir}/nlist.h
  231. %{_libdir}/libelf.so
  232. %{_libdir}/pkgconfig/libelf.pc
  233. %{_mandir}/man3/elf_*
  234. %files libelf-devel-static
  235. %defattr(-,root,root)
  236. %{_libdir}/libelf.a
  237. %if %{build_compat32}
  238. %files -n compat32-%{name}-libelf
  239. %defattr(-,root,root)
  240. %{_libdir}/libelf-%{version}.so
  241. %{_libdir}/libelf.so.*
  242. %endif
  243. %changelog
  244. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
  245. - new upstream release.
  246. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.177-1
  247. - new upstream release.
  248. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
  249. - rebuilt
  250. - 2vl7 was skipped (used for vl6)
  251. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  252. - updated to 0.170.
  253. - dropped all patches.
  254. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  255. - rebuild with gcc-5.4.0
  256. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  257. - create compat32-elfutils-libelf subpackage
  258. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  259. - update to 0.161
  260. - added Japanese summary
  261. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  262. - update to 0.157
  263. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  264. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  265. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  266. - update to 0.152
  267. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  268. - elfutils-libs: changed Group to System Environment/Libraries
  269. - elfutils-libelf: changed Group to System Environment/Libraries
  270. - elfutils-devel: changed Group to Development/Libraries
  271. - elfutils-devel-static: changed Group to Development/Libraries
  272. - elfutils-libelf-devel: changed Group to Development/Libraries
  273. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  274. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  275. - merged with Fedora 9 0.135-1
  276. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  277. - applied new versioning policy
  278. - added elfutils-0.131-readelf_c.patch
  279. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  280. - new upstream release
  281. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  282. - remove Obsoletes: libelf, libelf-devel from elfutils
  283. - add Obsoletes: libelf to elfutils-libelf
  284. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  285. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  286. - Update to 0.135
  287. - libdwfl: bug fixes
  288. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  289. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  290. - Update to 0.134
  291. - elflint: backend improvements for sparc, alpha (#204170)
  292. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  293. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  294. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  295. - Update to 0.133
  296. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  297. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  298. - libdwfl: bug fixes and optimization in relocation handling
  299. - elfcmp: bug fix for non-allocated section handling
  300. - ld: implement newer features of binutils linker.
  301. - Install eu-objdump and libasm, now has limited disassembler support.
  302. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  303. - Update to 0.132
  304. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  305. - eu-readelf: Fix handling of ET_REL files in archives.
  306. - libcpu: Implement x86 and x86-64 disassembler.
  307. - libasm: Add interface for disassembler.
  308. - all programs: add debugging of branch prediction.
  309. - libelf: new function elf_scnshndx.
  310. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  311. - Update to 0.131
  312. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  313. bug fixes for oddly-formatted DWARF
  314. - libdwfl: bug fixes in offline archive support, symbol table handling;
  315. apply partial relocations for dwfl_module_address_section on ET_REL
  316. - libebl: powerpc backend support for Altivec registers
  317. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  318. - Fix ET_REL support.
  319. - Fix odd indentation in eu-readelf -x output.
  320. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  321. - Update to 0.130
  322. - eu-readelf -p option can take an argument like -x for one section
  323. - eu-readelf --archive-index (or -c)
  324. - eu-readelf -n improved output for core dumps
  325. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  326. - eu-elflint: ditto
  327. - eu-elflint: stricter checks on debug sections
  328. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  329. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  330. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  331. - libebl: backend improvements (#324031)
  332. - libdwfl: build_id support, new functions for it
  333. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  334. - libdwfl offline archive support, new script eu-make-debug-archive
  335. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  336. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  337. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  338. - Update to 0.129
  339. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  340. - addr2line: new option --symbols (or -S)
  341. - libdw: dwarf_getscopes fixes (#230235)
  342. - libdwfl: dwfl_module_addrsym fixes (#249490)
  343. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  344. - Update to 0.128
  345. - new program: unstrip
  346. - elfcmp: new option --hash-inexact
  347. - Replace Conflicts: with Provides/Requires using -arch
  348. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  349. - Update to 0.127
  350. - libdw: new function dwarf_getsrcdirs
  351. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  352. dwfl_module_address_section
  353. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  354. - Update to 0.126
  355. - New program eu-ar.
  356. - libdw: fix missing dwarf_getelf (#227206)
  357. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  358. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  359. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  360. - Fix overeager warn_unused_result build failures.
  361. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  362. - Update to 0.125
  363. - elflint: Compare DT_GNU_HASH tests.
  364. - move archives into -static RPMs
  365. - libelf, elflint: better support for core file handling
  366. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  367. - Resolves: RHBZ #220817, RHBZ #213792
  368. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  369. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  370. - Update to 0.124
  371. - libebl: fix ia64 reloc support (#206981)
  372. - libebl: sparc backend support for return value location
  373. - libebl, libdwfl: backend register name support extended with more info
  374. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  375. - readelf, elflint: trivial bugs fixed
  376. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  377. - Update to 0.123
  378. - libebl: Backend build fixes, thanks to Stepan Kasal.
  379. - libebl: ia64 backend support for register names, return value location
  380. - libdwfl: Handle truncated linux kernel module section names.
  381. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  382. - elflint: Fix checks to permit --hash-style=gnu format.
  383. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  384. - Fix warnings in elflint compilation.
  385. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  386. - Update to 0.122
  387. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  388. - libebl: add function to test for relative relocation
  389. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  390. - elflint, readelf: add support for DT_GNU_HASH
  391. - libelf: add elf_gnu_hash
  392. - elflint, readelf: add support for 64-bit SysV-style hash tables
  393. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  394. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  395. - Update to 0.121
  396. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  397. - make all installed headers usable in C++ code (#193153).
  398. - eu-readelf: better output format.
  399. - eu-elflint: fix tests of dynamic section content.
  400. - libdw, libdwfl: handle files without aranges info.
  401. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  402. - rebuild to pick up -devel deps
  403. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  404. - Update to 0.120
  405. - License changed to GPL, with some exceptions for using
  406. the libelf, libebl, libdw, and libdwfl library interfaces.
  407. Red Hat elfutils is an included package of the Open Invention Network.
  408. - dwarf.h updated for DWARF 3.0 final specification.
  409. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  410. - libdwfl: New function dwfl_version; fixes for offline.
  411. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  412. - bump again for double-long bug on ppc(64)
  413. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  414. - rebuilt for new gcc4.1 snapshot and glibc changes
  415. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  416. - update to 0.119
  417. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  418. - rebuilt
  419. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  420. - update to 0.118
  421. - elflint: more tests.
  422. - libdwfl: New function dwfl_module_register_names.
  423. - libebl: New backend hook for register names.
  424. - Make sure -fexceptions is always in CFLAGS.
  425. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  426. - update to 0.117
  427. - libdwfl: New function dwfl_module_return_value_location (#166118)
  428. - libebl: Backend improvements for several CPUs
  429. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  430. - update to 0.116
  431. - libdw fixes, API changes and additions
  432. - libdwfl fixes (#169672)
  433. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  434. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  435. - Update requires/conflicts for better biarch update behavior.
  436. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  437. - update to 0.115
  438. - New program eu-strings.
  439. - libdw: New function dwarf_getscopes_die.
  440. - libelf: speed-ups of non-mmap reading.
  441. - Implement --enable-gcov option for configure.
  442. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  443. - update to 0.114
  444. - new program eu-ranlib
  445. - libdw: new calls for inlines
  446. - libdwfl: new calls for offline modules
  447. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  448. - update to 0.113
  449. - elflint: relax a bit. Allow version definitions for defined symbols
  450. against DSO versions also for symbols in nobits sections.
  451. Allow .rodata section to have STRINGS and MERGE flag set.
  452. - strip: add some more compatibility with binutils.
  453. - libdwfl: bug fixes.
  454. - Separate libdw et al into elfutils-libs subpackage.
  455. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  456. - update to 0.112
  457. - elfcmp: some more relaxation.
  458. - elflint: many more tests, especially regarding to symbol versioning.
  459. - libelf: Add elfXX_offscn and gelf_offscn.
  460. - libasm: asm_begin interface changes.
  461. - libebl: Add three new interfaces to directly access machine, class,
  462. and data encoding information.
  463. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  464. - update portability patch
  465. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  466. - update to 0.111
  467. - libdwfl library now merged into libdw
  468. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  469. - update to 0.110
  470. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  471. - update to 0.109
  472. - verify that libebl modules are from the same build
  473. - new eu-elflint checks on copy relocations
  474. - new program eu-elfcmp
  475. - new experimental libdwfl library
  476. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  477. - robustification of eu-strip and eu-readelf
  478. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  479. - more robustification
  480. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  481. - robustification
  482. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  483. - update to 0.108
  484. - merge strip fixes
  485. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  486. - update elf.h from glibc
  487. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  488. - fix strip -f byte-swapping bug
  489. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  490. - update to 0.107
  491. - readelf: improve DWARF output format
  492. - elflint: -d option to support checking separate debuginfo files
  493. - strip: fix ET_REL debuginfo files (#156341)
  494. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  495. - fix some bugs in new code, reenable make check
  496. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  497. - disable make check for most arches, for now
  498. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  499. - update to 0.106
  500. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  501. - update to 0.104
  502. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  503. - update to 0.103
  504. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  505. - update to 0.101.
  506. - use %%configure macro to get CFLAGS etc. right
  507. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  508. - upgrade to 0.99.
  509. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  510. - upgrade to 0.97.
  511. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  512. - upgrade to 0.96.
  513. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  514. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  515. warning
  516. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  517. - rebuilt
  518. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  519. - upgrade to 0.95.
  520. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  521. - rebuilt
  522. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  523. - rebuilt
  524. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  525. - upgrade to 0.94
  526. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  527. - upgrade to 0.93
  528. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  529. - full version
  530. - macroized spec file for GPL or OSL builds
  531. - include only libelf under GPL plus wrapper scripts
  532. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  533. - macroized spec file for GPL or OSL builds
  534. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  535. - split elfutils-devel into two packages.
  536. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  537. - include only libelf under GPL plus wrapper scripts
  538. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  539. - readelf, not readline, in %%description (#111214).
  540. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  541. - update to 0.89 (fix eu-strip)
  542. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  543. - update to 0.86 (fix eu-strip on s390x/alpha)
  544. - libebl is an archive now; remove references to DSO
  545. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  546. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  547. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  548. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  549. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  550. - upgrade to 0.82 (strip tests fixed on big-endian).
  551. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  552. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  553. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  554. - upgrade to 0.80 (debugedit changes for kernel in progress).
  555. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  556. - rebuilt
  557. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  558. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  559. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  560. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  561. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  562. - debuginfo rebuild
  563. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  564. - use the correct way of identifying the section via the sh_info link.
  565. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  566. - update to 0.75 (eu-strip -g fix)
  567. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  568. - update to 0.74 (fix for writing with some non-dirty sections)
  569. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  570. - another -0.73 update (with sparc fixes).
  571. - do "make check" in %%check, not %%install, section.
  572. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  573. - update to 0.73 (with s390 fixes).
  574. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  575. - rebuilt
  576. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  577. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  578. - fix other warnings
  579. - reenable checks on s390x
  580. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  581. - temporarily disable checks on s390x, until someone has
  582. time to look at it
  583. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  584. - update to 0.72
  585. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  586. - update to 0.71
  587. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  588. - update to 0.69.
  589. - add "make check" and segfault avoidance patch.
  590. - elfutils-libelf needs to run ldconfig.
  591. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  592. - update to 0.68.
  593. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  594. - update to 0.67.
  595. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  596. - update to 0.65.
  597. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  598. - update to 0.64.
  599. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  600. - split packages further into elfutils-libelf
  601. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  602. - update to 0.63.
  603. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  604. - Adjust for dropping libtool
  605. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  606. - update to 0.59
  607. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  608. - update to 0.56
  609. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  610. - update to 0.54
  611. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  612. - update to 0.53
  613. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  614. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  615. - get beehive to punch a rhpkg generated package.
  616. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  617. - build in 8.0.1.
  618. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  619. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  620. - Add libelf-devel to conflicts for elfutils-devel
  621. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  622. - Split into runtime and devel package
  623. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  624. - integrate into official sources
  625. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  626. - Swaddle.