libidn-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Disable static library creation by default.
  3. %define with_static 0
  4. Name: libidn
  5. Summary: Internationalized Domain Name support library
  6. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  7. Version: 1.36
  8. Release: 1%{?_dist_release}
  9. Group: system
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. License: GPLv3+ and LGPLv3+
  13. URL: https://www.gnu.org/software/libidn/
  14. Source0: https://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gettext
  17. BuildRequires: pkgconfig
  18. Requires(post): /sbin/install-info
  19. Requires(preun): /sbin/install-info
  20. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  21. %description
  22. GNU Libidn is an implementation of the Stringprep, Punycode and
  23. IDNA specifications defined by the IETF Internationalized Domain
  24. Names (IDN) working group, used for internationalized domain
  25. names.
  26. %package devel
  27. Summary: Development files for the libidn library
  28. Summary(ja): libidn ライブラリの開発用ファイル
  29. Group: programming
  30. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  31. Requires: %{name} = %{version}-%{release}
  32. Provides: pkgconfig(libidn) = %{version}
  33. %description devel
  34. This package includes header files and libraries necessary for
  35. developing programs which use the GNU libidn library.
  36. # compat32
  37. %package -n compat32-%{name}
  38. Summary: Internationalized Domain Name support library
  39. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  40. Group: system
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n compat32-%{name}
  43. GNU Libidn is an implementation of the Stringprep, Punycode and
  44. IDNA specifications defined by the IETF Internationalized Domain
  45. Names (IDN) working group, used for internationalized domain
  46. names.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development files for the libidn library
  49. Summary(ja): libidn ライブラリの開発用ファイル
  50. Group: programming
  51. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  52. Requires: compat32-%{name} = %{version}-%{release}
  53. Requires: %{name}-devel = %{version}-%{release}
  54. %description -n compat32-%{name}-devel
  55. This package includes header files and libraries necessary for
  56. developing programs which use the GNU libidn library.
  57. %debug_package
  58. %prep
  59. %setup -q
  60. %build
  61. %configure --disable-csharp --disable-java \
  62. %if ! %{with_static}
  63. --disable-static
  64. %endif
  65. make %{?_smp_mflags}
  66. make %{?_smp_mflags} -C tests check
  67. %install
  68. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  69. %makeinstall
  70. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
  71. # provide more examples
  72. make %{?_smp_mflags} -C examples distclean
  73. # clean up docs
  74. find doc -name "Makefile*" | xargs rm
  75. rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
  76. %find_lang %{name}
  77. %clean
  78. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  79. %post
  80. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
  81. /sbin/ldconfig
  82. %preun
  83. if [ $1 = 0 ]; then
  84. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
  85. fi
  86. %postun -p /sbin/ldconfig
  87. %if %{build_compat32}
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %endif
  91. %files -f %{name}.lang
  92. %defattr(-,root,root)
  93. %license COPYING*
  94. %doc AUTHORS ChangeLog NEWS FAQ README THANKS
  95. %{_bindir}/idn
  96. %{_mandir}/man1/idn.1*
  97. %{_datadir}/emacs/site-lisp
  98. %{_libdir}/libidn.so.*
  99. #{_libdir}/libidn.la
  100. %{_infodir}/*
  101. %files devel
  102. %defattr(0644,root,root,755)
  103. %doc doc/libidn.html doc/libidn-components.png examples contrib
  104. %{_libdir}/libidn.so
  105. %if %{with_static}
  106. %{_libdir}/libidn.a
  107. %endif
  108. %{_includedir}/*.h
  109. %{_libdir}/pkgconfig/*.pc
  110. %{_mandir}/man3/*
  111. # compat32
  112. %if %{build_compat32}
  113. %files -n compat32-%{name}
  114. %defattr(-,root,root)
  115. %{_libdir}/libidn.so.*
  116. #{_libdir}/libidn.la
  117. %files -n compat32-%{name}-devel
  118. %defattr(0644,root,root,755)
  119. %{_libdir}/libidn.so
  120. %if %{with_static}
  121. %{_libdir}/libidn.a
  122. %endif
  123. %{_libdir}/pkgconfig/*.pc
  124. %endif
  125. %changelog
  126. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.36-1
  127. - new upstream release.
  128. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.35-1
  129. - new upstream release.
  130. * Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.29-1
  131. - new upstream release
  132. - added Japanese summary
  133. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
  134. - new upstream release
  135. * Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
  136. - new upstream release
  137. - built with rpm-4.8.1
  138. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
  139. - added compat32 package for x86_64 arch support.
  140. - disabled static library creation by default.
  141. * Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
  142. - new upstream release
  143. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
  144. - new upstream release
  145. - applied new versioning policy
  146. - added --disable-csharp and --disable-java options to %%configure
  147. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
  148. - new upstream release
  149. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
  150. - new upstream release
  151. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
  152. - rebuild for VineSeed
  153. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
  154. - new upstream release
  155. * Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
  156. - rebuild for VineSeed
  157. * Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
  158. - new upstream release
  159. - build for Vine Linux 3.1
  160. * Thu Oct 7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
  161. - update to 0.5.6 (#134343)
  162. * Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
  163. - Fix Group: (#134068)
  164. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
  165. - move ldconfig from preun to postun (#131280)
  166. * Sun Aug 8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
  167. - update to 0.5.4 (#129341)
  168. * Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
  169. - upgrade to 0.5.2, enabled i18n support and info files (#127906)
  170. * Fri Jul 9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
  171. - update to 0.5.1 (#127496)
  172. * Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
  173. - update to 0.5.0 (#126836)
  174. * Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
  175. - add prereq: /sbin/ldconfig
  176. - move la file in main package
  177. * Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
  178. - upgrade to 0.4.9 (#126353)
  179. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  180. - rebuilt
  181. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
  182. - update to 0.4.4; remove contrib from -devel docs
  183. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
  184. - update to 0.4.3, remove -rpath patch
  185. * Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
  186. - update to 0.3.7, simplify
  187. * Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
  188. - 0.3.6
  189. * Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
  190. - 0.3.5
  191. * Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
  192. - drop the "soname fix" and use the correct way...
  193. * Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
  194. - 0.3.3
  195. * Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
  196. - initial cooker contrib
  197. - used the package from PLD as a start point