python-virtualenv-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201
  1. %global oname virtualenv
  2. Summary: Tool to create isolated Python environments
  3. Summary(ja): 隔離されたPython環境を構築するためのツール
  4. Name: python-%{oname}
  5. Version: 20.0.31
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: yasumichi
  11. License: MIT
  12. URL: https://pypi.python.org/pypi/%{oname}
  13. Source0: https://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
  14. # Add /usr/share/python-wheels to extra_search_dir
  15. BuildArch: noarch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: python-rpm-macros
  18. BuildRequires: python2-rpm-macros
  19. BuildRequires: python-devel
  20. BuildRequires: python-setuptools
  21. Requires: python-devel
  22. Requires: python-setuptools
  23. BuildRequires: python3-rpm-macros
  24. BuildRequires: python3-setuptools
  25. BuildRequires: python3-devel
  26. %description
  27. virtualenv is a tool to create isolated Python environments. virtualenv
  28. is a successor to workingenv, and an extension of virtual-python. It is
  29. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  30. licensed under an MIT-style permissive license.
  31. %package -n python3-virtualenv
  32. Summary: Tool to create isolated Python environments
  33. Summary(ja): 隔離されたPython環境を構築するためのツール
  34. Group: programming
  35. Requires: python3-setuptools
  36. Requires: python3-devel
  37. %description -n python3-virtualenv
  38. virtualenv is a tool to create isolated Python environments. virtualenv
  39. is a successor to workingenv, and an extension of virtual-python. It is
  40. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  41. licensed under an MIT-style permissive license
  42. %prep
  43. %setup -q -n %{oname}-%{version}
  44. %{__sed} -i -e "1s|#!/usr/bin/env python||" tasks/update_embedded.py
  45. # Remove the wheels provided by RPM packages
  46. rm src/virtualenv/seed/wheels/embed/pip-*
  47. rm src/virtualenv/seed/wheels/embed/setuptools-*
  48. rm src/virtualenv/seed/wheels/embed/wheel-*
  49. test ! -f src/virtualenv/seed/embed/wheels/*.whl
  50. %build
  51. # Build code
  52. %{py2_build}
  53. %{py3_build}
  54. %install
  55. rm -rf %{buildroot}
  56. %{py2_install}
  57. # The versioned 2.x script was removed from upstream. Add it back.
  58. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python_version}
  59. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-2
  60. rm %{buildroot}/%{_bindir}/virtualenv
  61. %{py3_install}
  62. # The versioned 3.x script was removed from upstream. Add it back.
  63. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python3_version}
  64. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-3
  65. %clean
  66. rm -rf %{buildroot}
  67. %files
  68. %defattr(-,root,root,-)
  69. %license LICENSE
  70. %doc docs/*rst README*
  71. %{_bindir}/virtualenv-2
  72. %{_bindir}/virtualenv-%{python_version}
  73. %{python_sitelib}/*
  74. %files -n python3-virtualenv
  75. %license LICENSE
  76. %doc docs/*rst README*
  77. %{_bindir}/virtualenv
  78. %{_bindir}/virtualenv-3
  79. %{_bindir}/virtualenv-%{python3_version}
  80. %{python3_sitelib}/virtualenv
  81. %{python3_sitelib}/virtualenv-*.egg-info/
  82. %changelog
  83. * Sat Aug 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.0.31-1
  84. - new upstream release.
  85. - made python3 primary (/usr/bin/virtualenv).
  86. - dropped Patch0.
  87. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.1.0-1
  88. - new upstream release.
  89. - added Patch0.
  90. - made to use python{,3}-rpm-macros.
  91. - added a sub-package for python3.
  92. * Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
  93. - new upstream release
  94. - add Vendor, Distribution and Packager
  95. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
  96. - rebuild with python-2.7.2
  97. * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
  98. - updated virtualenv to 1.5.1
  99. * Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
  100. - initial build for Vine Linux
  101. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
  102. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  103. * Wed Jul 7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
  104. - Fixed EPEL installation issue from BZ#611536
  105. * Tue Jun 8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
  106. - Only replace the python shebang on the first line (Robert Buchholz)
  107. * Wed Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
  108. - update pip to 0.7
  109. - move regen-docs into bin/
  110. - Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
  111. unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
  112. - unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
  113. - use the activate.sh in virtualenv.py via running bin/rebuild-script.py
  114. - add warning message if PYTHONHOME is set
  115. * Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
  116. - allow script creation without setuptools
  117. - fix problem with --relocate when bin/ has subdirs (fixes #12)
  118. - Allow more flexible .pth file fixup
  119. - make nt a required module, along with posix. it may not be a builtin module on jython
  120. - don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
  121. * Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
  122. - Updated for upstream release.
  123. * Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
  124. - Updated for upstream release.
  125. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  127. * Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
  128. - Updated for upstream release.
  129. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  131. * Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
  132. - Updated for upstream release.
  133. * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
  134. - Rebuild for Python 2.6
  135. * Mon Dec 1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
  136. - Added missing dependencies.
  137. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
  138. - Rebuild for Python 2.6
  139. * Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
  140. - Updated for upstream release
  141. * Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
  142. - Updated for upstream release
  143. * Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
  144. - Updated for upstream release
  145. * Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
  146. - Updated from review notes
  147. * Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
  148. - Updated from review notes
  149. * Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
  150. - Initial Version