perl-EV-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. Name: perl-EV
  2. Version: 4.25
  3. Release: 1%{?_dist_release}
  4. Summary: Wrapper for the libev high-performance event loop library
  5. Summary(ja): 高性能イベントループライブラリ libev の Perl ラッパー
  6. Group: Development/Libraries
  7. # Note: The source archive includes a libev/ folder which contents are licensed
  8. # as "BSD or GPLv2+". However, those are removed at build-time and
  9. # perl-EV is instead built against the system-provided libev.
  10. License: GPL+ or Artistic
  11. URL: http://search.cpan.org/dist/EV/
  12. Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
  13. Patch0: perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: perl(common::sense)
  18. BuildRequires: gdbm-devel
  19. BuildRequires: libxcrypt-devel
  20. BuildRequires: libev-source >= %{version}
  21. BuildRequires: perl(AnyEvent)
  22. BuildRequires: perl(Canary::Stability)
  23. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  24. # As per review, a perl-EV-devel subpackage had at first been pushed to the
  25. # repositories. It now has broken deps if it's not properly obsoleted/provided.
  26. # TODO: Remove those two lines during the Fedora 17 development cycle.
  27. Provides: %{name}-devel = %{version}-%{release}
  28. Obsoletes: %{name}-devel < 4.03-5
  29. %{?perl_default_filter}
  30. %description
  31. This module provides an interface to libev
  32. (<http://software.schmorp.de/pkg/libev.html>). While the included documentation
  33. is comprehensive, one might also consult the documentation of libev itself
  34. (<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
  35. semantics or some discussion on the available backends, or how to force a
  36. specific backend with "LIBEV_FLAGS", or just about in any case because it has
  37. much more detailed information.
  38. %prep
  39. %setup -q -n EV-%{version}
  40. # no questins during build
  41. %patch0 -p1
  42. # remove all traces of the bundled libev
  43. rm -fr libev/*
  44. # use the sources from the system libev
  45. mkdir -p ./libev
  46. cp -r /usr/share/libev-source/* ./libev/
  47. %build
  48. echo "y" | %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  49. make %{?_smp_mflags}
  50. %install
  51. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  52. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  53. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  54. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  55. chmod -R u+w %{buildroot}/*
  56. %check
  57. make test
  58. %clean
  59. rm -rf %{buildroot}
  60. %files
  61. %defattr(-,root,root,-)
  62. %license COPYING
  63. %doc Changes README
  64. %{perl_vendorarch}/auto/*
  65. %{perl_vendorarch}/EV.pm
  66. %{perl_vendorarch}/EV
  67. %{perl_vendorarch}/EV/*.h
  68. %{_mandir}/man3/*.3*
  69. %changelog
  70. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.25-1
  71. - new upstream release.
  72. - rebuilt with perl-5.26.
  73. - added BR:libxcrypt-devel.
  74. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.03-2
  75. - build with Perl 5.16
  76. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
  77. - initial build for Vine Linux
  78. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  80. * Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
  81. - Build-require exact or higher version of libev-source (bug #759021)
  82. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
  83. - Perl mass rebuild
  84. * Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
  85. - Add the correct Obsoletes/Provides to avoid broken deps from the -devel
  86. subpackage removal.
  87. * Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
  88. - Readded the header file to the main package, as per guidelines:
  89. -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
  90. * Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
  91. - Some more fixes as part of the review process:
  92. - Fix the license tag to be only the license of perl-EV, and add a note about
  93. the included libev sources.
  94. - Removed manual cleaning of the buildroot since it has been useless since
  95. Fedora 10 and even EPEL (>=6) doesn't need it now.
  96. * Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
  97. - Fixes asked during the review process:
  98. - Filter the private shared EV.so out of the automatic Provides
  99. - Put the header files in a -devel package
  100. - Removed the Buildroot line since it's useless for newer versions of Fedora
  101. and this package can only go in Fedora >= 15 due to its libev dependency)
  102. * Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
  103. - Update to 4.03.
  104. - Use the system libev instead of the bundled one.
  105. * Sun Nov 8 2009 kwizart < kwizart at gmail.com > - 3.8-1
  106. - Update to 3.8
  107. * Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
  108. - Update to 3.6
  109. * Mon Mar 2 2009 kwizart < kwizart at gmail.com > - 3.53-1
  110. - Update to 3.53
  111. * Tue Feb 3 2009 kwizart < kwizart at gmail.com > - 3.52-1
  112. - Update to 3.52
  113. * Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
  114. - Update to 3.44
  115. - WIP conditional --with systemlibev
  116. * Tue Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
  117. - Update to 3.431
  118. - Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
  119. - Add libev README and LICENSE
  120. * Tue Jul 8 2008 kwizart < kwizart at gmail.com > - 3.43-1
  121. - Update to 3.43
  122. * Mon Jun 9 2008 kwizart < kwizart at gmail.com > - 3.42-2
  123. - Disable filter AnyEvent
  124. * Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
  125. - Update to 3.42
  126. * Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
  127. - Initial package for Fedora