Browse Source

2014-11-01 Ryoichi INAGAKI <ryo1@toki.waseda.jp>

	* libev, xmlsec1: updated
	* accountsservice, ctpl, poppler-data: changed Group
	


git-svn-id: http://trac.vinelinux.org/repos/projects/specs@9049 ec354946-7b23-47d6-9f5a-488ba84defc7
inagaki 8 years ago
parent
commit
fd3cea1f53

+ 26 - 7
a/accountsservice/accountsservice-vl.spec

@@ -1,8 +1,8 @@
-
 Name:           accountsservice
 Version:        0.6.37
-Release:        1%{?_dist_release}
+Release:        2%{?_dist_release}
 Summary:        D-Bus interfaces for querying and manipulating user account information
+Summary(ja):    ユーザーアカウント情報の問合せや処理を行うための D-Bus インターフェース
 
 Group:          System Environment/Daemons
 License:        GPLv3+
@@ -11,8 +11,9 @@ URL:            http://www.fedoraproject.org/wiki/Features/UserAccountDialog
 Source0:        http://mclasen.fedorapeople.org/accounts/accountsservice-%{version}.tar.xz
 
 # for Vine Linux
-Patch1000:			accountsservice-0.6.37-vine-environment.patch
+Patch1000:	accountsservice-0.6.37-vine-environment.patch
 
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:  glib2-devel
 BuildRequires:  dbus-glib-devel
 BuildRequires:  polkit-devel
@@ -36,8 +37,9 @@ of these interfaces, based on the useradd, usermod and userdel commands.
 
 
 %package libs
-Summary: Client-side library to talk to accountservice
-Group: Development/Libraries
+Summary: Client-side library to talk to accountsservice
+Summary(ja): accountsservice と対話するためのクライアント側ライブラリ
+Group: System Environment/Libraries
 Requires: %{name} = %{version}-%{release}
 
 %description libs
@@ -48,6 +50,7 @@ daemon.
 
 %package devel
 Summary: Development files for accountsservice-libs
+Summary(ja): accountsservice-libs の開発用ファイル
 Group: Development/Libraries
 Requires: %{name}-libs = %{version}-%{release}
 
@@ -74,17 +77,28 @@ This package contains documentation for %{name}.
 %build
 autoreconf -if
 %configure \
-	--with-minimum-uid=500
+    --disable-static \
+    --with-minimum-uid=500 
 make %{?_smp_mflags}
 
 
 %install
+rm -rf $RPM_BUILD_ROOT
+
 make install DESTDIR=$RPM_BUILD_ROOT
 rm $RPM_BUILD_ROOT%{_libdir}/*.la
-rm $RPM_BUILD_ROOT%{_libdir}/*.a
+
 %find_lang accounts-service
 
 
+%post libs -p /sbin/ldconfig
+
+%postun libs -p /sbin/ldconfig
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
 %files -f accounts-service.lang
 %defattr(-,root,root,-)
 %doc COPYING README AUTHORS
@@ -116,6 +130,11 @@ rm $RPM_BUILD_ROOT%{_libdir}/*.a
 %{_datadir}/gtk-doc/html/libaccountsservice/
 
 %changelog
+* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.37-2
+- moved libs package to System Environment/Libraries
+- added %%post, %%postun and %%clean section
+- added Japanese summary
+
 * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.37-1
 - new upstream release
 - add Patch1000 (accountsservice-0.6.37-vine-environment.patch)

+ 14 - 11
c/ctpl/ctpl-vl.spec

@@ -2,7 +2,7 @@
 
 Name:           ctpl
 Version:        0.3.3
-Release:        2%{?_dist_release}
+Release:        3%{?_dist_release}
 Summary:        Template engine library written in C
 Summary(ja):    C で書かれたテンプレートエンジンライブラリ
 
@@ -10,8 +10,8 @@ Group:          Development/Tools
 License:        GPLv3+
 URL:            http://ctpl.tuxfamily.org/
 Source0:        http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
-BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 
+BuildRoot:      %{_tmppath}/%{name}-%{version}-root
 BuildRequires:  glib2-devel >= 2.10
 Requires:       ctpl-libs = %{version}-%{release}
 
@@ -32,8 +32,8 @@ CTPL has following features:
 
 %package libs
 Summary: Template library written in C
-Summary(ja):  C で書かれたテンプレートライブラリ
-Group:     Development/Tools
+Summary(ja): C で書かれたテンプレートライブラリ
+Group: System Environment/Libraries
 
 %description libs
 This package contains the CTPL library.
@@ -44,9 +44,9 @@ This package contains the CTPL library.
 
 %package devel
 Summary: Development headers of the template library written in C
-Summary(ja):  C で書かれたテンプレートライブラリの開発ヘッダ
-Group:     Development/Tools
-Requires:  ctpl-libs = %{version}-%{release}
+Summary(ja): C で書かれたテンプレートライブラリの開発ヘッダ
+Group:  Development/Libraries
+Requires: ctpl-libs = %{version}-%{release}
 
 %description devel
 This package contains the development headers of the CTPL library.
@@ -55,13 +55,11 @@ This package contains the development headers of the CTPL library.
 %package doc
 Summary:   Documentation for the CTPL library
 Summary:   CTPL ライブラリのドキュメント
-Group:     Development/Tools
+Group:     Documentation
+BuildArch: noarch
 Requires:  ctpl-libs = %{version}-%{release}
 Requires:  gtk-doc
 
-BuildArch: noarch
-
-
 %description doc
 This package contains the HTML documentation reference for the CTPL library.
 
@@ -130,6 +128,11 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Sat Nov  2 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.3.3-3
+- moved libs to System Environment/Libraries Group
+- moved devel to Development/Libraries Group
+- moved doc to Documentation Group
+
 * Sat May 24 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.3-2
 - rebuild with new toolchain
 

+ 22 - 15
lib/libe/libev/libev-vl.spec

@@ -2,15 +2,17 @@
 %global inst_srcdir %{buildroot}/%{source_dir}
 
 Name:		libev
-Version:	4.04
+Version:	4.19
 Release:	1%{?_dist_release}
 Summary:	High-performance event loop/event model with lots of features
-Summary(ja):    高機能・高性能のイベントループ・イベントモデル
+Summary(ja):    鬮俶ゥ溯�繝サ鬮俶€ァ閭ス縺ョ繧、繝吶Φ繝医Ν繝シ繝励�繧、繝吶Φ繝医Δ繝�Ν
 Group:		System Environment/Libraries
 License:	BSD or GPLv2+
 URL:		http://software.schmorp.de/pkg/libev.html
 Source0:	http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
 Source1:	%{name}.pc.in
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:	automake libtool
 
 %description
@@ -19,14 +21,15 @@ module, but is faster, scales better and is more correct, and also more
 featureful. And also smaller.
 
 %description -l ja
-libev は libevent および Perl の Event を大まかに参考にして作られましたが、
-それらより高速に動作し、よりスケールし、より正確で、より高機能で、
-同時によりコンパクトです。
+libev 縺ッ libevent 縺翫h縺ウ Perl 縺ョ Event 繧貞、ァ縺セ縺九↓蜿り€�↓縺励※菴懊i繧後∪縺励◆縺後€�
+縺昴l繧峨h繧企ォ倬€溘↓蜍穂ス懊@縲√h繧翫せ繧ア繝シ繝ォ縺励€√h繧頑ュ」遒コ縺ァ縲√h繧企ォ俶ゥ溯�縺ァ縲�
+蜷梧凾縺ォ繧医j繧ウ繝ウ繝代け繝医〒縺吶€�
 
 
 %package 	devel
-Summary:	High-performance event loop/event model with lots of features
-Group:		System Environment/Libraries
+Summary:        Development files for %{name}
+Summary(ja):    %{name} 縺ョ髢狗匱逕ィ繝輔ぃ繧、繝ォ
+Group:		Development/Libraries
 Requires:	%{name}%{?_isa} = %{version}-%{release}
 Requires:	pkgconfig
 
@@ -36,15 +39,14 @@ module, but is faster, scales better and is more correct, and also more
 featureful. And also smaller. Development libraries.
 
 %description    devel -l ja
-このパッケージには libev 用開発ライブラリとヘッダが収録されています。
+縺薙�繝代ャ繧ア繝シ繧ク縺ォ縺ッ libev 逕ィ髢狗匱繝ゥ繧、繝悶Λ繝ェ縺ィ繝倥ャ繝€縺悟庶骭イ縺輔l縺ヲ縺�∪縺吶€�
 
 
 %package	source
-Summary:	High-performance event loop/event model with lots of features
-Group:		System Environment/Libraries
-%if 0%{?fedora} >= 12 || 0%{?rhel} > 5
-BuildArch:     noarch
-%endif
+Summary:	Source code for libev
+Summary(ja):	libev 縺ョ繧ス繝シ繧ケ繧ウ繝シ繝�
+Group:		Development/Libraries
+BuildArch:      noarch
 
 %description	source
 This package contains the source code for libev.
@@ -54,7 +56,7 @@ module, but is faster, scales better and is more correct, and also more
 featureful. And also smaller. Development libraries.
 
 %description    source -l ja
-このパッケージには libev のソースコードが収録されています。
+縺薙�繝代ャ繧ア繝シ繧ク縺ォ縺ッ libev 縺ョ繧ス繝シ繧ケ繧ウ繝シ繝峨′蜿朱鹸縺輔l縺ヲ縺�∪縺吶€�
 
 
 %prep
@@ -116,6 +118,11 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
+- updated to 4.19
+- spec in UTF-8
+- moved devel and source packages to Development/Libraries Group
+
 * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
 - initial build for Vine Linux
 
@@ -127,7 +134,7 @@ rm -rf %{buildroot}
 - cleanup spec
 - update to 4.04
 
-* Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
+* Mon Jun 13 2011 Mat��ャイ Cepl <mcepl@redhat.com> - 4.03-2
 - EL5 cannot have noarch subpackages.
 
 * Sat Feb  5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1

+ 10 - 5
p/poppler-data/poppler-data-vl.spec

@@ -1,6 +1,6 @@
 %define name	poppler-data
 %define version	0.4.7
-%define release	1%{?_dist_release}
+%define release	2%{?_dist_release}
 
 Summary:	Poppler encoding data.
 Summary(ja): 	Poppler 用のエンコード用データ
@@ -8,7 +8,7 @@ Name:		%{name}
 Version:	%{version}
 Release: 	%{release}
 Source0:	http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
-License:	GPL
+License:	GPLv2 with exceptions
 Group:		System Environment/Libraries
 URL:		http://poppler.freedesktop.org/
 
@@ -31,6 +31,8 @@ Cyrillic properly.
 
 %package devel
 Summary: Developer files for %{name}
+Summary(ja): %{name} の開発用ファイル
+Group: Developmnet/Libraries
 Requires: %{name} = %{version}-%{release}
 
 %description devel
@@ -41,12 +43,12 @@ This package consists of development files for poppler.
 %setup -q
 
 %install
-%{__rm} -rf ${RPM_BUILD_ROOT}
-%{__make} DESTDIR=${RPM_BUILD_ROOT} datadir=%{_datadir} install
+%{__rm} -rf $RPM_BUILD_ROOT
+%{__make} DESTDIR=$RPM_BUILD_ROOT datadir=%{_datadir} install
 
 
 %clean
-%{__rm} -rf ${RPM_BUILD_ROOT}
+%{__rm} -rf $RPM_BUILD_ROOT
 
 
 %files
@@ -58,6 +60,9 @@ This package consists of development files for poppler.
 %{_datadir}/pkgconfig/poppler-data.pc
 
 %changelog
+* Sat Nov 02 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.7-2
+- added Group tag to devel package
+
 * Fri Sep 05 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.7-1
 - new upstream release
 - splitted subpackage -devel

+ 35 - 57
x/xmlsec1/xmlsec1-vl.spec

@@ -1,19 +1,26 @@
 Summary: Library providing support for "XML Signature" and "XML Encryption" standards
 Name: xmlsec1
-Version: 1.2.16
+Version: 1.2.20
 Release: 1%{?_dist_release}
 License: MIT
 Group: System Environment/Libraries
+URL: http://www.aleksey.com/xmlsec/
 Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
+
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
-URL: http://www.aleksey.com/xmlsec/
-Requires: libxml2 >= 2.6.0
-Requires: libxslt >= 1.1.0
 BuildRequires: libxml2-devel >= 2.6.0
 BuildRequires: libxslt-devel >= 1.1.0
+BuildRequires: openssl-devel >= 0.9.6
+BuildRequires: libgcrypt-devel >= 1.4.0
+BuildRequires: gnutls-devel >= 1.0.20
+BuildRequires: nss-devel >= 3.2
+BuildRequires: nspr-devel
 BuildRequires: libtool-ltdl-devel
-Prefix: %{_prefix}
-Docdir: %{_docdir}
+# extra build deps needed for autoreconf after above patch
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: libtool
 
 %description
 XML Security Library is a C library based on LibXML2  and OpenSSL. 
@@ -23,7 +30,7 @@ standards "XML Digital Signature" and "XML Encryption".
 %package devel 
 Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
 Group: Development/Libraries 
-Requires: xmlsec1 = %{version}
+Requires: xmlsec1 = %{version}-%{release}
 Requires: libxml2-devel >= 2.6.0
 Requires: libxslt-devel >= 1.1.0
 Requires: openssl-devel >= 0.9.6
@@ -37,11 +44,7 @@ Signatures and XML Encryption support.
 %package openssl
 Summary: OpenSSL crypto plugin for XML Security Library
 Group: System Environment/Libraries 
-Requires: xmlsec1 = %{version}
-Requires: libxml2 >= 2.6.0
-Requires: libxslt >= 1.1.0
-Requires: openssl >= 0.9.6
-BuildRequires: openssl-devel >= 0.9.6
+Requires: xmlsec1 = %{version}-%{release}
 
 %description openssl
 OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
@@ -50,21 +53,16 @@ for the xmlsec library
 %package openssl-devel
 Summary: OpenSSL crypto plugin for XML Security Library
 Group: Development/Libraries 
-Requires: xmlsec1 = %{version}
-Requires: xmlsec1-devel = %{version}
-Requires: xmlsec1-openssl = %{version}
-Requires: libxml2-devel >= 2.6.0
-Requires: libxslt-devel >= 1.1.0
-Requires: openssl >= 0.9.6
-Requires: openssl-devel >= 0.9.6
+Requires: xmlsec1-devel = %{version}-%{release}
+Requires: xmlsec1-openssl = %{version}-%{release}
 
 %description openssl-devel
 Libraries, includes, etc. for developing XML Security applications with OpenSSL
 
 %package gcrypt
 Summary: GCrypt crypto plugin for XML Security Library
-Group: Development/Libraries
-Requires: xmlsec1 = %{version}
+Group: System Environment/Libraries
+Requires: xmlsec1 = %{version}-%{release}
 
 %description gcrypt
 GCrypt plugin for XML Security Library provides GCrypt based crypto services
@@ -82,13 +80,7 @@ Libraries, includes, etc. for developing XML Security applications with GCrypt.
 %package gnutls
 Summary: GNUTls crypto plugin for XML Security Library
 Group: System Environment/Libraries 
-Requires: xmlsec1 = %{version}
-Requires: libxml2 >= 2.6.0
-Requires: libxslt >= 1.1.0
-Requires: libgcrypt >= 1.2.0
-Requires: gnutls >= 1.0.20
-BuildRequires: libgcrypt-devel >= 1.2.0
-BuildRequires: gnutls-devel >= 1.0.20
+Requires: xmlsec1 = %{version}-%{release}
 
 %description gnutls
 GNUTls plugin for XML Security Library provides GNUTls based crypto services
@@ -100,10 +92,6 @@ Group: Development/Libraries
 Requires: xmlsec1 = %{version}
 Requires: xmlsec1-devel = %{version}
 Requires: xmlsec1-openssl = %{version}
-Requires: libxml2-devel >= 2.6.0
-Requires: libxslt-devel >= 1.1.0
-Requires: libgcrypt >= 1.2.0
-Requires: gnutls >= 1.0.20
 Requires: libgcrypt-devel >= 1.2.0
 Requires: gnutls-devel >= 1.0.20
 
@@ -113,13 +101,7 @@ Libraries, includes, etc. for developing XML Security applications with GNUTls
 %package nss
 Summary: NSS crypto plugin for XML Security Library
 Group: System Environment/Libraries 
-Requires: xmlsec1 = %{version}
-Requires: libxml2 >= 2.4.24
-Requires: libxslt >= 1.0.20
-Requires: nss >= 3.2
-Requires: nspr
-BuildRequires: nss-devel >= 3.2
-BuildRequires: nspr-devel
+Requires: xmlsec1 = %{version}-%{release}
 
 %description nss
 NSS plugin for XML Security Library provides NSS based crypto services
@@ -128,11 +110,8 @@ for the xmlsec library
 %package nss-devel
 Summary: NSS crypto plugin for XML Security Library
 Group: Development/Libraries 
-Requires: xmlsec1 = %{version}
-Requires: xmlsec1-devel = %{version}
-Requires: xmlsec1-nss = %{version}
-Requires: libxml2-devel >= 2.4.24
-Requires: libxslt-devel >= 1.0.20
+Requires: xmlsec1-devel = %{version}-%{release}
+Requires: xmlsec1-nss = %{version}-%{release}
 Requires: nss-devel >= 3.2
 Requires: nspr-devel
 
@@ -143,12 +122,11 @@ Libraries, includes, etc. for developing XML Security applications with NSS
 %setup -q
 
 %build
-%configure
-#
-# Note: it seems that this may break on older version of Red Hat,
-#       and that replacing the following line with just "make" can
-#       fix the problem
-#
+autoreconf -if
+%configure --enable-silent-rules --disable-static
+
+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
 make
 
 # positively ugly but only sane way to get around #192756
@@ -158,13 +136,13 @@ sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+
 rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/usr/bin
 mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
-mkdir -p $RPM_BUILD_ROOT/usr/lib
+mkdir -p $RPM_BUILD_ROOT%{_libdir}
 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
 
-%makeinstall
+make install DESTDIR=$RPM_BUILD_ROOT
 #make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
 rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
-rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
+#rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
 
 rm -rf docs-to-install
 mkdir -p docs-to-install
@@ -208,7 +186,6 @@ rm -fr %{buildroot}
 %{_includedir}/xmlsec1/xmlsec/*.h
 %{_includedir}/xmlsec1/xmlsec/private/*.h
 %{_libdir}/libxmlsec1.so
-# %{prefix}/lib*/libxmlsec1.*a
 %{_libdir}/pkgconfig/xmlsec1.pc
 %{_libdir}/xmlsec1Conf.sh
 %{_datadir}/aclocal/*.m4
@@ -223,7 +200,6 @@ rm -fr %{buildroot}
 %files openssl-devel
 %defattr(-, root, root)  
 %{_includedir}/xmlsec1/xmlsec/openssl/*.h
-# %{prefix}/lib*/libxmlsec1-openssl.*a
 %{_libdir}/libxmlsec1-openssl.so
 %{_libdir}/pkgconfig/xmlsec1-openssl.pc
 
@@ -244,7 +220,6 @@ rm -fr %{buildroot}
 %files gnutls-devel
 %defattr(-, root, root)  
 %{_includedir}/xmlsec1/xmlsec/gnutls/*.h
-# %{prefix}/lib*/libxmlsec1-gnutls.*a
 %{_libdir}/libxmlsec1-gnutls.so
 %{_libdir}/pkgconfig/xmlsec1-gnutls.pc
 
@@ -255,11 +230,14 @@ rm -fr %{buildroot}
 %files nss-devel
 %defattr(-, root, root)  
 %{_includedir}/xmlsec1/xmlsec/nss/*.h
-# %{prefix}/lib*/libxmlsec1-nss.*a
 %{_libdir}/libxmlsec1-nss.so
 %{_libdir}/pkgconfig/xmlsec1-nss.pc
 
 %changelog
+* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
+- new upstream release
+- moved gcrypt to System Environment/Libraries Group
+
 * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
 - new upstream release
 - add BuildRequires: libtool-ltdl-devel