xmlsec1-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. Summary: Library providing support for "XML Signature" and "XML Encryption" standards
  2. Name: xmlsec1
  3. Version: 1.2.20
  4. Release: 1%{?_dist_release}
  5. License: MIT
  6. Group: System Environment/Libraries
  7. URL: http://www.aleksey.com/xmlsec/
  8. Source: ftp://ftp.aleksey.com/pub/xmlsec/releases/xmlsec1-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: libxml2-devel >= 2.6.0
  11. BuildRequires: libxslt-devel >= 1.1.0
  12. BuildRequires: openssl-devel >= 0.9.6
  13. BuildRequires: libgcrypt-devel >= 1.4.0
  14. BuildRequires: gnutls-devel >= 1.0.20
  15. BuildRequires: nss-devel >= 3.2
  16. BuildRequires: nspr-devel
  17. BuildRequires: libtool-ltdl-devel
  18. # extra build deps needed for autoreconf after above patch
  19. BuildRequires: autoconf
  20. BuildRequires: automake
  21. BuildRequires: gettext-devel
  22. BuildRequires: libtool
  23. %description
  24. XML Security Library is a C library based on LibXML2 and OpenSSL.
  25. The library was created with a goal to support major XML security
  26. standards "XML Digital Signature" and "XML Encryption".
  27. %package devel
  28. Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
  29. Group: Development/Libraries
  30. Requires: xmlsec1 = %{version}-%{release}
  31. Requires: libxml2-devel >= 2.6.0
  32. Requires: libxslt-devel >= 1.1.0
  33. Requires: openssl-devel >= 0.9.6
  34. Requires: zlib-devel
  35. Requires: pkgconfig
  36. %description devel
  37. Libraries, includes, etc. you can use to develop applications with XML Digital
  38. Signatures and XML Encryption support.
  39. %package openssl
  40. Summary: OpenSSL crypto plugin for XML Security Library
  41. Group: System Environment/Libraries
  42. Requires: xmlsec1 = %{version}-%{release}
  43. %description openssl
  44. OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
  45. for the xmlsec library
  46. %package openssl-devel
  47. Summary: OpenSSL crypto plugin for XML Security Library
  48. Group: Development/Libraries
  49. Requires: xmlsec1-devel = %{version}-%{release}
  50. Requires: xmlsec1-openssl = %{version}-%{release}
  51. %description openssl-devel
  52. Libraries, includes, etc. for developing XML Security applications with OpenSSL
  53. %package gcrypt
  54. Summary: GCrypt crypto plugin for XML Security Library
  55. Group: System Environment/Libraries
  56. Requires: xmlsec1 = %{version}-%{release}
  57. %description gcrypt
  58. GCrypt plugin for XML Security Library provides GCrypt based crypto services
  59. for the xmlsec library.
  60. %package gcrypt-devel
  61. Summary: GCrypt crypto plugin for XML Security Library
  62. Group: Development/Libraries
  63. Requires: xmlsec1-devel = %{version}-%{release}
  64. Requires: xmlsec1-gnutls-devel = %{version}-%{release}
  65. %description gcrypt-devel
  66. Libraries, includes, etc. for developing XML Security applications with GCrypt.
  67. %package gnutls
  68. Summary: GNUTls crypto plugin for XML Security Library
  69. Group: System Environment/Libraries
  70. Requires: xmlsec1 = %{version}-%{release}
  71. %description gnutls
  72. GNUTls plugin for XML Security Library provides GNUTls based crypto services
  73. for the xmlsec library
  74. %package gnutls-devel
  75. Summary: GNUTls crypto plugin for XML Security Library
  76. Group: Development/Libraries
  77. Requires: xmlsec1 = %{version}
  78. Requires: xmlsec1-devel = %{version}
  79. Requires: xmlsec1-openssl = %{version}
  80. Requires: libgcrypt-devel >= 1.2.0
  81. Requires: gnutls-devel >= 1.0.20
  82. %description gnutls-devel
  83. Libraries, includes, etc. for developing XML Security applications with GNUTls
  84. %package nss
  85. Summary: NSS crypto plugin for XML Security Library
  86. Group: System Environment/Libraries
  87. Requires: xmlsec1 = %{version}-%{release}
  88. %description nss
  89. NSS plugin for XML Security Library provides NSS based crypto services
  90. for the xmlsec library
  91. %package nss-devel
  92. Summary: NSS crypto plugin for XML Security Library
  93. Group: Development/Libraries
  94. Requires: xmlsec1-devel = %{version}-%{release}
  95. Requires: xmlsec1-nss = %{version}-%{release}
  96. Requires: nss-devel >= 3.2
  97. Requires: nspr-devel
  98. %description nss-devel
  99. Libraries, includes, etc. for developing XML Security applications with NSS
  100. %prep
  101. %setup -q
  102. %build
  103. autoreconf -if
  104. %configure --enable-silent-rules --disable-static
  105. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  106. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  107. make
  108. # positively ugly but only sane way to get around #192756
  109. sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
  110. %install
  111. rm -rf $RPM_BUILD_ROOT
  112. mkdir -p $RPM_BUILD_ROOT/usr/bin
  113. mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
  114. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  115. mkdir -p $RPM_BUILD_ROOT/usr/man/man1
  116. make install DESTDIR=$RPM_BUILD_ROOT
  117. #make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
  118. rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
  119. #rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
  120. rm -rf docs-to-install
  121. mkdir -p docs-to-install
  122. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
  123. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
  124. %clean
  125. rm -fr %{buildroot}
  126. %post -p /sbin/ldconfig
  127. %postun -p /sbin/ldconfig
  128. %post openssl -p /sbin/ldconfig
  129. %postun openssl -p /sbin/ldconfig
  130. %post gcrypt -p /sbin/ldconfig
  131. %postun gcrypt -p /sbin/ldconfig
  132. %post gnutls -p /sbin/ldconfig
  133. %postun gnutls -p /sbin/ldconfig
  134. %post nss -p /sbin/ldconfig
  135. %postun nss -p /sbin/ldconfig
  136. %files
  137. %defattr(-, root, root)
  138. %doc AUTHORS ChangeLog NEWS README Copyright
  139. %doc %{_mandir}/man1/xmlsec1.1*
  140. %{_libdir}/libxmlsec1.so.*
  141. %{_bindir}/xmlsec1
  142. %files devel
  143. %defattr(-, root, root)
  144. %{_bindir}/xmlsec1-config
  145. %{_includedir}/xmlsec1/xmlsec/*.h
  146. %{_includedir}/xmlsec1/xmlsec/private/*.h
  147. %{_libdir}/libxmlsec1.so
  148. %{_libdir}/pkgconfig/xmlsec1.pc
  149. %{_libdir}/xmlsec1Conf.sh
  150. %{_datadir}/aclocal/*.m4
  151. %doc AUTHORS HACKING ChangeLog NEWS README Copyright
  152. %doc docs-to-install/*
  153. %doc %{_mandir}/man1/xmlsec1-config.1*
  154. %files openssl
  155. %defattr(-, root, root)
  156. %{_libdir}/libxmlsec1-openssl.so.*
  157. %files openssl-devel
  158. %defattr(-, root, root)
  159. %{_includedir}/xmlsec1/xmlsec/openssl/*.h
  160. %{_libdir}/libxmlsec1-openssl.so
  161. %{_libdir}/pkgconfig/xmlsec1-openssl.pc
  162. %files gcrypt
  163. %defattr(-, root, root, -)
  164. %{_libdir}/libxmlsec1-gcrypt.so.*
  165. %files gcrypt-devel
  166. %defattr(-, root, root, -)
  167. %{_includedir}/xmlsec1/xmlsec/gcrypt/
  168. %{_libdir}/libxmlsec1-gcrypt.so
  169. %{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
  170. %files gnutls
  171. %defattr(-, root, root)
  172. %{_libdir}/libxmlsec1-gnutls.so.*
  173. %files gnutls-devel
  174. %defattr(-, root, root)
  175. %{_includedir}/xmlsec1/xmlsec/gnutls/*.h
  176. %{_libdir}/libxmlsec1-gnutls.so
  177. %{_libdir}/pkgconfig/xmlsec1-gnutls.pc
  178. %files nss
  179. %defattr(-, root, root)
  180. %{_libdir}/libxmlsec1-nss.so.*
  181. %files nss-devel
  182. %defattr(-, root, root)
  183. %{_includedir}/xmlsec1/xmlsec/nss/*.h
  184. %{_libdir}/libxmlsec1-nss.so
  185. %{_libdir}/pkgconfig/xmlsec1-nss.pc
  186. %changelog
  187. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
  188. - new upstream release
  189. - moved gcrypt to System Environment/Libraries Group
  190. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
  191. - new upstream release
  192. - add BuildRequires: libtool-ltdl-devel
  193. - add -gcrypt,-gcrypt-devel package
  194. * Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
  195. - new upstream release with security fix (CVE-2009-0217)
  196. - remove *.a files
  197. * Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
  198. - rebuilt with gnutls-2.6.3
  199. * Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
  200. - new upstream release
  201. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
  202. - initial build for Vine Linux
  203. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
  204. - rebuild
  205. * Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
  206. - rebuilt with new gnutls
  207. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
  208. - oops libxmlsec1.la was still there, should fix #171410 and #154142
  209. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
  210. - Ugly patch and sed based changes to work around #192756 xmlsec1-config
  211. multilib problem
  212. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
  213. - move .so symlinks to -devel subpackage
  214. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
  215. - bump again for double-long bug on ppc(64)
  216. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
  217. - rebuilt for new gcc4.1 snapshot and glibc changes
  218. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
  219. - NSS has been split out of the mozilla package, so require that now
  220. and update separate_nspr.patch to account for the new NSS as well
  221. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  222. - rebuilt
  223. * Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
  224. - rebuilt due to gnutls library revision
  225. * Wed Nov 9 2005 <veillard@redhat.com> 1.2.9-2
  226. - rebuilt due to openssl library revision
  227. * Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
  228. - update from upstream, release done in July
  229. - apparently nss is now available on ppc64
  230. * Mon Aug 8 2005 <veillard@redhat.com> 1.2.8-3
  231. - rebuilt with new gnutls
  232. - nspr has been split to a separate package
  233. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
  234. - Enabling the mozilla-nss crypto backend
  235. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
  236. - update from upstream, needed for openoffice
  237. * Tue Mar 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
  238. - rebuilt with gcc4
  239. * Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
  240. - Upstream release of 1.2.7, mostly bug fixes plus new functions
  241. to GetKeys from simple store and X509 handling.
  242. * Wed Feb 9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
  243. - Adding support for GNUTls crypto backend
  244. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
  245. - adding missing ldconfig calls
  246. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
  247. - updated with upstream release from Aleksey
  248. * Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
  249. - rebuilt
  250. * Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
  251. - updated with upstream release from Aleksey
  252. * Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
  253. - updated with upstream release from Aleksey
  254. * Tue Jan 6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
  255. - updated with upstream release from Aleksey
  256. * Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
  257. - updated with upstream release from Aleksey, specific patches should
  258. have been integrated now.
  259. * Thu Nov 6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
  260. - initial packaging based on the upstream one and libxml2 one.
  261. - desactivated mozilla-nss due to detection/architecture problems