Browse Source

updated 7 packages

ifuse-1.1.4-1

libgudev-233-1

libimobiledevice-1.3.0-1

libplist-2.2.0-1

libusbmuxd-2.0.2-1

upower-0.99.11-1

usbmuxd-1.1.1-1

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@12445 ec354946-7b23-47d6-9f5a-488ba84defc7
tomop 2 years ago
parent
commit
0e0ee534fb

+ 25 - 19
i/ifuse/ifuse-vl.spec

@@ -1,24 +1,21 @@
-Name:          ifuse
-Version:       1.1.3
-Release:       2%{?_dist_release}
-Summary:       Mount Apple iPhone and iPod touch devices
-Summary(ja):   Apple iPhone および iPod touch をマウントする
+Name:           ifuse
+Summary:        Mount Apple iPhone and iPod touch devices
+Summary(ja):    Apple iPhone および iPod touch をマウントする
+Version:        1.1.4
+Release:        1%{?_dist_release}
+Vendor:         Project Vine
+Distribution:   Vine Linux
+Packager:       daisuke
 
-Group:         System Environment/Base
-License:       GPLv2+
-URL:           http://matt.colyer.name/projects/iphone-linux/
+License:        GPLv2+
+URL:            http://matt.colyer.name/projects/iphone-linux/
+Source0:        https://github.com/libimobiledevice/ifuse/releases/download/%{version}/%{name}-%{version}.tar.bz2
 
-Source0:       http://cloud.github.com/downloads/MattColyer/%{name}/%{name}-%{version}.tar.bz2
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-
-BuildRequires: glib2-devel
-BuildRequires: fuse-devel
-BuildRequires: libimobiledevice-devel
-
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: daisuke
+BuildRequires:  glib2-devel
+BuildRequires:  fuse-devel
+BuildRequires:  libimobiledevice-devel
 
 %description
 A fuse filesystem for mounting iPhone and iPod touch devices
@@ -27,27 +24,36 @@ A fuse filesystem for mounting iPhone and iPod touch devices
 iFuse は iPhone や iPod touch デバイスをマウントするための 
 FUSE ファイルシステムです。
 
+
 %prep
 %setup -q
 
+
 %build
 %configure
 make %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING README
+%license COPYING
+%doc AUTHORS README*
 %{_bindir}/ifuse
 %{_mandir}/man1/ifuse.1.gz
 
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.4-1
+- new upstream release.
+
 * Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.3-2
 - rebuilt with libimobiledevice 1.2.0
 

+ 12 - 9
lib/libg/libgudev/libgudev-vl.spec

@@ -1,15 +1,16 @@
 %define build_compat32  %{?_with_compat32:1}%{!?_with_compat32:0}
 
-Name:           libgudev
-Version:        232
-Release:        1%{?_dist_release}
 Summary:        UDev GObject bindings
 Summary(ja):    UDev の GObject バインディング
+Name:           libgudev
+Version:        233
+Release:        1%{?_dist_release}
+Vendor:         Project Vine
+Distribution:   Vine Linux
 
-Group:          System Environment/Libraries
 License:        LGPLv2.1
-URL:            http://git.gnome.org/browse/libgudev
-Source0:        http://download.gnome.org/sources/%{name}/230/%{name}-%{version}.tar.xz
+URL:            https://gitlab.gnome.org/GNOME/libgudev
+Source0:        https://download.gnome.org/sources/%{name}/%{version}/%{name}-%{version}.tar.xz
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
@@ -23,9 +24,6 @@ Provides:   eudev-libgudev1 = 3.1.5
 Obsoletes:  libgudev1 < 230
 Provides:   libgudev1 = %{version}-%{release}
 
-Vendor: Project Vine
-Distribution: Vine Linux
-
 %description
 This package contains the libraries for adding libudev support to applications
 that use glib.
@@ -49,6 +47,7 @@ Provides:       libgudev1-devel = %{version}-%{release}
 The %{name}-devel package contains libraries and header files
 for developing applications that use %{name}.
 
+
 # compat32
 %package -n compat32-%{name}
 Summary:        UDev GObject bindings
@@ -83,6 +82,7 @@ Provides:       compat32-libgudev1-devel = %{version}-%{release}
 The %{name}-devel package contains libraries and header files
 for developing applications that use %{name}.
 
+
 %prep
 %setup -q
 
@@ -135,6 +135,9 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
 
 
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 233-1
+- new upstream release.
+
 * Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 232-1
 - new upstream release.
 

+ 52 - 45
lib/libi/libimobiledevice/libimobiledevice-vl.spec

@@ -1,46 +1,35 @@
 %bcond_with python
 
-Name:          libimobiledevice
-Version:       1.2.0
-Release:       2%{?_dist_release}
-Summary:       Library for connecting to mobile devices
-Summary(ja):   モバイルデバイスに接続するためのライブラリ
-
-Group:         System Environment/Libraries
-License:       LGPLv2+
-URL:           http://www.libimobiledevice.org/
-
-Source0:       http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
-# for gnutls-3.4
-Patch0:        issue225.patch
-
-
-BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: automake
-BuildRequires: autoconf
-BuildRequires: libxml2-devel
-BuildRequires: libusb1-devel
-BuildRequires: libtasn1-devel
-BuildRequires: libplist-devel >= 1.11
-BuildRequires: libplist-python
-BuildRequires: glib2-devel
-BuildRequires: gnutls-devel
-BuildRequires: python-devel
-%if %{with python}
-BuildRequires: Cython
-%endif
-BuildRequires: swig
-BuildRequires: libusbmuxd-devel >= 1.0.9
-BuildRequires: libgcrypt-devel
+Summary:        Library for connecting to mobile devices
+Summary(ja):    モバイルデバイスに接続するためのライブラリ
+Name:           libimobiledevice
+Version:        1.3.0
+Release:        1%{?_dist_release}
+Vendor:         Project Vine
+Distribution:   Vine Linux
+Packager:       daisuke
+
+License:        LGPLv2+
+URL:            https://libimobiledevice.org/
+Source0:        https://github.com/libimobiledevice/libimobiledevice/releases/download/%{version}/%{name}-%{version}.tar.bz2
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires:  automake
+BuildRequires:  autoconf
+BuildRequires:  libxml2-devel
+BuildRequires:  libusb1-devel
+BuildRequires:  libtasn1-devel
+BuildRequires:  libplist-devel >= 1.11
+BuildRequires:  glib2-devel
+BuildRequires:  gnutls-devel
+BuildRequires:  swig
+BuildRequires:  libusbmuxd-devel >= 1.0.9
+BuildRequires:  libgcrypt-devel
 #BuildRequires: readline-devel
 
 Provides: libiphone = %{version}
 Obsoletes: libiphone < 0.9.7 
 
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: daisuke
-
 %description
 libimobiledevice is a library for connecting to mobile devices including phones 
 and music players
@@ -56,25 +45,34 @@ Obsoletes: libiphone-devel < 0.9.7
 %description devel
 Files for development with libimobiledevice.
 
-%package python
+
+%if %{with python}
+%package -n python3-imobiledevice
 Summary: Python bindings for libimobiledevice
 Summary(ja): libimobiledevice の Python バインディング
 Group: System Environment/Libraries
+BuildRequires:  python3-devel
+BuildRequires:  python3-rpm-macros
+BuildRequires:  python3-setuptools
+BuildRequires:  python3-libplist
+BuildRequires:  python3-Cython
 Requires: %{name} = %{version}-%{release}
 Provides: libiphone-python = %{version}
 Obsoletes: libiphone-python < 0.9.7 
 
-%description python
+%description -n python3-imobiledevice
 Python bindings for libimobiledevice.
 
+%endif
+
+
 %prep
 %setup -q
 
-%patch0 -p1
-
 # Fix dir permissions on html docs
 chmod +x docs/html
 
+
 %build
 aclocal
 automake --add-missing --copy
@@ -94,6 +92,7 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
 
 make %{?_smp_mflags} V=1
 
+
 %install
 rm -rf %{buildroot}
 make install DESTDIR=%{buildroot}
@@ -101,34 +100,42 @@ make install DESTDIR=%{buildroot}
 #Remove libtool archives.
 find %{buildroot} -name '*.la' -exec rm -f {} ';'
 
+
 %clean
 rm -rf %{buildroot}
 
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
+
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING.LESSER README
+%license COPYING.LESSER
+%doc AUTHORS README*
 %doc %{_datadir}/man/man1/idevice*
 %{_bindir}/idevice*
-%{_libdir}/libimobiledevice.so.*
+%{_libdir}/libimobiledevice*.so.*
 
 %files devel
 %defattr(-,root,root,-)
 %doc docs/html/
 %{_libdir}/pkgconfig/libimobiledevice-1.0.pc
-%{_libdir}/libimobiledevice.so
+%{_libdir}/libimobiledevice*.so
 %{_includedir}/libimobiledevice/
 
 %if %{with python}
-%files python
+%files -n python3-imobiledevice
 %defattr(-,root,root,-)
-%{python_sitearch}/imobiledevice.so
+%{python3_sitearch}/imobiledevice.so
 %endif
 
+
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
+- new upstream release.
+
 * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-2
 - built with gnutls-3.4.x.
 

+ 24 - 16
lib/libp/libplist/libplist-vl.spec

@@ -1,35 +1,34 @@
 Name:           libplist
 Summary:        Library for manipulating Apple Binary and XML Property Lists
 Summary(ja):    Apple のバイナリおよび XML プロパティリストを操作するライブラリ
-Version:        2.0.0
+Version:        2.2.0
 Release:        1%{?_dist_release}
+Vendor:	        Project Vine
+Distribution:   Vine Linux
+Packager:       daisuke
 
-Group:          System Environment/Libraries
 License:        LGPLv2+
-URL:            http://www.libimobiledevice.org/
-
-Source0:        http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
+URL:            https://www.libimobiledevice.org/
+Source0:        https://github.com/libimobiledevice/libplist/releases/download/%{version}/%{name}-%{version}.tar.bz2
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires: libxml2-devel
 BuildRequires: glib2-devel
 BuildRequires: python3-devel
 BuildRequires: python3-rpm-macros
+BuildRequires: python3-setuptools
 BuildRequires: python3-Cython
 
 # to avoid for libplist-python to link with libplist.so.2...
 BuildConflicts: libplist-devel
 
-Vendor:		Project Vine
-Distribution: 	Vine Linux
-Packager: 	daisuke
-
 %description
 libplist is a library for manipulating Apple Binary and XML Property Lists
 
 %description -l ja
 libplist は Apple のバイナリおよび XML プロパティリストを操作するライブラリです.
 
+
 %package devel
 Summary: Development package for libplist
 Summary(ja): libplist の開発用パッケージ
@@ -39,6 +38,7 @@ Requires: %{name} = %{version}-%{release}
 %description devel
 %{name}, development headers and libraries.
 
+
 %package -n python3-libplist
 Summary: Python3 package for libplist
 Group: System Environment/Libraries
@@ -48,9 +48,11 @@ Requires: python3
 %description -n python3-libplist
 %{name}, python libraries and support
 
+
 %prep
 %setup -q
 
+
 %build
 export PYTHON=%{__python3}
 
@@ -58,6 +60,7 @@ export PYTHON=%{__python3}
 
 make %{?_smp_mflags} V=1
 
+
 %install
 export PYTHON=%{__python3}
 
@@ -65,34 +68,39 @@ make install DESTDIR=$RPM_BUILD_ROOT
 
 find $RPM_BUILD_ROOT -type f -name "*.la" -delete
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
+
 %files
 %defattr(-,root,root,-)
 %license COPYING.LESSER
-%doc AUTHORS README
+%doc AUTHORS README* NEWS
 %{_bindir}/plistutil
-%{_libdir}/libplist.so.*
-%{_libdir}/libplist++.so.*
+%{_libdir}/libplist*.so.*
+%{_mandir}/man1/plistutil.1*
 
 %files devel
 %defattr(-,root,root,-)
-%{_libdir}/pkgconfig/libplist.pc
-%{_libdir}/pkgconfig/libplist++.pc
-%{_libdir}/libplist.so
-%{_libdir}/libplist++.so
+%{_libdir}/pkgconfig/libplist*.pc
+%{_libdir}/libplist*.so
 %{_includedir}/plist
 
 %files -n python3-libplist
 %defattr(-,root,root,-)
 %{python3_sitearch}/*
 
+
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
+- new upstream release.
+
 * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1
 - new upstream release.
 

+ 29 - 12
lib/libu/libusbmuxd/libusbmuxd-vl.spec

@@ -1,21 +1,23 @@
 Name:		libusbmuxd
-Version:	1.0.10
-Release:	1%{?_dist_release}
 Summary: 	Client library USB multiplex daemon for Apple's iOS devices
+Version:	2.0.2
+Release:	1%{?_dist_release}
+Vendor:		Project Vine
+Distribution:	Vine Linux
 
-Group:         	System Environment/Libraries
-License:       	LGPLv2+
-URL:           	http://www.libimobiledevice.org/
-Source0:       	http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
+License:	LGPLv2+
+URL:		https://www.libimobiledevice.org/
+Source0:	https://github.com/libimobiledevice/libusbmuxd/releases/download/%{version}/%{name}-%{version}.tar.bz2
 
-BuildRequires: libplist-devel >= 1.11
-Conflicts:     usbmuxd < 1.0.9
+BuildRequires:	libplist-devel >= 1.11
+Conflicts:	usbmuxd < 1.0.9
 
 %description
 libusbmuxd is the client library used for communicating with Apple's iPod Touch,
 iPhone, iPad and Apple TV devices. It allows multiple services on the device 
 to be accessed simultaneously.
 
+
 %package utils
 Summary: 	Utilities for communicating with Apple's iOS devices
 Group: 		Applications/System
@@ -26,6 +28,7 @@ Conflicts: 	usbmuxd < 1.0.9
 %description utils
 Utilities for Apple's iOS devices
 
+
 %package devel
 Summary:	Development package for %{name}
 Summary(ja):	%{name} の開発用パッケージ
@@ -36,9 +39,11 @@ Conflicts: 	usbmuxd-devel < 1.0.9
 %description devel
 Files for development with %{name}.
 
+
 %prep
 %setup -q
 
+
 %build
 %configure --disable-static
 
@@ -47,35 +52,47 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
 
 make %{?_smp_mflags} V=1
 
+
 %install
 make install DESTDIR=%{buildroot} INSTALL='install -p'
 
 #Remove libtool archives.
 find %{buildroot} -name '*.la' -exec rm -f {} ';'
 
+
 %check
 make check
 
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
+
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING NEWS README
-%{_libdir}/libusbmuxd.so.*
+%license COPYING
+%doc AUTHORS NEWS README*
+%{_libdir}/libusbmuxd*.so.*
 
 %files utils
 %defattr(-,root,root,-)
+%{_bindir}/inetcat
 %{_bindir}/iproxy
+%{_mandir}/man1/inetcat.1*
+%{_mandir}/man1/iproxy.1*
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/usbmuxd*
-%{_libdir}/pkgconfig/libusbmuxd.pc
-%{_libdir}/libusbmuxd.so
+%{_libdir}/pkgconfig/libusbmuxd*.pc
+%{_libdir}/libusbmuxd*.so
+
 
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.2-1
+- new upstream release.
+
 * Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.10-1
 - new upstream release
 

+ 50 - 16
u/upower/upower-vl.spec

@@ -1,19 +1,22 @@
+%bcond_with systemd
+
 Summary:        Power Management Service
 Summary(ja):	電源管理サービス
 Name:           upower
-Version:        0.99.7
-Release:        1%{?_dist_release}
+Version:        0.99.11
+Release:        1%{?_dist_release}%{?with_systemd:.systemd}
+Vendor:         Project Vine
+Distribution:   Vine Linux
+
 License:        GPLv2+
-Group:          System Environment/Libraries
-URL:            http://upower.freedesktop.org/
-Source0:        http://upower.freedesktop.org/releases/upower-%{version}.tar.xz
+URL:            https://upower.freedesktop.org/
+Source0:        https://upower.freedesktop.org/releases/upower-%{version}.tar.xz
 
 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
 BuildRequires:  sqlite3-devel
 BuildRequires:  libtool
 BuildRequires:  intltool
 BuildRequires:  gettext
-BuildRequires:  eudev-libgudev1-devel
 BuildRequires:  libusb1-devel
 BuildRequires:  glib2-devel >= 2.6.0
 BuildRequires:  dbus-devel  >= 1.2
@@ -21,24 +24,27 @@ BuildRequires:  dbus-glib-devel >= 0.82
 BuildRequires:  polkit-devel >= 0.92
 BuildRequires:  gobject-introspection-devel
 BuildRequires:	libimobiledevice-devel
+BuildRequires:	libgudev-devel
 BuildRequires:  gtk-doc
 BuildRequires:  vim-tiny
 BuildRequires:  autoconf
 Requires:       polkit >= 0.92
-Requires:       eudev
 Requires:       pm-utils >= 1.4.1
 Requires:       gobject-introspection
 
+%if %{with systemd}
+BuildRequires:  systemd-devel
+%{?systemd_requires}
+%else
+BuildRequires:  eudev-libgudev1-devel
+Requires:       eudev
+%endif
+
 # Old project name
 Obsoletes: libupower09 < 0.9.24
 Obsoletes: DeviceKit-power < 1:0.9.0-2
 Provides: DeviceKit-power
 
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: daisuke, Takemikaduchi
-
-
 %description
 UPower (formerly DeviceKit-power) provides a daemon, API and command
 line tools for managing power devices attached to the system.
@@ -56,9 +62,11 @@ Provides: DeviceKit-power-devel
 %description devel
 Headers and libraries for UPower.
 
+
 %prep
 %setup -q 
 
+
 %build
 %configure \
 	--enable-gtk-doc \
@@ -67,6 +75,7 @@ Headers and libraries for UPower.
 	--with-udevrulesdir=/lib/udev/rules.d
 make V=1 %{?_smp_mflags}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT
@@ -74,19 +83,35 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 
 %find_lang %{name}
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
 
-%postun -p /sbin/ldconfig
+%post
+/sbin/ldconfig
+%if %{with systemd}
+%systemd_post upower.service
+%endif
+
+%if %{with systemd}
+%preun
+%systemd_preun upower.service
+%endif
+
+%postun
+/sbin/ldconfig
+%if %{with systemd}
+%systemd_postun_with_restart upower.service
+%endif
+
 
 %files -f %{name}.lang
 %defattr(-,root,root,-)
-%doc NEWS COPYING AUTHORS HACKING README
+%license COPYING
+%doc NEWS AUTHORS HACKING README*
 %{_libdir}/libupower-glib.so.*
 %{_libdir}/girepository-1.0/*.typelib
-%{_sysconfdir}/dbus-1/system.d/*.conf
 %{_sysconfdir}/UPower/UPower.conf
 /lib/udev/rules.d/*.rules
 %dir %{_localstatedir}/lib/upower
@@ -95,7 +120,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/*
 %{_mandir}/man7/*
 %{_mandir}/man8/*
+%{_datadir}/dbus-1/system.d/*.conf
 %{_datadir}/dbus-1/system-services/*.service
+%if %{with systemd}
+%{_unitdir}/*.service
+%endif
 
 %files devel
 %defattr(-,root,root,-)
@@ -109,7 +138,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/libupower-glib/up-*.h
 %{_includedir}/libupower-glib/upower.h
 
+
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.99.11-1
+- new upstream release.
+- added systemd support (disabled as default).
+
 * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.99.7-1
 - new upstream release.
 

+ 50 - 17
u/usbmuxd/usbmuxd-vl.spec

@@ -1,35 +1,40 @@
-#define gittag c24463e
-#define tarfile %{name}-%{version}-%{gittag}.tar.bz2
+%bcond_with systemd
 
 Summary:	Daemon for communicating with Apple's iPod Touch and iPhone
 Summary(ja):	Apple の iPod Touch や iPhone と通信するためのデーモン
-
 Name:		usbmuxd
-Version:	1.0.9
-Release:	2%{?_dist_release}
+Version:	1.1.1
+Release:	1%{?_dist_release}%{?with_systemd:.systemd}
+Vendor:		Project Vine
+Distribution:	Vine Linux
+Packager:	daisuke
 
-Group:		Applications/System
 # All code is dual licenses as GPLv3+ or GPLv2+
 License:	GPLv3+ or GPLv2+
-URL:           	http://www.libimobiledevice.org/
-Source0:       	http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
+URL:           	https://libimobiledevice.org/
+Source0:       	https://github.com/libimobiledevice/usbmuxd/releases/download/%{version}/%{name}-%{version}.tar.bz2
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires:	libusb1-devel
 BuildRequires:  libimobiledevice-devel
 BuildRequires:  libplist-devel
 Requires(pre):  shadow-utils
-Obsoletes: usbmuxd-devel < 1.0.9
+Obsoletes:      usbmuxd-devel < 1.0.9
 
-Vendor: Project Vine
-Distribution: Vine Linux
-Packager: daisuke
+%if %{with systemd}
+BuildRequires:  systemd-devel
+%{?systemd_requires}
+%else
+BuildRequires:  eudev-libgudev1-devel
+Requires:       eudev
+%endif
 
 %description
 usbmuxd is a daemon used for communicating with Apple's iPod Touch and iPhone
 devices. It allows multiple services on the device to be accessed
 simultaneously.
 
+
 %prep
 %setup -q
 
@@ -37,18 +42,28 @@ simultaneously.
 sed -i.owner 's/OWNER="usbmux"/OWNER="usbmuxd"/' udev/39-usbmuxd.rules.in
 sed -i.user 's/-U usbmux/-U usbmuxd/' udev/39-usbmuxd.rules.in
 
+
 %build
 #NOCONFIGURE=1 ./autogen.sh
-%configure --without-systemd
+%configure \
+    --with-udevrulesdir=/lib/udev/rules.d \
+%if !%{with systemd}
+    --without-systemd
+%endif
+    %{nil}
 
 make %{?_smp_mflags}
 
+
 %install
 make install DESTDIR=$RPM_BUILD_ROOT
+rm -f %{buildroot}/usr/lib/udev/rules.d/39-usbmuxd.rules
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+
 %pre
 getent group usbmuxd >/dev/null || groupadd -r usbmuxd
 getent passwd usbmuxd >/dev/null || \
@@ -56,17 +71,35 @@ useradd -r -g usbmuxd -d / -s /sbin/nologin \
 	-c "usbmuxd user" usbmuxd
 exit 0
 
-#post -p /sbin/ldconfig
-#postun -p /sbin/ldconfig
+%if %{with systemd}
+%post
+%systemd_post usbmuxd.service
+
+%preun
+%systemd_preun usbmuxd.service
+
+%postun
+%systemd_postun_with_restart usbmuxd.service
+%endif
+
 
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS README COPYING.GPLv2 COPYING.GPLv3
+%license COPYING.GPLv2 COPYING.GPLv3
+%doc AUTHORS README.md
 /lib/udev/rules.d/39-usbmuxd.rules
 %{_sbindir}/usbmuxd
-%{_mandir}/man1/*
+%{_mandir}/man*/*
+%if %{with systemd}
+%{_unitdir}/usbmuxd.service
+%endif
+
 
 %changelog
+* Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
+- new upstream release.
+- added systemd support (disabled as default).
+
 * Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.9-2
 - rebuilt with libimobiledevice 1.2.0 and libplist 1.12
 - added --without-systemd option