libimobiledevice-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. %bcond_with python
  2. Summary: Library for connecting to mobile devices
  3. Summary(ja): モバイルデバイスに接続するためのライブラリ
  4. Name: libimobiledevice
  5. Version: 1.3.0
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: daisuke
  10. License: LGPLv2+
  11. URL: https://libimobiledevice.org/
  12. Source0: https://github.com/libimobiledevice/libimobiledevice/releases/download/%{version}/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: automake
  15. BuildRequires: autoconf
  16. BuildRequires: libxml2-devel
  17. BuildRequires: libusb1-devel
  18. BuildRequires: libtasn1-devel
  19. BuildRequires: libplist-devel >= 1.11
  20. BuildRequires: glib2-devel
  21. BuildRequires: gnutls-devel
  22. BuildRequires: swig
  23. BuildRequires: libusbmuxd-devel >= 1.0.9
  24. BuildRequires: libgcrypt-devel
  25. #BuildRequires: readline-devel
  26. Provides: libiphone = %{version}
  27. Obsoletes: libiphone < 0.9.7
  28. %description
  29. libimobiledevice is a library for connecting to mobile devices including phones
  30. and music players
  31. %package devel
  32. Summary: Development package for libimobiledevice
  33. Summary(ja): libimobiledevice の開発用パッケージ
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Provides: libiphone-devel = %{version}
  37. Obsoletes: libiphone-devel < 0.9.7
  38. %description devel
  39. Files for development with libimobiledevice.
  40. %if %{with python}
  41. %package -n python3-imobiledevice
  42. Summary: Python bindings for libimobiledevice
  43. Summary(ja): libimobiledevice の Python バインディング
  44. Group: System Environment/Libraries
  45. BuildRequires: python3-devel
  46. BuildRequires: python3-rpm-macros
  47. BuildRequires: python3-setuptools
  48. BuildRequires: python3-libplist
  49. BuildRequires: python3-Cython
  50. Requires: %{name} = %{version}-%{release}
  51. Provides: libiphone-python = %{version}
  52. Obsoletes: libiphone-python < 0.9.7
  53. %description -n python3-imobiledevice
  54. Python bindings for libimobiledevice.
  55. %endif
  56. %prep
  57. %setup -q
  58. # Fix dir permissions on html docs
  59. chmod +x docs/html
  60. %build
  61. aclocal
  62. automake --add-missing --copy
  63. autoconf
  64. %configure \
  65. --disable-static \
  66. --disable-openssl \
  67. %if %{with python}
  68. --without-cython \
  69. --without-python \
  70. %endif
  71. ;
  72. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  73. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  74. make %{?_smp_mflags} V=1
  75. %install
  76. rm -rf %{buildroot}
  77. make install DESTDIR=%{buildroot}
  78. #Remove libtool archives.
  79. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  80. %clean
  81. rm -rf %{buildroot}
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,-)
  86. %license COPYING.LESSER
  87. %doc AUTHORS README*
  88. %doc %{_datadir}/man/man1/idevice*
  89. %{_bindir}/idevice*
  90. %{_libdir}/libimobiledevice*.so.*
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %doc docs/html/
  94. %{_libdir}/pkgconfig/libimobiledevice-1.0.pc
  95. %{_libdir}/libimobiledevice*.so
  96. %{_includedir}/libimobiledevice/
  97. %if %{with python}
  98. %files -n python3-imobiledevice
  99. %defattr(-,root,root,-)
  100. %{python3_sitearch}/imobiledevice.so
  101. %endif
  102. %changelog
  103. * Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
  104. - new upstream release.
  105. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.0-2
  106. - built with gnutls-3.4.x.
  107. * Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-1
  108. - new upstream release
  109. * Tue Jul 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.1.6-1
  110. - update to 1.1.6
  111. - add BR: libusbmuxd-devel >= 1.0.9, libgcrypt-devel, readline-devel
  112. - disable python
  113. - disable openssl
  114. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-2
  115. - rebuild with VineSeed environment
  116. - add Patch2 (libimobiledevice-1.1.5-cython.patch)
  117. * Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.5-1
  118. - new upstream release
  119. * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
  120. - new upstream release
  121. - add BuildRequires: openssl-devel, Cython
  122. - add Patch1 (libimobiledevice-1.1.4-pkgconfig.patch)
  123. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-2
  124. - rebuild with python-2.7.2
  125. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
  126. - new upstream release
  127. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  128. - new upstream release
  129. * Tue Dec 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  130. - new upstream release
  131. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
  132. - rebuilt with rpm-4.8.1 for pkg-config
  133. * Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  134. - new upstream release
  135. * Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-2
  136. - updated devel package Requires
  137. * Thu Apr 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  138. - initial build for Vine Linux
  139. * Sun Mar 21 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.0-1
  140. - New upstream stable 1.0.0 release
  141. * Mon Feb 15 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-3
  142. - Add patch to fix DSO linking. Fixes bug 565084
  143. * Wed Feb 3 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-2
  144. - Package review updates, add developer docs
  145. * Wed Jan 27 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.7-1
  146. - New package for new library name. Update to 0.9.7
  147. * Sun Jan 24 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.6-1
  148. - Update to 0.9.6 release
  149. * Sat Jan 9 2010 Peter Robinson <pbrobinson@gmail.com> 0.9.5-3
  150. - Updated to the new python sysarch spec file reqs
  151. * Tue Dec 15 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-2
  152. - Update python bindings
  153. * Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.5-1
  154. - Update to 0.9.5 release for new usbmuxd/libplist 1.0.0 final
  155. * Sat Dec 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-3
  156. - Rebuild for libplist .so bump
  157. * Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-2
  158. - Update from libusb to libusb1
  159. * Wed Oct 28 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.4-1
  160. - Update to 0.9.4 release for new usbmuxd 1.0.0-rc1
  161. * Mon Aug 10 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.3-1
  162. - Update to 0.9.3 release
  163. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-3
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  165. * Wed May 13 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-2
  166. - Add new build reqs
  167. * Tue May 12 2009 Peter Robinson <pbrobinson@gmail.com> 0.9.1-1
  168. - Update to official 0.9.1 release
  169. * Fri Apr 03 2009 - Bastien Nocera <bnocera@redhat.com> - 0.1.0-11.20090325git443edc8
  170. - Update to latest master version
  171. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-10.20090103git5cde554
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  173. * Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-9.git5cde554
  174. - Add back gnutls version patch
  175. * Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-8.git5cde554
  176. - Upload bzipped source file
  177. * Sat Jan 3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.0-7.git5cde554
  178. - New git snapshot
  179. * Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-6.git8c3a01e
  180. - Fix devel dependency
  181. * Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-5.git8c3a01e
  182. - Fix gnutls check for new rawhide version
  183. * Fri Dec 5 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-4.git8c3a01e
  184. - Rebuild for pkgconfig
  185. * Tue Dec 2 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-3.git8c3a01e
  186. - Fix git file generation
  187. * Mon Dec 1 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-2.git8c3a01e
  188. - Updates for package review
  189. * Sat Nov 29 2008 Peter Robinson <pbrobinson@gmail.com> 0.1.0-1
  190. - Initial package