vbootstrap.spec 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. # This package is maintained on trac svn repository. Please do not change on local.
  2. # If you find a BUG, please report to Vine@vinelinux.org or mailing list or BTS.
  3. %define version 0.0.5
  4. Summary: bootstrap scripts to create a basic Vine Linux system
  5. Summary(ja): Vine Linux の基本システムを作成するためのスクリプト
  6. Name: vbootstrap
  7. Version: %{version}
  8. Release: 1%{?_dist_release}
  9. License: public domain
  10. Group: Development/Tools
  11. Url: http://trac.vinelinux.org/wiki/VineBootstrap
  12. Source0: %{name}-%{version}.tar.bz2
  13. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildArch: noarch
  15. BuildRequires: sed
  16. Requires: bash, apt
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: daisuke, munepi
  20. %description
  21. vbootstrap is used to create a basic Vine Linux system on existing Vine Linux
  22. system. It uses rpm and apt to install basic rpm package into a directory
  23. which can be chrooted into.
  24. %description -l ja
  25. vbootstrap は Vine Linux の基本システムを既存の Vine Linux システム上で
  26. 作成するスクリプトです。rpm および apt を利用して、指定したディレクトリ
  27. 以下に基本の rpm パッケージをインストールし、chroot できるようにします。
  28. %prep
  29. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  30. %setup
  31. %build
  32. make
  33. %install
  34. make DESTDIR=$RPM_BUILD_ROOT install
  35. %clean
  36. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  37. %files
  38. %defattr(-,root,root)
  39. %{_sbindir}/vbootstrap
  40. %{_sbindir}/vbuilder
  41. %dir %{_datadir}/vbootstrap
  42. %{_datadir}/vbootstrap/*
  43. %config(noreplace) %{_sysconfdir}/vbootstrap/vbuilder.conf
  44. %changelog
  45. * Sat Oct 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-1
  46. - updated vbuilder.sh.in and vbuilder.conf.in
  47. - extended to store built rpms on chroot env. in each arch. of home rpm dir.
  48. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.4-1
  49. - added vine-release in BASE_PKGS of scripts/*
  50. - added vbuilder.conf
  51. - updated vbuilder.sh.in
  52. * Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-2
  53. - rebuilt to add signature
  54. * Mon Aug 31 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.3-1
  55. - support 5.0 (by daisuke-san)
  56. - update vbuilder.sh.in
  57. - check chroot archtecture
  58. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2-1
  59. - add vbuilder
  60. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-1
  61. - initial build