yatex-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393
  1. %define _noVersionedDependencies 1
  2. #% define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.78.4
  5. Release: 5%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. Source10: fwdevince.py
  15. ## Vine Patch(es)
  16. Patch1: yatexhlp-emacs.diff
  17. Patch2: yatex-make.diff
  18. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  19. # and modified to suit 1.70 release
  20. Patch3: yahtml-1.70-timestamp.patch
  21. Patch10: yatex-1.78.4-vine-vl7.patch
  22. URL: http://www.yatex.org/
  23. Group: Applications/Editors/Emacs
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Summary: YaTeX - Yet Another TeX mode for Emacs
  26. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  27. BuildArch: noarch
  28. Requires: evince python3
  29. Requires(post): emacsen
  30. Requires(post): emacsen-common
  31. Requires(post): make
  32. BuildRequires: emacsen-common
  33. BuildRequires: nkf perl
  34. Obsoletes: yatex-xemacs
  35. Distribution: Vine Linux
  36. Vendor: Project Vine
  37. Packager: munepi
  38. %description
  39. YaTeX is an intelligent, acquisitive and integrated package which reduces
  40. your efforts of composing LaTeX source on GNU Emacs.
  41. If you are YaTeX user and you install both yatex and auctex on your system,
  42. you may add the following configure in your emacs init file
  43. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  44. ;; I am a YaTeX user!!!
  45. (setq vine-default-auctex nil
  46. vine-default-preview-latex nil)
  47. %description -l ja
  48. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  49. してくれる、LaTeX 入力支援環境です。
  50. yatex と auctex パッケージの両方をインストールする場合、
  51. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  52. に以下の設定を追加するとよいでしょう。
  53. ;; YaTeX ユーザです!!!
  54. (setq vine-default-auctex nil
  55. vine-default-preview-latex nil)
  56. vine-default-yatex では、エディタ emacs と PDF プレビュー evince との
  57. forward/inverse search を設定済です。
  58. - emacs -> evince (forward search): C-c C-g
  59. - evince -> emacs (inverse search): Ctrl+左クリック
  60. %prep
  61. %setup -n yatex%{version}
  62. %patch1 -p1
  63. %patch2 -p1
  64. %patch3 -p1
  65. %patch10 -p1 -b .vine
  66. (cd docs
  67. # change permissions
  68. chmod 644 *
  69. # encode as utf-8 (LF)
  70. # NOTE: This changes needs to entry info files to Info DIR
  71. for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
  72. )
  73. %build
  74. %install
  75. %__rm -rf ${RPM_BUILD_ROOT}
  76. install -Dpm 755 %{SOURCE10} ${RPM_BUILD_ROOT}%{_bindir}/fwdevince
  77. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  80. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  81. #
  82. # install el files
  83. #
  84. %__cp -a *.el makefile help \
  85. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  86. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  87. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  88. #
  89. # install info files
  90. #
  91. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  92. ${RPM_BUILD_ROOT}%{_infodir}
  93. #
  94. # install script (bytecompile el and install elc, remove)
  95. #
  96. %_installemacsenscript %{name} %{SOURCE1}
  97. %_removeemacsenscript %{name} %{SOURCE2}
  98. %clean
  99. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  100. %post
  101. #
  102. # bytecompile and install
  103. #
  104. if [ "$1" = 2 ] ; then
  105. %_emacsenPackageRemove %{name}
  106. fi
  107. %_addemacsenlist %{name}
  108. %_emacsenPackageInstall %{name}
  109. for i in yatexe yatexj yahtmle yahtmlj; do
  110. /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
  111. %{_infodir}/${i}.gz
  112. done
  113. %preun
  114. if [ "$1" = 0 ]; then
  115. %_emacsenPackageRemove %{name}
  116. %_removeemacsenlist %{name}
  117. for i in yatexe yatexj yahtmle yahtmlj; do
  118. /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
  119. %{_infodir}/${i}.gz
  120. done
  121. fi
  122. %files
  123. %defattr(-,root,root)
  124. %doc 00readme install manifest yatex.new
  125. %doc docs
  126. %{_bindir}/fwdevince
  127. %{_datadir}/emacs/site-lisp/yatex/
  128. %{_infodir}/yahtmle*
  129. %{_infodir}/yahtmlj*
  130. %{_infodir}/yatexe*
  131. %{_infodir}/yatexj*
  132. %{emacsen_pkgdir}/install/%{name}
  133. %{emacsen_pkgdir}/remove/%{name}
  134. %changelog
  135. * Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-5
  136. - fixed fwdevince.py
  137. * Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-4
  138. - added Requires: evince python3
  139. * Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-3
  140. - updated vine-default-yatex.el
  141. - supported forward search via fwdevince.py/python3
  142. - supported inverse search via evince
  143. * Sun Jan 24 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-2
  144. - set uplatex+dvipdfmx as default
  145. * Mon Jan 11 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-1
  146. - new upstream release
  147. - TeX Live 2015
  148. * Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
  149. - new upstream release
  150. - applied yatex-1.77-vine-vl{6,7}.patch instead
  151. * Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
  152. - new upstream release
  153. - updated yatex-1.76-vine-vl{6,7}.patch
  154. * Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
  155. - source snapshot 20120511: testing version 1.76 development
  156. - dropped obsoleted/upstreamed patches
  157. - applied yatex-1.76-vine-vl{6,7}.patch
  158. * Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
  159. - added BuildRequires: nkf perl
  160. - updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
  161. - dropped pre-formatted info files
  162. - use original info files
  163. - encode info files as utf-8
  164. - add INFO-DIR-ENTRY
  165. * Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
  166. - fixed vine-default-yatex.el
  167. - applied yatex-1.74-vine.patch for vl6
  168. - updated yatex-1.74-vine.patch: support some extensions for \includegraphics
  169. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  170. - new upstream release
  171. - updated vine-default-yatex.el
  172. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  173. - support TeX Live 2011
  174. - applied yatex-1.74-vine-vl7.patch
  175. - updated vine-default-yatex.el
  176. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  177. - added Requires(post): make
  178. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  179. - updated vine-default-yatex.el
  180. - check 'YaTeX-inhibit-prefix-letter
  181. - used "pbibtex -kanji=utf8" as default bibtex-command
  182. - used "mendex -U" as default makeindex-command
  183. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  184. - updated vine-default-{yatex,yahtml}.el
  185. - revived auto-fill-mode on {yatex,yahtml}-mode
  186. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  187. - updated yatex-init.el
  188. - dropped all pathes of auctex and preview-latex from load-path
  189. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  190. - updated vine-default-yatex.el
  191. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  192. - supported TeX Live
  193. - used "eplatex", "pxdvi", "pdvips" as default commands
  194. - updated yatex-init.el
  195. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  196. - defined vine-default-yahtml
  197. - added vine-default-yahtml.el
  198. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  199. - updated vine-default-yatex.el
  200. - added bbl extension in auto-mode-alist to run yatex-mode
  201. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  202. - updated vine-default-yatex.el
  203. - supported new vine-default
  204. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  205. - new upstream release
  206. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  207. - updated vine-default-yatex.el
  208. - dropped (setq YaTeX-no-begend-shortcut t)
  209. - use %{emacsen_pkgdir}
  210. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  211. - updated vine-default-yatex.el
  212. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  213. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  214. - updated yatex-install.sh
  215. - *-init.el: changed from hard copy to symbolic link
  216. on /etc/emacs-XX.YY/site-start.d
  217. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  218. - fixed yatex-init.el
  219. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  220. - added yatex-init.el, vine-default-yatex.el
  221. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  222. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  223. - spec in utf8
  224. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  225. - applied new versioning policy
  226. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  227. - new upstream release
  228. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  229. - s/Copyright/License/
  230. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  231. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  232. - update yatex-1.72
  233. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  234. - update yatex-1.71
  235. * Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  236. - added Patch3 to add hhmts timestamp feature
  237. * Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  238. - update yatex-1.70
  239. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  240. - update yatex10203151806
  241. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  242. - fixed: bytecompile yatex19
  243. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  244. - now emacsen-common aware
  245. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  246. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  247. - 1.68-0vl2
  248. - no kanji code conversion of documents
  249. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  250. - 1.68-0vl1
  251. - update to 1.68
  252. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  253. - 1.67-6vl5
  254. - YATEXHLP.{jp,eng} moved to appropriate dir
  255. * Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  256. - 1.67-6vl3
  257. - rebuilt for emacs-20.7
  258. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  259. - 1.67-6vl2
  260. - oops ... fixed target dir for help files
  261. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  262. - 1.67-6vl1
  263. - rebuilt for emacs-20.6
  264. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  265. - 1.67-6
  266. - included forgotten info file for YaHTML
  267. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  268. - 1.67-5
  269. - updated for emacs-20.5a release
  270. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  271. - 1.67-4
  272. - change Group to Applications/Editors/EmacsLisp
  273. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  274. - 1.67-3
  275. - %post and %preun section modified
  276. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  277. - 1.67-2
  278. - fixed minor problem in the %files section
  279. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  280. - 1.67-1
  281. - updated to 1.67 release
  282. - rebuilt for emacs-20.4 on Vine Linux 1.9
  283. - updated URL for the new web site of YaTeX
  284. - some typo fix
  285. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  286. - Initial Release