yaml-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. %define pkg_name yaml
  2. %define pkg_version 0.11.0.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Support for parsing and rendering YAML documents
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: transformers-compat-0.6.2.tar.gz
  13. Source12: transformers-compat.cabal
  14. Source13: unliftio-core-0.1.2.0.tar.gz
  15. Source14: unliftio-core.cabal
  16. Source15: vector-algorithms-0.8.0.1.tar.gz
  17. Source16: vector-algorithms.cabal
  18. Source17: exceptions-0.10.0.tar.gz
  19. Source18: exceptions.cabal
  20. Source19: mono-traversable-1.0.9.0.tar.gz
  21. Source20: mono-traversable.cabal
  22. Source21: resourcet-1.2.2.tar.gz
  23. Source22: resourcet.cabal
  24. Source23: conduit-1.3.1.tar.gz
  25. Source24: conduit.cabal
  26. Source25: libyaml-0.1.0.0.tar.gz
  27. Source26: libyaml.cabal
  28. Source27: yaml-0.11.0.0.tar.gz
  29. Source28: yaml.cabal
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: ghc haskell-platform
  32. BuildRequires: libffi-devel gmp-devel zlib-devel
  33. BuildRequires: libghc-dlist
  34. BuildRequires: libghc-old-locale
  35. BuildRequires: libghc-aeson
  36. BuildRequires: libghc-semigroups
  37. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  38. Requires: ghc haskell-platform
  39. Requires: haskell-platform-dep
  40. Requires: libghc-dlist
  41. Requires: libghc-old-locale
  42. Requires: libghc-aeson
  43. Requires: libghc-semigroups
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: ara_t
  47. %description
  48. This package includes the full libyaml C library version 0.1.5
  49. by Kirill Simonov in the package so you don't need to worry
  50. about any non-Haskell dependencies.
  51. The package is broken down into two primary modules.
  52. "Data.Yaml" provides a high-level interface based around the JSON datatypes
  53. provided by the @aeson@ package.
  54. "Text.Libyaml" provides a lower-level, streaming interface.
  55. For most users, "Data.Yaml" is recommended.
  56. #'
  57. %prep
  58. %{__rm} -rf ${RPM_BUILD_ROOT}
  59. %build
  60. %ghc_pkg_init
  61. for pkg in `sed '$d' %{SOURCE0}`; do
  62. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  63. pushd ${pkg}
  64. %ghc_fix_dependencies ${pkg}
  65. %cabal_configure2 %{name} ${pkg}
  66. %cabal_build
  67. %cabal_haddock
  68. %cabal_copy_resister %{name}_${pkg}
  69. popd
  70. done
  71. # build yaml
  72. for pkg in `tail -n 1 %{SOURCE0}`; do
  73. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  74. pushd ${pkg}
  75. %ghc_fix_dependencies ${pkg}
  76. %cabal_configure2 %{name}/${pkg} \
  77. -f -no-exe
  78. %cabal_build
  79. %cabal_haddock
  80. %cabal_copy_resister %{pkg_name}-%{version}
  81. popd
  82. done
  83. %install
  84. # copy documents
  85. pushd %{_builddir}/%{pkg_name}-%{version}
  86. %{__cp} ChangeLog.md README.md \
  87. ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
  88. popd
  89. %clean
  90. %{__rm} -rf ${RPM_BUILD_ROOT}
  91. %post
  92. %ghc_pkg_recache
  93. %postun
  94. %ghc_pkg_recache
  95. %files
  96. %defattr(-, root, root)
  97. %{_bindir}/
  98. %{_libdir}/ghc-%{ghc_version}/
  99. %{_libdir}/ghc-lib/
  100. %{_docdir}/%{name}/
  101. %changelog
  102. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.11.0.0-1
  103. - update to 0.11.0.0
  104. - build using ghc-8.6.3
  105. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-2
  106. - rebuild with ghc-8.4.3-2
  107. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.9.0-1
  108. - update to 0.9.0
  109. - build using ghc-8.4.3
  110. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.8.30-1
  111. - update to 0.8.30
  112. - rebuild using ghc-8.4.2
  113. - rewrite using macro
  114. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.8.25.1-1
  115. - update to 0.8.25.1
  116. - build using ghc-8.2.2
  117. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-2
  118. - build using ghc-8.0.2
  119. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.8.21.2-1
  120. - update to 0.8.21.2
  121. - build using ghc-8.0.1
  122. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-3
  123. - rebuilt
  124. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-2
  125. - correct SPEC file
  126. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.8.16-1
  127. - new package