yakuake-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. Name: yakuake
  2. Summary: Terminal emulator
  3. Summary(ja): 端末エミュレータ
  4. Version: 2.9.9
  5. Release: 2%{?_dist_release}
  6. Group: User Interface/Desktops
  7. License: GPLv2+
  8. URL: http://extragear.kde.org/apps/yakuake/
  9. Source0: http://download.berlios.de/yakuake/%{name}-%{version}.tar.xz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: desktop-file-utils
  12. BuildRequires: gettext
  13. BuildRequires: kdelibs4-devel
  14. BuildRequires: soprano-devel
  15. # konsolepart
  16. Requires: kdebase4
  17. %description
  18. Yakuake is a "Quake console" like terminal emulator.
  19. %description -l ja
  20. Quake console ライクな端末エミュレータです.
  21. %prep
  22. %setup -q
  23. %build
  24. mkdir -p %{_target_platform}
  25. pushd %{_target_platform}
  26. %{cmake} \
  27. -DCMAKE_BUILD_TYPE=release \
  28. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  29. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  30. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  31. ..
  32. popd
  33. make %{?_smp_mflags} -C %{_target_platform}
  34. %install
  35. rm -rf %{buildroot}
  36. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  37. ## --vendor is discouraged/deprecated these days -- Rex
  38. #desktop-file-install --vendor="" \
  39. # --dir=%{buildroot}%{_datadir}/applications \
  40. # --add-category=Utility \
  41. # --delete-original \
  42. # %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
  43. %find_lang %{name}
  44. %check
  45. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
  46. %post
  47. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  48. %posttrans
  49. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  50. %postun
  51. if [ $1 -eq 0 ] ; then
  52. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  53. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  54. fi
  55. %clean
  56. rm -rf %{buildroot}
  57. %files -f %{name}.lang
  58. %defattr(-,root,root,-)
  59. %doc AUTHORS COPYING ChangeLog TODO
  60. %{_bindir}/yakuake
  61. %{_datadir}/applications/kde4/yakuake.desktop
  62. %{_datadir}/config/yakuake.knsrc
  63. %{_datadir}/kde4/apps/kconf_update/yakuake-2.9.9-startupnotification.pl
  64. %{_datadir}/kde4/apps/kconf_update/yakuake.upd
  65. %{_datadir}/kde4/apps/yakuake/
  66. %{_datadir}/icons/hicolor/*/*/*
  67. %changelog
  68. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.9-2
  69. - rebuild with gcc-5.4.0
  70. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.9-1
  71. - new upstream release
  72. - add BuildRequires: soprano-devel
  73. * Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.7-2
  74. - Initial build for Vine Linux
  75. * Sun Jul 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.9.7-1
  76. - 2.9.7
  77. - optimize scriptlets
  78. - use _kde4_ macros
  79. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.6-2
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  81. * Thu Jul 10 2009 Johan Cwiklinski <johan AT x-tnd DOT be> 2.9.6-1
  82. - 2.9.6
  83. * Sat Apr 17 2009 Johan Cwiklinski <johan AT x-tnd DOT be> 2.9.4-3
  84. - Fix crash with QT 4.5
  85. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  87. * Thu Sep 4 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.4-1
  88. - 2.9.4
  89. - change BR from kdelibs4-devel to kdelibs-devel
  90. * Fri Jun 20 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.3-1
  91. - 2.9.3
  92. - kdebase is required
  93. * Sat Apr 05 2008 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.1-1
  94. - 2.9.1
  95. - use of %%{cmake_kde4} macro
  96. - remove no longer needeed chrpath
  97. * Wed Apr 02 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.9-2.beta1
  98. - BR: kdelibs4-devel
  99. - description/summary: s/for KDE//
  100. * Mon Feb 11 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9-1.beta1
  101. - upstream release for KDE4
  102. * Mon Oct 30 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-4
  103. - Add support for KonsoleScripts (#212862)
  104. * Fri Sep 15 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-3
  105. - Rebuild for FE6
  106. - Update e-mail address
  107. - Fix mixed-use-of-spaces-and-tabs rpmlint warning
  108. * Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-2
  109. - Add dist tag
  110. * Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-1
  111. - Update to 2.7.5
  112. - Add `--disable-dependency-tracking' and `--enable-final' options
  113. - Include translations
  114. * Mon Oct 24 2005 Mickael <dreadyman@gmail.com>
  115. - initial release