xmlsec1-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. Summary: Library providing support for "XML Signature" and "XML Encryption" standards
  2. Name: xmlsec1
  3. Version: 1.3.2
  4. Release: 1%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: MIT
  9. URL: https://www.aleksey.com/xmlsec/
  10. Source: https://www.aleksey.com/xmlsec/download/xmlsec1-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel >= 2.6.0
  13. BuildRequires: libxslt-devel >= 1.1.0
  14. BuildRequires: openssl-devel >= 0.9.6
  15. BuildRequires: libgcrypt-devel >= 1.4.0
  16. BuildRequires: gnutls-devel >= 1.0.20
  17. BuildRequires: nss-devel >= 3.2
  18. BuildRequires: nspr-devel
  19. BuildRequires: libtool-ltdl-devel
  20. # extra build deps needed for autoreconf after above patch
  21. BuildRequires: autoconf
  22. BuildRequires: automake
  23. BuildRequires: gettext-devel
  24. BuildRequires: libtool
  25. %description
  26. XML Security Library is a C library based on LibXML2 and OpenSSL.
  27. The library was created with a goal to support major XML security
  28. standards "XML Digital Signature" and "XML Encryption".
  29. %package devel
  30. Summary: Libraries, includes, etc. to develop applications with XML Digital Signatures and XML Encryption support.
  31. Group: programming
  32. Requires: xmlsec1 = %{version}-%{release}
  33. Requires: libxml2-devel >= 2.6.0
  34. Requires: libxslt-devel >= 1.1.0
  35. Requires: openssl-devel >= 0.9.6
  36. Requires: zlib-devel
  37. Requires: pkgconfig
  38. %description devel
  39. Libraries, includes, etc. you can use to develop applications with XML Digital
  40. Signatures and XML Encryption support.
  41. %package openssl
  42. Summary: OpenSSL crypto plugin for XML Security Library
  43. Group: system
  44. Requires: xmlsec1 = %{version}-%{release}
  45. %description openssl
  46. OpenSSL plugin for XML Security Library provides OpenSSL based crypto services
  47. for the xmlsec library
  48. %package openssl-devel
  49. Summary: OpenSSL crypto plugin for XML Security Library
  50. Group: programming
  51. Requires: xmlsec1-devel = %{version}-%{release}
  52. Requires: xmlsec1-openssl = %{version}-%{release}
  53. %description openssl-devel
  54. Libraries, includes, etc. for developing XML Security applications with OpenSSL
  55. %package gcrypt
  56. Summary: GCrypt crypto plugin for XML Security Library
  57. Group: system
  58. Requires: xmlsec1 = %{version}-%{release}
  59. %description gcrypt
  60. GCrypt plugin for XML Security Library provides GCrypt based crypto services
  61. for the xmlsec library.
  62. %package gcrypt-devel
  63. Summary: GCrypt crypto plugin for XML Security Library
  64. Group: programming
  65. Requires: xmlsec1-devel = %{version}-%{release}
  66. Requires: xmlsec1-gnutls-devel = %{version}-%{release}
  67. %description gcrypt-devel
  68. Libraries, includes, etc. for developing XML Security applications with GCrypt.
  69. %package gnutls
  70. Summary: GNUTls crypto plugin for XML Security Library
  71. Group: system
  72. Requires: xmlsec1 = %{version}-%{release}
  73. %description gnutls
  74. GNUTls plugin for XML Security Library provides GNUTls based crypto services
  75. for the xmlsec library
  76. %package gnutls-devel
  77. Summary: GNUTls crypto plugin for XML Security Library
  78. Group: programming
  79. Requires: xmlsec1 = %{version}
  80. Requires: xmlsec1-devel = %{version}
  81. Requires: xmlsec1-openssl = %{version}
  82. Requires: libgcrypt-devel >= 1.2.0
  83. Requires: gnutls-devel >= 1.0.20
  84. %description gnutls-devel
  85. Libraries, includes, etc. for developing XML Security applications with GNUTls
  86. %package nss
  87. Summary: NSS crypto plugin for XML Security Library
  88. Group: system
  89. Requires: xmlsec1 = %{version}-%{release}
  90. %description nss
  91. NSS plugin for XML Security Library provides NSS based crypto services
  92. for the xmlsec library
  93. %package nss-devel
  94. Summary: NSS crypto plugin for XML Security Library
  95. Group: programming
  96. Requires: xmlsec1-devel = %{version}-%{release}
  97. Requires: xmlsec1-nss = %{version}-%{release}
  98. Requires: nss-devel >= 3.2
  99. Requires: nspr-devel
  100. %description nss-devel
  101. Libraries, includes, etc. for developing XML Security applications with NSS
  102. %debug_package
  103. %prep
  104. %autosetup -p1
  105. %build
  106. autoreconf -if
  107. %configure --enable-silent-rules --disable-static
  108. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  109. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  110. make
  111. # positively ugly but only sane way to get around #192756
  112. sed 's+/lib64+/$archlib+g' < xmlsec1-config | sed 's+/lib+/$archlib+g' | sed 's+ -DXMLSEC_NO_SIZE_T++' > xmlsec1-config.$$ && mv xmlsec1-config.$$ xmlsec1-config
  113. %install
  114. rm -rf $RPM_BUILD_ROOT
  115. mkdir -p $RPM_BUILD_ROOT/usr/bin
  116. mkdir -p $RPM_BUILD_ROOT/usr/include/xmlsec1
  117. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  118. mkdir -p $RPM_BUILD_ROOT/usr/man/man1
  119. make install DESTDIR=$RPM_BUILD_ROOT
  120. #make prefix=$RPM_BUILD_ROOT%{prefix} mandir=$RPM_BUILD_ROOT%{_mandir} install
  121. rm -fv $RPM_BUILD_ROOT%{_libdir}/*.la
  122. #rm -fv $RPM_BUILD_ROOT%{_libdir}/*.a
  123. rm -rf docs-to-install
  124. mkdir -p docs-to-install
  125. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1/* docs-to-install
  126. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/xmlsec1
  127. %clean
  128. rm -fr %{buildroot}
  129. %files
  130. %defattr(-, root, root)
  131. %license Copyright
  132. %doc AUTHORS ChangeLog NEWS README
  133. %doc %{_mandir}/man1/xmlsec1.1*
  134. %{_libdir}/libxmlsec1.so.*
  135. %{_bindir}/xmlsec1
  136. %files devel
  137. %defattr(-, root, root)
  138. %{_bindir}/xmlsec1-config
  139. %{_includedir}/xmlsec1
  140. %exclude %{_includedir}/xmlsec1/xmlsec/gcrypt
  141. %exclude %{_includedir}/xmlsec1/xmlsec/gnutls
  142. %exclude %{_includedir}/xmlsec1/xmlsec/nss
  143. %exclude %{_includedir}/xmlsec1/xmlsec/openssl
  144. %{_libdir}/libxmlsec1.so
  145. %{_libdir}/pkgconfig/xmlsec1.pc
  146. %{_libdir}/xmlsec1Conf.sh
  147. %{_datadir}/aclocal/*.m4
  148. %license Copyright
  149. %doc AUTHORS HACKING ChangeLog NEWS README
  150. %doc docs-to-install/*
  151. %doc %{_mandir}/man1/xmlsec1-config.1*
  152. %files openssl
  153. %defattr(-, root, root)
  154. %{_libdir}/libxmlsec1-openssl.so
  155. %{_libdir}/libxmlsec1-openssl.so.*
  156. %files openssl-devel
  157. %defattr(-, root, root)
  158. %{_includedir}/xmlsec1/xmlsec/openssl
  159. %{_libdir}/pkgconfig/xmlsec1-openssl.pc
  160. %files gcrypt
  161. %defattr(-, root, root, -)
  162. %{_libdir}/libxmlsec1-gcrypt.so
  163. %{_libdir}/libxmlsec1-gcrypt.so.*
  164. %files gcrypt-devel
  165. %defattr(-, root, root, -)
  166. %{_includedir}/xmlsec1/xmlsec/gcrypt
  167. %{_libdir}/pkgconfig/xmlsec1-gcrypt.pc
  168. %files gnutls
  169. %defattr(-, root, root)
  170. %{_libdir}/libxmlsec1-gnutls.so
  171. %{_libdir}/libxmlsec1-gnutls.so.*
  172. %files gnutls-devel
  173. %defattr(-, root, root)
  174. %{_includedir}/xmlsec1/xmlsec/gnutls
  175. %{_libdir}/pkgconfig/xmlsec1-gnutls.pc
  176. %files nss
  177. %defattr(-, root, root)
  178. %{_libdir}/libxmlsec1-nss.so
  179. %{_libdir}/libxmlsec1-nss.so.*
  180. %files nss-devel
  181. %defattr(-, root, root)
  182. %{_includedir}/xmlsec1/xmlsec/nss
  183. %{_libdir}/pkgconfig/xmlsec1-nss.pc
  184. %changelog
  185. * Fri Nov 03 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  186. - new upstream release.
  187. * Wed Jun 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  188. - new upstream release.
  189. * Thu Apr 13 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
  190. - new upstream release.
  191. * Tue Nov 29 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.37-1
  192. - new upstream release.
  193. * Wed Nov 02 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.36-1
  194. - new upstream release.
  195. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.35-1
  196. - new upstream release.
  197. * Sat Oct 16 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.32-1
  198. - new upstream release.
  199. - built with openssl-3.0.0.
  200. - dropped ldconfig scriptlets.
  201. * Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.29-1
  202. - new upstream release.
  203. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.27-1
  204. - new upstream release.
  205. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.22-1
  206. - new upstream release.
  207. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-3
  208. - rebuilt with gnutls-3.4.x.
  209. * Fri Jul 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.20-2
  210. - fixed %%files.
  211. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.20-1
  212. - new upstream release
  213. - moved gcrypt to System Environment/Libraries Group
  214. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.16-1
  215. - new upstream release
  216. - add BuildRequires: libtool-ltdl-devel
  217. - add -gcrypt,-gcrypt-devel package
  218. * Fri Jul 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.12-1
  219. - new upstream release with security fix (CVE-2009-0217)
  220. - remove *.a files
  221. * Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-2
  222. - rebuilt with gnutls-2.6.3
  223. * Wed Jul 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
  224. - new upstream release
  225. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
  226. - initial build for Vine Linux
  227. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-8.1
  228. - rebuild
  229. * Wed Jun 14 2006 Tomas Mraz <tmraz@redhat.com> - 1.2.9-8
  230. - rebuilt with new gnutls
  231. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-7
  232. - oops libxmlsec1.la was still there, should fix #171410 and #154142
  233. * Thu Jun 8 2006 Daniel Veillard <veillard@redhat.com> - 1.2.9-6
  234. - Ugly patch and sed based changes to work around #192756 xmlsec1-config
  235. multilib problem
  236. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.9-5
  237. - move .so symlinks to -devel subpackage
  238. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.2
  239. - bump again for double-long bug on ppc(64)
  240. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.9-4.1
  241. - rebuilt for new gcc4.1 snapshot and glibc changes
  242. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 1.2.9-4
  243. - NSS has been split out of the mozilla package, so require that now
  244. and update separate_nspr.patch to account for the new NSS as well
  245. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  246. - rebuilt
  247. * Wed Nov 23 2005 Tomas Mraz <tmraz@redhat.com> 1.2.9-3
  248. - rebuilt due to gnutls library revision
  249. * Wed Nov 9 2005 <veillard@redhat.com> 1.2.9-2
  250. - rebuilt due to openssl library revision
  251. * Tue Sep 20 2005 <veillard@redhat.com> 1.2.9-1
  252. - update from upstream, release done in July
  253. - apparently nss is now available on ppc64
  254. * Mon Aug 8 2005 <veillard@redhat.com> 1.2.8-3
  255. - rebuilt with new gnutls
  256. - nspr has been split to a separate package
  257. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-2
  258. - Enabling the mozilla-nss crypto backend
  259. * Fri Jul 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.8-1
  260. - update from upstream, needed for openoffice
  261. * Tue Mar 8 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-4
  262. - rebuilt with gcc4
  263. * Wed Feb 23 2005 Daniel Veillard <veillard@redhat.com> 1.2.7-1
  264. - Upstream release of 1.2.7, mostly bug fixes plus new functions
  265. to GetKeys from simple store and X509 handling.
  266. * Wed Feb 9 2005 Daniel Veillard <veillard@redhat.com> 1.2.6-4
  267. - Adding support for GNUTls crypto backend
  268. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-3
  269. - adding missing ldconfig calls
  270. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 1.2.6-2
  271. - updated with upstream release from Aleksey
  272. * Mon Jun 21 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-2
  273. - rebuilt
  274. * Mon Apr 19 2004 Daniel Veillard <veillard@redhat.com> 1.2.5-1
  275. - updated with upstream release from Aleksey
  276. * Wed Feb 11 2004 Daniel Veillard <veillard@redhat.com> 1.2.4-1
  277. - updated with upstream release from Aleksey
  278. * Tue Jan 6 2004 Daniel Veillard <veillard@redhat.com> 1.2.3-1
  279. - updated with upstream release from Aleksey
  280. * Wed Nov 12 2003 Daniel Veillard <veillard@redhat.com> 1.2.2-1
  281. - updated with upstream release from Aleksey, specific patches should
  282. have been integrated now.
  283. * Thu Nov 6 2003 Daniel Veillard <veillard@redhat.com> 1.2.1-1
  284. - initial packaging based on the upstream one and libxml2 one.
  285. - desactivated mozilla-nss due to detection/architecture problems