utempter-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. Summary: A privileged helper for utmp/wtmp updates.
  2. Name: utempter
  3. Version: 0.5.5
  4. Release: 6%{?_dist_release}
  5. License: MIT/LGPL
  6. Group: System Environment/Base
  7. Source: utempter-%{version}.tar.gz
  8. Prereq: /usr/sbin/groupadd, /sbin/ldconfig, fileutils
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  11. %description
  12. Utempter is a utility which allows some non-privileged programs to
  13. have required root access without compromising system
  14. security. Utempter accomplishes this feat by acting as a buffer
  15. between root and the programs.
  16. %package -n compat32-%{name}
  17. Summary: A privileged helper for utmp/wtmp updates.
  18. Group: System Environment/Base
  19. Requires: %{name} = %{version}-%{release}
  20. %description -n compat32-%{name}
  21. Utempter is a utility which allows some non-privileged programs to
  22. have required root access without compromising system
  23. security. Utempter accomplishes this feat by acting as a buffer
  24. between root and the programs.
  25. %prep
  26. %setup -q
  27. %build
  28. make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
  29. %install
  30. rm -rf $RPM_BUILD_ROOT
  31. make PREFIX=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
  32. /sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
  33. %clean
  34. rm -rf $RPM_BUILD_ROOT
  35. %pre
  36. /usr/sbin/groupadd -g 22 -r -f utmp
  37. %post
  38. {
  39. /sbin/ldconfig
  40. for file in /var/log/wtmp /var/run/utmp ; do
  41. if [ -f $file ]; then
  42. chown root:utmp $file
  43. chmod 664 $file
  44. fi
  45. done
  46. }
  47. %postun -p /sbin/ldconfig
  48. %post -n compat32-%{name} -p /sbin/ldconfig
  49. %postun -n compat32-%{name} -p /sbin/ldconfig
  50. %files
  51. %defattr(-,root,root)
  52. %attr(02755, root, utmp) %{_sbindir}/utempter
  53. %doc COPYING
  54. %{_libdir}/libutempter.so*
  55. %{_includedir}/utempter.h
  56. %if %{build_compat32}
  57. %files -n compat32-%{name}
  58. %defattr(-,root,root)
  59. %{_libdir}/libutempter.so*
  60. %endif
  61. %changelog
  62. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.5-6vl5
  63. - applied new versioning policy
  64. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.5.5-6vl2
  65. - added compat32- packages for x86_64 architecture support
  66. * Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.5-6vl1
  67. - based on Fedora 0.5.5-6
  68. * Mon Apr 19 2004 Mike A. Harris <mharris@redhat.com> 0.5.5-1
  69. - [SECURITY] Fix CAN-2004-0233 utempter directory traversal symlink attack
  70. issue for immediate erratum release.
  71. - Build all-arch test package 0.5.5-1 in dist-fc2-scratch
  72. * Mon Feb 23 2004 Mike A. Harris <mharris@redhat.com> 0.5.4-1
  73. - Rewrote post install script to be a bit cleaner and rebuilt in rawhide to
  74. pick up twaugh's chown change
  75. - Added 'srpm-x' target to Makefile for package maintainer SRPM building
  76. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
  77. - Use ':' instead of '.' as separator for chown.
  78. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.3-2vl1
  79. - based on Redhat Rawhide 0.5.3-2
  80. - Fri May 30 2003 Mike A. Harris <mharris@redhat.com> 0.5.3-1
  81. - Bump version and release and rebuild to strip debug info into .debuginfo
  82. package, as the Red Hat Linux 9 package shipped unstripped (#91664)
  83. - Updated license field to reflect dual license MIT style + LGPL
  84. - Changed spec file Copyright tag to proper License tag
  85. - Removed stupid crackrock "version" macro define
  86. - Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 0.5.2-9
  87. - Don't strip binary
  88. - Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
  89. - added LGPL notice
  90. * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-4vl2
  91. - rebuild to remove rpmlib dependancy
  92. * Tue May 29 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  93. - 0.5.2-4vl1
  94. - rebuilt for Vine Linux
  95. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  96. - automatic rebuild
  97. * Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
  98. - defattr root
  99. * Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
  100. - added LGPL notice
  101. * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
  102. - strip utempter
  103. * Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
  104. - add utmp as group 22
  105. * Fri Jun 4 1999 Jeff Johnson <jbj@redhat.com>
  106. - ignore SIGCHLD while processing utmp.