udisks-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. %bcond_with systemd
  2. %define glib2_version 2.6.0
  3. %define dbus_version 1.2
  4. %define dbus_glib_version 0.82
  5. %define polkit_version 0.92
  6. %define parted_version 2.3
  7. %define eudev_version 1.7
  8. %define mdadm_version 2.6.7
  9. %define device_mapper_version 1.02
  10. %define libatasmart_version 0.12
  11. %define sg3_utils_version 1.27
  12. %define smp_utils_version 0.94
  13. Summary: Storage Management Service
  14. Name: udisks
  15. Version: 1.0.5
  16. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  17. Group: system
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. License: GPLv2+
  21. URL: https://www.freedesktop.org/wiki/Software/udisks
  22. Source0: https://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
  23. # https://bugs.freedesktop.org/show_bug.cgi?id=90778
  24. Patch0: udisks-1.0.5-fix-build-with-glibc-2.20.patch
  25. Patch1: fix_bash_completion.patch
  26. # https://bugzilla.redhat.com/show_bug.cgi?id=1238664
  27. Patch2: udisks-1.0.5-fix-service-file.patch
  28. Patch3: udisks-1.0.5-fix-makedev-failure.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  30. BuildRequires: glib2-devel >= %{glib2_version}
  31. BuildRequires: dbus-devel >= %{dbus_version}
  32. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  33. BuildRequires: polkit-devel >= %{polkit_version}
  34. BuildRequires: parted-devel >= %{parted_version}
  35. BuildRequires: device-mapper-devel >= %{device_mapper_version}
  36. BuildRequires: intltool
  37. BuildRequires: libatasmart-devel >= %{libatasmart_version}
  38. BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
  39. %if %{with systemd}
  40. BuildRequires: systemd-devel
  41. BuildRequires: libgudev-devel
  42. %{?systemd_requires}
  43. %else
  44. BuildRequires: eudev-libgudev1-devel >= %{eudev_version}
  45. BuildRequires: eudev-libudev-devel >= %{eudev_version}
  46. %endif
  47. # needed to pull in the system bus daemon
  48. Requires: dbus >= %{dbus_version}
  49. # needed to pull in the udev daemon
  50. Requires: eudev >= %{eudev_version}
  51. # we need at least this version for bugfixes / features etc.
  52. Requires: libatasmart >= %{libatasmart_version}
  53. Requires: mdadm >= %{mdadm_version}
  54. # for smp_rep_manufacturer
  55. Requires: smp_utils >= %{smp_utils_version}
  56. # for mount, umount, mkswap
  57. Requires: util-linux-ng
  58. # for mkfs.ext3, mkfs.ext3, e2label
  59. Requires: e2fsprogs
  60. # for mkfs.xfs, xfs_admin
  61. Requires: xfsprogs
  62. # for mkfs.vfat
  63. Requires: dosfstools
  64. # for mlabel
  65. Requires: mtools
  66. # for mkntfs - no ntfsprogs on ppc, though
  67. %ifnarch ppc ppc64
  68. Requires: ntfsprogs
  69. %endif
  70. # for /proc/self/mountinfo, only available in 2.6.26 or higher
  71. Conflicts: kernel < 2.6.26
  72. # we need liblvm2app at least this recent since the ABI changed (sizes
  73. # reported in number of bytes instead of number of sectors) without
  74. # the sonumber changing
  75. #
  76. Requires: lvm2-libs >= %{lvm2_version}
  77. # Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
  78. # ABI just with a different name and versioning-scheme
  79. #
  80. Obsoletes: DeviceKit-disks <= 009
  81. Provides: DeviceKit-disks = 010
  82. %description
  83. udisks provides a daemon, D-Bus API and command line tools
  84. for managing disks and storage devices.
  85. %package devel
  86. Summary: D-Bus interface definitions for udisks
  87. Group: programming
  88. Requires: %{name} = %{version}-%{release}
  89. Requires: gtk-doc
  90. # See comment above
  91. #
  92. Obsoletes: DeviceKit-disks-devel <= 009
  93. Provides: DeviceKit-disks-devel = 010
  94. %description devel
  95. D-Bus interface definitions and documentation for udisks.
  96. %prep
  97. %setup -q
  98. %autopatch -p1
  99. # https://bugzilla.redhat.com/show_bug.cgi?id=673544#c15
  100. rm -f src/*-glue.h tools/*-glue.h
  101. autoreconf --force --install
  102. %build
  103. %configure \
  104. --enable-gtk-doc \
  105. %{nil}
  106. make %{_smp_mflags}
  107. %install
  108. rm -rf $RPM_BUILD_ROOT
  109. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  110. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  111. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  112. # for now, include a compat symlink for the command-line tool
  113. # and man page
  114. ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
  115. ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
  116. # TODO: should be fixed upstream
  117. chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
  118. %find_lang %{name}
  119. %clean
  120. rm -rf $RPM_BUILD_ROOT
  121. %if %{with systemd}
  122. %post
  123. %systemd_post udisks.service
  124. %preun
  125. %systemd_preun udisks.service
  126. %postun
  127. %systemd_postun_with_restart udisks.service
  128. %endif
  129. %files -f %{name}.lang
  130. %defattr(-,root,root,-)
  131. %license COPYING
  132. %doc README AUTHORS NEWS HACKING doc/TODO
  133. %{_sysconfdir}/avahi/services/udisks.service
  134. %{_sysconfdir}/dbus-1/system.d/*.conf
  135. %{_sysconfdir}/profile.d/*.sh
  136. %if %{with systemd}
  137. %{_unitdir}/udisks.service
  138. %endif
  139. /lib/udev/rules.d/*.rules
  140. /lib/udev/udisks-part-id
  141. /lib/udev/udisks-dm-export
  142. /lib/udev/udisks-probe-ata-smart
  143. /lib/udev/udisks-probe-sas-expander
  144. /sbin/umount.udisks
  145. %{_bindir}/*
  146. %{_libexecdir}/*
  147. %{_mandir}/man1/*
  148. %{_mandir}/man7/*
  149. %{_mandir}/man8/*
  150. %{_datadir}/polkit-1/actions/*.policy
  151. %{_datadir}/dbus-1/system-services/*.service
  152. %attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
  153. %files devel
  154. %defattr(-,root,root,-)
  155. %{_datadir}/dbus-1/interfaces/*.xml
  156. %{_datadir}/pkgconfig/udisks.pc
  157. %dir %{_datadir}/gtk-doc/html/udisks
  158. %{_datadir}/gtk-doc/html/udisks/*
  159. %changelog
  160. * Tue Aug 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-2
  161. - rebuilt with sg3_utils-1.45.
  162. - added systemd support (disabled as default).
  163. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-1
  164. - new upstream release.
  165. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-4
  166. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  167. - change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
  168. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
  169. - rebuild with parted-3.1
  170. * Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  171. - rebuild with parted-3.0
  172. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  173. - new upstream release
  174. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  175. - new upstream release
  176. - drop Patch0
  177. * Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  178. - add Patch0 (10-ide-cd-support.patch) from ubuntu
  179. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  180. - new upstream release
  181. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
  182. - rebuilt with parted 2.3
  183. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
  184. - new upstream release
  185. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
  186. - Initial build for Vine Linux
  187. * Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
  188. - Bump release and rebuild so we link to the new libparted.
  189. * Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
  190. - Update to release 1.0.0
  191. * Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
  192. - Update to new git snapshot
  193. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
  194. - Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
  195. * Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
  196. - Update for new liblvm2app library
  197. * Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
  198. - Update to git snapshot
  199. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
  200. - Rebuild
  201. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
  202. - New git snapshot with LVM support
  203. * Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
  204. - Rebuild for new libparted
  205. * Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
  206. - Rebuild
  207. * Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
  208. - Updated for package review (#543608)
  209. * Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
  210. - Git snapshot for upcoming 1.0.0 release