uClibc-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. #define prever rc3
  2. Summary: C library for embedded Linux
  3. Summary(ja): 組み込みLinux用のCライブラリ
  4. Name: uClibc
  5. Version: 0.9.33.2
  6. Release: 1%{?_dist_release}
  7. Group: Development/Libraries
  8. License: LGPLv2
  9. URL: http://www.uclibc.org/
  10. Source0: http://www.uclibc.org/downloads/%{name}-%{version}.tar.xz
  11. Source1: uClibc.config
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. %global debug_package %{nil}
  14. # This package only contains a static library
  15. ExcludeArch: ppc64
  16. # uclibc 0.9.30 does not support ppc64
  17. %description
  18. uClibc is a C library for developing embedded Linux systems.
  19. It is much smaller than the GNU C Library, but nearly all applications
  20. supported by glibc also work perfectly with uClibc.
  21. %package devel
  22. Summary: Header files and libraries for uClibc library
  23. Summary(ja): Header files and libraries for uClibc library
  24. Group: Development/Libraries
  25. Provides: uClibc-static = %{version}-%{release}
  26. %description devel
  27. uClibc is a C library for developing embedded Linux systems.
  28. It is much smaller than the GNU C Library, but nearly all applications
  29. supported by glibc also work perfectly with uClibc.
  30. This package contains the header files and libraries
  31. needed for uClibc package.
  32. %prep
  33. %setup -q -n %{name}-%{version}
  34. cat %{SOURCE1} >.config1
  35. iconv -f windows-1252 -t utf-8 README >README.pom
  36. mv README.pom README
  37. %build
  38. mkdir kernel-include
  39. cp -a /usr/include/asm kernel-include
  40. cp -a /usr/include/asm-generic kernel-include
  41. cp -a /usr/include/linux kernel-include
  42. arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/'`
  43. echo "TARGET_$arch=y" >.config
  44. echo "TARGET_ARCH=\"$arch\"" >>.config
  45. cat .config1 >>.config
  46. yes "" | make oldconfig %{?_smp_mflags}
  47. make V=1 %{?_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. mkdir -p $RPM_BUILD_ROOT/lib
  51. make install PREFIX="$RPM_BUILD_ROOT/"
  52. make install_headers PREFIX="$RPM_BUILD_ROOT/" DEVEL_PREFIX=""
  53. cp -a kernel-include/* $RPM_BUILD_ROOT/include/
  54. # move libraries to proper subdirectory
  55. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/uClibc
  56. mv $RPM_BUILD_ROOT/lib/* $RPM_BUILD_ROOT/%{_libdir}/uClibc/
  57. rm -rf $RPM_BUILD_ROOT/lib/
  58. # move the header files to /usr subdirectory
  59. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/uClibc
  60. mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT/%{_includedir}/uClibc
  61. rm -rf $RPM_BUILD_ROOT/include/
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files devel
  65. %defattr(-,root,root,-)
  66. %doc README docs/Glibc_vs_uClibc_Differences.txt docs/threads.txt docs/uClibc_vs_SuSv3.txt
  67. %doc TODO DEDICATION.mjn3 MAINTAINERS
  68. %doc docs/PORTING COPYING.LIB
  69. %{_includedir}/uClibc
  70. %{_libdir}/uClibc
  71. %changelog
  72. * Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.33.2-1
  73. - update to 0.9.33.2
  74. - update config
  75. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.32-1.rc3
  76. - initial build for Vine Linux
  77. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.32-0.2.rc2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  79. * Mon Feb 7 2011 Tom Callaway <spot@fedoraproject.org> - 0.9.32-0.1.rc2
  80. - update config for 0.9.32-rc2, busybox
  81. - patch getutent
  82. * Tue Nov 9 2010 Ivana Hutarova Varekova <varekova@redhat.com> - 0.9.31-2
  83. - update to 0.9.31
  84. * Fri Jun 5 2009 Ivana Varekova <varekova@redhat.com> - 0.9.30.1-2
  85. - initial build for Red Hat