totem-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608
  1. # define versions
  2. %define _glib_ver 2.48.0
  3. %define _gtk_ver 3.20.0
  4. %define _gnomeicon_ver 3.12.0
  5. %define _gnome_doc_utils_ver 0.20.0
  6. %define _dbus_ver 1.6.0
  7. %define _gst_ver 1.2.0
  8. %define _gstpb_ver 1.2.0
  9. %define _gstpg_ver 1.2.0
  10. %define _gstpbad_ver 1.2.0
  11. %define _xulrunner_ver 1.9
  12. %define _nautilus_ver 3.20.0
  13. %define _shared_mime_info_ver 0.17
  14. %define _unique_ver 1.0
  15. %define _totem_pl_parser_ver 3.4.4
  16. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  17. %define _unpackaged_files_terminate_build 1
  18. Summary: Movie player for GNOME 3
  19. Summary(ja): GNOME3 用動画プレイヤー
  20. Name: totem
  21. Version: 3.34.1
  22. Release: 1%{?_dist_release}
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. License: GPL
  26. URL: https://gitlab.gnome.org/GNOME/totem
  27. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  28. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  29. # from upstream
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. BuildRequires: meson
  32. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  33. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  34. BuildRequires: dbus-devel >= %{_dbus_ver}
  35. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  36. BuildRequires: gnome-desktop3-devel
  37. BuildRequires: gettext
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: yelp-tools
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: grilo-devel
  43. BuildRequires: bluez-libs-devel >= 5.00
  44. BuildRequires: lirc-devel
  45. BuildRequires: unique3-devel >= %{_unique_ver}
  46. BuildRequires: python3-devel
  47. BuildRequires: pylint
  48. BuildRequires: python3-pygobject
  49. BuildRequires: pygobject3-devel
  50. BuildRequires: libpeas-devel
  51. BuildRequires: libXtst-devel
  52. BuildRequires: gsettings-desktop-schemas-devel
  53. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  54. BuildRequires: vala
  55. BuildRequires: libappstream-glib-devel
  56. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  57. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  58. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  59. BuildRequires: clutter-gtk-devel
  60. BuildRequires: clutter-gst3-devel
  61. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  62. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  63. Requires: gstreamer1 >= %{_gst_ver}
  64. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  65. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  66. Requires: iso-codes
  67. Requires: grilo-plugins
  68. Obsoletes: nautilus-media
  69. Obsoletes: %{name}-gstreamer < 2.30.1-2
  70. Obsoletes: %{name}-xine < 2.30.1-2
  71. Obsoletes: %{name}-common < 2.30.1-3
  72. Obsoletes: %{name}-mozilla < 3.14.0
  73. Provides: nautilus-media
  74. Provides: %{name}-common = %{version}-%{release}
  75. Requires(post): ldconfig, desktop-file-utils
  76. Requires(postun): ldconfig, desktop-file-utils
  77. %description
  78. Totem is simple movie player for the Gnome desktop. It features a
  79. simple playlist, a full-screen mode, seek and volume controls, as well as
  80. a pretty complete keyboard navigation.
  81. %package devel
  82. Summary: Plugin writer's documentation for totem
  83. Group: Development/Libraries
  84. Requires: %{name} = %{version}-%{release}
  85. %description devel
  86. The %{name}-devel package contains API documentation for
  87. developing developing plugins for %{name}.
  88. %prep
  89. %setup -q
  90. %build
  91. export LANG=ja_JP.UTF-8
  92. %meson \
  93. -Denable-python=yes \
  94. -Denable-vala=yes \
  95. -Denable-nautilus=yes \
  96. -Denable-introspection=yes \
  97. -Dwith-plugins=auto
  98. %meson_build
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. export LANG=ja_JP.UTF-8
  102. %meson_install
  103. # remove unneeded files
  104. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  105. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  106. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  107. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  108. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  109. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  110. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  111. # remove unused file
  112. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  113. %__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
  114. %find_lang %{name} --with-gnome
  115. # save space by linking identical images in translated docs
  116. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  117. for f in $helpdir/C/figures/*.png; do
  118. b="$(basename $f)"
  119. for d in $helpdir/*; do
  120. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  121. g="$d/figures/$b"
  122. if [ -f "$g" ]; then
  123. if cmp -s $f $g; then
  124. rm "$g"; ln -s "../../C/figures/$b" "$g"
  125. fi
  126. fi
  127. fi
  128. done
  129. done
  130. %clean
  131. %__rm -rf %{buildroot}
  132. %post
  133. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  134. touch %{_datadir}/icons/hicolor
  135. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  136. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  137. fi
  138. %postun
  139. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  140. touch %{_datadir}/icons/hicolor
  141. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  142. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  143. fi
  144. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  145. %posttrans
  146. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  147. %files -f %{name}.lang
  148. %defattr(-,root,root,-)
  149. %license COPYING
  150. %doc AUTHORS NEWS README TODO
  151. %{_bindir}/totem
  152. %{_bindir}/totem-video-thumbnailer
  153. %{_datadir}/GConf/gsettings/opensubtitles.convert
  154. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  155. %{_datadir}/GConf/gsettings/totem.convert
  156. %{_datadir}/metainfo/org.gnome.Totem.appdata.xml
  157. %{_datadir}/applications/org.gnome.Totem.desktop
  158. %{_datadir}/dbus-1/services/org.gnome.Totem.service
  159. %{_datadir}/glib-2.0/schemas/*.xml
  160. %{_datadir}/icons/*/*/*/*
  161. %{_datadir}/thumbnailers/totem.thumbnailer
  162. %{_datadir}/%{name}
  163. #%{_datadir}/gtk-doc/html/totem
  164. %{_libdir}/libtotem.so.*
  165. %{_libdir}/girepository-1.0/*.typelib
  166. %dir %{_libdir}/totem
  167. %dir %{_libdir}/totem/plugins
  168. %{_libdir}/totem/plugins/apple-trailers/
  169. %{_libdir}/totem/plugins/autoload-subtitles
  170. %{_libdir}/totem/plugins/dbus
  171. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  172. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  173. %{_libdir}/totem/plugins/media-player-keys
  174. %{_libdir}/totem/plugins/open-directory
  175. %{_libdir}/totem/plugins/opensubtitles
  176. %{_libdir}/totem/plugins/properties
  177. %{_libdir}/totem/plugins/pythonconsole
  178. %{_libdir}/totem/plugins/recent
  179. %{_libdir}/totem/plugins/rotation
  180. %{_libdir}/totem/plugins/save-file/libsave-file.so
  181. %{_libdir}/totem/plugins/save-file/save-file.plugin
  182. %{_libdir}/totem/plugins/screensaver
  183. %{_libdir}/totem/plugins/screenshot
  184. %{_libdir}/totem/plugins/skipto
  185. %{_libdir}/totem/plugins/variable-rate
  186. %{_libdir}/totem/plugins/vimeo
  187. %{_libexecdir}/totem-gallery-thumbnailer
  188. %{_mandir}/man1/*
  189. %files devel
  190. %defattr(-, root, root,-)
  191. %{_includedir}/totem
  192. %{_libdir}/libtotem.so
  193. %{_libdir}/pkgconfig/totem.pc
  194. %{_datadir}/gir-1.0/Totem-1.0.gir
  195. #%{_datadir}/gtk-doc/html/totem
  196. %changelog
  197. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.34.1-1
  198. - new upstream release.
  199. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
  200. - new upstream release.
  201. - dropped Patch0: fixed in upstream.
  202. - drop lirc plugin: meson cannot detect lirc.
  203. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
  204. - new upstream release
  205. - add BuildRequires: lirc-devel
  206. - add Patch0 (totem-3.20.1-gint64-format.patch)
  207. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  208. - new upstream release
  209. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
  210. - new upstream release
  211. * Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  212. - add Requires: grilo-plugins
  213. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  214. - remove BuildRequires: gstreamer1-plugins-bad-free-devel
  215. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  216. - new upstream release
  217. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  218. - new upstream release
  219. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  220. - new upstream release
  221. - change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
  222. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  223. - new upstream release
  224. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  225. - new upstream release
  226. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  227. - new upstream release
  228. - add BuildRequires: gnome-desktop3-devel
  229. - remove BuildRequires: xulrunner-devel
  230. - remove %%{name}-mozilla subpackage
  231. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  232. - new upstream release
  233. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  234. - new upstream release
  235. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  236. - new upstream release
  237. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  238. - rebuild with VineSeed environment
  239. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  240. - new upstream release
  241. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  242. - new upstream release
  243. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  244. - new upstream release
  245. - add BuildRequires: yelp-tools, vala
  246. - change configure option (--enable-vala)
  247. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  248. - new upstream release
  249. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  250. - new upstream release
  251. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  252. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  253. - new upstream release
  254. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  255. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  256. - new upstream release
  257. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  258. - add configure option (--disable-vegas-plugin)
  259. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  260. - new upstream release
  261. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  262. - new upstream release
  263. - add BuildRequires: pylint
  264. - remove BuildRequires: libgdata-devel
  265. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  266. - new upstream release
  267. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  268. - new upstream release
  269. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  270. - new upstream release
  271. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  272. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  273. - new upstream release
  274. - change BuildRequires: gtk3-devel instead of gtk2-devel
  275. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  276. clutter-gst-devel, libmx-devel
  277. - change configure option (--disable-vala)
  278. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  279. - new upstream release
  280. - fix %files
  281. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  282. - new upstream release
  283. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  284. - clean up spec file
  285. - remove totem-common and merged to totem main package.
  286. - add Obsoletes: totem-common
  287. - remove unneeded BR: and R:
  288. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  289. - libmusicbrainz, alternatives
  290. - remove explicit dependency
  291. - gtk2, glib2, dbus
  292. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  293. - add R: gstreamer-plugins-good
  294. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  295. - rebuild with libgdata (add youtube plugin)
  296. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  297. - add Obsolete: totem-gstreamer, totem-xine)
  298. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  299. - new upstream release
  300. - chagnge _gst_ver from 0.10.19 to 0.10.29
  301. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  302. - new upstream release
  303. - drop totem-tracker package
  304. - add BuildRequires: unique-devel
  305. - remove BuildRequires: hal-devel
  306. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  307. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  308. - remove unneeded autoreconf
  309. - add BR: lirc
  310. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  311. - new upstream release
  312. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  313. - remove bemused plugin
  314. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  315. - new upstream release
  316. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  317. - added tracker video search sub-package
  318. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  319. - new upstream release
  320. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  321. - new upstream release
  322. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  323. - remove libxine dependency from totem-common
  324. - build xine backend with minimum dependency
  325. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  326. - add BR: bluez-libs-devel >= 4.15
  327. - fix typo in %%postun xine
  328. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  329. - rebuild with bluez-libs-devel-4.15
  330. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  331. - new upstream release
  332. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  333. - new upstream release
  334. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  335. - new upstream release
  336. - add patch1 to build with xulrunner-1.9
  337. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  338. - new upstream release
  339. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  340. - new upstream release
  341. - disabled devel package (replaced by totem-pl-parser-devel)
  342. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  343. - new upstream release
  344. - update version macros
  345. - enable browser plugins on x86_64
  346. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  347. - new upstream release
  348. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  349. - upstream release
  350. - drop obsolete ja.po.patch (patch0)
  351. - revert change of 1.4.4-0vl2
  352. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  353. - upstream release
  354. - enable browser plugins (exclude x86_64 arch)
  355. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  356. - upstream release
  357. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  358. - update configure options
  359. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  360. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  361. - fix mistranslation (patch0)
  362. - add icon symlink
  363. - add BuildRequires: gstreamer-plugins-good
  364. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  365. - upstream release
  366. - update %%_glib_ver, %%_xine_ver
  367. - add BuildRequires: hal
  368. - update %%configure options
  369. - update %%files
  370. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  371. - upstream release
  372. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  373. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  374. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  375. - upstream release
  376. - drop obsolete patch0
  377. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  378. - upstream release
  379. - add patch0 to build with intltool-0.35
  380. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  381. - upstream release
  382. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  383. - upstream release
  384. - update alternatives entry
  385. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  386. - upstream release
  387. - drop fix-sort-function.patch (was merged to upstream, #331426)
  388. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  389. - rebuild with gnome-2.14rc
  390. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  391. - upstream release
  392. - add macros
  393. - _gtk_ver, _glib_ver
  394. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  395. - _dbus_ver
  396. - _gst_ver, gstpb_ver, _xine_ver
  397. - add fix-sort-function.patch to build with glib < 2.9.1
  398. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  399. - upstream release
  400. - add BuildRequires:
  401. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  402. - gnome-vfs2-devel >= 2.9.92
  403. - dbus-devel >= 0.35
  404. - use gstreamer-0.10 as backend for totem-gstreamer
  405. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  406. - use gstreamer08 instead of gstreamer
  407. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  408. - upstream release
  409. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  410. - fix missing links
  411. - update file list
  412. - update update-alternatives scripts
  413. - fix totem-gstreamer's %%postun script
  414. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  415. - upstream release
  416. - add BuildRequires: iso-codes, libmusicbrainz-devel
  417. - add Requires: iso-codes, libmusicbrains to -common package
  418. - remove BuildRequires: nautilus-cd-burner
  419. - remove Requires: nautilus-cd-burner from -common package
  420. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  421. - totem-gstreamer obsoletes nautilus-media
  422. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  423. - upstream release
  424. - add Requires(post,postun): alternatives for gstreamer,xine
  425. - add Requires(postun,triggers): alternatives for common
  426. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  427. - upstream release
  428. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  429. - build xine backend
  430. - move common files to common package
  431. - move GStreamer related files to gstreamer package
  432. - install xine related files to xine package
  433. - fix scripts
  434. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  435. - upstream release
  436. - update URL
  437. - move *.{a,la} to devel package
  438. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  439. - fix %%{post,preun} script (video-thumbnail.schemas)
  440. - sync with Fedora Core's 1.0.1-1
  441. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  442. - Update to upstream version 1.0.1
  443. - Break out devel package
  444. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  445. - add %%{post,pre}un script
  446. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  447. - initial build for Vine Linux
  448. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  449. - fix %%post
  450. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  451. - Obsolete nautilus-media
  452. - Install property page and thumbnailer
  453. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  454. - Update to 0.101
  455. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  456. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  457. missing menu entry (144088)
  458. - Remove workaround for desktop file being misinstalled, fixed
  459. by above patch
  460. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  461. - New upstream version 0.100
  462. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  463. - update to 0.99.22
  464. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  465. - Add patch to remove removed items from package from help
  466. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  467. - New upstream 0.99.19
  468. - Fixes crasher with CD playback (see NEWS)
  469. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  470. - Call update-desktop-database in post
  471. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  472. - update to 0.99.18
  473. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  474. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>