tkscanfax-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. name: tkscanfax
  2. version: 1.01
  3. release: 1%{?_dist_release}
  4. summary: Tk/Tcl based GUI fax and scanner program
  5. summary(ja): GUIのFAXとScannerのプログラム
  6. License: GPL
  7. url: http://shino.pos.to/linux/tkscanfax.html
  8. group: Applications/Communications
  9. packager: Masaki SHINOMIYA <shino@pos.to>
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. source: http://shino.pos.to/linux/%{name}-%{version}.tar.gz
  13. prefix: %_prefix
  14. Buildarch: noarch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: tk, tcl, ImageMagick, ghostscript, file
  17. Requires: netpbm-progs
  18. #^ most of distributions including Vine-2.5
  19. #Requires: libgr-progs # for Vine-2.0/2.1.x
  20. #Requires: a2ps, psutils # or, mpage
  21. #Requires: efax >= 0.9a001114a6 # or, mgetty+sendfax
  22. #Requires: tetex, tetex-latex, tetex-ptex, tetex-dvips, tetex-fonts # optional
  23. #Requires: pLaTeX2e, pTeX, dvipsk # optional for Vine-2.0/2.1.x
  24. #Requires: sane-backends # optional
  25. %description
  26. TkFax, a Tk/Tcl based frontend of mgetty+sendfax or efax,
  27. combinated with TkScan, a frontend of scanner hanndling.
  28. It helps making the cover page, converting text files, postscript files and
  29. image files into fax file and sending. TkFax works with and without scanner.
  30. The efax program supports Class-1 faxmodems.
  31. %description -l ja
  32. Tcl/Tkで動くGUIのFAXプログラムTkFaxとスキャナプログラムTkScanです。
  33. カバーページの作成やテキスト、ポストスクリプト、画像ファイルから
  34. FAXページを作成、送信できます。またSANEなどと組合せスキャナも使えます。
  35. スキャナが無くてもFAXプログラムは動作します。
  36. FAXプログラムにはefaxかmgetty+sendfaxが使えます。efaxを使えば
  37. CLASS1コマンドのモデムもサポートできます。もちろん日本語も使えます。
  38. %prep
  39. %setup -q -n %{name}
  40. %build
  41. for i in tkscan tkfax; do
  42. sed "s,/usr/local,%{prefix}," $i > $i.tmp && ( mv $i.tmp $i; chmod +x $i )
  43. done
  44. mv doc/images/* images
  45. rmdir doc/images
  46. mv doc/* ./
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. mkdir -p $RPM_BUILD_ROOT%{prefix}/lib/%{name}
  50. cp -pR *.tcl tkfax tkscan scan-drivers tex $RPM_BUILD_ROOT%{prefix}/lib/%{name}
  51. mkdir -p $RPM_BUILD_ROOT%{prefix}/lib/%{name}/images
  52. cp -R images/*.gif $RPM_BUILD_ROOT%{prefix}/lib/%{name}/images
  53. mkdir -p $RPM_BUILD_ROOT%{prefix}/bin
  54. for i in tkscan tkfax; do
  55. ln -sf %{prefix}/lib/%{name}/$i $RPM_BUILD_ROOT%{prefix}/bin/$i
  56. done
  57. # prepare applnk
  58. %define applnkdir /etc/X11/applnk/Applications
  59. %define icondir %{prefix}/share/pixmaps
  60. mkdir -p $RPM_BUILD_ROOT%{icondir}
  61. cp -p images/tkfax-s.xpm $RPM_BUILD_ROOT%{icondir}
  62. mkdir -p $RPM_BUILD_ROOT/%{applnkdir}
  63. cat > $RPM_BUILD_ROOT/%{applnkdir}/%{name}.desktop <<EOF
  64. [Desktop Entry]
  65. Name=TkFax
  66. Comment=Sending and recieiving Fax
  67. Name[ja_JP.eucJP]=TkFax
  68. Comment[ja_JP.eucJP]=FAX送受信(TkFax)
  69. Exec=tkfax
  70. Icon=%{icondir}/tkfax-s.xpm
  71. Terminal=false
  72. MultipleArgs=false
  73. Type=Application
  74. EOF
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. #rm -rf $RPM_BUILD_DIR/%{name}
  78. %files
  79. %defattr(-, root, root)
  80. %{prefix}/bin/*
  81. %{prefix}/lib/%{name}/*-[^c]*.tcl
  82. #%{prefix}/lib/%{name}/fax-conf-win.tcl
  83. %{prefix}/lib/%{name}/msg*.tcl
  84. %config(noreplace) %{prefix}/lib/%{name}/tk*
  85. %config %{prefix}/lib/%{name}/*-conf.tcl
  86. #%config %{prefix}/lib/%{name}/*-conf_ja.tcl
  87. %config %{prefix}/lib/%{name}/tex/*
  88. %dir %{prefix}/lib/%{name}/tex
  89. %config %{prefix}/lib/%{name}/scan-drivers/*
  90. %dir %{prefix}/lib/%{name}/scan-drivers
  91. %{prefix}/lib/%{name}/images
  92. %dir %{prefix}/lib/%{name}
  93. %config(noreplace, missingok) %{icondir}/*
  94. %config(noreplace, missingok) %{applnkdir}/*.desktop
  95. %doc README* INSTALL* TRANSLATION *.html images *.sample* fax *.sh
  96. %changelog
  97. * Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.01-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. - s/Copyright/License/
  100. * Mon Apr 1 2002 Masaki Shinomiya <shino@pos.to>
  101. - 1.01-0vl1 for Vine-2.0/2.1.x, 1.01-0vl2 for Vine-2.5
  102. * Sun Mar 24 2002 Masaki Shinomiya <shino@pos.to>
  103. - version 1.01-1(/usr/doc) , -2(/usr/share/doc)
  104. - bugfix in making faxes using scanners
  105. * Sat Feb 2 2002 Masaki Shinomiya <shino@pos.to>
  106. - version 1.0-1(/usr/doc) , -2(/usr/share/doc), -0vl1 for Vine-2.x
  107. - log browser, bugfixes, requires
  108. * Sun Jan 20 2002 Masaki Shinomiya <shino@pos.to>
  109. - version 0.99final-1(/usr/doc) , -2(/usr/share/doc)
  110. - log browser
  111. * Mon Jan 14 2002 Masaki Shinomiya <shino@pos.to>
  112. - version 0.99f-1
  113. - Keep fax pages of previous session. Special charactors escaped. TkScan bugfix
  114. * Sun Dec 16 2001 Masaki Shinomiya <shino@pos.to>
  115. - version 0.99e-1
  116. - TkScan bugfix, fax spooling bugfix, fax spooling with LPRng
  117. - include fax script in doc
  118. * Sun Oct 21 2001 Masaki Shinomiya <shino@pos.to>
  119. - version 0.99d-1
  120. - fax spooling bugfix, english typo
  121. * Sun Oct 7 2001 Masaki Shinomiya <shino@pos.to>
  122. - version 0.99c-1
  123. - Support 'Fax Outgoing' box with efax spooling function.
  124. - Windows expandable
  125. - 'From', 'To' order in the cover page
  126. - error traps in fax^pbook.tcl
  127. - eliminate tex/cover-??.tex
  128. - include html documents on efax settings
  129. * Sat Sep 8 2001 Masaki Shinomiya <shino@pos.to>
  130. - version 0.99b-1
  131. - fixed some system does not work properly when calling dvips
  132. - Japanese input method in Tk-8.3
  133. - try to keep proper size in image conversion
  134. - allow to run without LaTeX
  135. - support 'a2ps' in place of 'mpage'
  136. - automatic configuration in selecting some commands for the system
  137. - configuration parameters
  138. - improved error trap
  139. * Sat Aug 25 2001 Masaki Shinomiya <shino@pos.to>
  140. - version 0.99a-1
  141. - looking up env(LANG)
  142. - fax-received box, fax print, fax view, english typo
  143. - images in documents
  144. * Sun Jul 29 2001 Masaki Shinomiya <shino@pos.to>
  145. - version 0.99-1, 1ja
  146. - add english documents
  147. * Fri Jul 20 2001 Masaki Shinomiya <shino@pos.to>
  148. - version 0.91j1-0.5
  149. - Link with LyX in face cover page making, by Ryoji Kawagishi
  150. * Wed Jul 4 2001 Masaki Shinomiya <shino@pos.to>
  151. - version 0.91j-0.5
  152. - GUI for face cover page making, by Ryoji Kawagishi
  153. * Fri Jun 15 2001 Masaki Shinomiya <shino@pos.to>
  154. - version 0.91-0.96e
  155. - launch fax-received window after receive completed
  156. - fixed misleading message after deleting fax page
  157. * Thu Jun 14 2001 Masaki Shinomiya <shino@pos.to>
  158. - version 0.91-0.95e
  159. - supports manual dialing
  160. - new scanner driver for SHARP JX-250
  161. * Sun Jun 10 2001 Masaki Shinomiya <shino@pos.to>
  162. - version 0.91-0.94e
  163. - fixed the problem in launching tkscan alone
  164. * Sat Jun 9 2001 Masaki Shinomiya <shino@pos.to>
  165. - version 0.91-0.93e
  166. - halftoning in scanner drivers, misc bugs fix
  167. - error logs to be colected in /var/log/fax
  168. - build architechture is now noarch
  169. * Mon Jun 4 2001 Masaki Shinomiya <shino@pos.to>
  170. - version 0.91-0.92e
  171. - Fixed image conversion
  172. * Thu May 31 2001 Masaki Shinomiya <shino@pos.to>
  173. - version 0.91-0.91e
  174. - Fixed printing nomal-mode fax
  175. * Wed May 30 2001 Masaki Shinomiya <shino@pos.to>
  176. - version 0.91-0.90e
  177. - Fixed printing, phone book, scroll mouse support
  178. * Tue May 29 2001 Masaki Shinomiya <shino@pos.to>
  179. - version 0.91-0.8efax2
  180. - Fixed scanning, printing, pbm to tiffg3
  181. * Mon May 28 2001 Masaki Shinomiya <shino@pos.to>
  182. - version 0.91-0.8efax1
  183. - Japanese TeX tenplate by Ryoji Kawagishi <kawagisi@yk.rim.or.jp>
  184. - bugfix in attaching text files
  185. * Tue May 23 2001 Masaki Shinomiya <shino@pos.to>
  186. - version 0.91-0.8efax
  187. - Implemented internationalization.
  188. - Primitive epson-scanimage driver