texlive-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20170520
  7. Summary: The TeX text formatting system
  8. Summary(ja): TeX 文書整形システム
  9. Name: texlive
  10. Version: 2017
  11. Release: 2%{?_dist_release}
  12. License: distributable
  13. Group: Applications/Publishing
  14. URL: http://www.tug.org/texlive/
  15. ## original TeX Live source
  16. #Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
  17. Source0: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  18. ## snapshot
  19. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  20. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  21. #Source0: %{name}-source-%{texlivesrcver}.tar.xz
  22. ## our updmap{,-hdr}.cfg from collection-basic 20140524
  23. ## NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
  24. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  25. Source7: updmap.cfg.texlive-%{texlivesrcver}
  26. ## desktop files
  27. Source11: texdoctk.desktop
  28. Source98: find-requires-texlive.sh
  29. ## find library sonames for libkpathsea, libptexenc, and libsynctex
  30. Source99: find-provides-texlive.sh
  31. ######
  32. # TeX patches
  33. ######
  34. ## vine
  35. Patch0: reautoconf-parallel.diff
  36. #Patch1: texlive-%{texlivesrcver}-vine.patch
  37. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  38. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  39. #Patch4: texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
  40. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  41. ## security
  42. Requires: perl-Tk perl-Tk-TableMatrix
  43. Requires: ghostscript >= 8.71
  44. Requires: nkf
  45. Requires(post,postun): fontconfig
  46. Requires(post): ed mktemp
  47. Requires(post): vutils >= 7.1
  48. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  49. BuildRequires: autoconf >= 2.68
  50. BuildRequires: bison flex
  51. BuildRequires: bzip2-devel
  52. BuildRequires: cairo-devel >= 1.12
  53. BuildRequires: fontconfig-devel
  54. BuildRequires: freetype2-devel >= 2.1.10
  55. BuildRequires: gd-devel
  56. BuildRequires: libjpeg-devel
  57. BuildRequires: libpng-devel >= 1.6
  58. BuildRequires: ncurses-devel
  59. BuildRequires: nkf
  60. BuildRequires: openssl-devel
  61. BuildRequires: pixman-devel >= 0.18
  62. #BuildRequires: poppler-devel >= 0.26
  63. BuildRequires: xorg-x11-devel
  64. BuildRequires: zlib-devel
  65. ## use distro's libpaper
  66. #BuildRequires: libpaper-devel >= 1.1.24-2
  67. ## do not xdvi(k)
  68. #BuildRequires: XOrg-devel
  69. #BuildRequires: openMotif-devel
  70. ## needs to build pxdvi
  71. #BuildRequires: t1lib-devel
  72. BuildRequires: texlive-vtlpkg = %{version}
  73. Buildroot: %{_tmppath}/%{name}-%{version}-root
  74. Vendor: Project Vine
  75. Distribution: Vine Linux
  76. Packager: munepi
  77. %description
  78. The TeX Live software distribution offers a complete TeX system for a
  79. variety of Unix, Macintosh, Windows and other platforms. It
  80. encompasses programs for editing, typesetting, previewing and printing
  81. of TeX documents in many different languages, and a large collection
  82. of TeX macros and font libraries.
  83. The distribution includes extensive general documentation about TeX,
  84. as well as the documentation for the included software packages.
  85. %description -l ja
  86. TeX Live ソフトウェアディストリビューションは、
  87. さまざまな Unix, Macintosh, Windows、および
  88. 他のプラットホームに対して完全な TeX システムを提供します。
  89. 多くの異なった言語を含む TeX ドキュメントの
  90. 編集、組版、閲覧、印刷するためのプログラム、
  91. そして、TeX マクロやフォントライブラリの大きなコレクションを
  92. 同梱しています。
  93. このディストリビューションは
  94. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  95. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  96. %package doc
  97. Summary: TeX Live: Documentation files of %{name}
  98. Group: Applications/Publishing
  99. Requires: %{name} = %{version}-%{release}
  100. BuildArch: noarch
  101. %description doc
  102. This package contains documentation files of %{name}.
  103. %package -n libkpathsea
  104. Summary: path search library for the TeX Live
  105. Summary(ja): TeX Live 用パス検索ライブラリ
  106. Group: System Environment/Libraries
  107. %description -n libkpathsea
  108. This package includes runtime part of the Kpathsea library.
  109. %package -n libkpathsea-devel
  110. Summary: path search libary and header files for the TeX Live
  111. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  112. Group: Development/Libraries
  113. Requires: libkpathsea = %{version}-%{release}
  114. %description -n libkpathsea-devel
  115. This package includes static library and header files of the Kpathsea library.
  116. %package -n libptexenc
  117. Summary: Kanji code convert library for Japanese pTeX
  118. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  119. Group: System Environment/Libraries
  120. Requires: libkpathsea = %{version}-%{release}
  121. %description -n libptexenc
  122. This package includes runtime part of the ptexenc library.
  123. %package -n libptexenc-devel
  124. Summary: Kanji code convert library and header files for Japanese pTeX
  125. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  126. Group: Development/Libraries
  127. Requires: libptexenc = %{version}-%{release}
  128. %description -n libptexenc-devel
  129. This package includes header files of the ptexenc library.
  130. %package -n libsynctex
  131. Summary: SyncTeX library
  132. Group: System Environment/Libraries
  133. %description -n libsynctex
  134. This package includes the runtime part of SyncTeX library.
  135. %package -n libsynctex-devel
  136. Summary: SyncTeX header files
  137. Group: Development/Libraries
  138. Requires: libsynctex = %{version}-%{release}
  139. %description -n libsynctex-devel
  140. This package includes the header files of SyncTeX library.
  141. %prep
  142. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  143. %setup -q -n %{name}-%{texlivesrcver}-source
  144. #% setup -q -n %{name}-source-%{texlivesrcver}
  145. %patch0 -p0 -b .parallel
  146. # %patch1 -p1 -b .vine
  147. %patch2 -p1 -b .vine
  148. %patch3 -p1 -b .vine
  149. # %patch4 -p1 -b .vine
  150. # ## Applying tlptexlive that provides pxdvi(k) and pmpost
  151. # echo "applying patches"
  152. # cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
  153. # echo $p | grep '^#' >/dev/null || \
  154. # patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
  155. # done
  156. ## Avoid pollution from internal libraries.
  157. #,paper,poppler,xpdf
  158. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
  159. ./reautoconf || exit 1
  160. %build
  161. set -x
  162. unset TEXINPUTS || :
  163. unset HOME || :
  164. export CFLAGS="$RPM_OPT_FLAGS" \
  165. CXXFLAGS="$RPM_OPT_FLAGS" \
  166. LANG=C
  167. PREFIX=$(pwd)/work
  168. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  169. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  170. TL_CONFIGURE_ARGS=" \
  171. --disable-multiplatform \
  172. --disable-native-texlive-build \
  173. --with-banner-add=\"/Vine Linux\" \
  174. --enable-shared --disable-static \
  175. --enable-compiler-warnings=max \
  176. --without-cxx-runtime-hack \
  177. \
  178. --with-system-xpdf=no --with-system-poppler=no \
  179. --with-system-gd \
  180. --with-system-t1lib \
  181. --with-system-libpng \
  182. --with-system-zlib \
  183. --with-system-freetype2 \
  184. --with-system-pixman \
  185. --with-system-cairo \
  186. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  187. --with-pic \
  188. \
  189. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  190. --disable-xdvik \
  191. --disable-dvi2tty \
  192. --disable-t1utils --disable-psutils --disable-detex \
  193. --disable-dvipng --disable-lcdf-typetools \
  194. "
  195. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  196. TL_MAKE=%__make ./Build || exit 1
  197. %install
  198. ## prepare %%install session
  199. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  200. ## copy inst directory to /usr
  201. %__mkdir_p %{buildroot}
  202. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  203. %ifarch x86_64
  204. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  205. %endif
  206. if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
  207. %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
  208. %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
  209. %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
  210. fi
  211. ## make some fundamental texmf trees
  212. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  213. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  214. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  215. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  216. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  217. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  218. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  219. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  220. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  221. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  222. distribution wide.
  223. You must not do any changes in this directory.
  224. EOF
  225. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  226. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  227. You should not use this directory to manage any other packages because
  228. we Project Vine use this directory to manage non-CTAN packages, some
  229. enhancement packages and so on.
  230. EOF
  231. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  232. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  233. If you are a privileged user of this system,
  234. you can use this directory to manage your local packages.
  235. EOF
  236. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  237. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  238. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  239. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  240. ## our map files for dvipdfmx
  241. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  242. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  243. for x in ptex uptex otf otf-up; do
  244. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  245. done
  246. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  247. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  248. done
  249. ## desktop things
  250. %__mkdir_p %{buildroot}%{_datadir}/applications
  251. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  252. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  253. # for created fonts
  254. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  255. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  256. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  257. ## set executable bit for the library
  258. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  259. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  260. # configure ConTeXt
  261. for x in context luatools texexec texmfstart; do
  262. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  263. done
  264. for x in contextjit; do
  265. %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
  266. done
  267. # touch ghosts
  268. touch %{buildroot}%{_tl_texmfvine}/ls-R
  269. touch %{buildroot}%{_tl_texmfdist}/ls-R
  270. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  271. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  272. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  273. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  274. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  275. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  276. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  277. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  278. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  279. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  280. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  281. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  282. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  283. #touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  284. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  285. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  286. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  287. ## remove unpackaging files
  288. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  289. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  290. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  291. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  292. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  293. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  294. %__rm -f %{buildroot}%{_infodir}/*
  295. ## use external packages
  296. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  297. ### Files list
  298. find %{buildroot} -type f -or -type l | \
  299. %__sed -e "s|%{buildroot}||g" | \
  300. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  301. %__grep -v "%{_includedir}" | \
  302. %__grep -v "%{_libdir}" | \
  303. %__grep -v "%{_infodir}" | \
  304. %__sed -e "s|.*ls-R$|%ghost &|" \
  305. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  306. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  307. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  308. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  309. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  310. -e "s|.*\.cnf$|%config(noreplace) &|" \
  311. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  312. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  313. -e "s|^.*/updmap/$|%config &|" \
  314. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  315. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  316. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  317. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  318. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  319. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  320. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  321. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  322. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  323. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  324. -e "s|%{_mandir}/.*|&*|" \
  325. > %{_builddir}/filelist.full
  326. find %{buildroot}%{_tl_texmfvine}* -type d | \
  327. %__sed -e "s|^%{buildroot}|%dir |" \
  328. -e "s|$|/|" >> %{_builddir}/filelist.full
  329. ## subpackages
  330. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  331. cat %{_builddir}/filelist.doc \
  332. %{_builddir}/filelist.full | \
  333. sort | uniq -u > %{_builddir}/filelist.tmp
  334. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  335. %clean
  336. %__rm -rf %{buildroot}
  337. %pretrans
  338. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
  339. [ $? -eq 1 ] && exit 0
  340. _trans_time=$(date +%Y%m%d)
  341. echo "Running some transitional processes on your TeX system ... "
  342. x=(
  343. /usr/share/texmf-local
  344. /usr/share/texmf-var
  345. /usr/share/texmf-config
  346. )
  347. for dir in ${x[@]}; do
  348. _trans_dir=${dir}.${_trans_time}.rpmorig
  349. [ -d ${_trans_dir}.old ] && \
  350. echo -n " " && \
  351. echo "Found ${_trans_dir}.old: " && \
  352. echo -n " " && \
  353. %__rm -rvf ${_trans_dir}.old
  354. [ -d ${_trans_dir} ] && \
  355. echo -n " " && \
  356. echo "Found ${_trans_dir}: " && \
  357. echo -n " " && \
  358. %__mv -v ${_trans_dir} ${_trans_dir}.old
  359. [ -d ${dir} ] && \
  360. echo -n " " && \
  361. echo "Found ${dir}: " && \
  362. echo -n " " && \
  363. %__mv -v ${dir} ${_trans_dir}
  364. done
  365. echo "done."
  366. %postun
  367. if [ "$1" = 0 ]; then
  368. %__rm -rf %{_tl_vartexfonts}
  369. fi
  370. exit 0
  371. %post
  372. %_tl_touch_run texhash
  373. %_tl_touch_run updmap
  374. %_tl_touch_run mtxrun
  375. %_tl_touch_run fmtutil
  376. exit 0
  377. %posttrans
  378. %__mkdir_p %{_tl_vartexfonts}
  379. %__chmod 1777 %{_tl_vartexfonts}
  380. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  381. ( %{_tl_exec_upddeffont} ) ||:
  382. %{_tl_exec_texhash}
  383. %{_tl_exec_mtxrun}
  384. %{_tl_exec_updmap}
  385. %{_tl_exec_fmtutil}
  386. exit 0
  387. %post -n libkpathsea
  388. /sbin/ldconfig
  389. # for x in kpathsea tds web2c; do
  390. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  391. # done
  392. # %preun -n libkpathsea
  393. # if [ "$1" = 0 ]; then
  394. # for x in kpathsea tds web2c; do
  395. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  396. # done
  397. # fi
  398. %postun -n libkpathsea
  399. /sbin/ldconfig
  400. %post -n libptexenc
  401. /sbin/ldconfig
  402. %postun -n libptexenc
  403. /sbin/ldconfig
  404. %triggerin -- ghostscript
  405. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  406. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  407. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  408. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  409. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  410. fi
  411. %_tl_touch_run texhash
  412. exit 0
  413. %files -f %{_builddir}/filelist.full
  414. %defattr(-,root,root)
  415. %{_libdir}/libtexlua52.so.*
  416. %{_libdir}/libtexluajit.so.*
  417. %dir %{_tl_aliasttfdir}
  418. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  419. # %config %{_sysconfdir}/cron.daily/texlive.cron
  420. %exclude %{_includedir}/texlua52/*.h
  421. %exclude %{_includedir}/texlua52/*.hpp
  422. %exclude %{_includedir}/texluajit/*.h
  423. %exclude %{_includedir}/texluajit/*.hpp
  424. %exclude %{_libdir}/libtexlua52.so
  425. %exclude %{_libdir}/libtexluajit.so
  426. %exclude %{_libdir}/pkgconfig/texlua52.pc
  427. %exclude %{_libdir}/pkgconfig/texluajit.pc
  428. %files doc -f %{_builddir}/filelist.doc
  429. %defattr(-,root,root)
  430. %files -n libkpathsea
  431. %defattr(-,root,root)
  432. %{_libdir}/libkpathsea.so.*
  433. # %{_infodir}/kpathsea.info*
  434. %files -n libkpathsea-devel
  435. %defattr(-,root,root)
  436. %{_libdir}/libkpathsea.so
  437. %dir %{_includedir}/kpathsea
  438. %{_includedir}/kpathsea/*.h
  439. %{_libdir}/pkgconfig/kpathsea.pc
  440. %files -n libptexenc
  441. %defattr(-,root,root)
  442. %{_libdir}/libptexenc.so.*
  443. %files -n libptexenc-devel
  444. %defattr(-,root,root)
  445. %{_libdir}/libptexenc.so
  446. %dir %{_includedir}/ptexenc
  447. %{_includedir}/ptexenc/*.h
  448. %{_libdir}/pkgconfig/ptexenc.pc
  449. %files -n libsynctex
  450. %defattr(-,root,root)
  451. %{_libdir}/libsynctex.so.*
  452. %files -n libsynctex-devel
  453. %defattr(-,root,root)
  454. %{_libdir}/libsynctex.so
  455. %dir %{_includedir}/synctex
  456. %{_includedir}/synctex/*.h
  457. %{_libdir}/pkgconfig/synctex.pc
  458. %changelog
  459. * Thu Jun 8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 2017-2
  460. - rebuilt
  461. * Wed Jun 7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 2017-1
  462. - upgraded to TeX Live 2017
  463. - texlive-20170520-source
  464. * Tue Jul 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-5
  465. - updated to texlive-source-20160702
  466. * Wed Jun 29 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-4
  467. - rebuilt with new toolchain
  468. * Mon Jun 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-3
  469. - texlive-20160523-source (TeX Live 2016)
  470. * Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-2
  471. - texlive-20160510-source (TeX Live 2016/pretest)
  472. * Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
  473. - texlive-20160427-source (TeX Live 2016/pretest)
  474. * Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
  475. - fixed some development files
  476. * Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
  477. - reverted to texlive-20150521-source (TeX Live 2015)
  478. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
  479. - texlive-source-20160110 (TeX Live 2016/dev)
  480. * Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
  481. - texlive-source-20150523 (TeX Live 2015/pretest)
  482. - configure ConTeXt/LuaTeX+LuaJIT
  483. * Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
  484. - texlive-source-20150426 (TeX Live 2015/pretest)
  485. * Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
  486. - texlive-source-20141230 (TeX Live 2015/dev)
  487. * Thu Jul 3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
  488. - texlive-source-20140525 + tlptexlive 20140507
  489. - dropped texlive-20140524-vine.patch: built with libpng >= 1.6
  490. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  491. - upgrade to TeX Live 2014
  492. - texlive-source-20140524 + tlptexlive 20140507
  493. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
  494. - rebuild with poppler-0.24.5
  495. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
  496. - rebuilt
  497. * Fri Nov 1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
  498. - texlive-source-20131101 2014/dev + tlptexlive 20130815
  499. - added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
  500. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  501. - updated texlive-20131002-texmfcnf-vine.patch:
  502. texmf.cnf (shell_escape_commands): added some programs
  503. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  504. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  505. - defined %%global __find_requires find-requires-texlive.sh
  506. - dropped unused dependencies of Requires
  507. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  508. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  509. - correct some scripts of README.vine for each texmf trees
  510. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  511. - upgrade to TeX Live 2013
  512. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  513. - dropped Requires: jvf
  514. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  515. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  516. - fixed duplicated lw35 for updmap.pl
  517. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  518. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  519. - touch the map files generated by updmap-sys
  520. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  521. - fixed Source7: updmap.cfg.texlive-20120701
  522. (upto /etc/texmf/web2c/updmap.cfg)
  523. - fixex %%triggerin -- ghostscript
  524. - replaced %%exec_texhash with %%touch_run texhash
  525. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  526. - TeX Live 2012 + tlptexlive 20121107
  527. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  528. - drop BR: poppler-devel temporaly
  529. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  530. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  531. - build with poppler-0.18.4
  532. - remove tlmgr
  533. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  534. - updated to tl11supp-120120
  535. - run %%{exec_fmtutil} at %%post when upgrading
  536. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  537. - updated to tl11supp-111214
  538. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  539. - added BuildRequires: texlive-common
  540. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  541. - check japanese.ldf
  542. - updated tl11supp-111120-vine.patch
  543. - added the following options to $$TL_CONFIGURE_ARGS:
  544. --disable-detex
  545. --disable-dvipng
  546. --disable-lcdf-typetools
  547. - remove some files of asymptote
  548. - remove a man file of latexmk
  549. - remove man files of lcdf-typetools
  550. - remove man files of dvipng
  551. - remove a man file of detex
  552. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  553. - added find-provides-texlive.sh and set it to %%__find_provides
  554. - use to find library sonames for libkpathsea and libptexenc
  555. - added cmex.enc (%%{SOURCE110})
  556. - do not install cmex.enc in our TDS, yet
  557. - removed some unused directories in texmf/fonts/map
  558. - removed man files of lcdf-typetools
  559. - moved texdoc{,tk} and its related files to texlive-doc
  560. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  561. - TeX Live 2011 + tl11supp-111120
  562. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  563. - make the directory VARTEXFONTS (%%posttrans)
  564. - dropped %%triggerpostun -- texlive < 2009-17vl6
  565. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  566. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  567. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  568. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  569. - added %%pre to avoid conflictions of texmf-{config,var}
  570. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  571. - dropped Requires: texlive-common
  572. - added perl-Tk-TableMatrix
  573. - supported texdoctk
  574. - removed broken symbolic links in /usr/bin
  575. - for each these symbolic links, the package of its real file/path
  576. should be its owner.
  577. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  578. - added %%triggerpostun -- texlive < 2009-17vl6
  579. - make the directory VARTEXFONTS
  580. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  581. - fixed %%dir VARTEXFONTS around in %%files
  582. - dropped BuildRequires: t1utils
  583. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  584. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  585. - changed VARTEXFONTS to /var/lib/texmf/fonts
  586. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  587. - fixed updmap.cfg
  588. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  589. - dropped Requires: texlive-macros
  590. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  591. - updated ptexlive-20100711-pxdvik-vine.patch
  592. and added texlive-20091107-xdvik-vine.patch
  593. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  594. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  595. - supported Vine Linux 5
  596. - for vl5, changed a requirement of Japanese VF package
  597. - added Requires: texlive-jvf = 2009 (vl5)
  598. - dropped dependencies of Provides:/Obsoletes: tags
  599. - merged these dependencies in texlive-common-vl.spec
  600. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  601. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  602. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  603. - applied some security patches from Debian
  604. - texlive-2009-CVE-2010-0827.patch
  605. - texlive-2009-CVE-2010-1440.patch
  606. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  607. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  608. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  609. - fixed some dependencies
  610. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  611. - added BuildArch: noarch in %%package doc
  612. - removed some comment-out sentences
  613. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  614. - separeted texmf-dist to texlive-common package
  615. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  616. - unpacked texlive-20091107-source.tar.xz
  617. - babel is available now
  618. - applied eptex-100420 and some patches:
  619. - eptex-100420-vine.patch
  620. - eptex-100420-patch1.diff
  621. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  622. - updated ptexlive-20100711
  623. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  624. - customized updmap.cfg to correspond installed fonts
  625. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  626. - fixed insttexfont()
  627. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  628. - added jvf of MORISAWA basic 5 fonts
  629. - added cm-super, mathdesign in fntlst
  630. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  631. - define insttexfont() in %%install
  632. - copy almost compatible tetex-3.0
  633. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  634. - ptexlive-20090322 + TeXLive 2009
  635. - added BuildRequires: openssl-devel
  636. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  637. - ptexlive-20091009 + TeXLive 2008