tcsh-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344
  1. %define _bindir /bin
  2. Summary: An enhanced version of csh, the C shell
  3. Summary(ja): csh, Cシェルの進化バージョン
  4. Name: tcsh
  5. Version: 6.22.02
  6. Release: 1%{?_dist_release}
  7. License: BSD
  8. URL: http://www.tcsh.org/
  9. Group: System Environment/Shells
  10. Source: https://astron.com/pub/tcsh/%{name}-%{version}.tar.gz
  11. # NOTE: 'autosetup' macro (below) uses 'git' for applying the patches:
  12. # ->> All the patches should be provided in 'git format-patch' format.
  13. # ->> Auxiliary repository will be created during 'fedpkg prep', you
  14. # can see all the applied patches there via 'git log'.
  15. # Upstream patches -- official upstream patches released by upstream since the
  16. # ---------------- last rebase that are necessary for any reason:
  17. Patch001: tcsh-6.22.02-avoid-gcc-to-fail.patch
  18. # Downstream patches -- these should be always included when doing rebase:
  19. # ------------------
  20. Patch100: tcsh-6.20.00-manpage-memoryuse.patch
  21. Provides: csh = %{version}
  22. Requires(post): grep
  23. Requires(postun): coreutils, grep
  24. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. BuildRequires: autoconf, automake, ncurses-devel, gettext-devel, git
  26. %description
  27. Tcsh is an enhanced but completely compatible version of csh, the C
  28. shell. Tcsh is a command language interpreter which can be used both
  29. as an interactive login shell and as a shell script command processor.
  30. Tcsh includes a command line editor, programmable word completion,
  31. spelling correction, a history mechanism, job control and a C language
  32. like syntax.
  33. %description -l ja
  34. tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
  35. さらに機能強化したシェルです。対話的なログインシェル、またシェルス
  36. クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
  37. リタです。
  38. tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
  39. スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
  40. %prep
  41. %autosetup -N -S git
  42. # NOTE: If more files needs to be converted, add them here:
  43. for file in Fixes; do
  44. iconv -f iso-8859-1 -t utf-8 "$file" > "${file}.converted" && \
  45. touch -r "$file" "${file}.converted" && \
  46. mv "${file}.converted" "$file"
  47. done
  48. # Also, rename the Copyright so we comply with more generally accepted name:
  49. mv Copyright COPYING
  50. # Amend the converted files to the initial commit, and patch the source code:
  51. git add --all --force
  52. git commit --all --amend --no-edit > /dev/null
  53. %autopatch -p1
  54. %build
  55. # For tcsh-6.14.00-tinfo.patch
  56. autoreconf
  57. %configure --without-hesiod
  58. make %{?_smp_mflags} all
  59. make %{?_smp_mflags} -C nls catalogs
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
  63. install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
  64. install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
  65. ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
  66. ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
  67. while read lang language ; do
  68. dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
  69. if test -f tcsh.$language.cat ; then
  70. mkdir -p $dest
  71. install -p -m 644 tcsh.$language.cat $dest/tcsh
  72. echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
  73. fi
  74. done > tcsh.lang << _EOF
  75. de german
  76. el greek
  77. en C
  78. es spanish
  79. et et
  80. fi finnish
  81. fr french
  82. it italian
  83. ja ja
  84. pl pl
  85. ru russian
  86. uk ukrainian
  87. _EOF
  88. %check
  89. %make_build check
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %post
  93. if [ ! -f /etc/shells ]; then
  94. echo "%{_bindir}/tcsh" >> /etc/shells
  95. echo "%{_bindir}/csh" >> /etc/shells
  96. else
  97. grep -q '^%{_bindir}/tcsh$' /etc/shells || \
  98. echo "%{_bindir}/tcsh" >> /etc/shells
  99. grep -q '^%{_bindir}/csh$' /etc/shells || \
  100. echo "%{_bindir}/csh" >> /etc/shells
  101. fi
  102. %postun
  103. if [ ! -x %{_bindir}/tcsh ]; then
  104. grep -v '^%{_bindir}/tcsh$' /etc/shells | \
  105. grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
  106. mv /etc/shells.rpm /etc/shells
  107. fi
  108. %files -f tcsh.lang
  109. %defattr(-,root,root,-)
  110. %doc BUGS FAQ Fixes NewThings WishList complete.tcsh
  111. %{_bindir}/tcsh
  112. %{_bindir}/csh
  113. %{_mandir}/man1/*.1*
  114. %changelog
  115. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.22.02
  116. - new upstream release.
  117. * Sun Jul 20 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.18.01-1
  118. - update to 6.18.01
  119. * Sun Jun 12 2011 IWAI, Masaharu <iwai@alib.jp> 6.17-1
  120. - new upstream release
  121. - drop wide str patch (Patch12): upstream fixed
  122. - update ca-color patch (Patch6) from Fedora tcsh-6.17-15
  123. - update syntax patch (Patch8) from Fedora tcsh-6.17-15
  124. - update rs-color patch from Fedora tcsh-6.17-15
  125. - resync with Fedora tcsh-6.17-15
  126. - change patch number Patch13 -> Patch12
  127. - add Patch13..24
  128. * Thu Mar 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-15
  129. - Avoid infinite loop pendjob()-xprintf() when stdout is closed
  130. Resolves: #690356
  131. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.17-14
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  133. * Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
  134. - Modify verbose patch to match with upstream (don't print on history -S)
  135. Resolves: #672810
  136. * Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
  137. - Fix error message on exit
  138. Resolves: #672810
  139. * Mon Jan 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-11
  140. - Don't set $REMOTEHOST on the local machine
  141. Resolves: #669176
  142. - Don't print history in verbose mode
  143. Resolves: #583075, #658171
  144. - Don't allow illegal variable names to be set
  145. Resolves: #436901
  146. - Revert "Fix incorrect $status value of pipelined commands"
  147. * Tue Dec 21 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-10
  148. - Make wait builtin command interruptible
  149. Resolves: #440465
  150. - Fix incorrect $status value of pipelined commands
  151. Resolves: #638955 (Patch by Tomas Smetana <tsmetana@redhat.com>)
  152. * Wed Oct 6 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-9
  153. - Remove fork when tcsh processes backquotes
  154. * Wed Apr 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-8
  155. - Fix testsuite
  156. * Mon Mar 1 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-7
  157. - Ship README file
  158. * Tue Dec 15 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-6
  159. - Fix tcsh obeys printexitvalue for back-ticks
  160. * Wed Nov 4 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-5
  161. - Fix few globbing problems
  162. * Mon Oct 19 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-4
  163. - Fix tcsh globbing causing bad automount
  164. - Fix truncated history file after network crash
  165. * Wed Aug 26 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-3
  166. - Add new colorls variable
  167. Resolves: #518808
  168. * Sun Jul 26 2009 Fedora Release Engineering <releng@lists.fedoraproject.org> - 6.17-2
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  170. * Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
  171. - Update to tcsh-6.17.00
  172. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
  173. - rebuilt with current VineSeed
  174. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
  175. - new upstream release
  176. - resync with 6.16-1(fc12)
  177. - drop vine patch
  178. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
  179. - applied new versioning policy, spec in utf-8
  180. * Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
  181. - added patch11 from fedora
  182. * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
  183. - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
  184. (#186037)
  185. - added japanese description
  186. * Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
  187. - added patch from fedora
  188. * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
  189. - remove declaration of setpgrp() which conflicts with libc's (#115185)
  190. * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
  191. - add missing buildprereqs on groff, libtermcap-devel (#110599)
  192. * Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
  193. - rebuild with new toolchains
  194. - s/Copyright/License/
  195. - fix spec file to build correctly (based on Rawhide spec file)
  196. * Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
  197. - "Re"-changed the way of fixing check locale from Patch8 to Patch9
  198. on ppc strlen() can not deal with 'short' variables
  199. * Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
  200. - fixed changelog
  201. * Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
  202. - update
  203. * Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
  204. - change limit.patch
  205. * Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
  206. - fixed limit by Patch10
  207. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
  208. - changed the way of fixing check locale from Patch8 to Patch9
  209. on ppc strlen() can not deal with 'short' variables
  210. * Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
  211. - update
  212. * Fri Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
  213. - fixed check locale
  214. - merged some patches from RHL-7.2
  215. * Thu Aug 09 2001 <sagami@vinelinux.org>
  216. - 6.10.02-0vl1
  217. * Sun Jan 7 2001 Jun Nishii <jun@vinelinux.org>
  218. - 6.10-1vl2
  219. - build with gcc
  220. * Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
  221. - syncronized release tcsh based on a securty fix for RH6.2.
  222. * Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  223. - update to 6.10.00 to fix here-script vulnerability
  224. * Mon Sep 18 2000 Adrian Havill <havill@redhat.com>
  225. - fix catalog locale dirname for Japanese
  226. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  227. - FHS packaging.
  228. - add locale support (#10345).
  229. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  230. - rebuild for sparc baud rates > 38400.
  231. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  232. - rebuild to fix dependencies
  233. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  234. - append entries to spanking new /etc/shells.
  235. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
  236. - update to 6.09.
  237. - fix strcoll oddness (#6000, #6244, #6398).
  238. * Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
  239. - fix $shell by using --bindir
  240. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  241. - auto rebuild in the new build environment (release 5)
  242. * Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
  243. - patch for using PATH_MAX instead of some silly internal #defines for
  244. variables that handle filenames.
  245. * Fri Nov 6 1998 Jeff Johnson <jbj@redhat.com>
  246. - update to 6.08.00.
  247. * Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
  248. - upgraded to 6.07.09 from the freebsd
  249. - security fix
  250. * Wed Aug 5 1998 Jeff Johnson <jbj@redhat.com>
  251. - use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
  252. - update url's
  253. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  254. - translations modified for de, fr, tr
  255. * Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  256. - updated to 6.07; added BuildRoot
  257. - cleaned up the spec file; fixed source url
  258. * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
  259. - added termios hacks for new glibc
  260. - added /bin/csh to file list
  261. * Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
  262. - built against glibc
  263. * Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
  264. - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
  265. isn't installed.