tcl-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498
  1. %global itcl_version 4.2.0
  2. %global tdbc_version 1.1.1
  3. %global thread_version 2.8.5
  4. %{!?sdt:%define sdt 0}
  5. Summary: A Tcl/Tk development environment: tcl
  6. Summary(ja): Tcl/Tk 開発環境: tcl
  7. Name: tcl
  8. Version: 8.6.13
  9. %global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  10. %global minorver %(echo %{version} | sed -e 's/^.*\.//')
  11. %global htmlver %{version}
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: TCL
  17. URL: http://tcl.sourceforge.net/
  18. Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  19. #Source1: https://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  20. Patch0: tcl-8.6.12-autopath.patch
  21. Patch1: tcl-8.6.12-conf.patch
  22. Patch2: tcl-8.6.13-hidden.patch
  23. Patch3: tcl-8.6.13-tcltests-path-fix.patch
  24. Patch4: tcl-8.6.13-configure-c99.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: autoconf
  27. BuildRequires: zlib-devel
  28. %if %sdt
  29. BuildRequires: systemtap-sdt-devel
  30. %endif
  31. %description
  32. Tcl is a simple scripting language designed to be embedded into
  33. other applications. Tcl is designed to be used with Tk, a widget
  34. set, which is provided in the tk package. This package also includes
  35. tclsh, a simple example of a Tcl application.
  36. %description -l ja
  37. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  38. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  39. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  40. も含んでいます。
  41. %package devel
  42. Summary: Tcl scripting language development environment
  43. Summary(ja): Tcl スクリプト言語の開発環境
  44. Group: programming
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. Tcl is a simple scripting language designed to be embedded into
  48. other applications. Tcl is designed to be used with Tk, a widget
  49. set, which is provided in the tk package. This package also includes
  50. tclsh, a simple example of a Tcl application.
  51. The package contains the development files and man pages for tcl.
  52. %package itcl
  53. Summary: Object oriented extensions to Tcl and Tk
  54. Summary(ja): Tcl/Tk のオブジェクト指向拡張
  55. Group: programming
  56. Requires: %{name} = %{version}-%{release}
  57. Provides: itcl = %{itcl_version}
  58. Obsoletes: itcl < 4.0.0
  59. %description itcl
  60. [incr Tcl] is Tcl extension that provides object-oriented features that are
  61. missing from the Tcl language.
  62. %package itcl-devel
  63. Summary: Development headers and libraries for linking against tcl-itcl
  64. Summary(ja): tcl-itclとリンクするためのヘッダ・ライブラリ
  65. Group: programming
  66. Requires: %{name}-itcl = %{version}-%{release}
  67. Provides: itcl-devel = %{itcl_version}
  68. Obsoletes: itcl-devel < 4.0.0
  69. %description itcl-devel
  70. Development headers and libraries for linking against itcl.
  71. %package tdbc
  72. Summary: database extensions to Tcl and Tk
  73. Summary(ja): Tcl/Tk のデータベース拡張
  74. Group: Development/Libraries
  75. Requires: %{name} = %{version}-%{release}
  76. Provides: tdbc = %{tdbc_version}
  77. %description tdbc
  78. tdbc is Tcl extension that provides database features to tcl/tk.
  79. %package tdbc-devel
  80. Summary: Development headers and libraries for linking against tcl-tdbc
  81. Summary(ja): tcl-tdbcとリンクするためのヘッダ・ライブラリ
  82. Group: programming
  83. Requires: %{name}-tdbc = %{version}-%{release}
  84. Requires: sqlite3-tcl
  85. Provides: tdbc-devel = %{tdbc_version}
  86. %description tdbc-devel
  87. Development headers and libraries for linking against tdbc.
  88. %package thread
  89. Summary: thread extensions to Tcl and Tk
  90. Summary(ja): Tcl/Tk のスレッド拡張
  91. Group: programming
  92. Requires: %{name} = %{version}-%{release}
  93. Provides: thread = %{thread_version}
  94. Obsoletes: thread < 2.8.0
  95. %description thread
  96. You can use this extension to gain script-level access to Tcl threading
  97. capabilities.
  98. %debug_package
  99. %prep
  100. #setup -n %{name}%{version} -q -a 1
  101. %setup -n %{name}%{version} -q
  102. #mv tcl%{htmlver}/html .
  103. %autopatch -p1
  104. rm -rf compat/zlib
  105. pushd unix
  106. sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtcl%{majorver}.so/' Makefile.in
  107. popd
  108. %build
  109. pushd unix
  110. autoconf
  111. %configure \
  112. %if %sdt
  113. --enable-dtrace \
  114. %endif
  115. --disable-threads \
  116. --enable-symbols \
  117. --enable-shared
  118. make %{?_smp_mflags} CFLAGS="%{optflags} -fPIC" TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  119. %install
  120. rm -rf $RPM_BUILD_ROOT
  121. make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
  122. ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
  123. # for linking with -lib%{name}
  124. ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  125. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
  126. # postgresql and maybe other packages too need tclConfig.sh
  127. # paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
  128. ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
  129. mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
  130. find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
  131. pushd $RPM_BUILD_ROOT/%{_includedir}
  132. for i in *.h ; do
  133. [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
  134. done
  135. popd
  136. # remove buildroot traces
  137. sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
  138. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
  139. rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
  140. # sqlite3 extension is provided by sqlite3-tcl
  141. rm -rf %{buildroot}%{_libdir}/sqlite3*
  142. rm -f %{buildroot}%{_mandir}/mann/sqlite3*
  143. %clean
  144. rm -rf $RPM_BUILD_ROOT
  145. %files
  146. %defattr(-,root,root,-)
  147. %license license.terms
  148. %doc README.md changes
  149. #doc html/*
  150. %{_bindir}/tclsh*
  151. %{_libdir}/libtcl%{majorver}.so
  152. %dir %{_libdir}/tcl%{majorver}
  153. %{_datadir}/%{name}8
  154. %{_datadir}/tcl%{majorver}
  155. %{_mandir}/man1/*
  156. %{_mandir}/mann/*
  157. # itcl
  158. %exclude %{_mandir}/mann/body.n*
  159. %exclude %{_mandir}/mann/class.n*
  160. %exclude %{_mandir}/mann/code.n*
  161. %exclude %{_mandir}/mann/configbody.n*
  162. %exclude %{_mandir}/mann/delete.n*
  163. %exclude %{_mandir}/mann/ensemble.n*
  164. %exclude %{_mandir}/mann/find.n*
  165. %exclude %{_mandir}/mann/is.n*
  166. %exclude %{_mandir}/mann/itcl*.n*
  167. %exclude %{_mandir}/mann/local.n*
  168. %exclude %{_mandir}/mann/scope.n*
  169. # tdbc
  170. %exclude %{_mandir}/mann/tdbc*
  171. # thread
  172. %exclude %{_mandir}/mann/thread.n*
  173. %exclude %{_mandir}/mann/tpool.n*
  174. %exclude %{_mandir}/mann/tsv.n*
  175. %exclude %{_mandir}/mann/ttrace.n*
  176. %files devel
  177. %defattr(-,root,root,-)
  178. %{_includedir}/*
  179. %{_libdir}/pkgconfig/tcl.pc
  180. %{_libdir}/libtcl.so
  181. %{_libdir}/libtclstub%{majorver}.a
  182. %{_libdir}/tclConfig.sh
  183. %{_libdir}/tclooConfig.sh
  184. %{_libdir}/tcl%{majorver}/tclConfig.sh
  185. %{_mandir}/man3/*
  186. %files itcl
  187. %{_libdir}/itcl*
  188. %exclude %{_libdir}/itcl*/itclConfig.sh
  189. %exclude %{_libdir}/itcl*/libitclstub*.a
  190. %{_mandir}/mann/body.n*
  191. %{_mandir}/mann/class.n*
  192. %{_mandir}/mann/code.n*
  193. %{_mandir}/mann/configbody.n*
  194. %{_mandir}/mann/delete.n*
  195. %{_mandir}/mann/ensemble.n*
  196. %{_mandir}/mann/find.n*
  197. %{_mandir}/mann/is.n*
  198. %{_mandir}/mann/itcl*.n*
  199. %{_mandir}/mann/local.n*
  200. %{_mandir}/mann/scope.n*
  201. %files itcl-devel
  202. %{_libdir}/itcl*/itclConfig.sh
  203. %{_libdir}/itcl*/libitclstub*.a
  204. %{_includedir}/itcl*.h
  205. %files tdbc
  206. %{_libdir}/tdbc*
  207. %exclude %{_libdir}/tdbc*/libtdbcstub*.a
  208. %exclude %{_libdir}/tdbc*/tdbcConfig.sh
  209. %{_bindir}/sqlite3_analyzer
  210. %{_libdir}/tcl8/%{majorver}/tdbc/sqlite3-*.tm
  211. %{_mandir}/mann/tdbc*
  212. %files tdbc-devel
  213. %{_libdir}/tdbc*/libtdbcstub*.a
  214. %{_libdir}/tdbc*/tdbcConfig.sh
  215. %{_includedir}/tdbc*.h
  216. %files thread
  217. %{_libdir}/thread*
  218. %{_mandir}/mann/thread.n*
  219. %{_mandir}/mann/tpool.n*
  220. %{_mandir}/mann/tsv.n*
  221. %{_mandir}/mann/ttrace.n*
  222. %changelog
  223. * Sat Oct 21 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.13-1
  224. - new upstream release.
  225. - dropped ldconfig scriptlets.
  226. - re-imported patches from rawhide.
  227. * Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
  228. - new upstream release.
  229. - replaced all patches to the newest rawhide's.
  230. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
  231. - new upstream release.
  232. - dropped Patch101: get same effects by sed and configure options.
  233. - imported Patch103.
  234. - added subpackages: itcl{,-devel}, tdbc{,-devel} and thread.
  235. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
  236. - split development files into devel subpackage
  237. * Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
  238. - rebuilt with the current environment
  239. * Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
  240. - update to 8.5.15
  241. - update Patch101 (tcl-8.5.15-conf.patch)
  242. - remove Patch103 (tcl-8.5.7-sigabrt.patch)
  243. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
  244. - update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
  245. - update License: TCL
  246. - drop obsolete patches
  247. - tclm4-soname patch (Patch1)
  248. - lib-perm patch (Patch2)
  249. - configure patch (Patch3)
  250. - no rpath patch (Patch4)
  251. - init lib64 patch (Patch10)
  252. - add some patches from RHEL tcl-8.5.7-6.el6
  253. - autopath patch (Patch100)
  254. - conf patch (Patch101)
  255. - hidden patch (Patch102)
  256. - sigabrt patch (Patch103)
  257. - update build and install section: sync RHEL tcl-8.5.7-6.el6
  258. - add BR: systemtap-sdt-devel: default disable
  259. * Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
  260. - added imake to BR:.
  261. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  262. - rebuilt with rpm-4.8.1-3
  263. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  264. - rebuilt with new environment
  265. - updated Patch3: tcl8.4.16-configure.patch
  266. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  267. - new upstream release
  268. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  269. - spec in UTF-8
  270. - configure with disabled threads. See:
  271. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  272. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  273. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  274. - rebuild with new environment
  275. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  276. - updated tcl to 8.4.18
  277. - updated tcl-html to 8.4.18
  278. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  279. - updated tcl to 8.4.16
  280. - updated tcl-html to 8.4.16
  281. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  282. - added Patch3: tcl8.4.16-configure.patch
  283. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  284. - updated tcl to 8.4.15
  285. - updated tcl-html to 8.4.15
  286. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  287. - added Patch10: tcl-8.4.15-init.lib64.patch
  288. - rebuilt with new toolchain
  289. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  290. - updated tcl to 8.4.13
  291. - updated tcl-html to 8.4.13
  292. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  293. - updated tcl to 8.4.12
  294. - updated patch4
  295. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  296. - updated tcl to 8.4.11
  297. - updated Patch4
  298. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  299. - updated tcl to 8.4.6
  300. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  301. - merged with fedora
  302. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  303. - removed rpath (patch 4)
  304. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  305. - put private header files under generic and unix subdirs
  306. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  307. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  308. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  309. - new package split out from tcltk
  310. - update to tcl 8.4.5 (#88429)
  311. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  312. and tcl8.3.5-koi8-u.enc-88806.patch
  313. - include private include headers under %{_includedir}/tcl-private
  314. - filtered changelog for tcl
  315. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  316. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  317. - update based on BitWalk's tcltk-8.4.2-83bw
  318. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  319. - split source package.
  320. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  321. - expand some macros.. (FIXME)
  322. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  323. - use %configure macros
  324. - add Patch 47,50
  325. * Thu May 31 2001 <sagami@vinelinux.org>
  326. - 8.0.5_jp-10
  327. - unexpand old %%{configure}, new one causes build failure
  328. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  329. - install manpages into %%{_mandir} and mode 644
  330. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  331. - 8.0.5_jp-9
  332. - modified %install section to handle compressed man pages
  333. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  334. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  335. - changed default fonts
  336. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  337. - added defattr
  338. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  339. - added some symlinks, such as libtcl8.0.so.
  340. - obsoletes version number using _jp, now 8.0.5-31vl1
  341. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  342. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  343. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  344. - fix tclX symlinks.
  345. - compile on systems where SIGPWR == SIGLOST.
  346. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  347. - update tcl/tk to 8.0.5.
  348. - avoid "containing" in Tix (#2332).
  349. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  350. - use /usr/bin/write in kibitz (#1320).
  351. - use cirrus.sprl.umich.edu in weather (#1926).
  352. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  353. - auto rebuild in the new build environment (release 28)
  354. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  355. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  356. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  357. - expect does unaligned access on alpha (#989)
  358. - upgrade tcl/tk/tclX to 8.0.4
  359. - upgrade expect to 5.28.
  360. - add itcl 3.0.1
  361. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  362. - call libtoolize to allow building on the arm
  363. - build for glibc 2.1
  364. - strip binaries
  365. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  366. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  367. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  368. - expect: mkpasswd needs delay before sending password (problem #576)
  369. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  370. - translations modified for de, fr, tr
  371. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  372. - fixed expect binaries exec permissions
  373. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  374. - updated to Tix 4.1.0.006
  375. - updated version numbers of tcl/tk to relflect includsion of p2
  376. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  377. - updated tcl/tk to patch level 2
  378. - updated tclX to 8.0.2
  379. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  380. - fixed filelist for tix... replacing path to the expect binary in scripts
  381. was leaving junk files around.
  382. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  383. - added patch to remove libieee test in configure.in for tcl and tk.
  384. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  385. solution for all systems
  386. - fixed src urls
  387. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  388. - removed version numbers from descriptions
  389. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  390. - updated to tcl/tk 8.0 and related versions of packages
  391. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  392. - built against glibc
  393. - fixed dangling tclx/tkx symlinks