tamago-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(pre):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define _libdir %{_prefix}/lib
  4. %define origver 4.0.6
  5. %define origname tamago
  6. %define egg_anthy_version 20070606
  7. Summary: Tamago Version 4 -- EGG Input Method Architecture for Emacsen
  8. Summary(ja): たまご第4版
  9. Name: %{origname}
  10. Version: %{origver}
  11. Release: 11.egganthy%{egg_anthy_version}%{?_dist_release}
  12. Source0: ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
  13. Source1: %{origname}-install.sh
  14. Source2: %{origname}-remove.sh
  15. Source3: http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
  16. Source4: egg-anthy.tar.gz
  17. Source10: vine-default-%{origname}.el
  18. Source11: %{origname}-init.el
  19. Patch0: tamago-4.0.6-cvshead.patch
  20. Patch3: tamago-4.0.6-eggrc.patch
  21. Patch4: tamago-4.0.6-makefile.patch
  22. Patch5: tamago-4.0.6-canna-unix-domain-socket.patch
  23. Patch10: tamago-emcws.patch
  24. Patch20: tamago-4.0.6-vine-romakana.patch
  25. Patch30: tamago-4.0.6-egg-helper-path.patch
  26. Patch40: tamago-4.0.6-wnn8_rev2.patch
  27. ### for emacs
  28. ### from http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
  29. Patch50: tamago-4.0.6-emacs23.patch
  30. Patch60: tamago-4.0.6-make-local-hook-obsoleted.patch
  31. License: GPL
  32. Group: Applications/Editors/Emacs
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. Requires: emacsen
  35. Requires: emacsen-common
  36. BuildRequires: apel
  37. %prereq_ge apel
  38. Obsoletes: tamago-el
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. %description
  42. EGG Emacs20(Emacs21) Input Method Architecture.
  43. Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
  44. character string conversion with the back end.
  45. And this package includes egg-anthy. Egg can use Anthy.
  46. %description -l ja
  47. GNU Emacs 20.5 以降で多言語入力環境を提供します。
  48. バックエンドサーバとしては、FreeWnn (jserver,
  49. cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応。
  50. また、本パッケージには egg-anthy も同梱しているため、Anthy にも対応。
  51. %prep
  52. %setup -n %{origname}-%{origver} -a 4
  53. %patch0 -p1
  54. %patch3 -p1
  55. #% patch4 -p1
  56. %patch5 -p1
  57. # cp %{SOURCE3} .
  58. %__cp -a %{SOURCE10} %{SOURCE11} .
  59. #% patch10 -p1
  60. %patch20 -p1
  61. %patch30 -p1
  62. %patch40 -p1
  63. %patch50 -p1
  64. %patch60 -p1
  65. # rename canna stuff
  66. #mv egg/canna.el egg/canna-tamago.el
  67. # copy egg-anthy stuff
  68. cp egg-anthy-%{egg_anthy_version}/*.el egg/
  69. %build
  70. %configure
  71. gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
  72. %install
  73. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  74. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  75. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  76. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  77. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  78. #
  79. # install el files
  80. #
  81. cp -r eggrc *.el egg its* Makefile \
  82. $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
  83. #
  84. # install egg-helper
  85. #
  86. install -d $RPM_BUILD_ROOT%{_libexecdir}
  87. install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
  88. #
  89. # install script( bytecompile el and install elc , remove )
  90. #
  91. %_installemacsenscript %{origname} %{SOURCE1}
  92. %_removeemacsenscript %{origname} %{SOURCE2}
  93. #
  94. # install info file
  95. #
  96. mkdir -p ${RPM_BUILD_ROOT}/usr/info
  97. %post
  98. #
  99. # bytecompile and install
  100. #
  101. if [ "$1" = 2 ]; then
  102. %_emacsenPackageRemove %{origname}
  103. fi
  104. %_addemacsenlist %{origname}
  105. %_emacsenPackageInstall %{origname}
  106. %preun
  107. if [ "$1" = 0 ]; then
  108. %_emacsenPackageRemove %{origname}
  109. %_removeemacsenlist %{origname}
  110. fi
  111. %clean
  112. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  113. %files
  114. %defattr(-,root,root)
  115. %doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
  116. %doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
  117. %{_datadir}/emacs/site-lisp/%{origname}/
  118. %{_libdir}/emacsen-common/packages/install/%{origname}
  119. %{_libdir}/emacsen-common/packages/remove/%{origname}
  120. %{_libexecdir}/egg-helper
  121. %changelog
  122. * Fri Apr 29 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-11.egganthy20070606
  123. - added Patch60, as 'make-local-hook' is obsoleted on emacs24
  124. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.6-10.egganthy20070606
  125. - new release number for RPM package
  126. - update description
  127. * Sun Jun 6 2010 IWAI, Masaharu <iwai@alib.jp> 4.0.6-9
  128. - update to egg-anthy 20070606
  129. - update vine-default-tamago.el: connect to anthy with utf-8
  130. * Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
  131. - update vine-default-tamago.el to support emacs >= 23.1.96
  132. * Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
  133. - update patch40 (tamago-4.0.6--wnn8_rev2.patch)
  134. - fix bugs on 64bit architecture.
  135. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
  136. - applied tamago-4.0.6-emacs23.patch
  137. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
  138. - updated tamago-install.sh
  139. - *-init.el: changed from hard copy to symbolic link
  140. on /etc/emacs-XX.YY/site-start.d
  141. * Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
  142. - no applied:
  143. - egg-canna.el
  144. - tamago-4.0.6-makefile.patch
  145. - tamago-emcws.patch
  146. - added vine-default-tamago.el and tamago-init.el
  147. - updated tamago-install.sh for vine-default-tamago.el
  148. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
  149. - change from noarch to per-arch for egg-helper.
  150. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
  151. - applied new versioning policy
  152. - added %%define _libdir %%{_prefix}/lib
  153. * Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
  154. - add Patch40 to support wnn7 and wnn8 (taken from debian package)
  155. * Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
  156. - restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
  157. * Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
  158. - add Patch5
  159. tamago-canna backend connect to cannaserver using UNIX domain
  160. socket by default. (taken from debian package)
  161. - add Patch30 to change egg-helper path.
  162. * Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
  163. - modified its/hira.el to add some roma-kana conversion map.
  164. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
  165. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  166. * Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
  167. - update to cvs head
  168. - add egg-anthy
  169. http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
  170. - add documents to %%files
  171. - use License: instead of Copyright:
  172. * Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
  173. - update tamago-install.sh
  174. - rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
  175. - rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
  176. * Fri May 9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
  177. - update tamago-remove.sh: delete ${SITELISP}/egg
  178. * Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
  179. - rebuild
  180. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
  181. - add patch10 to use with emcws
  182. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
  183. - remove conflicts to emacs-dl-*
  184. - rename canna.el to canna-tamago.el (we use emcws for canna)
  185. * Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
  186. - modified patch3 for Canna-3.5b2-41
  187. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
  188. - added patch4
  189. * Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
  190. - update source3
  191. * Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
  192. - added patch3
  193. * Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
  194. - update patch2
  195. - added source3
  196. * Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
  197. - tamago-el -> tamago again
  198. - spec file cleaned up
  199. * Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
  200. - fixed install time no-compile bug( edit tamago-{install,remove}.sh )
  201. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
  202. - support emacsen
  203. * Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
  204. - canna support patch upgrade.
  205. * Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
  206. - version 4.0.6
  207. - merge canna support patch.
  208. * Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
  209. - version 4.0.5