t-gnus-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define tgnusver 6_15_4-09
  4. Summary: T-gnus - a branch of Gnus (SEMI compatible) for FSF Emacs 20.x
  5. Summary(ja): T-gnus - SEMI 対応の Gnus (Emacs20 用)
  6. Name: t-gnus
  7. Version: 6.15.4.09
  8. Release: 0vl2
  9. License: GPL
  10. Source0: ftp://ftp.jpl.org/pub/elisp/t-gnus-6.14/snapshots/t-gnus-%{tgnusver}-quimby.tar.gz
  11. Source1: t-gnus-install.sh
  12. Source2: t-gnus-remove.sh
  13. Patch0: t-gnus-%{tgnusver}-info.patch
  14. Group: Applications/Editors/Emacs
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildArch: noarch
  17. PreReq: emacsen
  18. %prereq_ge emacsen-common
  19. %prereq_ge semi
  20. BuildRequires: emacsen-common, semi
  21. Obsoletes: t-gnus-xemacs
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  25. %description
  26. T-gnus is a variation of Gnus and SEMI-capable.
  27. It is a replacement for Gnus with gnus-mime combination.
  28. Install t-gnus package if you want to use T-gnus on Emacs 20.x.
  29. %description -l ja
  30. T-gnus は SEMI 対応の Gnus の1つです.
  31. gnus-mime と Gnus の組合せを置き換えるものです.
  32. %prep
  33. %setup -q -n t-gnus-%{tgnusver}-quimby
  34. %patch0 -p1
  35. cd texi
  36. # change info filename to avoid conflict with Gnus of emacs-20.4
  37. #
  38. sed -e 's/@c @direntry/@direntry/' \
  39. -e 's/@c \* Emacs MIME/\* Emacs MIME/' \
  40. -e 's/@c @end direntry/@end direntry/' \
  41. emacs-mime.texi > emacs-mime-new.texi
  42. mv emacs-mime-new.texi emacs-mime.texi
  43. sed -e 's/@c @direntry/@direntry/' \
  44. -e 's/@c \* Gnus-ja/\* Gnus-ja/' \
  45. -e 's/@c @end direntry/@end direntry/' \
  46. -e 's/@setfilename gnus-ja/@setfilename t-gnus-ja/' \
  47. -e 's/Gnus-ja: (gnus-ja)/T-Gnus-ja: (t-gnus-ja)/' \
  48. gnus-ja.texi > t-gnus-ja.texi
  49. sed -e 's/@c @direntry/@direntry/' \
  50. -e 's/@c \* Gnus/\* Gnus/' \
  51. -e 's/@c @end direntry/@end direntry/' \
  52. -e 's/@setfilename gnus/@setfilename t-gnus/' \
  53. -e 's/Gnus: (gnus)/T-Gnus: (t-gnus)/' \
  54. gnus.texi > t-gnus.texi
  55. sed -e 's/@c @direntry/@direntry/' \
  56. -e 's/@c \* Message/\* Message/' \
  57. -e 's/@c @end direntry/@end direntry/' \
  58. -e 's/@setfilename message-ja/@setfilename t-gnus-message-ja/' \
  59. -e 's/Message-ja: (message-ja)/T-Gnus-Message-ja: (t-gnus-message-ja)/' \
  60. message-ja.texi > t-gnus-message-ja.texi
  61. sed -e 's/@c @direntry/@direntry/' \
  62. -e 's/@c \* Message/\* Message/' \
  63. -e 's/@c @end direntry/@end direntry/' \
  64. -e 's/@setfilename message/@setfilename t-gnus-message/' \
  65. -e 's/Message: (message)/T-Gnus-Message: (t-gnus-message)/' \
  66. message.texi > t-gnus-message.texi
  67. %build
  68. ./configure
  69. make clean
  70. %install
  71. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  72. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  73. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  74. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
  75. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
  76. #
  77. # install el files
  78. #
  79. cp -a Makefile* aclocal.m4 config* etc install-sh lisp mkinstalldirs texi \
  80. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  81. #
  82. # format info files and install them
  83. #
  84. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  85. ( cd texi;
  86. make all-info ja-info
  87. install -m 644 *.info* ${RPM_BUILD_ROOT}%{_infodir}/.
  88. )
  89. #
  90. # install script (bytecompile el and install elc, remove)
  91. #
  92. %_installemacsenscript %{name} %{SOURCE1}
  93. %_removeemacsenscript %{name} %{SOURCE2}
  94. %post
  95. #
  96. # bytecompile and install
  97. #
  98. if [ "$1" = 2 ] ; then
  99. %_emacsenPackageRemove %{name}
  100. fi
  101. %_addemacsenlist %{name}
  102. %_emacsenPackageInstall %{name}
  103. /sbin/install-info %{_infodir}/emacs-mime.info.gz %{_infodir}/dir \
  104. --section="MIME Interface"
  105. /sbin/install-info %{_infodir}/sieve.info.gz %{_infodir}/dir \
  106. --section="Newsreader"
  107. /sbin/install-info %{_infodir}/t-gnus.info.gz %{_infodir}/dir \
  108. --section="Newsreader"
  109. /sbin/install-info %{_infodir}/t-gnus-ja.info.gz %{_infodir}/dir \
  110. --section="Newsreader"
  111. /sbin/install-info %{_infodir}/t-gnus-message.info.gz %{_infodir}/dir \
  112. --section="Newsreader"
  113. /sbin/install-info %{_infodir}/t-gnus-message-ja.info.gz %{_infodir}/dir \
  114. --section="Newsreader"
  115. %preun
  116. if [ "$1" = 0 ]; then
  117. %_emacsenPackageRemove %{name}
  118. %_removeemacsenlist %{name}
  119. /sbin/install-info --delete %{_infodir}/emacs-mime.info.gz %{_infodir}/dir
  120. /sbin/install-info --delete %{_infodir}/sieve.info.gz %{_infodir}/dir
  121. /sbin/install-info --delete %{_infodir}/t-gnus.info.gz %{_infodir}/dir
  122. /sbin/install-info --delete %{_infodir}/t-gnus-ja.info.gz %{_infodir}/dir
  123. /sbin/install-info --delete %{_infodir}/t-gnus-message.info.gz \
  124. %{_infodir}/dir
  125. /sbin/install-info --delete %{_infodir}/t-gnus-message-ja.info.gz \
  126. %{_infodir}/dir
  127. fi
  128. %clean
  129. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  130. %files
  131. %defattr(-,root,root)
  132. %doc ChangeLog* GNUS-NEWS Mule23@1934*
  133. %doc README* TODO* contrib sample.lpath.el todo
  134. %{_infodir}/*
  135. %{_datadir}/emacs/site-lisp/%{name}/
  136. %{_libdir}/emacsen-common/packages/install/%{name}
  137. %{_libdir}/emacsen-common/packages/remove/%{name}
  138. %changelog
  139. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.15.4.09-0vl2
  140. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  141. - s/Copyright/License/
  142. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.15.4.09-0vl1
  143. - now emacsen-common aware
  144. - updated to new upstream release
  145. * Thu Jul 12 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
  146. - 6.15.3.02-0vl1
  147. - update to 6_14_5-02
  148. - fix t-gnus-info.patch, and modify building function of info for emacs
  149. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  150. - 6.14.5.04-0vl2
  151. - rebuilt with apel-10.3, flim-1.14.3, semi-1.14.3
  152. * Mon Sep 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  153. - 6.14.5.04-0vl1
  154. - updated to 6_14_5-04 snapshot release
  155. - now both emacs/xemacs packages are merged into one srpm
  156. - modified for brp-redhat
  157. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  158. - 6.14.1.01-1vl1
  159. - rebuild with apel-10.2
  160. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji
  161. - 6.14.1.01-1
  162. - updated to 6.14.1.01
  163. * Tue Dec 28 1999 MATSUBAYASHI 'Shaolin' Kohji
  164. - 6.14.0.14-1
  165. - updated to 6.14.0.14
  166. * Sat Dec 4 1999 MATSUBAYASHI 'Shaolin' Kohji
  167. - 6.13.4.01-1
  168. - updated to 6.13.4.01
  169. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
  170. - 6.13.3.06-1
  171. - updated to 6.13.3.06 for semi-1.13.7
  172. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
  173. - 6.12.0-2
  174. - now info file is converted into EUC format
  175. - %post and %preun section fixed
  176. * Tue Sep 21 1999 MATSUBAYASHI 'Shaolin' Kohji
  177. - 6.12.0-1
  178. - first rpm package for Vine 1.9
  179. - changed info filename from gnus-* to t-gnus-*
  180. (to avoid conflicts with Gnus info that comes with emacs-20.4)