scim-bridge-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name scim-bridge
  3. %define version 0.4.16
  4. %define release 19%{?_dist_release}
  5. %define qt3_ver 3.3.8
  6. %define qt4_ver 4.8.6
  7. # build qt3 immodule ("--without qt3" to disable qt3)
  8. %bcond_without qt3
  9. %define _qt3_version 3.3.8
  10. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  11. %define _qt3_plugindir %{_qt3_prefix}/plugins
  12. # build qt4 immodule ("--without qt4" to disable qt4)
  13. %bcond_without qt4
  14. # Qt4 version auto-detection -- inagaki
  15. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  16. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  17. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  18. Summary: yet another IM client of SCIM
  19. Summary(ja): もう一つ別の SCIM IM クライアント
  20. Name: %{name}
  21. Version: %{version}
  22. Release: %{release}
  23. Group: System Environment/Libraries
  24. License: GPL/LGPL
  25. URL: http://www.scim-im.org/projects/scim_bridge
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Source0: http://jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  29. # Patch from Fedora 10
  30. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  31. Patch1: scim-bridge-0.4.15-bz461373.patch
  32. # Patch from Mandriva 2009
  33. Patch2: bug-351920-should-return-retval.patch
  34. Patch3: scim-bridge-0.4.15.2-linkage.patch
  35. # Patch from Fedora development
  36. Patch4: scim-bridge-0.4.15-EOF.patch
  37. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  38. Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
  39. Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
  40. Patch100: scim-bridge-0.4.16-header.patch
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. BuildRequires: scim-devel >= 1.4
  43. BuildRequires: pkgconfig >= 0.9.0
  44. BuildRequires: gtk2-devel >= 2.14.0
  45. Requires: scim >= 1.4
  46. %description
  47. Scim-bridge is yet another IM client of SCIM.
  48. The im-module of scim-bridge communicates with scim via socket.
  49. %description -l ja
  50. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  51. scim-bridge の im-module はソケット経由で SCIM と通信します。
  52. %package gtk
  53. Summary: SCIM Bridge GTK IM Module
  54. Summary(ja): SCIM Bridge GTK IM モジュール
  55. Group: System Environment/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: gtk2 >= 2.14.0
  58. Requires(post): gtk2 >= 2.14.0
  59. Requires(postun): gtk2 >= 2.14.0
  60. Obsoletes: %{name} <= 0.1.7
  61. %description gtk
  62. This package provides the SCIM Bridge GTK IM module.
  63. %description -l ja gtk
  64. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  65. %if !%{without qt3}
  66. %package qt
  67. Summary: SCIM Bridge Qt IM Module
  68. Summary(ja): SCIM Bridge Qt IM モジュール
  69. Group: System Environment/Libraries
  70. Requires: %{name} = %{version}-%{release}
  71. Requires: qt = %{_qt3_version}
  72. BuildRequires: qt-devel
  73. BuildRequires: libXmu-devel
  74. %description qt
  75. This package provides the SCIM Bridge Qt IM module.
  76. %description -l ja qt
  77. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  78. %endif
  79. %if !%{without qt4}
  80. %package qt4
  81. Summary: SCIM Bridge Qt4 IM Module
  82. Summary(ja): SCIM Bridge Qt4 IM モジュール
  83. Group: System Environment/Libraries
  84. Requires: %{name} = %{version}-%{release}
  85. Requires: qt4 >= %{_qt4_version}
  86. BuildRequires: qt4-devel
  87. %description qt4
  88. This package provides the SCIM Bridge Qt4 IM module.
  89. %description -l ja qt4
  90. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  91. %endif
  92. ## to build compat32 for x86_64 architecture support
  93. %package -n compat32-%{name}-gtk
  94. Summary: SCIM Bridge GTK IM Module
  95. Summary(ja): SCIM Bridge GTK IM モジュール
  96. Group: System Environment/Libraries
  97. Requires: %{name} = %{version}-%{release}
  98. Requires: compat32-gtk2 >= 2.14.0
  99. Requires(post): gtk2 >= 2.14.0
  100. Requires(postun): gtk2 >= 2.14.0
  101. %description -n compat32-%{name}-gtk
  102. This package provides the SCIM Bridge GTK IM module.
  103. %description -l ja -n compat32-%{name}-gtk
  104. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  105. %if !%{without qt3}
  106. %package -n compat32-%{name}-qt
  107. Summary: SCIM Bridge Qt IM Module
  108. Summary(ja): SCIM Bridge Qt IM モジュール
  109. Group: System Environment/Libraries
  110. Requires: %{name} = %{version}-%{release}
  111. Requires: compat32-qt >= %{_qt3_version}
  112. BuildRequires: qt-devel
  113. %description -n compat32-%{name}-qt
  114. This package provides the SCIM Bridge Qt IM module.
  115. %description -l ja -n compat32-%{name}-qt
  116. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  117. %endif
  118. %if !%{without qt4}
  119. %package -n compat32-%{name}-qt4
  120. Summary: SCIM Bridge Qt4 IM Module
  121. Summary(ja): SCIM Bridge Qt4 IM モジュール
  122. Group: System Environment/Libraries
  123. Requires: %{name} = %{version}-%{release}
  124. Requires: compat32-qt4 >= %{_qt4_version}
  125. BuildRequires: qt4-devel
  126. %description -n compat32-%{name}-qt4
  127. This package provides the SCIM Bridge Qt4 IM module.
  128. %description -l ja -n compat32-%{name}-qt4
  129. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  130. %endif
  131. %prep
  132. %setup -q
  133. %patch0 -p1 -b .0-fix-gdm
  134. %patch1 -p1
  135. %patch2 -p1
  136. %patch3
  137. %patch4 -p1
  138. %patch5 -p1
  139. pushd client-gtk
  140. %patch6 -p0
  141. popd
  142. %patch7 -p1
  143. %patch100 -p1
  144. %build
  145. %if !%{without qt3}
  146. export QT3_PREFIX=%{_qt3_prefix}
  147. %endif
  148. %if !%{without qt4}
  149. export QT4_PREFIX=%{_qt4_prefix}
  150. %endif
  151. %configure --disable-static \
  152. %if %{without qt3}
  153. --disable-qt3-immodule \
  154. %else
  155. --enable-qt3-immodule \
  156. %endif
  157. %if %{without qt4}
  158. --disable-qt4-immodule \
  159. %else
  160. --enable-qt4-immodule \
  161. %endif
  162. --enable-gtk2-immodule
  163. %__make %{?_smp_mflags}
  164. %install
  165. %__rm -rf %{buildroot}
  166. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  167. %__make DESTDIR=%{buildroot} install
  168. # remove unneeded files
  169. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  170. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  171. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  172. %clean
  173. %__rm -rf %{buildroot}
  174. %post gtk
  175. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  176. %postun gtk
  177. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  178. %post -n compat32-%{name}-gtk
  179. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  180. %postun -n compat32-%{name}-gtk
  181. %{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
  182. %files
  183. %defattr(-,root,root)
  184. %license COPYING doc/LICENSE*
  185. %doc AUTHORS ChangeLog NEWS README
  186. %{_bindir}/scim-bridge
  187. %files gtk
  188. %defattr(-,root,root)
  189. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  190. %if !%{without qt3}
  191. %files qt
  192. %defattr(-,root,root)
  193. %{_qt3_plugindir}/inputmethods/*.so
  194. %endif
  195. %if !%{without qt4}
  196. %files qt4
  197. %defattr(-,root,root)
  198. %{_qt4_plugindir}/inputmethods/*.so
  199. %endif
  200. ## to build compat32 for x86_64 architecture support
  201. %if %{build_compat32}
  202. %files -n compat32-%{name}-gtk
  203. %defattr(-,root,root)
  204. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  205. %if !%{without qt3}
  206. %files -n compat32-%{name}-qt
  207. %defattr(-,root,root)
  208. %{_qt3_plugindir}/inputmethods/*.so
  209. %endif
  210. %if !%{without qt4}
  211. %files -n compat32-%{name}-qt4
  212. %defattr(-,root,root)
  213. %{_qt4_plugindir}/inputmethods/*.so
  214. %endif
  215. %endif
  216. %changelog
  217. * Fri Jul 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.16-19
  218. - rebuilt with new toolchain.
  219. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.16-18
  220. - fixed compat32 Requires
  221. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-17
  222. - rebuild with VineSeed environment
  223. - add Patch100 (scim-bridge-0.4.16-header.patch)
  224. * Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
  225. - rebuilt with qt4-4.8.0
  226. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
  227. - rebuilt with qt4-4.7.2
  228. * Sat Feb 5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
  229. - added BR: libXmu-devel to qt package
  230. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
  231. - rebuilt with qt4-4.7.1
  232. * Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
  233. - added compat32-* packages for x86_64 architecture support
  234. * Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
  235. - rebuilt with qt4-4.6.3
  236. * Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
  237. - used %{?_smp_mflags} macro on build
  238. - deleted in unused log in changelog
  239. - Patch8 was none, forgot to delete...
  240. * Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
  241. - added Patch6,7 from Fedora development
  242. - to fix Text input in firefox becomes increasingly sluggish (Patch6)
  243. - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
  244. - added configure --disable-static option
  245. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  246. - updated Qt version detection macros to build properly
  247. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  248. - rebuilt with qt4-4.6.1
  249. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  250. - rebuilt with qt4-4.5.3
  251. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  252. - cleaned up spec
  253. - renumbered patch
  254. - added Patch5 from Fedora
  255. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  256. - rebuild with qt4-4.5.2
  257. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  258. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  259. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  260. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  261. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  262. - new upstream release
  263. - dropt Pacth3,4,5 (these patches are merged)
  264. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  265. - spec in UTF-8
  266. - fixed description in scim-bridge-qt4
  267. - added patch6,7 (import Fedora, Mandriva patches)
  268. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  269. - new upstream release
  270. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  271. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  272. - rebuild with qt4-4.4.2
  273. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  274. - add qt4 immodule
  275. - build gtk,qt3,qt4 immodule by default
  276. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  277. - rebuild with gtk+-2.14
  278. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  279. - new upstream release
  280. - apply new versioning policy
  281. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  282. - drop unnecessary BuildRequires for qt3-immodule package
  283. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  284. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  285. - new upstream release
  286. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  287. - update BuildRequires
  288. - drop doxygen
  289. - add XOrg-gl-devel for building qt3-immodule
  290. - move libmng-devel for building qt3-immodule
  291. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  292. - rebuild for Vine Linux 4.2.
  293. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  294. - add patch0 to fix symbol lookup error with qt3.
  295. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  296. - rebuild for Vine Linux 4.2.
  297. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  298. - new upstrm release
  299. - detect qt version at build time.
  300. - add --disable-qt4-immodule configure option.
  301. - add BuildRequires libmng-devel.
  302. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  303. - rebuild with libstdc++34
  304. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  305. - new upstream release
  306. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  307. - change License to GPL/LGPL
  308. - add doc/LICENSE.* as documents
  309. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  310. - new upstream release
  311. - add BuildRequires: doxygen, qt-devel
  312. - add new sub-packages:
  313. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  314. - qt: Qt IM module
  315. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  316. - new upstream release
  317. - add documents
  318. - running gtk-query-immodules-2.0 in post and postun scripts
  319. - add PreReq: gtk2 > 2.2
  320. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  321. - new upstream release
  322. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  323. - initial release