quota-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417
  1. %bcond_with systemd
  2. %bcond_with quota_enables_tcpwrappers
  3. Name: quota
  4. Summary: System administration tools for monitoring users' disk usage.
  5. Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
  6. Version: 4.09
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2 and GPLv2+
  12. URL: https://sourceforge.net/projects/linuxquota/
  13. Source0: https://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
  14. Source1: quota_nld.init
  15. Source2: quota_nld.sysconfig
  16. Source101: quota_nld.service
  17. Source103: rpc-rquotad.service
  18. Source104: rpc-rquotad.sysconfig
  19. # Not accepted changes (378a64006bb1e818e84a1c77808563b802b028fa), bug #680919
  20. Patch0: quota-4.06-warnquota-configuration-tunes.patch
  21. # Fix parsing a TCP port number
  22. Patch1: quota-4.03-Validate-upper-bound-of-RPC-port.patch
  23. BuildRoot: %{_tmppath}/%{name}-root
  24. BuildRequires: e2fsprogs-devel, gettext
  25. BuildRequires: nss-devel
  26. BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl3-devel
  27. BuildRequires: rpcgen
  28. BuildRequires: pkgconfig(libtirpc)
  29. %if %{with quota_enables_tcpwrappers}
  30. BuildRequires: tcp_wrappers
  31. Requires: tcp_wrappers
  32. %endif
  33. Conflicts: nfs-utils < 1.0.1
  34. %if %{with systemd}
  35. BuildRequires: systemd
  36. Requires: kernel >= 4.0
  37. %{?systemd_requires}
  38. %else
  39. Requires: kernel >= 4.0, initscripts >= 6.38
  40. Requires(post): chkconfig
  41. Requires(preun): chkconfig
  42. %endif
  43. %description
  44. The quota package contains system administration tools for monitoring
  45. and limiting user and or group disk usage per filesystem.
  46. %description -l ja
  47. quota パッケージには,ユーザやグループのディスク使用量を監視したり
  48. 制限したりできるシステム管理ツールが収録されています.これらの操作
  49. はファイルシステム単位で行うことが出来ます.
  50. ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
  51. ストールして下さい.
  52. %debug_package
  53. %prep
  54. %setup -q
  55. %autopatch -p1
  56. # Regenerate build scripts
  57. autoreconf -f -i
  58. %build
  59. %configure \
  60. --enable-bsd-behaviour \
  61. --enable-ext2direct=yes \
  62. --enable-ldapmail=yes \
  63. %if %{with quota_enables_tcpwrappers}
  64. --enable-libwrap=yes \
  65. %else
  66. --disable-libwrap \
  67. %endif
  68. --enable-netlink=yes \
  69. --enable-nls \
  70. --with-pid-dir=/run \
  71. --disable-rpath \
  72. --enable-rpc=yes \
  73. --enable-rpcsetquota=yes \
  74. --disable-silent-rules \
  75. --disable-xfs-roothack \
  76. --enable-rootsbin=yes \
  77. --enable-strip-binaries=no
  78. make %{?_smp_mflags}
  79. %install
  80. rm -fr %{buildroot}
  81. mkdir -p %{buildroot}/sbin
  82. mkdir -p %{buildroot}%{_sysconfdir}
  83. mkdir -p %{buildroot}%{_sbindir}
  84. mkdir -p %{buildroot}%{_bindir}
  85. mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
  86. make install DESTDIR=%{buildroot}
  87. rm -rf %{buildroot}%{_datadir}/doc/%{name}
  88. install -p -m644 -D %{SOURCE2} \
  89. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
  90. install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
  91. %if %{with systemd}
  92. install -p -m644 -D %{SOURCE101} $RPM_BUILD_ROOT%{_unitdir}/quota_nld.service
  93. install -p -m644 -D %{SOURCE103} $RPM_BUILD_ROOT%{_unitdir}/rpc-rquotad.service
  94. install -p -m644 -D %{SOURCE104} \
  95. $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rpc-rquotad
  96. %else
  97. install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
  98. %endif
  99. mv %{buildroot}%{_sbindir}/quota{check,off,on} %{buildroot}/sbin/
  100. %find_lang %{name}
  101. %check
  102. make check
  103. %clean
  104. rm -rf %{buildroot}
  105. %post
  106. %if %{with systemd}
  107. %systemd_post quota_nld.service
  108. %systemd_post rpc-rquotad.service
  109. %else
  110. /sbin/chkconfig --add quota_nld
  111. %endif
  112. %preun
  113. %if %{with systemd}
  114. %systemd_preun quota_nld.service
  115. %systemd_preun rpc-rquotad.service
  116. %else
  117. if [ $1 = 0 -o -x /bin/systemctl ] ; then
  118. /sbin/service quota_nld stop >/dev/null 2>&1
  119. /sbin/chkconfig --del quota_nld
  120. fi
  121. %endif
  122. %if %{with systemd}
  123. %postun
  124. %systemd_postun_with_restart quota_nld.service
  125. %systemd_postun_with_restart rpc-rquotad.service
  126. %endif
  127. %files -f %{name}.lang
  128. %defattr(-,root,root)
  129. %license COPYING
  130. %doc Changelog doc/ README*
  131. %config(noreplace) %{_sysconfdir}/warnquota.conf
  132. %config(noreplace) %{_sysconfdir}/quotagrpadmins
  133. %config(noreplace) %{_sysconfdir}/quotatab
  134. /sbin/*
  135. %{_bindir}/*
  136. %{_sbindir}/*
  137. %{_includedir}/rpcsvc/*
  138. %{_mandir}/man1/*
  139. %{_mandir}/man3/*
  140. %{_mandir}/man5/*
  141. %{_mandir}/man8/*
  142. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
  143. %if %{with systemd}
  144. %{_unitdir}/quota_nld.service
  145. %{_unitdir}/rpc-rquotad.service
  146. %config(noreplace) %{_sysconfdir}/sysconfig/rpc-rquotad
  147. %else
  148. %{_initrddir}/quota_nld
  149. %endif
  150. %changelog
  151. * Mon Nov 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.09-1
  152. - new upstram release.
  153. * Thu Mar 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.06-1
  154. - new upstram release.
  155. - updated all patches.
  156. * Thu Aug 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.05-1
  157. - new upstram release.
  158. - updated all patches.
  159. - disabled tcp_wrappers as default.
  160. - added systemd support (disabled as default).
  161. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.04-1
  162. - new upstram release.
  163. - dropped BR:libnl-devel.
  164. - added BR:libnl3-devel.
  165. - dropped all patches.
  166. - imported patched from rawhide.
  167. * Mon Mar 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.00-1
  168. - new upstram release
  169. - add BR: tcp_wrappers, nss-devel, openldap-devel,
  170. openssl-devel, dbus-devel, libnl-devel
  171. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.15-2
  172. - rebuilt with rpm-4.8.1-3
  173. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
  174. - applied new versioning policy, spec in utf-8
  175. * Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
  176. - updated quota to 3.15
  177. * Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
  178. - oops, removed unnecessary Patch3
  179. * Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
  180. - based on 3.12-5, being merged into 3.06-7vl1
  181. - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
  182. - add URL (bz# 131862)
  183. - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
  184. - Fixed typos in warnquota.conf patch
  185. (bz# 82250 and bz# 83974)
  186. - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
  187. - upgraded to 3.12
  188. - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  189. - add -pie support
  190. - update to 3.10
  191. - Sat Aug 16 2003 Steve Dickson <SteveD@RedHat.com>
  192. - upgraded to 3.0.9
  193. - added quota-3.09-root_sbindir.patch
  194. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
  195. - merged with Vine Linux package (quota-2.00stable-0vl1)
  196. - based on rawhide release 3.06-7
  197. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  198. - 2.00stable-0vl1
  199. - ver.up
  200. * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
  201. - 2.00pre3-8vl2
  202. - added documents
  203. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  204. - 2.00pre3-8vl1
  205. - based on 2.00pre3-8 from Rawhide
  206. - added Japanese summary and description
  207. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  208. - rebuilt
  209. * Mon Nov 18 2002 Tim Powers <timp@redhat.com>
  210. - rebuild on all arches
  211. * Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
  212. - added --with-ext2direct=no to fix #73244
  213. without this users with UID's > 65535 will not
  214. be able to exist on a quota enabled FS
  215. * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
  216. - Man page change. #60108
  217. * Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
  218. - Bah, I'd dropped epoch from the spec file but seems
  219. we need this if you want to upgrade as the epoch
  220. number has precedence over the version/release
  221. numbers.
  222. * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
  223. - Lets stop the makefile from stripping the
  224. binaries as thats rpms job (apparently)
  225. * Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
  226. - Ditched the 3.01-pre9 src base for 3.06
  227. Rebuilt without any patchs
  228. ============================================================
  229. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  230. - automated rebuild
  231. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  232. - automated rebuild
  233. * Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
  234. - IfArch the badkernelinclude patch for ppc-only.
  235. - Update to 3.03
  236. * Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
  237. - Make #include of kernel header file work on non-x86
  238. * Wed Sep 5 2001 Preston Brown <pbrown@redhat.com>
  239. - require new initscripts
  240. * Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
  241. - fixed bug #52075 (problem with ext2 labels)
  242. - backup data files off by default in quotacheck, optional backup flag added
  243. - fix bug where giving a bad directory or device would cause
  244. quotaon/quotacheck to simulate "-a" behaviour
  245. - if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
  246. point
  247. * Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
  248. - return an error code in more cases in convertquota
  249. * Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
  250. - 3.01pre9
  251. * Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
  252. - more cleanups on 3.01pre8
  253. * Mon Jul 2 2001 Preston Brown <pbrown@redhat.com>
  254. - 3.01 version, everything has changed again. :(
  255. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  256. - Bump release + rebuild.
  257. * Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
  258. - use rpc.rquotad from here again (#33738)
  259. * Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
  260. - enable ALT_FORMAT for edquota
  261. * Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
  262. - I broke passing devices on the cmd line. Fixed.
  263. * Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
  264. - quota 3.00 is required by recent kernel 2.4 changes
  265. - no warnquota included this time, not yet ported
  266. - quite a bit of work on quotacheck to make is backwards compatible
  267. - we will likely go back to "quota 2.00" as these projects merge...
  268. * Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  269. - use "rm -f" instead of only "rm"
  270. * Wed Feb 7 2001 Preston Brown <pbrown@redhat.com>
  271. - fix quotacheck man page for -a option (#26380)
  272. * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
  273. - 2.00 final, rolls in pretty much all our patches. :)
  274. - fix reporting of in use dquot entries from quotastats
  275. - change repquota man page to fix documentation of -v (#10330)
  276. - include warnquota.conf
  277. * Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
  278. - fix ia64 build
  279. * Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
  280. - add LABEL=foo support (#16390).
  281. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  282. - remote NFS quotas with different blocksize converted incorrectly (#11932).
  283. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  284. - automatic rebuild
  285. * Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
  286. - FHS packaging.
  287. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  288. - apply patch5 (H.J. Lu)
  289. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  290. - fix description
  291. - man pages are compressed
  292. * Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
  293. - quota 2.00 series
  294. - removed unnecessary patches
  295. * Thu Aug 5 1999 Jeff Johnson <jbj@redhat.com>
  296. - fix man page FUD (#4369).
  297. * Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
  298. - changes to allow non-root users to build too (Makefile patch, %attr)
  299. * Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
  300. - fix for sparc64 quotas (#2147)
  301. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  302. - auto rebuild in the new build environment (release 5)
  303. * Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
  304. - don't install rpc.rquotad - we will use the one from the knfsd package
  305. instead
  306. * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
  307. - merge ultrapenguin 1.1.9 changes.
  308. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  309. - translations modified for de, fr, tr
  310. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  311. - removed patch for mntent
  312. * Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  313. - updated to quota 1.66
  314. * Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
  315. - builds rquotad
  316. - installs rpc.rquotad.8 symlink
  317. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  318. - removed /usr/include/rpcsvc/* from filelist
  319. - uses a buildroot and %attr
  320. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  321. - built against glibc
  322. * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
  323. - Moved /usr/sbin/quota to /usr/bin/quota