mozjs17-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. Summary: The Mozilla library for JavaScript
  2. Name: mozjs17
  3. Version: 17.0.0
  4. Release: 4%{?_dist_release}
  5. # The sources are triple licensed, but when we link against readline which is
  6. # GPL, the result can only be GPL.
  7. %if 0%{?_without_readline:1}
  8. License: GPLv2+ or LGPLv2+ or MPLv1.1
  9. %else
  10. License: GPLv2+
  11. %endif
  12. Group: Development/Languages
  13. URL: http://www.mozilla.org/js/
  14. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
  15. Patch0: mozjs17-17.0.0-Makefile.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Buildrequires: nspr-devel >= 4.7
  18. Buildrequires: readline-devel
  19. Buildrequires: zlib-devel
  20. BuildRequires: autoconf213
  21. BuildRequires: python
  22. BuildRequires: zip
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: Takemikaduchi
  26. %description
  27. JavaScript is the Netscape-developed object scripting language used in millions
  28. of web pages and server applications worldwide. Netscape's JavaScript is a
  29. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  30. with only mild differences from the published standard.
  31. %package devel
  32. Summary: Header files, libraries and development documentation for %{name}
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. Requires: pkgconfig
  36. Requires: ncurses-devel readline-devel
  37. Provides: libjs-devel = %{version}-%{release}
  38. %description devel
  39. This package contains the header files, static libraries and development
  40. documentation for %{name}. If you like to develop programs using %{name},
  41. you will need to install %{name}-devel.
  42. %prep
  43. %setup -q -n mozjs%{version}
  44. %patch0 -p1
  45. cd js
  46. # Rm parts with spurios licenses, binaries
  47. rm -rf src/ctypes/libffi src/editline
  48. pushd src
  49. autoconf-2.13
  50. %configure \
  51. --with-system-nspr \
  52. --enable-threadsafe \
  53. %if 0%{!?_without_readline:1}
  54. --enable-readline \
  55. %endif
  56. popd
  57. %build
  58. cd js
  59. %{__make} %{?_smp_mflags} -C src
  60. %install
  61. cd js
  62. %{__make} -C src install DESTDIR=%{buildroot}
  63. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  64. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  65. %clean
  66. %{__rm} -rf %{buildroot}
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %files
  70. %defattr(-,root,root,-)
  71. %doc js/src/README.html
  72. %{_bindir}/js17
  73. %{_libdir}/libmozjs-17.0.so
  74. %files devel
  75. %defattr(-,root,root,-)
  76. %{_bindir}/js17-config
  77. %{_includedir}/js-17.0
  78. %{_libdir}/pkgconfig/mozjs-17.0.pc
  79. %changelog
  80. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-4
  81. - rebuild with gcc-5.4.0
  82. - add Buildrequires: zlib-devel
  83. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-3
  84. - rebuild with readline-6.3
  85. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-2
  86. - rebuild with VineSeed environment
  87. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-1
  88. - initial build