monodoc-core-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. %define mono_dir %(/usr/bin/monodir)
  2. Name: monodoc-core
  3. License: GNU General Public License (GPL)
  4. Group: Development/Tools/Other
  5. Summary: Monodoc--A Documentation Browser Written in C#
  6. Summary(ja): C# で書かれたドキュメントブラウザ
  7. URL: http://www.mono-project.com
  8. Version: 2.0
  9. Release: 1%{?_dist_release}
  10. Source0: http://mono.ximian.com/monobuild/preview/sources/monodoc/monodoc-%{version}.zip
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Provides: monodoc
  13. BuildArch: noarch
  14. BuildRequires: mono-devel unzip
  15. BuildRequires: mono-web
  16. %description
  17. Monodoc is a documentation browser for the Mono project. It is written
  18. in C# using the GTK# libraries.
  19. %if 0
  20. %define __find_provides env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-provides && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-provides ; } | sort | uniq'
  21. %define __find_requires env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-requires && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-requires ; } | sort | uniq'
  22. %endif
  23. %prep
  24. %setup -q -n monodoc-%{version}
  25. %build
  26. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  27. ./configure \
  28. --prefix=%{_prefix} \
  29. --libdir=%{_prefix}/lib \
  30. --libexecdir=%{_prefix}/lib \
  31. --localstatedir=%{_localstatedir} \
  32. --mandir=%{_mandir} \
  33. --infodir=%{_infodir} \
  34. --sysconfdir=%{_sysconfdir}
  35. make
  36. %install
  37. %{__rm} -rf $RPM_BUILD_ROOT
  38. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  39. make install DESTDIR=$RPM_BUILD_ROOT
  40. install -d $RPM_BUILD_ROOT%{_datadir}
  41. mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig $RPM_BUILD_ROOT%{_datadir}
  42. ## remove files
  43. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/monodoc/sources/gtk-sharp-docs.tree
  44. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/monodoc/sources/gtk-sharp-docs.zip
  45. %clean
  46. rm -rf ${RPM_BUILD_ROOT}
  47. %files
  48. %defattr(-, root, root)
  49. %doc AUTHORS ChangeLog NEWS README
  50. %{_bindir}/mdassembler
  51. %{_bindir}/mdcs2ecma
  52. %{_bindir}/mdnormalizer
  53. %{_bindir}/mdoc
  54. %{_bindir}/mdoc-assemble
  55. %{_bindir}/mdoc-export-html
  56. %{_bindir}/mdoc-export-msxdoc
  57. %{_bindir}/mdoc-update
  58. %{_bindir}/mdoc-validate
  59. %{_bindir}/mdvalidater
  60. %{_bindir}/mod
  61. %{_bindir}/monodocer
  62. %{_bindir}/monodocs2html
  63. %{_bindir}/monodocs2slashdoc
  64. %{mono_dir}/monodoc
  65. %{mono_dir}/gac/monodoc
  66. %{_prefix}/lib/monodoc
  67. %{_datadir}/pkgconfig/monodoc.pc
  68. %{_mandir}/man1/*
  69. %{_mandir}/man5/mdoc.5*
  70. # Should be in mono-tools now...?
  71. #%{_prefix}/share/applications/monodoc.desktop
  72. #%{_prefix}/share/pixmaps/monodoc.png
  73. %changelog
  74. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
  75. - initial build for VineSeed
  76. - updated monodoc to 2.0
  77. - applied vine versioning policy
  78. - added japanese summary
  79. - spec in utf-8
  80. * Tue Mar 25 2008 wberrier@suse.de
  81. - Update to 1.9
  82. - Documentation fixes and updates to match mono 1.9
  83. * Mon Jan 14 2008 wberrier@suse.de
  84. - Update to 1.2.6
  85. - Documentation updates to match mono 1.2.6
  86. * Fri Aug 3 2007 wberrier@suse.de
  87. - Update to 1.2.5
  88. - Documentation updates to match mono 1.2.5
  89. - several improvements and fixes to 'monodocer' utility
  90. * Wed Jun 6 2007 wberrier@novell.com
  91. - Update to 1.2.4
  92. - Documentation updates to match mono 1.2.4
  93. * Fri Apr 13 2007 wberrier@novell.com
  94. - add %%debug_package so debug packages get created
  95. * Wed Apr 11 2007 wberrier@novell.com
  96. - Add mono dep/req for older distros
  97. * Thu Mar 1 2007 wberrier@suse.de
  98. - Update to 1.2.3
  99. - API Documentation updates
  100. - Formatting fixes
  101. - Sub documentation for 2.0 APIs
  102. * Sat Dec 2 2006 wberrier@suse.de
  103. - Update to 1.2.1 (Fate #301111)
  104. - Sqlite Docs update
  105. - new manpages
  106. - doc generation updates and fixes
  107. * Fri Oct 20 2006 wberrier@suse.de
  108. - Update to 1.1.18
  109. - generics support and will display generic types
  110. - documents custom attributes with their actual constructor calls
  111. - monodocs2html now includes inherited members on type pages
  112. * Wed Oct 18 2006 wberrier@suse.de
  113. - Remove manual Requires. mono-devel isn't needed, and all other
  114. deps will be generated automatically. (bnc #212972)
  115. * Wed Aug 30 2006 wberrier@suse.de
  116. - Update to 1.1.17
  117. - Updated documentation for mono 1.1.17
  118. * Mon Jul 31 2006 wberrier@suse.de
  119. - Update to 1.1.16
  120. - Fixes problem with missing documentation (pathnames too long
  121. for a tar.gz file)
  122. - Append the node kind to the node caption. Fixes a crash when
  123. editing uncompiled help sources.
  124. * Wed Jan 25 2006 mls@suse.de
  125. - converted neededforbuild to BuildRequires
  126. * Wed Jan 11 2006 ro@suse.de
  127. - added mono-devel to nfb to get monoized provides
  128. * Fri Jan 6 2006 wberrier@suse.de
  129. - Update to 1.1.13, clean up deps
  130. * Thu Dec 15 2005 wberrier@suse.de
  131. - Update to 1.1.11, remove run_ldconfig
  132. * Thu Nov 10 2005 wberrier@suse.de
  133. - Update to 1.1.10, remove icu deps
  134. * Fri Oct 7 2005 wberrier@suse.de
  135. - Update to 1.1.9
  136. * Wed Sep 28 2005 dmueller@suse.de
  137. - add norootforbuild
  138. * Sun Sep 25 2005 ro@suse.de
  139. - fix file-conflict with gtk-sharp2
  140. * Fri Aug 26 2005 wberrier@suse.de
  141. - renmae package to monodoc-core
  142. * Mon Aug 15 2005 ro@suse.de
  143. - added check-build.sh
  144. * Thu Aug 11 2005 ro@suse.de
  145. - fix last change
  146. * Thu Aug 11 2005 ro@suse.de
  147. - moved pkgconfig file to /usr/share (noarch package)
  148. * Wed Aug 10 2005 ro@suse.de
  149. - keep monodoc script until we have a mono-tools package
  150. * Tue Aug 9 2005 gekker@suse.de
  151. - Update to version 1.0.7
  152. - Remove upstreamed patches
  153. * Mon Jul 18 2005 dkukawka@suse.de
  154. - changed package to noarch
  155. * Tue Feb 22 2005 ro@suse.de
  156. - fix build on x86_64
  157. * Mon Feb 21 2005 clahey@suse.de
  158. - Update to 1.0.6.
  159. * Sun Feb 6 2005 ro@suse.de
  160. - adapt pc-file
  161. * Thu Jan 20 2005 ro@suse.de
  162. - fix build on lib64
  163. * Fri Dec 3 2004 dkukawka@suse.de
  164. - fix libexecdir, now all {libdir}/monodoc files now at /usr/lib
  165. instead of /usr/lib64 (with symlink)
  166. * Fri Dec 3 2004 ro@suse.de
  167. - removed wrong re-definitions of find_{requires,provides}
  168. * Tue Nov 30 2004 dkukawka@suse.de
  169. - init