mdadm-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. %bcond_with systemd
  2. %define _udevrulesdir /lib/udev/rules.d
  3. Summary: Utilities for Linux md devices (software RAID arrays)
  4. Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
  5. Name: mdadm
  6. Version: 4.2
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. License: GPL
  13. URL: https://www.kernel.org/pub/linux/utils/raid/mdadm/
  14. Source: https://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
  15. Source1: mdmonitor.init
  16. Source2: raid-check
  17. Source3: mdadm.rules
  18. Source4: mdadm-raid-check-sysconfig
  19. Source5: mdadm-cron
  20. Source103: mdadm.rules.systemd
  21. Source104: mdmonitor.service
  22. Source105: mdadm.conf
  23. Source106: mdadm_event.conf
  24. Source107: raid-check.timer
  25. Source108: raid-check.service
  26. Patch97: mdadm-3.3-udev.patch
  27. Patch98: mdadm-2.5.2-static.patch
  28. Obsoletes: mdctl,raidtools
  29. Requires: postfix
  30. BuildRequires: glibc-static
  31. %if %{with systemd}
  32. BuildRequires: systemd-devel
  33. Requires(post): systemd coreutils
  34. Requires(preun): systemd
  35. Requires(postun): systemd coreutils
  36. %else
  37. BuildRequires: eudev-libudev-devel
  38. Requires(post): /sbin/chkconfig
  39. Requires(preun): /sbin/chkconfig
  40. Requires(preun): /sbin/service
  41. Requires(postun): /sbin/service
  42. %endif
  43. %description
  44. mdadm is used to create, manage, and monitor Linux MD (software RAID)
  45. devices. As such, it provides similar functionality to the raidtools
  46. package. However, mdadm is a single program, and it can perform
  47. almost all functions without a configuration file, though a configuration
  48. file can be used to help with some common tasks.
  49. %debug_package
  50. %prep
  51. %setup -q
  52. %autopatch -p1
  53. sed -i -e 's/ -Werror / /' Makefile
  54. %build
  55. make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
  56. %install
  57. rm -rf %{buildroot}
  58. %if %{with systemd}
  59. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin SYSTEMD_DIR=%{_unitdir} install install-systemd
  60. %else
  61. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
  62. %endif
  63. install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
  64. install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
  65. %if %{with systemd}
  66. install -Dp -m 644 %{SOURCE103} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  67. # systemd
  68. mkdir -p %{buildroot}%{_unitdir}
  69. install -m644 %{SOURCE104} %{buildroot}%{_unitdir}
  70. install -m644 %{SOURCE107} %{buildroot}%{_unitdir}
  71. install -m644 %{SOURCE108} %{buildroot}%{_unitdir}
  72. # tmpfile
  73. mkdir -p %{buildroot}%{_tmpfilesdir}
  74. install -m 0644 %{SOURCE105} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  75. install -d -m 0710 %{buildroot}/run/%{name}/
  76. # abrt
  77. #mkdir -p %{buildroot}/etc/libreport/events.d
  78. #install -m644 %{SOURCE6} %{buildroot}/etc/libreport/events.d
  79. %else
  80. # initscript
  81. mkdir -p %{buildroot}%{_initdir}
  82. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
  83. install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
  84. install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  85. mkdir -p %{buildroot}%{_localstatedir}/run/mdadm
  86. %endif
  87. %clean
  88. rm -rf %{buildroot}
  89. %post
  90. %if %{with systemd}
  91. %systemd_post mdmonitor.service raid-check.{service,timer}
  92. %else
  93. /sbin/chkconfig --add mdmonitor
  94. %endif
  95. %preun
  96. %if %{with systemd}
  97. %systemd_preun mdmonitor.service raid-check.timer
  98. %else
  99. if [ "$1" = 0 -o -x /bin/systemctl ]; then
  100. service mdmonitor stop > /dev/null 2>&1 ||:
  101. /sbin/chkconfig --del mdmonitor
  102. fi
  103. if [ -e %{_initrddir}/mdmpd ]; then
  104. service mdmpd stop > /dev/null 2>&1 ||:
  105. /sbin/chkconfig --del mdmpd
  106. fi
  107. %endif
  108. %postun
  109. %if %{with systemd}
  110. %systemd_postun_with_restart mdmonitor.service
  111. %else
  112. if [ "$1" -ge "1" ]; then
  113. service mdmonitor condrestart > /dev/null 2>&1
  114. fi
  115. %endif
  116. %files
  117. %defattr(-,root,root)
  118. %license COPYING
  119. %doc mdadm.conf-example misc/*
  120. /sbin/*
  121. %{_sbindir}/*
  122. %if %{with systemd}
  123. %{_unitdir}/*
  124. /lib/systemd/system-shutdown/*
  125. %config(noreplace) %{_tmpfilesdir}/%{name}.conf
  126. %else
  127. %{_initdir}/*
  128. %config(noreplace) %{_sysconfdir}/cron.d/*
  129. %dir %{_localstatedir}/run/%{name}/
  130. %endif
  131. %{_mandir}/man*/md*
  132. %{_udevrulesdir}/*
  133. %config(noreplace) %{_sysconfdir}/sysconfig/*
  134. %changelog
  135. * Mon Nov 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2-1
  136. - new upstream release.
  137. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
  138. - new upstream release.
  139. - added systemd support (disabled as default).
  140. - dropped Patch93-96.
  141. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-1
  142. - new upstream release.
  143. * Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  144. - new upstream release.
  145. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
  146. - rebuild with VineSeed environment
  147. * Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
  148. - added BR: glibc-static
  149. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
  150. - rebuilt with rpm-4.8.1-3
  151. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
  152. - new upstream release
  153. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
  154. - applied new versioning policy, spec in utf-8
  155. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  156. - new upstream release
  157. * Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
  158. - initial build for Vine Linux
  159. * Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
  160. - Update to 2.5.3 which upstream calls a "bug fix" release
  161. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
  162. - rebuild
  163. * Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
  164. - Update to 2.5.2
  165. - Remove auto default patch as upstream now has a preferred default auto method
  166. * Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
  167. - fix build on ppc64
  168. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
  169. - fix build on ppc
  170. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
  171. - update to 2.3.1 to fix raid5 (#184284)
  172. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
  173. - bump again for double-long bug on ppc(64)
  174. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
  175. - rebuilt for new gcc4.1 snapshot and glibc changes
  176. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  177. - rebuilt
  178. * Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
  179. - 2.2 upgrade (#167897)
  180. - disable diet because we don't ship it anymore
  181. and we don't actually use mdassemble now
  182. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
  183. - Make the mdmonitor init script use the pid-file option, major cleanup
  184. of the script now possible (#134459)
  185. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
  186. - Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
  187. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
  188. - Change the default auto= mode so it need not be on the command line to
  189. work with udev, however it is still supported on the command line (#132706)
  190. - Add a man page (from Luca Berra) for mdassemble
  191. * Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
  192. - Upgrade to 1.11.0
  193. * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
  194. - fix mdmonitor initscript (#144717)
  195. * Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
  196. - Build mdadm.static and mdassemble (static as well) to be used in initrd
  197. images
  198. * Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
  199. - Initial upgrade to 1.9.0 and update of doc files
  200. - Fix an s390 build error
  201. * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
  202. - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
  203. if it's needed.
  204. * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
  205. - Update to newer upstream version
  206. - Make mdmpd work on kernels that don't have the event interface patch
  207. * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
  208. - Create a directory /var/run/mdadm to contain mdadm.pid
  209. - This cleans up SELinux problem
  210. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  211. - rebuilt
  212. * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
  213. - Fix Makefile and build method to satisfy bz #123769
  214. - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
  215. - Make sure mdadm --monitor closes all md device files so that md devices
  216. can be stopped while mdadm is still running - bz #119532
  217. * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
  218. - remove unneeded patch, can use --run instead
  219. * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
  220. - add patch with reallyforce mode on creation to be used by anaconda
  221. * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
  222. - Fix a bug in the %postun scriptlet related to downgrading to a version
  223. of mdadm that doesn't include the mdmpd daemon.
  224. * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
  225. - Disable service mdmpd by default to avoid [Failed] messages on
  226. current 2.6 kernels. Possibly re-enable it by default once the
  227. 2.6 kernels have the md event interface.
  228. * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
  229. - Update mdmonitor script to start daemon more cleanly
  230. - Repackage mdmpd tarball to include gcc-3.4 changes and to make
  231. mdmpd properly daemonize at startup instead of forking and leaving
  232. the child attached to the terminal.
  233. * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
  234. - ship /var/run/mpmpd (#117497)
  235. * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
  236. - Add a default MAILADDR line to the mdadm.conf file installed by default
  237. (Bugzilla #92447)
  238. - Make it build with gcc-3.4
  239. * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
  240. - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
  241. * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
  242. - fix problem with recovery thread sleeping in mdmpd
  243. * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
  244. - sync upstream
  245. - add mdmpd package into mdadm package
  246. * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
  247. - sync upstream
  248. * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
  249. - sync upstream
  250. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
  251. - update for rebuild
  252. * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
  253. - fix references to %%install in the changelog so that it will build
  254. * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
  255. - Rebuild
  256. * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
  257. - Changed RPM Group to System Environment/Base
  258. * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
  259. - minor cleanups to the text, conditionalize rm -rf
  260. - added mdmonitor init script
  261. * Fri May 10 2002 <neilb@cse.unsw.edu.au>
  262. - update to 1.0.0
  263. - Set CXFLAGS instead of CFLAGS
  264. * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
  265. - change %%install to use "make install"
  266. * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
  267. - beautification
  268. - made mdadm.conf non-replaceable config
  269. - renamed Copyright to License in the header
  270. - added missing license file
  271. - used macros for file paths
  272. * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
  273. - Added Obsoletes: mdctl
  274. - missingok for configfile
  275. * Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
  276. - Add md.4 and mdadm.conf.5 man pages
  277. * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
  278. - builds properly as non-root.
  279. * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
  280. - updated for 0.7, fixed /usr/share/doc and added manpage
  281. * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
  282. - initial RPM build