imlib-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. # Note that this is NOT a relocatable package
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Name: imlib
  4. Summary: Image loading and rendering library for X11R6
  5. Summary(ja): 画像の読み込み/レンダリング用のライブラリ
  6. Version: 1.9.15
  7. Release: 6%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. Source0: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
  11. Patch1: imlib-1.9.13-sec2.patch
  12. Patch2: imlib-1.9.14-configure-x86_64.patch
  13. Patch3: imlib-1.9.15-libpng15.patch
  14. Patch4: imlib-1.9.15-bpp16-CVE-2007-3568.patch
  15. Patch5: imlib-1.9.13-underquoted.patch
  16. Patch6: imlib-1.9.15-giflib4.patch
  17. Obsoletes: Imlib
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: giflib-devel
  20. BuildRequires: gtk+-devel >= 1.2.1
  21. BuildRequires: libjpeg-devel
  22. BuildRequires: libpng-devel >= 2:1.2.5
  23. BuildRequires: libtiff-devel
  24. BuildRequires: libSM-devel
  25. BuildRequires: libXt-devel
  26. BuildRequires: zlib-devel
  27. Requires: netpbm-progs
  28. %description
  29. Imlib is an advanced replacement library for libraries like libXpm that
  30. provides many more features with much greater flexability and
  31. speed.
  32. %package -n compat32-%{name}
  33. Summary: Image loading and rendering library for X11R6
  34. Summary(ja): 画像の読み込み/レンダリング用のライブラリ
  35. Group: System Environment/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. %description -n compat32-%{name}
  38. Imlib is an advanced replacement library for libraries like libXpm that
  39. provides many more features with much greater flexability and
  40. speed.
  41. %package devel
  42. Summary: Imlib headers, static libraries and documentation
  43. Summary(ja): Imlib のヘッダファイルおよび静的ライブラリ、ドキュメント
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: libungif-devel libjpeg-devel
  47. Requires: libtiff-devel libpng-devel zlib-devel
  48. Obsoletes: Imlib
  49. %description devel
  50. Headers, static libraries and documentation for Imlib.
  51. %package cfgeditor
  52. Summary: Imlib configuration editor
  53. Summary(ja): Imlib 設定エディタ
  54. Group: Applications/System
  55. Requires: %{name} = %{version}
  56. #Requires: gtk+ >= 1.2.1
  57. %description cfgeditor
  58. The imlib_config program allows you to control the way imlib uses
  59. color and handles gamma correction/etc.
  60. %prep
  61. %setup -q
  62. #patch0 -p1 -b .bmp-buffer-overflow
  63. %patch1 -p1 -b .can-2004-1025_1026
  64. %patch2 -p1 -b .x86_64
  65. %patch3 -p0 -b .libpng
  66. ## CVE-2007-3568 (DoS via a BMP image with a Bits Per Page of 0) (#426091)
  67. %patch4 -p0 -b .bpp16
  68. ## Fix underquoted m4 definitions
  69. %patch5 -p1 -b .underquoted
  70. %patch6 -p1 -b .giflib4
  71. %build
  72. %define __libtoolize /bin/true
  73. %configure --disable-static
  74. ## Remove -L%%{_libdir} from imlib-config if present;
  75. ## it's redundant and breaks multilib compatibility
  76. sed -i -e 's,-L%{_libdir} ,,g' imlib-config
  77. ## Kill bogus RPATHs
  78. sed -i 's|^sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/%{_lib} %{_libdir}|' libtool
  79. if [ "$SMP" != "" ]; then
  80. (make "MAKE=make -k -j $SMP"; exit 0)
  81. make
  82. else
  83. make
  84. fi
  85. %install
  86. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  89. ##%find_lang %{name}
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %post -n compat32-%{name} -p /sbin/ldconfig
  93. %postun -n compat32-%{name} -p /sbin/ldconfig
  94. %clean
  95. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  96. ##%files -f %{name}.lang
  97. %files
  98. %defattr(-,root,root)
  99. %doc README AUTHORS ChangeLog NEWS
  100. %config %{_sysconfdir}/*
  101. %{_libdir}/lib*.so.*
  102. %{_libdir}/libimlib-*.so
  103. %files cfgeditor
  104. %defattr(-,root,root)
  105. %{_bindir}/imlib_config
  106. %{_mandir}/man1/imlib_config*
  107. %files devel
  108. %defattr(-,root,root)
  109. %doc doc/*.gif doc/*.html
  110. %{_bindir}/imlib-config
  111. %{_libdir}/libImlib.so
  112. %{_libdir}/libgdk_imlib.so
  113. %{_libdir}/pkgconfig/*
  114. %{_includedir}/*
  115. %{_datadir}/aclocal/*
  116. %{_mandir}/man1/imlib-config*
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-,root,root)
  120. %{_libdir}/lib*.so.*
  121. %{_libdir}/libimlib-*.so
  122. %endif
  123. %changelog
  124. * Sun Sep 28 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.15-6
  125. - fixed Group typo on cfgeditor subpackage
  126. * Fri Sep 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.15-5
  127. - added Patch4, Patch5 from Fedora
  128. - added Patch6 to build with giflib-4.2.3
  129. * Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.15-4
  130. - add BuildRequires: libSM-devel, libXt-devel
  131. - add Patch3 (imlib-1.9.15-libpng15.patch) from fedora
  132. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.9.15-3
  133. - rebuilt with rpm-4.8.1 for pkg-config
  134. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.15-2
  135. - spec in utf-8
  136. * Tue Jul 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.15-1
  137. - updated to 1.9.15 (dropped Patch0)
  138. - applied to new versioning policy
  139. * Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.9.14-0vl10
  140. - added compat32-imlib package for x86_64 architecture support
  141. * Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 1.9.14-0vl9
  142. - added imlib-1.9.14-configure-x86_64.patch
  143. - disable %%find_lang macro
  144. - rebuilt for x86_64 architecture
  145. * Sat May 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.14-0vl8
  146. - added Requires: lib*-devel to devel package
  147. - added %{_libdir}/pkgconfig/*.pc files to devel package
  148. - removed gtk+ dependancy on main package
  149. * Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.14-0vl7
  150. - rebuild for VineSeed
  151. * Mon Jan 31 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl6.1
  152. - Added a security patch for CAN-2004-1025 and CAN-2004-1026.
  153. - Patch1: imlib-1.9.13-sec2.patch
  154. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138516
  155. * Fri Sep 17 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.9.14-0vl6
  156. - Updated Patch0: http://bugzilla.gnome.org/show_bug.cgi?id=151034#c8
  157. * Wed Sep 1 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.9.14-0vl5
  158. - Added a security patch for buffer overflow in bmp handling (Patch0).
  159. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.9.14-0vl4
  160. - rebuild
  161. * Sat Apr 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.9.14-0vl2
  162. - rebuild with libpng12-devel
  163. - add BuildPrereq
  164. * Sat Mar 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.14-0vl1
  165. - updated to new upstream release
  166. - Patch0 removed (merged into upstream source)
  167. * Sat Jul 14 2001 <sagami@vinelinux.org>
  168. - 1.9.10-0vl2: fix to build against new libtool
  169. * Tue May 8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.10-0vl1
  170. - New upstream release.
  171. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.9.9-0vl1
  172. - New upstream release.
  173. - use rpmmacros.
  174. * Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
  175. - 1.9.8.1-2vl2
  176. - requires netpbm-progs instead of libgr-progs
  177. * Sun Jul 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  178. - change to use libtoolize
  179. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  180. - change group
  181. - added Japanese summary
  182. * Wed Jan 5 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
  183. - added setlocale patch
  184. * Mon Jan 11 1999 Carsten Haitzler <raster@redhat.com>
  185. - up to 1.9.0
  186. * Wed Sep 23 1998 Carsten Haitzler <raster@redhat.com>
  187. - up to 1.8.1
  188. * Tue Sep 22 1998 Cristian Gafton <gafton@redhat.com>
  189. - yet another build for today (%defattr and %attr in the files lists)
  190. - devel docs are back on the spec file
  191. * Tue Sep 22 1998 Carsten Haitzler <raster@redhat.com>
  192. - Added minor patch for ps saving code.
  193. * Mon Sep 21 1998 Cristian Gafton <gafton@redhat.com>
  194. - updated to version 1.8
  195. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  196. - take out imlib_config from devel package
  197. * Wed Sep 9 1998 Michael Fulbright <msf@redhat.com>
  198. - upgraded to 1.7
  199. - changed name so it will persist if user later install devel imlib
  200. - added subpackage for imlib_config
  201. * Fri Apr 3 1998 Michael K. Johnson <johnsonm@redhat.com>
  202. - fixed typo
  203. * Fri Mar 13 1998 Marc Ewing <marc@redhat.com>
  204. - Added -k, Obsoletes
  205. - Integrate into CVS source tree