icu-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: International Components for Unicode
  3. Summary(ja): ユニコード用国際化コンポーネント
  4. Name: icu
  5. Version: 74.1
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. %define sover %(echo %{version} | cut -d . -f 1)
  11. %define minorver %(echo %{version} | cut -d . -f 2)
  12. License: MIT
  13. URL: http://icu-project.org/
  14. Source0: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
  15. Source1: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: gcc-c++
  18. BuildRequires: unzip perl
  19. Requires: libicu%{sover} = %{version}-%{release}
  20. %description
  21. ICU is a C++ and C library that provides robust and full-featured Unicode
  22. support. This package contains the Unicode character database and derived
  23. properties, along with converters and time zones data.
  24. %package -n libicu%{sover}
  25. Summary: International Components for Unicode (library)
  26. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  27. Group: system
  28. Provides: libicu = %{version}-%{release}
  29. %description -n libicu%{sover}
  30. ICU is a C++ and C library that provides robust and full-featured Unicode
  31. support. This package contains the runtime libraries for ICU. It does not
  32. contain any of the data files needed at runtime.
  33. %package -n libicu-devel
  34. Summary: Header files, libraries and development documentation for libicu
  35. Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
  36. Group: programming
  37. Requires: libicu%{sover} = %{version}-%{release}
  38. %description -n libicu-devel
  39. This package contains the header files, static libraries for %{name}.
  40. If you like to develop programs using %{name}, you will need to install
  41. %{name}-devel.
  42. %package -n libicu-doc
  43. Summary: Documentation for International Components for Unicode
  44. Summary(ja): ユニコード用国際化コンポーネントのドキュメント
  45. Group: documentation
  46. BuildArch: noarch
  47. Requires: libicu%{sover} = %{version}-%{release}
  48. %description -n libicu-doc
  49. This package contains the development documentation for %{name}.
  50. # compat32
  51. %if %{build_compat32}
  52. %package -n compat32-libicu%{sover}
  53. Summary: International Components for Unicode (library)
  54. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  55. Group: system,legacy
  56. Provides: compat32-libicu = %{version}-%{release}
  57. %description -n compat32-libicu%{sover}
  58. ICU is a C++ and C library that provides robust and full-featured Unicode
  59. support. This package contains the runtime libraries for ICU. It does not
  60. contain any of the data files needed at runtime.
  61. %endif
  62. %debug_package
  63. %prep
  64. %setup -q -n icu
  65. find . -name CVS -o -name .cvsignore | xargs -r rm -rf
  66. perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
  67. mkdir docs
  68. pushd docs
  69. unzip %{SOURCE1}
  70. popd
  71. %build
  72. cd source
  73. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  74. export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  75. %configure --disable-static --with-data-packaging=library --disable-samples
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make -C source install DESTDIR=$RPM_BUILD_ROOT
  80. cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
  81. chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
  82. %ifarch x86_64
  83. %check
  84. %make_build -C source check
  85. %endif
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %files
  89. %defattr(-, root, root, 0755)
  90. %license LICENSE
  91. %doc license.html readme.html
  92. %{_bindir}/derb
  93. %{_bindir}/genbrk
  94. %{_bindir}/gencfu
  95. %{_bindir}/gencnval
  96. %{_bindir}/gendict
  97. %{_bindir}/genrb
  98. %{_bindir}/icuexportdata
  99. %{_bindir}/icuinfo
  100. %{_bindir}/makeconv
  101. %{_bindir}/pkgdata
  102. %{_bindir}/uconv
  103. %{_sbindir}/*
  104. %{_mandir}/man?/*
  105. %exclude %{_mandir}/man1/icu-config.1*
  106. %files -n libicu%{sover}
  107. %license LICENSE
  108. %defattr(-, root, root, 0755)
  109. %{_libdir}/*.so.*
  110. %files -n libicu-devel
  111. %license LICENSE
  112. %defattr(-, root, root, 0755)
  113. %{_bindir}/icu-config
  114. %{_includedir}/unicode
  115. %{_libdir}/*.so
  116. %{_libdir}/%{name}
  117. %{_libdir}/pkgconfig/*.pc
  118. %{_mandir}/man1/icu-config.1*
  119. %{_datadir}/%{name}
  120. %files -n libicu-doc
  121. %license LICENSE
  122. %defattr(-,root,root,-)
  123. %doc docs/*
  124. %if %{build_compat32}
  125. %files -n compat32-libicu%{sover}
  126. %license LICENSE
  127. %defattr(-, root, root, 0755)
  128. %{_libdir}/*.so.*
  129. %endif
  130. %changelog
  131. * Wed Nov 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 74.1-1
  132. - updated to 74.1.
  133. * Wed Oct 19 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 72.1-1
  134. - updated to 72.1.
  135. * Fri Oct 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 70.1-1
  136. - updated to 70.1.
  137. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 69.1-1
  138. - updated to 69.1.
  139. - dropped ldconfig scriptlets.
  140. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 67.1-1
  141. - updated to 67.1.
  142. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 66.1-1
  143. - updated to 66.1.
  144. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-2
  145. - made to build compat32-* package.
  146. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-1
  147. - updated to 65.1.
  148. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.3-1
  149. - updated to 60.3.
  150. - disabled tests on i686.
  151. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.2-1
  152. - updated to 60.2.
  153. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-2
  154. - rebuild with gcc-5.4.0
  155. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-1
  156. - update to 56.1
  157. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 54.1-1
  158. - update to 54.1
  159. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 52.1-1
  160. - new upstream release
  161. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 51.2-1
  162. - update to 51.2
  163. * Tue Apr 13 2010 Shu KONNO <owa@bg.wakwak.com> 4.4-2
  164. - install libicutest.so*
  165. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4-1
  166. - new upstream release
  167. - built with new toolchain
  168. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
  169. - new upstream release
  170. - updated URL
  171. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
  172. - applied new versioning policy, spec in utf-8
  173. * Tue Sep 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
  174. - updated to 3.6
  175. - removed ".so ver" from libicu package name
  176. - changed Group to Development/Tools
  177. - changed libicu-doc Group to Applications/Documentation
  178. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
  179. - updated to 3.4.1
  180. * Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
  181. - updated to 3.2 based on Fedora extra
  182. - new subpackage libicu-doc for API document
  183. * Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
  184. - Build for Vine Linux
  185. - add developers document to devel package
  186. - add Japanese summary
  187. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
  188. - Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
  189. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
  190. - Initial package. (using DAR)