ibus-qt-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  2. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  3. %define ver 1.3.2
  4. %define rel 4
  5. Summary: Qt IBus library and Qt input method plugin
  6. Summary(ja): Qt iBus ライブラリと入力メソッドプラグイン
  7. Name: ibus-qt
  8. Version: %{ver}
  9. Release: %{rel}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Libraries
  12. URL: http://code.google.com/p/ibus/
  13. Source0: http://ibus.googlecode.com/files/%{name}-%{version}-Source.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: cmake
  16. BuildRequires: qt4-devel >= 4.5
  17. BuildRequires: dbus-devel >= 1.2
  18. BuildRequires: ibus-devel >= 1.3.7
  19. BuildRequires: libicu-devel >= 4.0
  20. BuildRequires: doxygen >= 1.6
  21. Requires: ibus >= 1.3.7
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: iwaim
  25. %description
  26. This includes Qt IBus library and Qt input method plugin.
  27. %package devel
  28. Summary: Development tools for ibus Qt
  29. Summary(ja): ibus Qt の開発用ファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description devel
  33. The ibus-qt-devel package contains the header files for ibus Qt library.
  34. %prep
  35. %setup -q -n %{name}-%{version}-Source
  36. %build
  37. %cmake \
  38. -DCMAKE_INSTALL_PREFIX=%{_usr} \
  39. -DLIBDIR=%{_libdir} \
  40. -DCMAKE_CXX_FLAGS="-std=c++11"
  41. make \
  42. VERBOSE=1 \
  43. C_DEFINES="$RPM_OPT_FLAGS" \
  44. CXX_DEFINES="$RPM_OPT_FLAGS" \
  45. %{?_smp_mflags}
  46. make docs
  47. %install
  48. %{__rm} -rf %{buildroot}
  49. make install DESTDIR=%{buildroot}
  50. %clean
  51. %{__rm} -rf %{buildroot}
  52. %post -p /sbin/ldconfig
  53. %postun -p /sbin/ldconfig
  54. %files
  55. %defattr(-,root,root,-)
  56. %doc AUTHORS COPYING README
  57. %{_libdir}/libibus-qt.so.*
  58. %{_qt4_plugindir}/inputmethods/libqtim-ibus.so
  59. %files devel
  60. %defattr(-,root,root,-)
  61. %doc docs/html
  62. %dir %{_includedir}/ibus-qt
  63. %{_includedir}/ibus-qt/*.h
  64. %{_libdir}/libibus-qt.so
  65. %changelog
  66. * Thu Jan 18 2018 Toshiaki Ara <ara_t@384.jp> 1.3.2-4
  67. - rebuild with icu-60.2
  68. - add option: -DCMAKE_CXX_FLAGS="-std=c++11"
  69. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 1.3.2-3
  70. - rebuild with gcc-5.4.0
  71. * Sun Nov 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.2-2
  72. - rebuilt with libuci 54.1
  73. * Tue Nov 4 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.2-1
  74. - updated to 1.3.2
  75. - added BR: ibus-devel
  76. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
  77. - rebuilt with qt-4.8.0
  78. * Sun Jun 6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
  79. - Initial build.