expat-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Expat is an XML 1.0 parser written in C
  3. Summary(ja): C で書かれた XML 1.0 パーサ
  4. Name: expat
  5. Version: 2.5.0
  6. Release: 1%{?_dist_release}
  7. Group: accessories
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT/X
  11. URL: https://libexpat.github.io/
  12. %global altver %(echo %{version} | tr '.' '_')
  13. Source: https://github.com/libexpat/libexpat/releases/download/R_%{altver}/%{name}-%{version}.tar.xz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Requires: lib%{name} = %{version}-%{release}
  16. BuildRequires: libtool
  17. %description
  18. This is Expat, a C library for parsing XML, written by James Clark.
  19. Expat is a stream-oriented XML parser. This means that you register
  20. handlers with the parser before starting the parse. These handlers
  21. are called when the parser discovers the associated structures in the
  22. document being parsed. A start tag is an example of the kind of
  23. structures for which you may register handlers.
  24. %package -n lib%{name}
  25. Summary: Runtime library of expat
  26. Summary(ja): Expat のための実行ライブラリ
  27. Group: system
  28. %description -n lib%{name}
  29. This package contains the runtime, shared library of expat, the C
  30. library for parsing XML.
  31. %description -n lib%{name} -l ja
  32. Expat を動作させるために必用となるライブラリです.
  33. %package devel
  34. Summary: Development environment for the expat XML parser
  35. Summary(ja): expat XML パーサ用開発環境
  36. Group: programming
  37. Requires: lib%{name} = %{version}-%{release}
  38. Requires: pkgconfig
  39. %description devel
  40. Development environment for the expat XML parser
  41. %description devel -l ja
  42. expat XML パーサ用開発環境です.
  43. ## to build compat32 for x86_64 architecture support
  44. %package -n compat32-lib%{name}
  45. Summary: Runtime library of expat
  46. Summary(ja): Expat のための実行ライブラリ
  47. Group: system,legacy
  48. Requires: lib%{name} = %{version}-%{release}
  49. %description -n compat32-lib%{name}
  50. This package contains the runtime, shared library of expat, the C
  51. library for parsing XML.
  52. %description -n compat32-lib%{name} -l ja
  53. Expat を動作させるために必用となるライブラリです.
  54. %package -n compat32-%{name}-devel
  55. Summary: Development environment for the expat XML parser
  56. Summary(ja): expat XML パーサ用開発環境
  57. Group: programming,legacy
  58. Requires: %{name}-devel = %{version}-%{release}
  59. Requires: compat32-lib%{name} = %{version}-%{release}
  60. %description -n compat32-%{name}-devel
  61. Development environment for the expat XML parser
  62. %description -n compat32-%{name}-devel -l ja
  63. expat XML パーサ用開発環境です.
  64. %debug_package
  65. %prep
  66. %setup -q
  67. %autopatch -p2
  68. %build
  69. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  70. %configure --enable-shared
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. rm -f examples/*.dsp
  75. chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
  76. make DESTDIR=$RPM_BUILD_ROOT install
  77. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  78. rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
  79. mkdir -p %{buildroot}%{_mandir}/man1
  80. install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root)
  85. %license COPYING
  86. %doc AUTHORS Changes README.md
  87. %{_bindir}/xmlwf
  88. %{_mandir}/man1/xmlwf.1*
  89. %files -n lib%{name}
  90. %defattr(-,root,root)
  91. %license COPYING
  92. %doc AUTHORS Changes README.md
  93. %{_libdir}/libexpat.so.*
  94. %files devel
  95. %defattr(-,root,root)
  96. %license COPYING
  97. %doc AUTHORS Changes README.md
  98. %doc doc/* examples
  99. %{_includedir}/*
  100. %{_libdir}/libexpat.a
  101. %{_libdir}/libexpat.so
  102. %{_libdir}/pkgconfig/%{name}.pc
  103. %dir %{_libdir}/cmake
  104. %{_libdir}/cmake/expat-%{version}
  105. ## to build compat32 for x86_64 architecture support
  106. %if %{build_compat32}
  107. %files -n compat32-lib%{name}
  108. %defattr(-,root,root)
  109. %{_libdir}/libexpat.so.*
  110. %files -n compat32-%{name}-devel
  111. %defattr(-,root,root)
  112. %{_libdir}/libexpat.a
  113. %{_libdir}/libexpat.so
  114. %endif
  115. %changelog
  116. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.0-1
  117. - new upstream release.
  118. * Wed Sep 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.9-1
  119. - new upstream release.
  120. * Tue Mar 29 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.8-1
  121. - new upstream release.
  122. * Sat Mar 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.7-1
  123. - new upstream release.
  124. * Mon Feb 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
  125. - new upstream release.
  126. * Sat Feb 19 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.5-1
  127. - new upstream release.
  128. * Sun Jan 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.4-1
  129. - new upstream release.
  130. - dropped Patch1000 and 1001: fixed in upstream.
  131. * Sun Jan 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.3-2
  132. - imported Patch1000 from upstream to fix CVE-2022-23852.
  133. - imported Patch1001 from upstream to fix CVE-2022-23990.
  134. * Mon Jan 17 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.3-1
  135. - new upstream release.
  136. * Fri Jul 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  137. - new upstream release.
  138. - dropped ldconfig scriptlets.
  139. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.10-1
  140. - new upstream release.
  141. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  142. - new upstream release.
  143. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
  144. - new upstream release.
  145. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
  146. - new upstream release.
  147. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
  148. - new upstream release.
  149. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
  150. - rebuild with VineSeed environment
  151. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
  152. - update to 2.1.0
  153. - remove old patches
  154. * Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
  155. - update patch100 to regrassion fix (same as debian bug #561658)
  156. - add Vendor and Distribution tags
  157. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  158. - rebuilt with rpm-4.8.1-3
  159. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  160. - rebuilt with gcc-4.4.3-3 on ppc
  161. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  162. - rebuilt with new toolchains (for VineSeed)
  163. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  164. - add patch110 for fix CVE-2009-3720 (xml parser)
  165. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  166. - add Patch100 for fix CVE-2009-3560 (xml parser)
  167. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  168. - added Requires: tag to compat32-* sub-packages.
  169. - removed unnecessary %%configure CC='gcc -m32' option
  170. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  171. - applied new versioning policy and spec in utf-8
  172. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  173. - removed %%if !%%{build_compat32} case condition
  174. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  175. - new upstream release
  176. - drop Patch0
  177. - drop .la
  178. - chmod 644 the documentation
  179. - strip DSP files from examples
  180. - update description and drop description-ja
  181. - add -fPIC
  182. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  183. - rebuilt
  184. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  185. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  186. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  187. - added compat32* packages for x86_64 architecture support
  188. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  189. - add missing header file (expat_external.h) to %%files.
  190. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  191. - updated/revised Patch1 (%%install will fail without this patch)
  192. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  193. - new upstream release
  194. -- dropped patch1
  195. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  196. - updated to 1.95.7
  197. - changed URL and Group
  198. - fixed License to MIT/X (based on rpm package at sourceforge)
  199. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  200. - version up to 1.95.6
  201. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  202. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  203. - add manpage (xmlwf.1)
  204. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  205. - fixed license ( s/MPL or GPL/distributable/ )
  206. - use License tag
  207. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  208. - new sub-package libexpat.
  209. - added BuildPreReq: libtool
  210. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  211. - updated to 1.95.2 release
  212. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  213. - 1.95.1-3vl1
  214. - based on 1.95.1-3mdk from Mandrake 8.0
  215. - added Japanese summary and description
  216. - modified spec macros for Vine
  217. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  218. - real version is 1.95.1
  219. - reenable optimisations
  220. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  221. - release .
  222. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  223. - Don't try to use optimizations
  224. - Bzip2 sources
  225. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  226. - first version