bash-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595
  1. %define bashversion 5.2
  2. %define patchlevel 15
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPLv3+
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-001
  17. Patch2: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-002
  18. Patch3: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-003
  19. Patch4: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-004
  20. Patch5: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-005
  21. Patch6: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-006
  22. Patch7: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-007
  23. Patch8: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-008
  24. Patch9: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-009
  25. Patch10: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-010
  26. Patch11: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-011
  27. Patch12: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-012
  28. Patch13: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-013
  29. Patch14: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-014
  30. Patch15: https://ftp.gnu.org/gnu/bash/bash-%{bashversion}-patches/bash52-015
  31. # We don't want to add '/etc:/usr/etc' in standard utils path.
  32. Patch101: bash-2.03-paths.patch
  33. # Non-interactive shells beginning with argv[0][0] == '-' should run the startup files when not in posix mode.
  34. Patch102: bash-2.03-profile.patch
  35. # https://bugzilla.redhat.com/show_bug.cgi?id=60870
  36. Patch103: bash-2.05a-interpreter.patch
  37. # Generate info for debuginfo files.
  38. Patch104: bash-2.05b-debuginfo.patch
  39. # Pid passed to setpgrp() can not be pid of a zombie process.
  40. Patch105: bash-2.05b-pgrp_sync.patch
  41. # Enable audit logs
  42. Patch106: bash-3.2-audit.patch
  43. # Source bashrc file when bash is run under ssh.
  44. Patch107: bash-3.2-ssh_source_bash.patch
  45. # Use makeinfo to generate .texi file
  46. # Patch108: bash-infotags.patch
  47. # Try to pick up latest `--rpm-requires` patch from http://git.altlinux.org/gears/b/bash4.git
  48. Patch109: bash-requires.patch
  49. Patch110: bash-setlocale.patch
  50. # Disable tty tests while doing bash builds
  51. Patch111: bash-tty-tests.patch
  52. # 484809, check if interp section is NOBITS
  53. Patch116: bash-4.0-nobits.patch
  54. # Do the same CFLAGS in generated Makefile in examples
  55. Patch117: bash-4.1-examples.patch
  56. # Builtins like echo and printf won't report errors
  57. # when output does not succeed due to EPIPE
  58. Patch118: bash-4.1-broken_pipe.patch
  59. # Enable system-wide .bash_logout for login shells
  60. Patch119: bash-4.2-rc2-logout.patch
  61. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  62. Patch120: bash-4.2-coverity.patch
  63. # 799958, updated info about trap
  64. # This patch should be upstreamed.
  65. Patch122: bash-4.2-manpage_trap.patch
  66. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  67. # This patch should be upstreamed.
  68. Patch123: bash-4.2-size_type.patch
  69. # 1112710 - mention ulimit -c and -f POSIX block size
  70. # This patch should be upstreamed.
  71. Patch124: bash-4.3-man-ulimit.patch
  72. # 1102815 - fix double echoes in vi visual mode
  73. Patch125: bash-4.3-noecho.patch
  74. #1241533,1224855 - bash leaks memory when LC_ALL set
  75. Patch126: bash-4.3-memleak-lc_all.patch
  76. # bash-4.4 builds loadable builtin examples by default
  77. # this patch disables it
  78. Patch127: bash-4.4-no-loadable-builtins.patch
  79. # 2020528 - Add a runtime option to enable history logging to syslog
  80. # This option is undocumented in upstream and is documented by this patch
  81. Patch128: bash-5.0-syslog-history.patch
  82. Buildroot: %{_tmppath}/%{name}-%{version}-root
  83. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  84. Obsoletes: bash <= 1.14.7
  85. Obsoletes: bash2
  86. %description
  87. Bash is a GNU project sh-compatible shell or command language
  88. interpreter. Bash (Bourne Again shell) incorporates useful features
  89. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  90. can be run by bash without modification.
  91. Bash offers several improvements over sh, including command line
  92. editing, unlimited size command history, job control, shell
  93. functions and aliases, indexed arrays of unlimited size and
  94. integer arithmetic in any base from two to 64. Bash is ultimately
  95. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  96. Tools standard.
  97. %package doc
  98. Summary: Documentation for the GNU Bourne Again shell (bash).
  99. Summary(ja): GNU Bourne Again シェル向けドキュメント
  100. Group: documentation
  101. Requires: %{name} = %{version}-%{release}
  102. Obsoletes: bash2-doc
  103. %description doc
  104. This is a separate documentation package for the GNU Bourne
  105. Again shell.
  106. %debug_package
  107. %prep
  108. %setup -q -n %{name}-%{bashversion}
  109. %autopatch -p0 -m1 -M99
  110. %autopatch -p1 -m100
  111. echo %{version} > _distribution
  112. echo %{release} |sed 's/vl.*//' > _patchlevel
  113. %build
  114. autoconf
  115. %configure --with-bash-malloc=no
  116. # Recycles pids is neccessary. When bash's last fork's pid was X
  117. # and new fork's pid is also X, bash has to wait for this same pid.
  118. # Without Recycles pids bash will not wait.
  119. MFLAGS="CPPFLAGS=-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS` -DSYSLOG_HISTORY -DSYSLOG_SHOPT=0"
  120. # work around missing deps in Makefiles
  121. make "$MFLAGS" version.h
  122. make "$MFLAGS" %{?_smp_mflags} -C builtins
  123. make "$MFLAGS" %{?_smp_mflags}
  124. %install
  125. if [ -e autoconf ]; then
  126. # Yuck. We're using autoconf 2.1x.
  127. export PATH=.:$PATH
  128. fi
  129. # Fix bug #83776
  130. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  131. make DESTDIR=$RPM_BUILD_ROOT install
  132. mkdir -p %{buildroot}/%{_sysconfdir}
  133. pushd $RPM_BUILD_ROOT
  134. mkdir ./bin
  135. mv ./usr/bin/bash ./bin/bash
  136. ln -s bash ./bin/sh
  137. rm -f .%{_infodir}/dir
  138. popd
  139. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  140. # make manpages for bash builtins as per suggestion in DOC/README
  141. pushd doc
  142. sed -e '
  143. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  144. /^\.SH NAME/d
  145. s/^bash, //
  146. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  147. s/,//g
  148. b
  149. }
  150. d
  151. ' builtins.1 > man.pages
  152. for i in echo pwd test kill; do
  153. perl -pi -e "s,$i,,g" man.pages
  154. perl -pi -e "s, , ,g" man.pages
  155. done
  156. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  157. for i in `cat man.pages` ; do
  158. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  159. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  160. done
  161. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  162. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  163. # Not for printf, false and true (conflict with coreutils)
  164. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  165. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  166. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  167. popd
  168. %find_lang %{name}
  169. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  170. %clean
  171. rm -rf %{buildroot}
  172. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  173. # to prevent prereq loops
  174. # post is in lua so that we can run it without any external deps. Helps
  175. # for bootstrapping a new install.
  176. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  177. %post -p <lua>
  178. bashfound = false;
  179. shfound = false;
  180. f = io.open("/etc/shells", "r");
  181. if f == nil
  182. then
  183. f = io.open("/etc/shells", "w");
  184. else
  185. repeat
  186. t = f:read();
  187. if t == "/bin/bash"
  188. then
  189. bashfound = true;
  190. end
  191. if t == "/bin/sh"
  192. then
  193. shfound = true;
  194. end
  195. until t == nil;
  196. end
  197. f:close()
  198. f = io.open("/etc/shells", "a");
  199. if not bashfound
  200. then
  201. f:write("/bin/bash\n")
  202. end
  203. if not shfound
  204. then
  205. f:write("/bin/sh\n")
  206. end
  207. f:close()
  208. %files -f %{name}.lang
  209. %defattr(-,root,root)
  210. %license COPYING
  211. %doc CHANGES
  212. %doc examples
  213. %config(noreplace) /etc/bashrc
  214. /bin/bash
  215. /bin/sh
  216. %{_infodir}/bash.info*
  217. %{_mandir}/*/*
  218. %{_mandir}/*/..1*
  219. %{_bindir}/bashbug
  220. %files doc
  221. %defattr(-,root,root)
  222. %doc COMPAT NEWS NOTES POSIX RBASH
  223. %doc examples/functions/ examples/misc/
  224. %doc examples/scripts*/
  225. %doc examples/startup-files/ examples/complete/ examples/loadables/
  226. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  227. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  228. %changelog
  229. * Thu Jan 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.15-1
  230. - updated to 5.2 patch level 15.
  231. * Sun Nov 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.2.2-1
  232. - updated to 5.2 patch level 2.
  233. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.16-1
  234. - updated to 5.1 patch level 16.
  235. * Wed Dec 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.12-1
  236. - updated to 5.1 patch level 12.
  237. * Thu Sep 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.8-1
  238. - updated to 5.1 patch level 8.
  239. - updated patches.
  240. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
  241. - updated to 5.0 patch level 18.
  242. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  243. - updated to 5.0 patch level 16.
  244. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  245. - updated to 5.0 patch level 11.
  246. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  247. - updated to 5.0 patch level 9.
  248. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  249. - imported Patch140 from rawhide.
  250. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  251. - updated to 4.3 patch level 46.
  252. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  253. - updated to 4.3 patch level 42.
  254. - imported patch 128-139 from RawHide.
  255. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  256. - updated to 4.3 patch level 29.
  257. - removed patch1000 (included in 4.3.26).
  258. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  259. - added patch1000 to fix CVE-2014-7169.
  260. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  261. - updated to 4.3 patch level 25.
  262. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  263. - update to 4.3 patch level 18
  264. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  265. - update to 4.3 patch level 11
  266. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  267. - update to 4.2 patch level 45
  268. - import some patch from fedora package (122-127)
  269. - patch122: Don't call malloc in signal handler
  270. - patch123: #799958, updated info about trap
  271. - patch124: #695656, block the signal and unblock it after the
  272. new handler is installed
  273. - patch125: Use unsigned type for size
  274. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  275. - patch126: #903833, Fix missing close(), fixes fd leaks
  276. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  277. - remove postun lua script because bash will be never uninstalled
  278. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  279. - update to 4.2 patch level 37
  280. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  281. - update to 4.2 patch level 20
  282. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  283. - update to 4.2 patch level 8
  284. - use lua script in post/postun
  285. - update patches from fedora
  286. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  287. - update to 4.1 patch level 7
  288. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  289. - check if /bin/grep exists on %%post script
  290. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  291. - rebuilt with gcc-4.4.3-3 on ppc
  292. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  293. - rebuilt with new toolchain
  294. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  295. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  296. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  297. - add Requires(post): grep
  298. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  299. - remove obsolete /bin/bash2 entry from /etc/shells
  300. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  301. - add Requires(post): ncurses (should be added by find-requires..)
  302. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  303. - add upstream patch (from 040 to 048)
  304. - build against ncurses-devel (libtinfo)
  305. - spec in utf-8
  306. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  307. - added upstream patch (from 026 to 039)
  308. - added Japanese summary
  309. - applied new versioning policy
  310. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  311. - rebuilt with libtermcap-devel
  312. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  313. - new upstream release
  314. - add upstream patch (from 001 to 025)
  315. - remove Provides: bash2
  316. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  317. - rebuilt with new toolchain
  318. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  319. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  320. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  321. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  322. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  323. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  324. - update to 2.05b
  325. - rebuild with new toolchains
  326. - add make check
  327. - add %postun script based on Fedora development
  328. - README file moved doc package
  329. - update Patch5 and Patch8 from Fedora development
  330. - change Patch6
  331. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  332. - add Patch11--39 from Fedora development 2.05b-36
  333. * Tim Waugh <twaugh@redhat.com>
  334. - Fix parameter expansion in multibyte locales (bug #112657).
  335. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  336. bug #110777).
  337. - Apply upstream patches (bug #109269 among others).
  338. - Fix bash.info (bug #83776).
  339. - Add bash205b-007 patch to fix bug #106876.
  340. - Avoid crashing on multibyte input when locale is set incorrectly
  341. (bug #74266).
  342. - LFS support (bug #103627).
  343. - Fix completion display when multibyte or control characters are to be
  344. shown (bug #90201).
  345. - Fix a warning message (bug #79629).
  346. - Don't build with AFS support (bug #86514).
  347. - Don't explicitly strip binaries (bug #85995).
  348. - Really fix bug #83331 for good.
  349. - Fix builtins.1.
  350. - Actually apply the patch (bug #83331).
  351. - Fix history/UTF-8 bug (bug #83331).
  352. - More tab-completion fixing (bug #72512).
  353. - Force pgrp synchronization (bug #81653).
  354. - Prevent prompt overwriting output (bug #74383).
  355. - Fix '-rbash' (bug #78455).
  356. - Add readline-init patch (bug #74925).
  357. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  358. - Ship '.' man page, which doesn't get picked up by glob.
  359. - Locale shell variables fix (bug #74701).
  360. * Elliot Lee <sopwith@redhat.com>
  361. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  362. cross compiles.
  363. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  364. - update to 2.05
  365. - add README.jpatch to %doc
  366. - remove patch4 (bash2): revert command name in man pages to "bash"
  367. - fix perl command to remove man pages conflict with sh-utils
  368. - remove section of config.h.in from patch0 to prevent remake of configure
  369. - change patch9: define in config-top.h to avoid conflict with patch100
  370. - remove patches 7, 10 & 101
  371. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  372. - made a link for man sh
  373. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  374. - added missing %%post and %%triggerpostun section
  375. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  376. - 2.04-1vl12
  377. - now bash2 is finally bash
  378. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  379. - build for Playstation2
  380. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  381. - 2.04-1vl10
  382. - Provides: bash = %%{version}
  383. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  384. - added Provides: bash
  385. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  386. - Obsoletes: bash
  387. - changed Copyright to License
  388. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  389. - 2.04-1vl7
  390. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  391. - corrected: bashrc-vine -> bashrc
  392. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  393. - combined bash-1.x and bash-2.x packages
  394. - added some patches from bash-2.04-13mdk
  395. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  396. - fix spec macros
  397. - added tests
  398. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  399. - build with gcc-2.95.3
  400. - partially used rpmmacros
  401. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  402. - minor bug fix in spec file
  403. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  404. - 2.04-1vl3
  405. - modified %install and %files section to handle compressed man page(s)
  406. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  407. - added pcomplete patch to fix complete if the candidate list is NULL.
  408. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  409. - updated to 2.04
  410. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  411. - Remove annoying ^H's from documentation
  412. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  413. - patch to detect what executables are required by a script.
  414. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  415. - auto rebuild in the new build environment (release 4)
  416. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  417. - strip binaries.
  418. - include bash-doc correctly.
  419. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  420. - fixed post/postun /etc/shells work.
  421. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  422. - updated again text in the spec file
  423. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  424. - updated text in spec file.
  425. - update to 2.03.
  426. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  427. - build it as bash2 instead of bash
  428. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  429. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  430. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  431. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  432. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  433. - patch for the arm
  434. - use $RPM_ARCH-redhat-linux as the build target
  435. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  436. - rewrite %pre, axe %postun (to avoid prereq loops)
  437. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  438. - resurrect for RH 6.0.
  439. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  440. - update to 2.02.1
  441. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  442. - Package for 5.2.
  443. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  444. - added POSIX.NOTES doc file
  445. - some extraneous doc files removed
  446. - minor .spec file changes
  447. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  448. - upgraded to version 2.02
  449. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  450. - glibc & signal patches no longer required
  451. - added documentation subpackage (doc)
  452. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  453. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  454. is based on a change made in bash 2.0. Should fix some early exit
  455. problems with suspends and fg.
  456. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  457. - added %clean
  458. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  459. - added comment explaining why install-info isn't used
  460. - added mips patch
  461. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  462. - added BuildRoot
  463. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  464. - built against glibc