authconfig-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736
  1. Summary: Command line tool for setting up authentication from network services
  2. Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
  3. Name: authconfig
  4. Version: 7.0.1
  5. Release: 4%{?_dist_release}
  6. Group: admin-tools
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://pagure.io/authconfig
  11. Source: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.bz2
  12. # fedora patches
  13. Patch1: authconfig-6.2.6-gdm-nolastlog.patch
  14. Patch2: authconfig-7.0.1-nss-update.patch
  15. # remove selinux stuff
  16. Patch100: authconfig-7.0.1-noselinux.patch
  17. # elogind patch
  18. Patch1000: authconfig-7.0.1-elogind.patch
  19. # stop warning flood by tempfile in python3.5
  20. Patch1001: authconfig-7.0.1-fix-temp-warning.patch
  21. ExclusiveOS: Linux
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel
  24. BuildRequires: python3-devel
  25. BuildRequires: intltool, gettext
  26. Requires: pam
  27. Requires: openssl
  28. Conflicts: samba-common < 3.0, samba-client < 3.0
  29. Conflicts: nss_ldap < 254
  30. Obsoletes: authconfig-gtk < 7.0.0
  31. %description
  32. Authconfig is a command line utility which can configure a workstation
  33. to use shadow (more secure) passwords. Authconfig can also configure a
  34. system to be a client for certain networked user information and
  35. authentication schemes.
  36. %description -l ja
  37. authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
  38. コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
  39. サービスを利用するように設定することもできます。
  40. %prep
  41. %setup -q -n %{name}-%{version}
  42. %patch1 -p1
  43. %patch2 -p1
  44. %patch1000 -p1
  45. %patch1001 -p1
  46. %patch100 -p1
  47. perl -pi -e 's|/usr/lib|/lib|' authinfo.py
  48. %build
  49. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  50. %configure --with-python-rev=3
  51. make
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. make install DESTDIR=$RPM_BUILD_ROOT
  55. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.a
  56. rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.la
  57. %find_lang %{name}
  58. find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %post
  62. authconfig --updateall --nostart &>/dev/null ||:
  63. %triggerin -- authconfig <= 6.2.3
  64. if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
  65. authconfig --updateall --nostart >/dev/null 2>&1 || :
  66. fi
  67. if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
  68. cd %{_sysconfdir}/pam.d; \
  69. ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
  70. fi
  71. %files -f %{name}.lang
  72. %defattr(-,root,root,-)
  73. %license COPYING
  74. %doc NOTES TODO HOWTO.AD-client
  75. %ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
  76. %ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
  77. %ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
  78. %ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
  79. %ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
  80. %ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
  81. %{_sbindir}/cacertdir_rehash
  82. %{_sbindir}/authconfig
  83. %{_mandir}/man8/*
  84. %{_mandir}/man5/*
  85. %{_libdir}/python*/site-packages/acutil.so
  86. %dir %{_datadir}/%{name}
  87. %{_datadir}/%{name}/authconfig.py*
  88. %{_datadir}/%{name}/authinfo.py*
  89. %{_datadir}/%{name}/shvfile.py*
  90. %{_datadir}/%{name}/dnsclient.py*
  91. %attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
  92. %changelog
  93. * Thu May 04 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-4
  94. - rebuilt with python-3.11.
  95. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-3
  96. - rebuilt with python-3.8.
  97. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-2
  98. - updated Patch100.
  99. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  100. - new upstream release.
  101. - switched to python3.
  102. - updated Patch100.
  103. - added elogind support.
  104. - dropped Patch10 and 11.
  105. - dropped a subpackage "gtk": no longer supported in the upstream.
  106. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.2.8-2
  107. - add Patch100 to remove selinux staff (again)
  108. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
  109. - update to 6.2.8
  110. - remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  111. * Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
  112. - update to 6.2.4
  113. - run "authconfig --updateall --nostart" on %%post script
  114. * Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
  115. - update to 6.2.3
  116. - update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
  117. - update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
  118. - add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
  119. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
  120. - rebuild with python-2.7.2
  121. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
  122. - rebuilt with rpm-4.8.1-3
  123. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
  124. - rebuilt with python-2.6.4
  125. * Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
  126. - update Patch11
  127. - old patch does not fix problem on some environment..
  128. * Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
  129. - add Patch10
  130. - Fingerprint auth requires fprintd-pam package not pam_fprintd
  131. - add Patch11 to fix broken help messages on some locale.
  132. * Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
  133. - new upstream release
  134. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
  135. - new upstream release
  136. - historical changelogs are following:
  137. * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
  138. - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
  139. - added BuildRequires: desktop-file-utils
  140. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
  141. - rebuilt with python-2.4.1-0vl1
  142. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
  143. - rebuilt with python-2.3.3-0vl1
  144. * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
  145. - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
  146. * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
  147. - updated to 4.6.1
  148. - updated Patch0 and Source1
  149. - rebuild with new toolchains
  150. - Reqyires: glib2, BuildRequires: glib2-devel
  151. * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
  152. - add vinized color palette
  153. * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
  154. - rebuild for Vine Linux
  155. - based on Red Hat Linux 7.2, merged with Vine Linux package.
  156. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  157. - 3.0.3-1vl5
  158. - change checkbox color
  159. * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
  160. - add %patch1 to fix mandir
  161. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
  162. - build with gcc-2.95.3
  163. - partially used rpmmacros
  164. * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  165. - 3.0.3-1vl2
  166. - modified %files section to handle compressed man page
  167. * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
  168. - 3.0.3-1vl1
  169. - build for Vine
  170. * Tue Aug 5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
  171. - do not call domainname when run with --nostart (#457697)
  172. * Fri Jun 6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
  173. - remove the --enableldapssl alias and add some help to GUI tooltips
  174. to clear up some confusion (#220973)
  175. - add option --enablepreferdns to prefer DNS over NIS or WINS in
  176. hostname resolution
  177. * Tue Apr 8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
  178. - read wins setting from nsswitch.conf correctly (#440459)
  179. - do not ignore --enablemd5/--disablemd5 options
  180. * Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
  181. - fixed backup directory in Makefile and spec (#437040)
  182. * Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
  183. - include config-util in console.apps files
  184. - add support for saving/restoring backups of configuration
  185. files affected by authconfig (#433776)
  186. - improve the authconfig manual page (#432023, #432938)
  187. * Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
  188. - correct the fix for bug #237956
  189. * Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
  190. - update translations
  191. * Wed Jan 9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
  192. - support new sha256 and sha512 password hash algorithms
  193. - add support for pam_mkhomedir (#212790)
  194. - do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
  195. the idea how to fix that
  196. - setup password hash algorithm in /etc/login.defs (#218652)
  197. - update translations
  198. * Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
  199. - improve krb5.conf handling (#238766)
  200. * Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
  201. - remove obsolete pam_krb5afs support (#250704)
  202. - add support for pam_access (#251360)
  203. - update translations
  204. * Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
  205. - license tag fix
  206. * Thu Aug 9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
  207. - require newt-python (#251359)
  208. * Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
  209. - add support for winbind offline login (#232955)
  210. * Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
  211. - dnsclient fixes by Simo Sorce
  212. - add Categories to .desktop file (#245868)
  213. - fixed traceback when calling joinDomain (#245374)
  214. - disable smart card action setting when gnome-screensaver
  215. not installed (#209643)
  216. - do not change protocols and services in nsswitch.conf (#236669)
  217. * Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
  218. - authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
  219. - drop explicit requirement on python version as it is now
  220. generated automatically
  221. - improve writing /etc/samba/smb.conf (based on patch by
  222. Simo Sorce)
  223. - merge changes upstream
  224. * Fri May 4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
  225. - local nis domain is obtained from sysconfig/network (#235927)
  226. - set "local authorization is sufficient" on by default
  227. * Thu Apr 5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
  228. - minor changes and cleanups for merge review (#225293)
  229. * Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
  230. - nss_ldap is now in /usr/lib (#232975)
  231. * Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
  232. - another traceback in --probe and other fixes (#218874)
  233. - make smbRealm a default realm when appropriate (#219300)
  234. - added missing languages in LINGUAS
  235. * Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
  236. - when pam_krb5 auth fails with smartcard login don't enforce it
  237. in the account stack (#214931)
  238. - updated translations (#216570)
  239. - winbind should be added only to user tables (#216862)
  240. * Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
  241. - fixed --smartcardaction command line option (#211552)
  242. * Fri Oct 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
  243. - fixed passwd PAM stack when PKCS11 enabled (#195960)
  244. - make authconfig --probe work again (#209676)
  245. * Mon Oct 2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
  246. - updated translations (#207095)
  247. - correctly write pam_smb.conf with only one server specified (#208365)
  248. * Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
  249. - move options to another tab to fit on 800x600 screen (#207357)
  250. * Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
  251. - improve PAM setup for smart card login
  252. - support smart card login with kerberos (PKINIT)
  253. - add pam_pkcs11 to password PAM stack
  254. * Mon Sep 4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
  255. - skip pam_unix for session for crond service
  256. - fixed a bug in saving when smartcard settings changed (#204838)
  257. - removed allow_ypbind setsebool as it is now handled in ypbind
  258. * Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
  259. - improve smart card related UI strings
  260. - removed possibility to set smart card type from authconfig-gtk
  261. as only coolkey will be supported for now
  262. * Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
  263. - pass options given to authconfig-gtk to authconfig (#203955)
  264. * Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
  265. - write out new "wait_for_card" config option if we're
  266. forcing smart card authentication
  267. - add "use_uid" option to smart card pam_succeed_if line to
  268. work around bug where pam_succeed_if checks user information
  269. even in cases where the conditional doesn't depend on it.
  270. - remove unimplemented "logout" smart card removal action from
  271. settings
  272. - remove unnecessary "card_only" argument
  273. * Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
  274. - don't start sceventd when smartcard login is enabled
  275. - improve pam config for smartcard login
  276. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
  277. - don't require pam_pkcs11 to run
  278. * Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
  279. - screensavers should be authenticated by smartcard too
  280. - add feature to download a CA certificate for LDAP from
  281. an URL (#197103)
  282. - add pam_keyinit session module to the PAM configuration (#198638)
  283. * Fri Jul 7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
  284. - added support for smartcard authentication
  285. - fixed parsing kerberos realms
  286. * Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
  287. - write ldap servers as URIs and not HOSTs (#191842)
  288. - fix a typo in --test output
  289. - updated summary, converted changelog to UTF-8
  290. * Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
  291. - added crond to the services restarted after firstboot (#187334)
  292. - when checking nscd status redirect output to /dev/null (#188555)
  293. * Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
  294. - make smb.conf and krb5.conf loading more robust (#185766)
  295. * Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
  296. - add try_first_pass option to pam_unix for better integration
  297. with individual service configurations (#182350)
  298. - updated translations
  299. * Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
  300. - don't crash in TUI when some options aren't set (#182151)
  301. * Fri Feb 3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
  302. - redesigned GUI (#178112)
  303. - added man page for system-config-ac (#179584)
  304. - disable authentication of system accounts by network services
  305. by default, added option for changing that (#179009)
  306. - updated translations, new languages
  307. * Mon Jan 9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
  308. - fixed regression when saving nsswitch.conf
  309. * Fri Jan 6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
  310. - print warning if PAM module is missing when the PAM configuration
  311. is saved (#168880)
  312. * Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
  313. - make child dialog preset code more robust (#176462)
  314. * Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
  315. - update only configuration files which settings were modified (#72290)
  316. * Mon Dec 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
  317. - don't ignore krb5realm command line option (#174838)
  318. - read dns_lookup_realm and dns_lookup_kdc values correctly
  319. - the PAM configuration is now written in system-auth-ac file
  320. which is then symlinked from system-auth, the symlink is not
  321. overwritten so local PAM configuration is now possible (#165342)
  322. * Mon Nov 7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
  323. - add symlinks to python scripts in sbindir
  324. - don't override nullok setting from system-auth (#96996)
  325. * Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
  326. - authinfo-tui.py is now symlink
  327. - reword the CA certificate message (#154317)
  328. - use include instead of pam_stack in pam config
  329. - don't break yp.conf with multiple domains (#127306)
  330. * Mon Sep 5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
  331. - fixed a few errors catched by pychecker
  332. * Sat Sep 3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
  333. - C code completely rewritten in Python
  334. - some bugs fixed in the process (and no doubt new introduced)
  335. - TUI deprecated, opens only when run as authconfig-tui
  336. * Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
  337. - set domain and ypserver option correctly when multiple servers
  338. specified in kickstart (#159214)
  339. * Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
  340. - replaced deprecated gtk.TRUE/FALSE (#153034)
  341. - updated translations
  342. * Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
  343. - propagate the --enablewinbindauth option to the configuration (#151018)
  344. * Fri Mar 4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
  345. - changed version propagation
  346. * Thu Mar 3 2005 Tomas Mraz <tmraz@redhat.com>
  347. - updated translations
  348. - fixed build on gcc4
  349. * Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
  350. - updated translations
  351. * Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
  352. - improved the code that writes tls_cacertdir to ldap.conf
  353. * Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
  354. - renamed functions in authconfigmodule to be more clear
  355. - implemented cacertdir for LDAP with TLS
  356. * Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
  357. - fixed a bug in authinfo_differs when called from python
  358. * Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
  359. - add option for making local authorization sufficient for local users
  360. this is attempt to 'solve/workaround' the problem with blocking local logins by
  361. pulling out network cable (#115181)
  362. * Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
  363. - remove dependency on nscd
  364. - don't show warning messages when switching options off
  365. * Mon Dec 6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
  366. - updated translations
  367. - winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
  368. - use GtkComboBox instead of deprecated GtkOptionMenu
  369. - disable options with not installed binaries, remove unnecessary deps of
  370. authconfig-gtk
  371. * Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
  372. - merged patches from dist
  373. - fix versioning
  374. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
  375. - rebuild against python 2.4
  376. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  377. - Fix setsebool patch to turn off boolean
  378. * Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
  379. - Add setsebool for NIS
  380. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  381. - force broken_shadow option on network auth (#136760)
  382. * Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
  383. - force restart of autofs on firstboot call when using NIS (#133035, #124498)
  384. * Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
  385. - require python to install (#134654)
  386. * Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
  387. - updated translations from upstream
  388. - autogeneration of build stripts in prep phase
  389. * Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
  390. - fixed man page
  391. - added dependency on nscd
  392. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
  393. - regenerated build scripts
  394. * Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
  395. - fixed all po files to translate correctly messages with modified accelerators (#133742)
  396. - added translations for Arabic, Bulgarian and other languages (#133716, #133158)
  397. * Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
  398. - added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
  399. * Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
  400. - corrected package dependencies #132411
  401. - regenerated glade.strings.h #132369
  402. * Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
  403. - modified authconfig-gtk interface to fit lower resolution screens (#127175)
  404. - modified accelerators in authconfig-gtk (#125797)
  405. - updated package dependencies (#125306)
  406. * Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
  407. - updated configure scripts
  408. - warnfixes and minor hacks
  409. * Mon Jun 7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
  410. - tweak account management to fix #55193 correctly
  411. - require anything we might want to run in the gui subpackage because it
  412. doesn't warn about missing things and you don't have a terminal to see
  413. error messages about missing commands
  414. - properly display the domain in the GUI join dialog (#124621)
  415. * Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
  416. - omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
  417. - properly warn about missing "net" (samba-client) and libnss_winbind and
  418. pam_winbind (samba-common) in text mode (#122802)
  419. * Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
  420. - learn all about pam_passwdqc
  421. - preserve arguments to pam_cracklib and pam_passwdqc
  422. - short-circuit PAM authorization checks for users with UID < 100
  423. - remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
  424. * Fri Feb 6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
  425. - fix man page: --enableldapssl should be --enableldaptls
  426. - make --enableldapssl an alias for --enableldaptls
  427. * Thu Jan 8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
  428. - authconfig-gtk.py: require rhpl, which is required by the script (#104209)
  429. - both: require usermode (authconfig-gtk transitively), else leave a dangling
  430. symlink (#104209)
  431. - the great redhat-config-authentication/system-config-authentication renaming,
  432. as was foretold in the fedora-config-list archives
  433. * Wed Jan 7 2004 Nalin Dahyabhai <nalin@redhat.com>
  434. - preserve "compat" if it's used in /etc/nsswitch.conf
  435. * Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
  436. - add options for toggling krb5's use of DNS
  437. * Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
  438. - rework tui to include winbind options. there wasn't enough room in the old
  439. dialog to include the important options, so the whole thing's been reworked
  440. * Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
  441. - conflict with older versions of samba which expect different configuration
  442. * Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
  443. - initial support for configuring winbind
  444. * Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
  445. - make pam_cracklib requisite instead of required in generated PAM configs
  446. * Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
  447. - rebuild with current translations
  448. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
  449. - make the tarball name include the release number
  450. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
  451. - authconfig-gtk: condrestart certain additional services if invoked with
  452. the --firstboot flag (half of #91268, needs cooperating firstboot)
  453. - translation updates
  454. * Mon Jul 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
  455. - translation updates
  456. * Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
  457. - add 'redhat-config-authentication' as an alias for authconfig-gtk
  458. - make authconfig-gtk exec authconfig if gui startup fails and it looks like
  459. we're connected to a tty
  460. * Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
  461. - rebuilt
  462. * Mon May 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
  463. - translation updates
  464. - close unusable file descriptors if locking fails
  465. * Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
  466. - learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
  467. * Fri Feb 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
  468. - look in /lib64 for modules for nsswitch and PAM by default on
  469. x86_64, ppc64, and s390x (#83049)
  470. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  471. - rebuilt
  472. * Mon Nov 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
  473. - update translations
  474. - update copyright strings (only took 10 months!)
  475. * Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
  476. - require a version of PAM (0.75-43) which supports $ISA
  477. - use $ISA in our own PAM config files
  478. * Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
  479. - add $ISA to the name of the directory in which we expect PAMs to be stored
  480. * Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
  481. - build with -fPIC, necessary on some arches
  482. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
  483. - update translations
  484. * Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
  485. - Update translations
  486. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
  487. - modify spacing and layout in authconfig-gtk
  488. * Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
  489. - translation updates
  490. - rebuild to pick up dependency changes
  491. * Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
  492. - include the userhelper configuration file
  493. - require sufficiently-new pam package in the gui subpackage
  494. * Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
  495. - actually include the icon in the package
  496. - translation updates
  497. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
  498. - use desktop-file-install (#69376)
  499. - include an icon for the menu item (#68577)
  500. * Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
  501. - own the pkgdatadir
  502. - pull in translation updates
  503. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
  504. - add --enable-experimental to enable some of that experimental code
  505. - add --enable-local to enable local policies
  506. - update translations
  507. * Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
  508. - use the current revision of python by default
  509. - get the intltool/gettext situation sorted out
  510. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  511. - automated rebuild
  512. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
  513. - remove bogus buildrequires left over from when authconfig-gtk was C code
  514. - buildrequires python-devel in addition to python (to build the python module,
  515. but we still need python to byte-compile the python script)
  516. * Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
  517. - add missing translations back in
  518. - convert .mo files at install-time
  519. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
  520. - refresh translations
  521. * Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
  522. - actually add the .desktop files
  523. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
  524. - refresh translations
  525. - destroy the python object correctly
  526. * Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
  527. - add the .desktop file
  528. * Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
  529. - rework the auth stack logic to require all applicable auth modules
  530. * Fri Mar 1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
  531. - allow pam_krb5afs to be used for account management, too
  532. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
  533. - refresh translations
  534. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
  535. - refresh translations
  536. * Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
  537. - actually free authInfo structures when asked to
  538. - use pam_krb5's account management facilities
  539. - conflict with versions of pam_krb5 which don't offer account management
  540. * Mon Feb 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
  541. - add python bindings for the back-end
  542. - redo the gui so that it exercises the python bindings
  543. - take a shot at getting authconfig to work in a firstboot container
  544. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
  545. - rebuild again
  546. * Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
  547. - rebuilt against new glib
  548. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
  549. - rebuild in new environment
  550. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
  551. - add some more experimental options
  552. - clean up the glade files a bit
  553. - don't destroy a garbage pointer on main cancel, destroy the main dialog
  554. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
  555. - bump release and rebuild
  556. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
  557. - make setting of experimental options only possible through
  558. /etc/sysconfig/authconfig, to keep accidents from happening
  559. - add some more support for experimental stuff
  560. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
  561. - fix setting of LDAP TLS option in authconfig-gtk
  562. - change Apply to Ok, Close to Cancel, because that's how they work
  563. * Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
  564. - add the glade XML file to the -gtk subpackage (fix from katzj)
  565. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
  566. - port to glib2
  567. - move post code to the back-end
  568. - add a libglade GUI in a -gtk subpackage
  569. - set up to use userhelper