attr-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Utilities for managing filesystem extended attributes
  3. Name: attr
  4. Version: 2.5.1
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://savannah.nongnu.org/projects/attr
  11. Source: http://download.savannah.nongnu.org/releases/attr/attr-%{version}.tar.gz
  12. # xattr.conf: remove entries for NFSv4 ACLs namespaces (#1031423)
  13. # https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00000.html
  14. # https://lists.nongnu.org/archive/html/acl-devel/2019-03/msg00001.html
  15. # https://lists.nongnu.org/archive/html/acl-devel/2019-05/msg00000.html
  16. Patch3: 0003-attr-2.4.48-xattr-conf-nfs4-acls.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: gettext
  19. BuildRequires: libtool
  20. Requires: libattr = %{version}-%{release}
  21. Conflicts: xfsdump < 2.0.0
  22. %description
  23. A set of tools for manipulating extended attributes on filesystem
  24. objects, in particular getfattr(1) and setfattr(1).
  25. An attr(1) command is also provided which is largely compatible
  26. with the SGI IRIX tool of the same name.
  27. %package -n libattr
  28. Summary: Dynamic library for extended attribute support
  29. Group: system
  30. License: LGPLv2+
  31. %description -n libattr
  32. This package contains the libattr.so dynamic library which contains
  33. the extended attribute system calls and library functions.
  34. %package -n libattr-devel
  35. Summary: Extended attribute static libraries and headers
  36. Group: programming
  37. License: LGPLv2+
  38. Requires: libattr = %{version}-%{release}
  39. %description -n libattr-devel
  40. This package contains the libraries and header files needed to
  41. develop programs which make use of extended attributes.
  42. For Linux programs, the documented system call API is the
  43. recommended interface, but an SGI IRIX compatibility interface
  44. is also provided.
  45. Currently only ext2, ext3 and XFS support extended attributes.
  46. The SGI IRIX compatibility API built above the Linux system calls is
  47. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  48. You should install libattr-devel if you want to develop programs
  49. which make use of extended attributes. If you install libattr-devel,
  50. you'll also want to install attr.
  51. # compat32
  52. %package -n compat32-libattr
  53. Summary: Dynamic library for extended attribute support
  54. Group: system,legacy
  55. License: LGPLv2+
  56. %description -n compat32-libattr
  57. This package contains the libattr.so dynamic library which contains
  58. the extended attribute system calls and library functions.
  59. %package -n compat32-libattr-devel
  60. Summary: Extended attribute static libraries and headers
  61. Group: programming,legacy
  62. License: LGPLv2+
  63. Requires: libattr-devel = %{version}-%{release}
  64. Requires: compat32-libattr = %{version}-%{release}
  65. %description -n compat32-libattr-devel
  66. This package contains the libraries and header files needed to
  67. develop programs which make use of extended attributes.
  68. For Linux programs, the documented system call API is the
  69. recommended interface, but an SGI IRIX compatibility interface
  70. is also provided.
  71. Currently only ext2, ext3 and XFS support extended attributes.
  72. The SGI IRIX compatibility API built above the Linux system calls is
  73. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  74. You should install libattr-devel if you want to develop programs
  75. which make use of extended attributes. If you install libattr-devel,
  76. you'll also want to install attr.
  77. %debug_package
  78. %prep
  79. %setup -q
  80. %autopatch -p1
  81. %build
  82. # attr abuses libexecdir
  83. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  84. %make_build
  85. %install
  86. rm -rf %{buildroot}
  87. %make_install
  88. # get rid of libattr.a and libattr.la
  89. rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.{l,}a
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/libattr.{l,}a
  91. # fix links to shared libs and permissions
  92. rm -f %{buildroot}%{_libdir}/libattr.so
  93. mkdir -p %{buildroot}%{_libdir}
  94. ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
  95. chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
  96. # remove documents without version
  97. rm -rf %{buildroot}%{_datadir}/doc/attr
  98. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  99. %find_lang %{name}
  100. %check
  101. if ./setfattr -n user.name -v value .; then
  102. make tests || exit $?
  103. else
  104. echo '*** xattrs are probably not supported by the file system,' \
  105. 'the test-suite will NOT run ***'
  106. fi
  107. %clean
  108. rm -rf %{buildroot}
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %doc doc/CHANGES
  112. %license doc/COPYING*
  113. %{_bindir}/attr
  114. %{_bindir}/getfattr
  115. %{_bindir}/setfattr
  116. %{_mandir}/man1/attr.1*
  117. %{_mandir}/man1/getfattr.1*
  118. %{_mandir}/man1/setfattr.1*
  119. %files -n libattr-devel
  120. %defattr(-,root,root)
  121. /%{_lib}/libattr.so
  122. %{_includedir}/attr
  123. %{_libdir}/libattr.*
  124. %{_libdir}/pkgconfig/*.pc
  125. %{_mandir}/man3/attr_*.3.*
  126. %files -n libattr
  127. /%{_lib}/libattr.so.*
  128. %config(noreplace) %{_sysconfdir}/xattr.conf
  129. # compat32
  130. %if %{build_compat32}
  131. %files -n compat32-libattr-devel
  132. %defattr(-,root,root)
  133. /%{_lib}/libattr.so
  134. %{_libdir}/libattr.*
  135. %{_libdir}/pkgconfig/*.pc
  136. %files -n compat32-libattr
  137. /%{_lib}/libattr.so.*
  138. %config(noreplace) %{_sysconfdir}/xattr.conf
  139. %endif
  140. %changelog
  141. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.1-1
  142. - new upstream release.
  143. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-2
  144. - dropped scriptlets.
  145. - imported Patch1-3 from rawhide.
  146. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-1
  147. - new upstream release.
  148. - dropped Patch1, 2.
  149. * Fri Sep 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-2
  150. - removed a manpage (attr.5).
  151. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
  152. - new upstream release.
  153. - replaced patches to the newest rawhide's.
  154. * Sat Apr 9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
  155. - new upstream release
  156. - remove static library from devel package
  157. - added Patch2-9
  158. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
  159. - fix typos in attr(1) man page (#669095)
  160. * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
  161. - setfattr.1: document supported encodings of values (#587516)
  162. - getfattr: encode NULs properly with --encoding=text (#650539)
  163. - getfattr: return non-zero exit code on failure (#660619)
  164. - walk_tree: do not follow symlink to directory with -h (#660613)
  165. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
  166. - let attr depend on the same version of libattr (#595689)
  167. - silence compile-time warnings
  168. * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
  169. - Fixed memory leaks (#485473)
  170. * Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
  171. - added compat32 package for x86_64 arch support
  172. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
  173. - new upstream release
  174. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
  175. - initial build for Vine Linux
  176. * Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
  177. - New version 2.4.41
  178. - Removed useless attr-2.0.8-docperms.patch
  179. * Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
  180. - New version 2.4.39
  181. - Resolves #284121
  182. * Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
  183. - Removed explicit Requires(post + postun)
  184. - Resolves #225290
  185. * Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
  186. - New version 2.4.38
  187. - Resolves #245415
  188. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
  189. - add disttag
  190. - remove trailing dot from summary
  191. - fix buildroot
  192. - -devel package requires same libattr version
  193. - change prereq to Requires(post)
  194. - escape macro in changelog
  195. - replace absolute link with relative link (libattr.so)
  196. - use %%doc macro
  197. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
  198. - rebuild
  199. * Wed Jul 5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
  200. - new version 2.4.32
  201. - fixes segmentation fault in attr, which affects #189106
  202. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
  203. - rebuild for -devel deps
  204. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
  205. - bump again for double-long bug on ppc(64)
  206. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
  207. - rebuilt for new gcc4.1 snapshot and glibc changes
  208. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
  209. - new version 2.4.28
  210. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  211. - rebuilt
  212. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
  213. - spec file cleanup
  214. - mark po files as lang specific
  215. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  216. - 2.4.24
  217. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
  218. - update to 2.4.23
  219. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
  220. - get rid of *.la files
  221. - remove duplicate doc files
  222. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
  223. - Rebuild
  224. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
  225. - Build requires libtool >= 1.5
  226. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
  227. - Make libattr.so.* executable.
  228. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
  229. - Update to latest upstream version.
  230. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
  231. - Fix bug #125304 (Steve Grubb: build requires gettext)
  232. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  233. - rebuilt
  234. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
  235. - Add missing %%defattr
  236. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
  237. - Add /usr/include/attr to files manifest
  238. - Fix location of doc files, add main doc dir to files manifest
  239. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  240. - rebuilt
  241. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  242. - rebuilt
  243. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
  244. - Fix libtool
  245. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
  246. - update to attr-2.4.1
  247. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
  248. - update/rebuild
  249. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
  250. - set execute bits on library so that requires are generated.
  251. * Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
  252. - Redo multilib patch to work everywhere
  253. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
  254. - Added fix to install libs in correct directory on 64bit machine
  255. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
  256. - Made the package only own the one directory that is unique to it:
  257. /usr/include/attr
  258. * Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
  259. - get perl out of base with attr-2.0.8-docperms.patch
  260. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
  261. - Initial Red Hat package
  262. Made as few changes as possible relative to upstream packaging to
  263. make it easier to maintain long-term. This means that some of
  264. the techniques used here are definitely not standard Red Hat
  265. techniques. If you are looking for an example package to fit
  266. into Red Hat Linux transparently, this would not be the one to
  267. pick.
  268. - attr-devel -> libattr-devel