WebKit3-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit3
  15. Version: 2.4.11
  16. Release: 3%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk3-devel
  32. BuildRequires: at-spi2-core-devel
  33. BuildRequires: gtk2-devel
  34. BuildRequires: harfbuzz-icu-devel
  35. BuildRequires: libjpeg-turbo-devel
  36. BuildRequires: libtool
  37. BuildRequires: libxslt-devel
  38. BuildRequires: libXt-devel
  39. BuildRequires: pcre-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: geoclue-devel
  42. BuildRequires: gcr-devel
  43. BuildRequires: gstreamer1-devel
  44. BuildRequires: gstreamer1-plugins-base-devel
  45. BuildRequires: enchant-devel
  46. BuildRequires: libwebp-devel
  47. BuildRequires: libsecret-devel
  48. BuildRequires: gobject-introspection-devel
  49. BuildRequires: gsettings-desktop-schemas
  50. BuildRequires: gtk-doc
  51. %if %{with pango}
  52. BuildRequires: pango-devel
  53. %else
  54. BuildRequires: cairo-devel
  55. BuildRequires: fontconfig-devel
  56. BuildRequires: freetype2-devel
  57. %endif
  58. BuildRequires: libsoup-devel >= 2.28.2
  59. %description
  60. WebKit is an open source web browser engine.
  61. %package gtk
  62. Summary: GTK+ port of WebKit
  63. Summary(ja): WebKit の GTK+ ポート
  64. Group: Development/Libraries
  65. Provides: webkitgtk3 = %{version}-%{release}
  66. %description gtk
  67. %{name} is an open-source Web content engine library. This package contains
  68. the shared libraries for the WebKit GTK+ port as well as the sample
  69. GtkLauncher tool.
  70. %package gtk-devel
  71. Summary: Development package for %{name}
  72. Summary(ja): %{name} の開発パッケージ
  73. Group: Development/Libraries
  74. Provides: webkitgtk3-devel = %{version}-%{release}
  75. Requires: %{name}-gtk = %{version}-%{release}
  76. Requires: pkgconfig
  77. Requires: gtk3-devel
  78. Requires: libsoup-devel >= 2.28.2
  79. %description gtk-devel
  80. The %{name}-gtk-devel package contains libraries, build data, and header
  81. files for developing applications that use %{name}-gtk.
  82. Please note that the WebKit/GTK+ API is not yet stable. This should
  83. only be used as a "preview" rather than a stable platform library.
  84. %package docs
  85. Summary: Documentation for %{name}
  86. Summary(ja): %{name} のドキュメント
  87. Group: Documentation
  88. BuildArch: noarch
  89. Provides: webkitgtk3-docs = %{version}-%{release}
  90. Provides: %{name}-doc = %{version}-%{release}
  91. %description docs
  92. %{name} is an open-source Web content engine library. This package contains
  93. the documentation for %{name}, including various LICENSE, README, and
  94. AUTHORS files.
  95. %prep
  96. %setup -q -n webkitgtk-%{version}
  97. perl -pi -e 's/static_cast/reinterpret_cast/' ./Source/WebKit2/Shared/API/c/WKString.cpp
  98. %build
  99. autoreconf -ifv
  100. CXXFLAGS="%{optflags} -fpermissive --std=c++11" \
  101. %configure \
  102. --with-gtk=3.0 \
  103. --with-gstreamer=1.0 \
  104. --enable-icon-database \
  105. --enable-geolocation \
  106. --enable-introspection=yes \
  107. --enable-dependency-tracking \
  108. %{?with_coverage: --enable-coverage } \
  109. %{?with_pango: --with-font-backend=pango } \
  110. %{?with_wml: --enable-wml }
  111. make %{?_smp_mflags}
  112. #make V=1
  113. # workaround for bug 488112
  114. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  115. ##touch JavaScriptCore/AllInOneFile.cpp
  116. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  117. %install
  118. rm -rf %{buildroot}
  119. make install DESTDIR=%{buildroot}
  120. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  121. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  122. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  123. # conflict with WebKit-doc
  124. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
  125. # Finally, copy over and rename the various files for %%doc inclusion.
  126. %add_to_doc_files Source/WebKit/LICENSE
  127. %add_to_doc_files Source/WebKit/gtk/NEWS
  128. %add_to_doc_files Source/WebCore/icu/LICENSE
  129. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  130. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  131. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  132. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  133. %add_to_doc_files Source/JavaScriptCore/THANKS
  134. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  135. %add_to_doc_files Source/JavaScriptCore/icu/README
  136. %find_lang WebKitGTK-3.0
  137. %clean
  138. rm -rf %{buildroot}
  139. %post gtk -p /sbin/ldconfig
  140. %posttrans gtk
  141. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  142. %postun gtk
  143. /sbin/ldconfig
  144. if [ $1 -eq 0 ] ; then
  145. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  146. fi
  147. # %files -f webkit.lang gtk
  148. %files gtk -f WebKitGTK-3.0.lang
  149. %defattr(-,root,root,-)
  150. %{_bindir}/jsc-3
  151. %{_libdir}/*.so.*
  152. %{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
  153. %{_libdir}/girepository-1.0/*.typelib
  154. %{_libexecdir}/WebKit3/
  155. %{_libexecdir}/WebKitNetworkProcess
  156. %{_libexecdir}/WebKitPluginProcess
  157. %{_libexecdir}/WebKitWebProcess
  158. %{_datadir}/webkitgtk-3.0/*
  159. %files gtk-devel
  160. %defattr(-,root,root,-)
  161. %exclude %{_libdir}/*.la
  162. %{_includedir}/webkitgtk-3.0
  163. %{_libdir}/*.so
  164. %{_libdir}/pkgconfig/*.pc
  165. %{_datadir}/gir-1.0/*.gir
  166. %files docs -f docfiles.list
  167. %defattr(-,root,root,-)
  168. %changelog
  169. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-3
  170. - rebuilt with libicu-60.2.
  171. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-2
  172. - rebuilt with new toolchain.
  173. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
  174. - new upstream release
  175. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
  176. - rebuild with icu-56.1
  177. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
  178. - new upstream release
  179. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
  180. - new upstream release
  181. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
  182. - new upstream release
  183. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
  184. - new upstream release
  185. * Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
  186. - new upstream release
  187. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
  188. - new upstream release
  189. * Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
  190. - new upstream release
  191. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
  192. - new upstream release
  193. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
  194. - new upstream release
  195. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
  196. - new upstream release
  197. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
  198. - rebuild with icu-52.1
  199. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
  200. - new upstream release
  201. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
  202. - new upstream release
  203. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
  204. - new upstream release
  205. - add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
  206. - change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
  207. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  208. - new upstream release
  209. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  210. - new upstream release
  211. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  212. - new upstream release
  213. - add BuildRequires: ruby, gtk2-devel
  214. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  215. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
  216. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  217. - new upstream release
  218. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  219. - new upstream release
  220. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  221. - new upstream release
  222. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  223. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  224. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  225. - new upstream release
  226. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  227. - new upstream release
  228. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  229. - new upstream release
  230. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  231. - initial build for Vine Linux