OpenColorIO-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %bcond_with bootstrap
  2. %bcond_with doc
  3. # Filter provides from Python libraries
  4. %{?filter_setup:
  5. %filter_provides_in %{python3_sitearch}.*\.so$
  6. %filter_setup
  7. }
  8. Name: OpenColorIO
  9. Version: 2.2.1
  10. Release: 1%{?_dist_release}
  11. Summary: Enables color transforms and image display across graphics apps
  12. Summary(ja): アプリケーション間での色変換と画像表示を行うためのライブラリ
  13. Group: system
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: BSD
  17. URL: https://opencolorio.org/
  18. # Github archive was generated on the fly using the following URL:
  19. # https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
  20. Source0: https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: cmake
  23. BuildRequires: git
  24. BuildRequires: help2man
  25. BuildRequires: python3-devel
  26. BuildRequires: python3-rpm-macros
  27. %if %{with doc}
  28. BuildRequires: texlive-collection-fontsrecommended
  29. BuildRequires: texlive-collection-latexextra
  30. BuildRequires: texlive-collection-latexrecommended
  31. %endif
  32. # Libraries
  33. BuildRequires: OpenEXR-devel
  34. BuildRequires: libboost-devel
  35. BuildRequires: expat-devel
  36. BuildRequires: freeglut-devel
  37. BuildRequires: glew-devel
  38. BuildRequires: libX11-devel libXmu-devel libXi-devel
  39. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  40. #BuildRequires: opencv-devel
  41. BuildRequires: pybind11-devel
  42. BuildRequires: python3-devel
  43. BuildRequires: python3-pip
  44. #BuildRequires: pystring-devel
  45. BuildRequires: zlib-devel
  46. %if %{without bootstrap}
  47. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  48. # If an ABI incompatible update is done in one, the other also needs to be
  49. # rebuilt.
  50. BuildRequires: OpenImageIO-devel
  51. BuildRequires: OpenImageIO-iv
  52. BuildRequires: OpenImageIO-utils
  53. %endif
  54. #######################
  55. # Unbundled libraries #
  56. #######################
  57. BuildRequires: lcms2-devel
  58. #BuildRequires: yaml-cpp-devel
  59. # The following bundled projects are only used for document generation.
  60. #BuildRequires: python-docutils
  61. #BuildRequires: python-jinja2
  62. #BuildRequires: python-pygments
  63. #BuildRequires: python-setuptools
  64. #BuildRequires: python-sphinx
  65. %if ! %{with doc}
  66. Obsoletes: %{name}-doc < %{version}-%{release}
  67. %endif
  68. %description
  69. OCIO enables color transforms and image display to be handled in a consistent
  70. manner across multiple graphics applications. Unlike other color management
  71. solutions, OCIO is geared towards motion-picture post production, with an
  72. emphasis on visual effects and animation color pipelines.
  73. %package devel
  74. Summary: Development libraries and headers for %{name}
  75. Summary(ja): %{name} の開発用ライブラリおよびヘッダファイル
  76. Group: programming
  77. Requires: %{name} = %{version}-%{release}
  78. %description devel
  79. Development libraries and headers for %{name}.
  80. %package doc
  81. Summary: API Documentation for %{name}
  82. Summary(ja): %{name} API のドキュメント
  83. Group: documentation
  84. BuildArch: noarch
  85. Requires: %{name} = %{version}-%{release}
  86. %description doc
  87. API documentation for %{name}.
  88. %debug_package
  89. %prep
  90. %autosetup -p1
  91. %build
  92. rm -rf %{_vpath_builddir}
  93. export CXXFLAGS="%{optflags} -Wno-deprecated-declarations -Wno-cast-function-type -Wno-unused-function"
  94. %cmake \
  95. -DPYTHON=%{__python3} \
  96. -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
  97. -DOCIO_BUILD_STATIC=OFF \
  98. %if %{with doc}
  99. -DOCIO_BUILD_DOCS=ON \
  100. %else
  101. -DOCIO_BUILD_DOCS=OFF \
  102. %endif
  103. -DOCIO_BUILD_TESTS=ON \
  104. -DOCIO_USE_HEADLESS=ON \
  105. -DOCIO_PYGLUE_SONAME=OFF \
  106. -DUSE_EXTERNAL_YAML=FALSE \
  107. -DUSE_EXTERNAL_LCMS=TRUE \
  108. %ifnarch x86_64
  109. -DOCIO_USE_SSE=OFF \
  110. %endif
  111. -DOpenGL_GL_PREFERENCE=GLVND
  112. %cmake_build
  113. %install
  114. rm -rf %{buildroot}
  115. %cmake_install
  116. # Remove static libs
  117. find %{buildroot} -type f -name "*.a" -exec rm -f {} \;
  118. # Generate man pages
  119. pushd %{_vpath_builddir}/src/apps
  120. mkdir -p %{buildroot}%{_mandir}/man1
  121. for app in ociobakelut ociocheck ociochecklut ocioconvert ociolutimage ociomakeclf ocioperf ociowrite; do \
  122. help2man -N -s 1 %{?fedora:--version-string=%{version}} \
  123. -o %{buildroot}%{_mandir}/man1/$app.1 \
  124. $app/$app
  125. done
  126. popd
  127. # Move installed documentation back so it doesn't conflict with the main package
  128. %if %{with doc}
  129. rm -rf _tmpdoc
  130. mkdir -p _tmpdoc
  131. mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
  132. %endif
  133. %check
  134. # Testing passes locally in mock but fails on the fedora build servers.
  135. #pushd build && make test
  136. %clean
  137. rm -rf %{buildroot}
  138. %files
  139. %license LICENSE
  140. %doc CHANGELOG* README*
  141. %{_bindir}/*
  142. %{_libdir}/*.so.*
  143. %dir %{_datadir}/ocio
  144. %{_datadir}/ocio/setup_ocio.sh
  145. %{_mandir}/man1/*
  146. %{python3_sitearch}/*.so
  147. %files devel
  148. %{_includedir}/OpenColorIO/
  149. %{_libdir}/*.so
  150. %dir %{_libdir}/pkgconfig
  151. %{_libdir}/pkgconfig/%{name}.pc
  152. %dir %{_libdir}/cmake
  153. %{_libdir}/cmake/*
  154. %if %{with doc}
  155. %files doc
  156. %doc _tmpdoc/*
  157. %endif
  158. %changelog
  159. * Thu Mar 02 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.1-1
  160. - new upstream release.
  161. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.1.0-1
  162. - new upstream release.
  163. - dropped ldconfig scriptlets.
  164. - dropped Patch1.
  165. - imported Patch0 from rawhide.
  166. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
  167. - new upstream release.
  168. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
  169. - rebuild with gcc-5.4.0
  170. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
  171. - Initial build for Vine Linux
  172. - used bundled yaml-cpp
  173. * Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
  174. - Rebuild against yaml-cpp03 compatibility package.
  175. * Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
  176. - Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
  177. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  179. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  181. * Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
  182. - Update to latest upstream release.
  183. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  185. * Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
  186. - Only use SSE instructions on x86_64.
  187. * Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
  188. - Misc spec cleanup for packaging guidelines.
  189. - Disable testing for now since it fails on the build servers.
  190. * Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
  191. - Latest upstream release.
  192. * Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
  193. - Latest upstream release.
  194. * Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
  195. - Initial release.