MySQL-python-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315
  1. %bcond_with debug
  2. Summary: An interface to MySQL
  3. Summary(ja): MySQL に対する python インターフェース
  4. Name: MySQL-python
  5. Version: 1.2.5
  6. Release: 2%{?_dist_release}
  7. License: GPLv2+
  8. Group: Development/Libraries
  9. URL: https://github.com/farcepest/MySQLdb1
  10. Source0: http://pypi.python.org/packages/source/M/%{name}/%{name}-%{version}.zip
  11. BuildRequires: python-devel python-setuptools
  12. BuildRequires: libmysqlclient-devel zlib-devel
  13. %if %{with debug}
  14. BuildRequires: python-debug
  15. %endif
  16. %description
  17. Python interface to MySQL
  18. MySQLdb is an interface to the popular MySQL database server for Python.
  19. The design goals are:
  20. - Compliance with Python database API version 2.0
  21. - Thread-safety
  22. - Thread-friendliness (threads will not block each other)
  23. - Compatibility with MySQL 3.23 and up
  24. This module should be mostly compatible with an older interface
  25. written by Joe Skinner and others. However, the older version is
  26. a) not thread-friendly, b) written for MySQL 3.21, c) apparently
  27. not actively maintained. No code from that version is used in MySQLdb.
  28. %if %{with debug}
  29. %package debug
  30. Summary: An interface to MySQL, built for the CPython debug runtime
  31. Group: Applications/System
  32. # Require the base package for the .py/.pyc files:
  33. Requires: MySQL-python%{_isa} = %{version}-%{release}
  34. %description debug
  35. Python interface to MySQL, built for the CPython debug runtime
  36. %endif # with debug
  37. %prep
  38. %setup -q -n %{name}-%{version}
  39. %build
  40. rm -f doc/*~
  41. export libdirname=%{_lib}
  42. CFLAGS="$RPM_OPT_FLAGS" python setup.py build
  43. %if %{with debug}
  44. CFLAGS="$RPM_OPT_FLAGS" python-debug setup.py build
  45. %endif
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. export libdirname=%{_lib}
  49. python setup.py install --root=$RPM_BUILD_ROOT
  50. #python setup.py install --root=$RPM_BUILD_ROOT ---record=INSTALLED_FILES
  51. %if %{with debug}
  52. python-debug setup.py install --root=$RPM_BUILD_ROOT
  53. %endif
  54. %check
  55. # You need MySQL (or MariaDB) running
  56. # and ~/.my.conf configured to have access rights
  57. #
  58. # cd tests/
  59. # python -m unittest test_MySQLdb_capabilities
  60. # python -m unittest test_MySQLdb_dbapi20
  61. # python -m unittest test_MySQLdb_nonstandard
  62. %clean
  63. rm -rf $RPM_BUILD_ROOT
  64. %files
  65. %doc README.md doc/*
  66. %dir %{python_sitearch}/MySQLdb
  67. %dir %{python_sitearch}/MySQLdb/constants
  68. %dir %{python_sitearch}/MySQL_python-%{version}-py2.7.egg-info
  69. %{python_sitearch}/MySQLdb/*.py*
  70. %{python_sitearch}/MySQLdb/constants/*.py*
  71. %{python_sitearch}/MySQL_python-%{version}-py2.7.egg-info/*
  72. %{python_sitearch}/*.py*
  73. %{python_sitearch}/*.so
  74. %if %{with debug}
  75. %files debug
  76. %{python_sitearch}/_mysql_d.so
  77. %endif
  78. %changelog
  79. * Tue Feb 3 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.2.5-2
  80. - Inital build for Vine Linux
  81. * Wed Jan 21 2015 Roman Rakus <roman@romanrakus.cz> - 1.2.5-1
  82. - Update to 1.2.5
  83. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-13
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  85. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-12
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  87. * Fri Mar 7 2014 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-11
  88. - explain how to run the tests
  89. Resolves: #1073847
  90. * Mon Nov 11 2013 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-10
  91. - added --without-debug option
  92. Related: #669835
  93. * Mon Nov 11 2013 Jakub Dorňák <jdornak@redhat.com> - 1.2.3-9
  94. - added debug subpackage
  95. Related: #669835
  96. * Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> - 1.2.3-8
  97. - Spec file clean-up, use proper python paths
  98. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-7
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  100. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-6
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  102. * Sat Jul 14 2012 Tom Lane <tgl@redhat.com> 1.2.3-5
  103. - Fix failure to enable SSL support with mysql 5.5, per Matthias Runge
  104. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-4
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  106. * Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 1.2.3-3
  107. - Rebuild for libmysqlclient 5.5.10 soname version bump
  108. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  110. * Fri Dec 24 2010 Tom Lane <tgl@redhat.com> 1.2.3-1
  111. - Update to final release of 1.2.3
  112. Resolves: #660484
  113. - Rebuild was needed anyway for mysql ABI break (no more libmysqlclient_r)
  114. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.2.3-0.5.c1
  115. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  116. * Mon Nov 23 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.4.c1
  117. - Fix format mismatch in _mysql_ConnectionObject_kill
  118. Resolves: #538234
  119. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.3-0.3.c1
  120. - rebuilt with new openssl
  121. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-0.2.c1
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  123. * Sun Jun 28 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.1.c1
  124. - Update to release candidate 1.2.3c1 for better mysql 5.1 and python 2.6
  125. compatibility
  126. Resolves: #505611
  127. - Use python-setuptools instead of distutils, stop using old setup.py
  128. Resolves: #467510
  129. - Remove unnecessary manual Requires: specifications
  130. Resolves: #507750
  131. * Wed Apr 15 2009 Karsten Hopp <karsten@redhat.com> 1.2.2-11
  132. - bump release and rebuild for s390x
  133. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-10
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  135. * Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 1.2.2-9
  136. - Rebuild for mysql 5.1
  137. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.2-8
  138. - Rebuild for Python 2.6
  139. * Thu Jun 19 2008 Tom Lane <tgl@redhat.com> 1.2.2-7
  140. - Fix broken escape() method
  141. Resolves: #331021
  142. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-6
  143. - Autorebuild for GCC 4.3
  144. * Wed Dec 5 2007 Tom Lane <tgl@redhat.com> 1.2.2-5
  145. - Rebuild for new openssl
  146. * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 1.2.2-4
  147. - Update License tag to match code.
  148. * Tue Jul 3 2007 Tom Lane <tgl@redhat.com> 1.2.2-3
  149. - Ooops, previous fix for quoting bug was wrong, because it converted the
  150. version_info tuple to a string in Python's eyes
  151. Resolves: #246366
  152. * Tue Jun 12 2007 Tom Lane <tgl@redhat.com> 1.2.2-2
  153. - Fix quoting bug in use of older setup.py: need to quote version_info now
  154. Resolves: #243877
  155. * Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 1.2.2-1
  156. - Update to 1.2.2, but not 1.2.2 setup.py (since we don't ship setuptools yet)
  157. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1_p2-2
  158. - rebuild for python 2.5
  159. * Wed Dec 6 2006 Tom Lane <tgl@redhat.com> 1.2.1_p2-1
  160. - Update to 1.2.1_p2
  161. * Fri Jul 21 2006 Tom Lane <tgl@redhat.com> 1.2.1-1
  162. - Update to 1.2.1
  163. - Remove hardwired python version number in favor of asking Python
  164. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2.1
  165. - rebuild
  166. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2
  167. - rebump for build order issues during double-long bump
  168. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.1
  169. - bump again for double-long bug on ppc(64)
  170. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2
  171. - rebuilt for new gcc4.1 snapshot and glibc changes
  172. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  173. - rebuilt
  174. * Wed Nov 9 2005 Tom Lane <tgl@redhat.com> 1.2.0-3
  175. - Rebuild due to mysql 5.0 update and openssl library update.
  176. * Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 1.2.0-2
  177. - package all python files. INSTALLED_FILES doesn't contain files created
  178. by the brp-python-bytecompile script
  179. * Thu Apr 21 2005 Tom Lane <tgl@redhat.com> 1.2.0-1
  180. - Update to 1.2.0, per bug #155341
  181. - Link against mysql 4.x not 3.x, per bug #150828
  182. * Sun Mar 6 2005 Tom Lane <tgl@redhat.com> 1.0.0-3
  183. - Rebuild with gcc4.
  184. * Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-2
  185. - bring us to python 2.4
  186. * Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-1
  187. - update to 1.0.0; rebuild against mysqlclient10
  188. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  189. - rebuilt
  190. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  191. - rebuilt
  192. * Fri Feb 20 2004 Tom Lane <tgl@redhat.com>
  193. - reinstate (and update) patch for /usr/lib64 compatibility
  194. - rebuilt
  195. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  196. - rebuilt
  197. * Tue Nov 25 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.2-1
  198. - update to 0.9.2
  199. - remove patches (no longer applicable)
  200. * Sat Nov 15 2003 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-10
  201. - bring us to python 2.3
  202. * Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-9
  203. - rebuilt
  204. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.9.1-8
  205. - rebuilt
  206. * Tue Mar 04 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-7
  207. - explicitly define the constants directory in case a more
  208. restrictive umask is encountered (#74019)
  209. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  210. - rebuilt
  211. * Wed Dec 11 2002 Tim Powers <timp@redhat.com> 0.9.1-5
  212. - lib64'ize
  213. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  214. - automated rebuild
  215. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  216. - automated rebuild
  217. * Mon May 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-2
  218. - Build for newer python
  219. * Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-1
  220. - 0.9.1
  221. * Tue Feb 26 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-6
  222. - Rebuild
  223. * Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 0.9.0-5
  224. - Change python conflicts to requires
  225. - Use pybasever/pynextver macros.
  226. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  227. - automated rebuild
  228. * Fri Sep 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-3
  229. - Build for Python 2.2
  230. * Mon Jul 23 2001 Trond Eivind Glomsrd <teg@redhat.com>
  231. - Add zlib-devel to buildrequires (#49788)
  232. * Tue Jun 19 2001 Trond Eivind Glomsrd <teg@redhat.com>
  233. - Initial build