ModemManager-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416
  1. %bcond_with systemd
  2. #%define git_snapshot .git20130607
  3. %define git_snapshot %{nil}
  4. #define ppp_version 2.4.7
  5. %define glib2_version 2.40
  6. Name: ModemManager
  7. Summary: Mobile broadband modem management service
  8. Summary(ja): モバイルブロードバンドモデム運用サービス
  9. Version: 1.20.6
  10. Release: 1%{git_snapshot}%{?_dist_release}%{?with_systemd:.systemd}
  11. Group: network,system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPLv2+
  15. URL: https://www.freedesktop.org/wiki/Software/ModemManager/
  16. Source: https://gitlab.freedesktop.org/mobile-broadband/ModemManager/-/archive/%{version}/ModemManager-%{version}.tar.bz2
  17. #https://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: glib2-devel >= %{glib2_version}
  20. BuildRequires: meson
  21. BuildRequires: gobject-introspection-devel
  22. BuildRequires: vala
  23. BuildRequires: vala-libs
  24. BuildRequires: polkit-devel
  25. BuildRequires: dbus-devel
  26. # for xsltproc
  27. BuildRequires: libxslt
  28. %if %{with systemd}
  29. BuildRequires: systemd-devel
  30. %{?systemd_requires}
  31. %endif
  32. BuildRequires: libgudev-devel
  33. Requires: dbus-glib
  34. %description
  35. The ModemManager service manages WWAN modems and provides a consistent API for
  36. interacting with these devices to client applications.
  37. %package devel
  38. Summary: Development tools for %{name}
  39. Summary(ja): %{name} の開発環境
  40. Group: programming
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description devel
  44. Header files and libraries for building a extension library for the %{name}.
  45. %package glib
  46. Summary: Libraries for adding ModemManager support to applications that use glib.
  47. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  48. Group: system
  49. Requires: glib2 >= %{glib2_version}
  50. %description glib
  51. This package contains the libraries that make it easier to use some ModemManager
  52. functionality from applications that use glib.
  53. %package glib-devel
  54. Summary: Development tools for %{name}-glib
  55. Summary(ja): %{name}-glib の開発環境
  56. Group: programming
  57. Requires: %{name}-glib = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. Requires: glib2-devel
  60. Requires: pkgconfig
  61. %description glib-devel
  62. Header files and libraries for building a extension library for the %{name}-glib.
  63. %debug_package
  64. %prep
  65. %setup -q
  66. %build
  67. %meson \
  68. -Ddist_version='"%{version}-%{release}"' \
  69. -Dvapi=true \
  70. -Dudevdir=/lib/udev \
  71. -Dpolkit=permissive \
  72. -Dbash_completion=false \
  73. -Dgtk_doc=false \
  74. -Dmbim=false \
  75. -Dqmi=false \
  76. -Dqrtr=false \
  77. -Dplugin_fibocom=disabled \
  78. -Dplugin_foxconn=disabled \
  79. -Dplugin_qcom_soc=disabled \
  80. %if %{with systemd}
  81. -Dsystemd_journal=true \
  82. -Dsystemd_suspend_resume=true \
  83. -Dsystemdsystemunitdir=%{_unitdir} \
  84. %else
  85. -Dsystemd_journal=false \
  86. -Dsystemd_suspend_resume=false \
  87. -Dsystemdsystemunitdir="no" \
  88. %endif
  89. %{nil}
  90. %meson_build
  91. %install
  92. %meson_install
  93. %find_lang %{name}
  94. mkdir -p %{buildroot}%{_datadir}/bash-completion/completions/
  95. cp -a cli/mmcli-completion %{buildroot}%{_datadir}/bash-completion/completions/mmcli
  96. %check
  97. %if %{with systemd}
  98. %post
  99. %systemd_post ModemManager.service
  100. %endif
  101. %if %{with systemd}
  102. %preun
  103. %systemd_preun ModemManager.service
  104. %endif
  105. %if %{with systemd}
  106. %postun
  107. %systemd_postun ModemManager.service
  108. %endif
  109. %files -f %{name}.lang
  110. %defattr(-,root, root,-)
  111. %license COPYING
  112. %doc README
  113. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  114. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  115. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  116. %attr(0755,root,root) %{_sbindir}/ModemManager
  117. %attr(0755,root,root) %{_bindir}/mmcli
  118. %dir %{_libdir}/%{name}
  119. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  120. %dir %{_datadir}/%{name}
  121. %{_datadir}/%{name}/*
  122. /lib/udev/rules.d/*
  123. %{_datadir}/dbus-1/interfaces/*.xml
  124. %{_datadir}/icons/hicolor/22x22/apps/*.png
  125. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  126. %{_mandir}/man1/*
  127. %{_mandir}/man8/*
  128. %dir %{_datadir}/bash-completion
  129. %dir %{_datadir}/bash-completion/completions
  130. %{_datadir}/bash-completion/completions/*
  131. %if %{with systemd}
  132. %{_unitdir}/*.service
  133. %endif
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %{_includedir}/ModemManager/*.h
  137. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  138. %{_libdir}/pkgconfig/%{name}.pc
  139. %files glib
  140. %defattr(-,root,root,-)
  141. %{_libdir}/libmm-glib.so.*
  142. %files glib-devel
  143. %defattr(-,root,root,-)
  144. %{_libdir}/libmm-glib.so
  145. %dir %{_includedir}/libmm-glib
  146. %{_includedir}/libmm-glib/*.h
  147. %{_libdir}/pkgconfig/mm-glib.pc
  148. %dir %{_datadir}/vala
  149. %dir %{_datadir}/vala/vapi
  150. %{_datadir}/vala/vapi/libmm-glib.*
  151. %changelog
  152. * Fri Apr 21 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.6-1
  153. - new upstream release.
  154. * Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.10-1
  155. - new upstream release.
  156. * Mon Aug 3 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
  157. - new upstream release.
  158. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  159. - new upstream release.
  160. * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  161. - new upstream release.
  162. - added elogind support.
  163. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
  164. - new upstream release.
  165. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  166. - new upstream release
  167. - change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
  168. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
  169. - fix spec file
  170. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  171. - fix spec file
  172. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  173. - new upstream release
  174. - add BuildRequires: gobject-introspection-devel, polkit-devel
  175. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  176. - new upstream release
  177. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  178. - new upstream release
  179. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  180. - new upstream release
  181. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  182. - new upstream release
  183. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  184. - new upstream release
  185. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  186. - moved ModemManager-glib to System Environment/Libraries Group
  187. - removed BR: ppp, ppp-devel and dbus-glib-devel
  188. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  189. - new upstream release
  190. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  191. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  192. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  193. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  194. - new upstream release
  195. - update Patch0
  196. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  197. - update to 0.7.991 snapshot
  198. - fix spec file based on FC package
  199. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  200. - Update to 0.7.991 snapshot
  201. - Fix SMS validity parsing
  202. - Allow registration changes to 'searching' without disconnecting
  203. - Fix reading SMS messages from some QMI-based devices
  204. - Increase connection timeout for Novatel E362
  205. - Fix PIN retries checking when unlocking Ericsson devices
  206. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  207. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  208. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  209. - new upstream release
  210. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  211. - new upstream release
  212. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  213. - delete Patch20
  214. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  215. - update Patch20 (ModemManager-0.4-git20110428.patch)
  216. - delete Patch21,22
  217. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  218. - update to 0.4
  219. - add Patch20 (ModemManager-0.4-git20100720.patch)
  220. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  221. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  222. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  223. - initial build for Vine Linux
  224. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  225. - core: ignore some failures on disconnect (rh #578280)
  226. - core: add support for platform serial devices
  227. - gsm: better Blackberry DUN support
  228. - gsm: periodically poll access technology
  229. - cdma: prevent crash on modem removal (rh #571921)
  230. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  231. - novatel: better signal strength reporting on CDMA cards
  232. - novatel: add access technology and mode preference support on GSM cards
  233. - zte: fix mode preference retrieval
  234. - longcheer: add support for Zoom modems (4595, 4596, etc)
  235. - longcheer: add access technology and mode preference support
  236. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  237. - Silence %%post
  238. - Update scripts
  239. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  240. - gsm: fix parsing Blackberry supported character sets response
  241. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  242. - mbm: fix retrieval of current allowed mode
  243. - gsm: fix initialization issues with some devices (like Blackberries)
  244. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  245. - core: fix detection of some generic devices (rh #579247)
  246. - core: fix detection regression of some Huawei devices in 0.3-5
  247. - cdma: periodically poll registration state and signal quality
  248. - cdma: really fix registration detection on various devices (rh #569067)
  249. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  250. - core: fix PPC/SPARC/etc builds
  251. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  252. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  253. - cdma: handle signal quality requests while connected for more devices
  254. - cdma: handle serving system requests while connected for more devices
  255. - gsm: determine current access technology earlier
  256. - huawei: work around automatic registration issues on some devices
  257. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  258. - core: ensure enabled modems are disabled when MM stops
  259. - core: better capability detection for Blackberry devices (rh #573510)
  260. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  261. - gsm: don't block modem when it requires PIN2
  262. - option: fix access technology updates
  263. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  264. - mbm: add device IDs for C3607w
  265. - mbm: fail earlier during connection failures
  266. - mbm: fix username/password authentication when checked by the network
  267. - hso: implement asynchronous signal quality updates
  268. - option: implement asynchronous signal quality updates
  269. - novatel: correctly handle CDMA signal quality
  270. - core: basic PolicyKit support
  271. - core: fix direct GSM registration information requests
  272. - core: general GSM PIN/PUK unlock fixes
  273. - core: poll GSM registration state internally for quicker status updates
  274. - core: implement GSM 2G/3G preference
  275. - core: implement GSM roaming allowed/disallowed preference
  276. - core: emit signals on access technology changes
  277. - core: better handling of disconnections
  278. - core: fix simple CDMA status requests
  279. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  280. - core: startup speed improvements
  281. - core: GSM PIN checking improvements
  282. - huawei: fix EVDO-only connections on various devices (rh #553199)
  283. - longcheer: add support for more devices
  284. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  285. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  286. - core: fix crashes when devices are unplugged during operation (rh #553953)
  287. - cdma: prefer primary port for status/registration queries
  288. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  289. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  290. - gsm: fix Nokia N80 network scan parsing
  291. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  292. - core: fix apparent hangs by limiting retried serial writes
  293. - gsm: ensure modem state is reset when disabled
  294. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  295. - sierra: fix CDMA registration detection in some cases (rh #547513)
  296. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  297. - sierra: ensure CDMA device is powered up when trying to use it
  298. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  299. - zte: handle unsolicited messages better during probing
  300. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  301. - cdma: fix signal strength reporting on some devices
  302. - cdma: better registration state detection when dialing (ex Sierra 5275)
  303. - option: always use the correct tty for dialing commands
  304. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  305. - core: fix reconnect after manual disconnect (rh #541314)
  306. - core: fix various segfaults during registration
  307. - core: fix probing of various modems on big-endian architectures (ie PPC)
  308. - core: implement modem states to avoid duplicate operations
  309. - hso: fix authentication for Icera-based devices like iCON 505
  310. - zte: use correct port for new devices
  311. - nozomi: fix detection
  312. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  313. - Update to latest git
  314. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  315. - cdma: wait for network registration before trying to connect
  316. - gsm: add cell access technology reporting
  317. - gsm: allow longer-running network scans
  318. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  319. - nokia: don't power down phones on disconnect
  320. - hso: fix disconnection/disable
  321. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  322. - Fixes for Motorola and Ericsson devices
  323. - Fixes for CDMA "serving-system" command parsing
  324. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  325. - Fix a typo in one of the udev rules files
  326. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  327. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  328. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  329. - Fix source repo location
  330. - Fix directory ownership
  331. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  332. - Initial version