netatalk-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define _sysconfdir /etc
  2. ################################################# BASIC PACKAGE INFORMATION
  3. Summary: AFP fileserver for Macintosh clients
  4. Summary(ja): Macintoshクライアント向けのAFPファイルサーバー
  5. Name: netatalk
  6. Version: 3.1.8
  7. Release: 2%{_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Daemons
  10. URL: http://netatalk.sourceforge.net/
  11. Source0: %{name}-%{version}.tar.bz2
  12. Source1: netatalk.pam-system-auth
  13. Patch0: netatalk-3.0.1-basedir.patch
  14. Patch1: netatalk-3.1.8-ipv6.patch
  15. ############################################################## REQUIREMENTS
  16. Requires(post): /sbin/chkconfig /sbin/ldconfig
  17. Requires(preun): /sbin/chkconfig
  18. Requires(preun): /sbin/service
  19. Requires(postun): /sbin/service /sbin/ldconfig
  20. BuildRequires: cracklib openssl-devel pam quota libtool automake
  21. BuildRequires: autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
  22. BuildRequires: avahi-devel libacl-devel openldap-devel
  23. BuildRequires: dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
  24. BuildRequires: libevent-devel libtdb-devel libmysqlclient-devel
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: shaolin, tomop
  29. %description
  30. Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
  31. system running Netatalk is capable of serving many Macintosh clients
  32. simultaneously as an AppleShare file server (AFP).
  33. %description -l ja
  34.  Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
  35. Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
  36. アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
  37. 可能です。
  38. %package devel
  39. Group: Development/Libraries
  40. Summary: Headers for Netatalk development
  41. Summary(ja): Netatalk開発用ヘッダファイル
  42. %description devel
  43. This package contains the header files for Netatalk.
  44. %prep
  45. %setup -q
  46. %patch0 -p1 -b .basedir
  47. %patch1 -p1 -b .ipv6
  48. ln -s ./NEWS ChangeLog
  49. %build
  50. export CFLAGS="$RPM_OPT_FLAGS"
  51. %ifnarch x86_64
  52. # XXX : enable for x86_64 when glibc bug 149284 is fixed!
  53. export CFLAGS="$CFLAGS -fPIE"
  54. export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
  55. #"export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen"
  56. #Also in case of i686, nodlopen causes the problem.
  57. %endif
  58. %configure \
  59. --with-pkgconfdir=%{_sysconfdir}/netatalk \
  60. --with-cracklib \
  61. --with-pam \
  62. --with-shadow \
  63. --with-uams-path=%{_libdir}/netatalk \
  64. --enable-shared \
  65. --enable-krbV-uam \
  66. --enable-overwrite \
  67. --with-gnu-ld \
  68. --with-init-style=redhat-sysv \
  69. --with-libgcrypt \
  70. --without-libevent \
  71. --without-tdb \
  72. --with-pam-confdir=%{_sysconfdir}/pam.d \
  73. --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d
  74. make %{?_smp_mflags} all
  75. %install
  76. ### INSTALL (USING "make install") ###
  77. rm -rf ${RPM_BUILD_ROOT}
  78. make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
  79. # install example config files in doc
  80. mkdir config.example
  81. cp -fp config/afp.conf config.example
  82. cp -fp config/extmap.conf config.example
  83. mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
  84. cp -fp %{SOURCE1} config.example
  85. # XXX bad hack until this file is updated in glibc-headers:
  86. rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
  87. # Clean up .a and .la files
  88. find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
  89. find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
  90. %post
  91. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
  92. mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
  93. fi
  94. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
  95. mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
  96. fi
  97. /sbin/chkconfig --add netatalk
  98. /sbin/ldconfig
  99. %preun
  100. if [ "$1" = "0" ] ; then
  101. # check for existence due to renaming initscript
  102. if [ -x %{_initrddir}/netatalk ] ; then
  103. /sbin/service netatalk stop > /dev/null 2>&1
  104. /sbin/chkconfig --del netatalk
  105. fi
  106. fi
  107. %postun
  108. if [ "$1" -ge "1" ]; then
  109. # Package upgrade, not uninstall
  110. if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
  111. mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
  112. fi
  113. if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
  114. mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
  115. fi
  116. /sbin/service netatalk condrestart > /dev/null 2>&1 || :
  117. fi
  118. /sbin/ldconfig
  119. %clean
  120. rm -rf ${RPM_BUILD_ROOT}
  121. %files
  122. %defattr(-,root,root)
  123. %doc COPYRIGHT COPYING ChangeLog VERSION NEWS
  124. %doc config.example
  125. %attr(755,root,root) %{_initrddir}/netatalk
  126. %dir %{_sysconfdir}/netatalk
  127. %config(noreplace) %{_sysconfdir}/netatalk/afp.conf
  128. %config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
  129. %config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
  130. %config(noreplace) %{_sysconfdir}/pam.d/netatalk
  131. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
  132. %{_sbindir}/*
  133. %{_bindir}/*
  134. %exclude %{_bindir}/netatalk-config
  135. %{_mandir}/man*/*
  136. %exclude %{_mandir}/man*/netatalk-config*
  137. %{_datadir}/netatalk
  138. %{_libdir}/*.so
  139. %{_libdir}/*.so.*
  140. %dir %{_libdir}/netatalk
  141. %{_libdir}/netatalk/*.so
  142. %{_localstatedir}/netatalk
  143. %files devel
  144. %defattr(-,root,root)
  145. %doc COPYRIGHT COPYING
  146. %dir %{_includedir}/atalk
  147. %attr(0644,root,root) %{_includedir}/atalk/*
  148. %{_datadir}/aclocal/netatalk.m4
  149. %{_bindir}/netatalk-config
  150. %{_mandir}/man*/netatalk-config.1*
  151. %changelog
  152. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
  153. - added Patch1.
  154. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
  155. - new upstream release.
  156. * Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
  157. - new upstream release.
  158. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
  159. - rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
  160. * Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
  161. - new upstream release.
  162. - added build option 'force_uidgid'.
  163. * Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
  164. - new upstream release
  165. - fix configure options; add missing BRs
  166. * Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
  167. - now back from the upstream confusion (and one more or two...)
  168. new upstream release 2.2.0 at the official site
  169. * Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
  170. - fix Patch10 to follow HAT-san's strong and confident objection
  171. (no need to set ATALK_NAME explicitly in netatalk.conf)
  172. * Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
  173. - new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
  174. - add Source100 to add one missing header file in the tarball
  175. - revise Patch10
  176. - explicitly specify --disable-ddp for the first time
  177. * Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
  178. - new upstream release
  179. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
  180. - rebuild with openssl-1.0.0c
  181. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
  182. - fix Patch10 & update description - upon HAT-san's suggestions
  183. * Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
  184. - new upstream release
  185. - update Vine patch
  186. * Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
  187. - new upstream release
  188. * Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  189. - new upstream release
  190. * Sun Mar 8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
  191. - rebuilt both for VineSeed / VinePlus-4.0
  192. * Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
  193. - updated to the cjk-6 patch
  194. - Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
  195. - Patch14 updated for db46
  196. * Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
  197. - remove openslp dependency
  198. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
  199. - add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
  200. - TODO: remember to revise this fix after VineSeed changes default locale
  201. from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
  202. * Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
  203. - revise description (thanks HAT-san for pointing this out)
  204. - run libtoolize/aclocal/auto{make,conf,header} before doing configure
  205. (without this, uams_* modules won't get .so suffix)
  206. * Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
  207. - Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
  208. (Patch10 now includes all the modifications and more fixes)
  209. * Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
  210. - add patch13 and patch14 for db-4.3.
  211. - move files in %%_libexecdir to %%libdir.
  212. * Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
  213. - updated to 2.0.3 release w/ cjk patches (see the above Patch section)
  214. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  215. - security fix: added Patch10 (CAN-2004-0974)
  216. * Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  217. - configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
  218. * Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
  219. - updated to 2.0 with cjk patch
  220. (see the above Patch section for details)
  221. * Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
  222. - merge the patch repairing bug for System 7.5.5
  223. - (patch6 netatalk-1.5.3.oldsys.patch)
  224. - made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
  225. - patch6 addupted no matter noeuc is, license GPL, URL in comment
  226. * Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
  227. - euc and kana patch originally by
  228. - Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
  229. - applied to netatalk-1.5.2 by me
  230. - README.vine
  231. - omit VERSION from doc, omit perl from require
  232. * Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
  233. - this package is removed because the release number duplicated
  234. * Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
  235. - move acleandir.rc to the doc directory, remove executable flag.
  236. * Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
  237. - updated to new upstream release
  238. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
  239. - added Japanese Summary for devel and corrected Group
  240. * Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
  241. - Oops, check /var/lock/atalkd instead of /var/run/atd.pid
  242. (say atd.pid doesn't have anything to do with netatalk!!)
  243. * Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
  244. - updated to new upstream release
  245. * Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
  246. - install man pages into %%{_mandir}
  247. - PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
  248. - let pre script exit 0
  249. * Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
  250. - spec cleanup
  251. - backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
  252. - restart atalk daemons in the %%post section
  253. * Sun Feb 3 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  254. - v1.5.1.1-0vl1
  255. * Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
  256. - v1.5.0-0vl1
  257. - release 1.5.0 for sourceforge
  258. * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  259. - v1.5pre6-1rh7
  260. - pre-release 6 for sourceforge
  261. * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  262. - v1.5pre5-1
  263. - pre-release 5 for sourceforge
  264. * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  265. - v1.5pre5-0
  266. - pre-release 5 for sourceforge (prebuild)
  267. * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  268. - v1.5pre4-1
  269. - pre-release 4 for sourceforge
  270. - modified/split mandrake spec for redhat 7 build
  271. * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  272. - v1.5pre3-1mdk
  273. - pre-release 3 for sourceforge
  274. - moved away from 1.4.99 ...
  275. * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  276. - v1.4.99-0.20001108mdk
  277. - pre-release 2 for sourceforge
  278. * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  279. - v1.4.99-0.20000927mdk
  280. - pre-release 1 for sourceforge