qt5-qtlocation-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %global qt_module qtlocation
  2. # define to build docs, need to undef this for bootstrapping
  3. # where qt5-qttools builds are not yet available
  4. # only primary archs (for now), allow secondary to bootstrap
  5. #global bootstrap 1
  6. %if ! 0%{?bootstrap}
  7. %ifarch %{arm} %{ix86} x86_64
  8. #define docs 1
  9. %endif
  10. %endif
  11. #define prerelease
  12. %global qt5_minorver 5.12
  13. %global qt5_version 5.12.8
  14. #global qt5_patchlevel 1
  15. Summary: Qt5 - Location component
  16. Name: qt5-%{qt_module}
  17. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  18. Release: 1%{?_dist_release}
  19. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  20. License: LGPLv2 with exceptions or GPLv3 with exceptions
  21. Url: https://www.qt.io/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  25. # build failure with gcc10
  26. # various C++ runtime headers indirectly included <string> which in turn
  27. # included <local> and <cerrno>. Those indirect inclusions have been
  28. # eliminated which in turn forces packages to include the C++ headers they
  29. # actually need.
  30. Patch0: qtlocation-gcc10.patch
  31. # filter plugin/qml provides
  32. %global __provides_exclude_from ^(%{_qt5_archdatadir}/qml/.*\\.so|%{_qt5_plugind
  33. ir}/.*\\.so)$
  34. BuildRequires: cmake
  35. BuildRequires: qt5-rpm-macros
  36. BuildRequires: qt5-srpm-macros
  37. BuildRequires: qt5-qtbase-devel >= %{version}
  38. BuildRequires: qt5-qtdeclarative-devel >= %{version}
  39. # QtPositioning core-private
  40. BuildRequires: qt5-qtbase-private-devel
  41. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  42. BuildRequires: pkgconfig(icu-i18n)
  43. BuildRequires: openssl-devel
  44. BuildRequires: zlib-devel
  45. %description
  46. The Qt Location and Qt Positioning APIs gives developers the ability to
  47. determine a position by using a variety of possible sources, including
  48. satellite, or wifi, or text file, and so on.
  49. %package devel
  50. Summary: Development files for %{name}
  51. Requires: %{name}%{?_isa} = %{version}-%{release}
  52. Requires: qt5-qtbase-devel%{?_isa}
  53. %description devel
  54. %{summary}.
  55. %if 0%{?docs}
  56. %package doc
  57. Summary: API documentation for %{name}
  58. Requires: %{name} = %{version}-%{release}
  59. BuildRequires: qt5-qdoc
  60. BuildRequires: qt5-qhelpgenerator
  61. BuildArch: noarch
  62. %description doc
  63. %{summary}.
  64. %endif
  65. %package examples
  66. Summary: Programming examples for %{name}
  67. Requires: %{name}%{?_isa} = %{version}-%{release}
  68. %description examples
  69. %{summary}.
  70. %prep
  71. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  72. %patch0 -p1 -b .gcc10
  73. %build
  74. mkdir %{_target_platform}
  75. pushd %{_target_platform}
  76. %{qmake_qt5} ..
  77. make %{?_smp_mflags}
  78. %if 0%{?docs}
  79. make %{?_smp_mflags} docs
  80. %endif
  81. popd
  82. %install
  83. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  84. %if 0%{?docs}
  85. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  86. %endif
  87. ## .prl/.la file love
  88. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  89. pushd %{buildroot}%{_qt5_libdir}
  90. for prl_file in libQt5*.prl ; do
  91. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  92. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  93. rm -fv "$(basename ${prl_file} .prl).la"
  94. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  95. fi
  96. done
  97. popd
  98. %post -p /sbin/ldconfig
  99. %postun -p /sbin/ldconfig
  100. %files
  101. %license LICENSE.GPL* LICENSE.LGPL*
  102. %{_qt5_libdir}/libQt5Location.so.5*
  103. %{_qt5_archdatadir}/qml/QtLocation/
  104. %{_qt5_plugindir}/geoservices/
  105. %{_qt5_libdir}/libQt5Positioning.so.5*
  106. %dir %{_qt5_archdatadir}/qml/QtPositioning
  107. %{_qt5_archdatadir}/qml/QtPositioning/*
  108. %{_qt5_plugindir}/position/
  109. %{_qt5_libdir}/libQt5PositioningQuick.so.5*
  110. %dir %{_qt5_archdatadir}/qml/Qt
  111. %dir %{_qt5_archdatadir}/qml/Qt/labs
  112. %{_qt5_archdatadir}/qml/Qt/labs/location
  113. %files devel
  114. %{_qt5_headerdir}/QtLocation/
  115. %{_qt5_libdir}/libQt5Location.so
  116. %{_qt5_libdir}/libQt5Location.prl
  117. %{_qt5_headerdir}/QtPositioning/
  118. %{_qt5_libdir}/libQt5Positioning.so
  119. %{_qt5_libdir}/libQt5Positioning.prl
  120. %{_qt5_headerdir}/QtPositioningQuick/
  121. %{_qt5_libdir}/libQt5PositioningQuick.so
  122. %{_qt5_libdir}/libQt5PositioningQuick.prl
  123. %{_qt5_libdir}/pkgconfig/Qt5Location.pc
  124. %dir %{_qt5_libdir}/cmake/Qt5Location
  125. %{_qt5_libdir}/cmake/Qt5Location/Qt5Location*.cmake
  126. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_location*.pri
  127. %{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
  128. %dir %{_qt5_libdir}/cmake/Qt5Positioning
  129. %{_qt5_libdir}/cmake/Qt5Positioning/Qt5Positioning*.cmake
  130. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  131. %{_qt5_libdir}/pkgconfig/Qt5PositioningQuick.pc
  132. %dir %{_qt5_libdir}/cmake/Qt5PositioningQuick/
  133. %{_qt5_libdir}/cmake/Qt5PositioningQuick/Qt5PositioningQuick*.cmake
  134. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
  135. %if 0%{?docs}
  136. %files doc
  137. %license LICENSE.FDL
  138. %{_qt5_docdir}/qtlocation.qch
  139. %{_qt5_docdir}/qtlocation/
  140. %{_qt5_docdir}/qtpositioning.qch
  141. %{_qt5_docdir}/qtpositioning/
  142. %endif
  143. %if 0%{?_qt5_examplesdir:1}
  144. %files examples
  145. %{_qt5_examplesdir}/
  146. %endif
  147. %changelog
  148. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  149. - new upstream release.
  150. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  151. - new upstream release.
  152. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  153. - new upstream release.
  154. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  155. - new upstream release.
  156. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  157. - initial build for Vine Linux.
  158. - new upstream release.
  159. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  160. - drop pkgconfig-style Qt5 deps
  161. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  162. - Update to 5.6.1
  163. * Thu Apr 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
  164. - BR: qt5-qtbase-private-devel
  165. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  166. - rebuild
  167. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  168. - rebuild
  169. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  170. - 5.6.0 final release
  171. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
  172. - Update to final RC
  173. * Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.9.rc
  174. - rebuild
  175. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
  176. - Update RC release
  177. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  179. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
  180. - update source URL, use %%license, BR: cmake
  181. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
  182. - Update to final beta release
  183. * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
  184. - (re) add bootstrap macro support
  185. - drop geoclue(1) dep (unused at build time anyway (#1286886)
  186. - drop (deprecated) gypsy support (#1069225)
  187. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  188. - Official beta release
  189. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  190. - (re)add bootstrap macro support
  191. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  192. - Start to implement 5.6.0 beta
  193. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  194. - Update to final release 5.5.1
  195. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  196. - Update to Qt 5.5.1 RC1
  197. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  198. - -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
  199. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  200. - tighten qtbase dep (#1233829), .spec cosmetics, (re)enable docs
  201. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  202. - New final upstream release Qt 5.5.0
  203. * Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  204. - Update for official RC1 released packages
  205. * Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
  206. - Qt 5.5.0 RC1
  207. * Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
  208. - 5.4.2
  209. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  210. - Rebuilt for GCC 5 C++11 ABI change
  211. * Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
  212. - rebuild (gcc5)
  213. * Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
  214. - 5.4.1
  215. * Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
  216. - rebuild (gcc5)
  217. * Wed Dec 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-2
  218. - BR: pkgconfig(Qt5Qml) > 5.4.0 (#1177986)
  219. * Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
  220. - 5.4.0 (final)
  221. * Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
  222. - 5.4.0-rc
  223. * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
  224. - out-of-tree build, use %%qmake_qt5
  225. * Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
  226. - 5.4.0-beta
  227. * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  228. - 5.3.2
  229. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  230. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  231. * Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
  232. - 5.3.1
  233. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  235. * Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
  236. - 5.3.0
  237. * Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  238. - sanitize .prl file(s)
  239. * Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  240. - 5.2.1
  241. * Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
  242. - build -examples only when supported
  243. * Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
  244. - -examples subpkg
  245. * Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
  246. - first try