tomoe-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. # to activate, add --with [python|ruby] to rpmbuild
  2. %bcond_with python
  3. %bcond_with ruby
  4. Summary: Japanese handwritten input system
  5. Summary(ja): 日本語手書き文字認識エンジン
  6. Name: tomoe
  7. Version: 0.6.0
  8. Release: 3%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPLv2
  11. URL: http://tomoe.sourceforge.jp/
  12. Source0: tomoe-%{version}.tar.gz
  13. Patch0: tomoe-0.6.0-multiarch-conflict.patch
  14. Patch1: tomoe-0.6.0-bz502662.patch
  15. Patch2: tomoe-0.6.0-fixes-glib-includes.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: gettext
  18. BuildRequires: glib2-devel >= 2.4.0
  19. BuildRequires: gtk-doc >= 1.4
  20. BuildRequires: intltool
  21. BuildRequires: libtool
  22. BuildRequires: perl(XML::Parser)
  23. BuildRequires: python
  24. %if %{with python}
  25. BuildRequires: pygobject-devel
  26. BuildRequires: pygtk2-devel
  27. BuildRequires: python-devel
  28. %endif
  29. %if %{with ruby}
  30. BuildRequires: ruby-gnome2-devel
  31. %endif
  32. ## for extra dictionary backends
  33. #BuildRequires: mysql-devel, subversion-devel, hyperestraier-devel
  34. %if %{with python}
  35. Requires: python
  36. Provides: python-tomoe = %{version}-%{release}
  37. %endif
  38. %description
  39. A program which does Japanese handwriting recognition.
  40. %description -l ja
  41. 日本語の手書き文字を認識するエンジンです。
  42. %package devel
  43. Summary: Header files for developing tomoe applications
  44. Summary(ja): tomoe アプリケーション開発用ヘッダファイル
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: pkgconfig
  48. %if %{with python}
  49. Requires: pygobject-devel
  50. Provides: python-tomoe-devel = %{version}-%{release}
  51. %endif
  52. %description devel
  53. The tomoe-devel package includes the header files for the tomoe package.
  54. Install this package if you want to develop programs which use tomoe.
  55. %description -l ja devel
  56. tomoe-devel パッケージには、tomoe を使うアプリケーションを開発するための
  57. ヘッダファイルが含まれています。
  58. %if %{with ruby}
  59. %package -n ruby-tomoe
  60. Summary: Tomoe library for Ruby
  61. Summary(ja): Ruby から巴を使うためのライブラリ
  62. Group: System Environment/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: ruby
  65. %description -n ruby-tomoe
  66. Ruby extension library to use Tomoe
  67. %description -l ja -n ruby-tomoe
  68. Ruby から巴を使うための拡張ライブラリです。
  69. %package -n ruby-tomoe-devel
  70. Summary: Header files for developing ruby-tomoe applications
  71. Summary(ja): ruby-tomoe アプリケーション開発用ヘッダファイル
  72. Group: Development/Libraries
  73. Requires: ruby-tomoe = %{version}-%{release}
  74. Requires: %{name}-devel = %{version}-%{release}
  75. %description -n ruby-tomoe-devel
  76. The ruby-tomoe-devel package includes the header files for the ruby-tomoe
  77. package.
  78. Install this package if you want to develop programs which use ruby-tomoe.
  79. %description -l ja -n ruby-tomoe-devel
  80. ruby-tomoe-devel パッケージには、ruby-tomoe を使うアプリケーションを開発
  81. するためのヘッダファイルが含まれています。
  82. %endif
  83. %prep
  84. %setup -q
  85. %patch0 -p0 -b .multiarch-conflict
  86. %patch1 -p0 -b .bz502662
  87. %patch2 -p1 -b .glib
  88. %build
  89. autoreconf -vif
  90. %configure \
  91. --disable-static \
  92. --enable-silent-rules \
  93. %if %{without python}
  94. --without-python \
  95. %endif
  96. %if %{with ruby}
  97. --with-ruby-extdir=%{rarchdir} \
  98. --with-ruby-libdir=%{rlibdir} \
  99. %else
  100. --without-ruby \
  101. %endif
  102. --enable-gtk-doc
  103. make %{?_smp_mflags}
  104. %install
  105. rm -rf $RPM_BUILD_ROOT
  106. make DESTDIR=$RPM_BUILD_ROOT install
  107. %if %{with ruby}
  108. #rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/tomoe.rb $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*-linux/*
  109. chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/xml2est.rb
  110. %endif
  111. # remove unneeded files
  112. rm -f $RPM_BUILD_ROOT%{_libdir}/tomoe/module/dict/libmysql.*
  113. rm -f $RPM_BUILD_ROOT%{_libdir}/tomoe/module/dict/libsvn.*
  114. find $RPM_BUILD_ROOT -name '*.la' | xargs rm
  115. #%if !%{with ruby}
  116. #rm -rf %{buildroot}%{rarchdir}
  117. #rm -rf %{buildroot}%{rlibdir}
  118. #endif
  119. %find_lang %{name}
  120. %clean
  121. rm -rf $RPM_BUILD_ROOT
  122. %post -p /sbin/ldconfig
  123. %postun -p /sbin/ldconfig
  124. %files -f %{name}.lang
  125. %defattr(-,root,root,-)
  126. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  127. %dir %{_sysconfdir}/tomoe
  128. %config(noreplace) %{_sysconfdir}/tomoe/config
  129. %{_libdir}/*.so.*
  130. %if %{with python}
  131. %{_libdir}/python?.?/site-packages/tomoe.so
  132. %endif
  133. %dir %{_libdir}/tomoe
  134. %dir %{_libdir}/tomoe/module
  135. %dir %{_libdir}/tomoe/module/dict
  136. %{_libdir}/tomoe/module/dict/*.so
  137. %dir %{_libdir}/tomoe/module/recognizer
  138. %{_libdir}/tomoe/module/recognizer/*.so
  139. %{_datadir}/tomoe
  140. %files devel
  141. %defattr(-,root,root,-)
  142. %{_includedir}/tomoe
  143. %{_libdir}/pkgconfig/*.pc
  144. %{_libdir}/*.so
  145. %{_datadir}/gtk-doc/html/tomoe
  146. %if %{with ruby}
  147. %files -n ruby-tomoe
  148. %defattr(-,root,root,-)
  149. %{rarchdir}/*.so.*
  150. %{rlibdir}/tomoe.rb
  151. %files -n ruby-tomoe-devel
  152. %defattr(-,root,root,-)
  153. %{rarchdir}/*.h
  154. %{rarchdir}/*.so
  155. %endif
  156. %changelog
  157. * Mon Nov 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.0-3
  158. - rebuilt on current VineSeed
  159. - added Patch1 and 2 from Fedora
  160. * Tue Jul 24 2012 Peng Wu <pwu@redhat.com> - 0.6.0-22
  161. - Fixes glib includes
  162. * Tue Jun 2 2009 Ding-Yi Chen <dchen at redhat.com> - 0.6.0-14
  163. - [Bug 502662] SCIM-tomoe doesn't load - no error msgs
  164. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2
  165. - rebuilt with rpm-4.8.1 for pkg-config
  166. * Sun May 31 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
  167. - new upstream release
  168. - added --disable-static in %%configure
  169. - applied tomoe-0.6.0-multiarch-conflict.patch
  170. * Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.1-1vl5
  171. - applied new versioning policy, spec in utf-8
  172. - remove *.la
  173. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.1-0vl1
  174. - new upstream release
  175. * Sun Jan 07 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl3
  176. - disable ruby extension by default
  177. * Fri Jan 05 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl2
  178. - move from tomoe-devel to tomoe
  179. - %%{_libdir}/tomoe/module/dict/*.so
  180. - %%{_libdir}/tomoe/module/recognizer/*.so
  181. * Sat Dec 31 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl1
  182. - new upstream release
  183. - add BuildRequires: unzip
  184. - update %%files section
  185. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.4.0-0vl1
  186. - new upstream release
  187. - update dependencies
  188. - drop BuildRequires: libxml2-devel, libxslt-devel, doxygen
  189. - add BuildRequires:
  190. - gtk-doc, libxslt, glib2-devel
  191. - ruby-devel, ruby-gnome2-devel
  192. - drop Requires: libxml2, libxslt
  193. - add Requires: glib2
  194. - add new sub-package: ruby-tomoe
  195. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl2
  196. - oops, add Requires: libxml2, libxslt instead of *-devel
  197. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl1
  198. - new upstream release
  199. - add BuildRequires: libxml2-devel, libxslt-devel, doxygen
  200. - add Requires: pkgconfig to -devel package
  201. - update %%files
  202. * Mon Nov 07 2005 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.2.1-3vl1
  203. - initial release for Vine Linux
  204. - disable %%__libtoolize
  205. - add Japanase summary and description
  206. * Sat Sep 3 2005 Warren Togami <wtogami@redhat.com> - 0.2.1-3
  207. - some spec cleanup
  208. * Sat Sep 2 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-2
  209. - Sync with Jens's spec file
  210. * Wed Aug 31 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-1
  211. - Initial packaging for Extras
  212. * Fri Jul 1 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
  213. - (0.2.0-1m)
  214. - version 0.2.0
  215. - add a package tomoe-devel
  216. - add %%post and %%postun sections
  217. * Wed Mar 2 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
  218. - (0.1.1-1m)
  219. - initial package for Momonga Linux
  220. - import %%description from cooker