R-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479
  1. %define pkg_version 3.1.2
  2. %define pkg_release 2%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: GPLv2+
  9. Group: Applications/Edutainment
  10. URL: http://www.r-project.org
  11. Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
  12. Source1: R.desktop
  13. # Patch0: R-release.diff.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: gcc-gfortran libgfortran
  17. BuildRequires: texlive-common
  18. BuildRequires: texlive-collection-basic
  19. BuildRequires: texlive-collection-latexextra
  20. %if %{?_dist_release} == "vl6"
  21. BuildRequires: texlive-collection-texinfo
  22. BuildRequires: java-1.6.0-openjdk-devel
  23. %else
  24. BuildRequires: texlive-collection-plainextra
  25. BuildRequires: texlive-collection-fontsextra
  26. BuildRequires: texlive-collection-fontsrecommended
  27. BuildRequires: java-1.7.0-openjdk-devel
  28. %endif
  29. BuildRequires: texinfo tcl tk
  30. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  31. BuildRequires: readline-devel libtermcap-devel
  32. BuildRequires: zlib-devel bzip2-devel
  33. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  34. BuildRequires: cairo-devel pango-devel
  35. BuildRequires: libicu-devel
  36. Requires: libgfortran
  37. Requires: libicu
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: Toshiaki Ara <ara_t@384.jp>
  41. %description
  42. 'GNU S' - A language and environment for statistical computing and
  43. graphics. R is similar to the award-winning S system, which was
  44. developed at Bell Laboratories by John Chambers et al. It provides
  45. a wide variety of statistical and graphical techniques (linear and
  46. nonlinear modelling, statistical tests, time series analysis,
  47. classification, clustering, ...).
  48. R is designed as a true computer language with control-flow
  49. constructions for iteration and alternation, and it allows users to
  50. add additional functionality by defining new functions.
  51. For computationally intensive tasks, C, C++ and Fortran code
  52. can be linked and called at run time.
  53. %description -l ja
  54. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  55. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  56. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  57. 幅広い統計解析・視覚化手法を提供する。
  58. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  59. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  60. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  61. 使用することができる。
  62. %package devel
  63. Summary: files for development of R packages.
  64. Summary(ja): Rパッケージ開発用ファイル
  65. Group: Development/Libraries
  66. Requires: R = %{version}-%{release}
  67. %description devel
  68. Install R-devel if you are going to develop or compile R packages.
  69. This is just a stub package containing the documentation on
  70. "Writing R Extensions". However, installing it will ensure that
  71. the build environment for R packages is correct.
  72. %description -l ja devel
  73. Rパッケージを開発したりコンパイルする場合には、このR-develを
  74. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  75. が含まれているだけのサブパッケージですが、正しくRパッケージを
  76. 開発するための助けになるでしょう。
  77. %package -n libRmath
  78. Summary: standalone math library from the R project
  79. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  80. Group: System Environment/Libraries
  81. %description -n libRmath
  82. A standalone library of mathematical and statistical functions derived
  83. from the R project. This packages provides the shared libRmath library.
  84. %description -l ja -n libRmath
  85. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  86. 共有ライブラリを提供する。
  87. %package -n libRmath-devel
  88. Summary: standalone math library from the R project
  89. Summary(ja): libRmathの開発ライブラリ
  90. Group: Development/Libraries
  91. Requires: libRmath = %{version}-%{release}
  92. %description -n libRmath-devel
  93. A standalone library of mathematical and statistical functions derived
  94. from the R project. This packages provides the header files.
  95. %description -l ja -n libRmath-devel
  96. libRmathのヘッダファイル(Rmath.h)
  97. %package -n libRmath-static
  98. Summary: Static R Standalone math library
  99. Summary(ja): libRmath の静的ライブラリ
  100. Group: Development/Libraries
  101. Requires: libRmath-devel = %{version}-%{release}
  102. %description -n libRmath-static
  103. A standalone library of mathematical and statistical functions derived
  104. from the R project. This package provides the static libRmath library.
  105. %prep
  106. %{__rm} -rf ${RPM_BUILD_ROOT}
  107. %setup -q
  108. # %patch0 -p1
  109. %build
  110. export R_PDFVIEWER="%{_bindir}/xdg-open"
  111. export R_PRINTCMD="lpr"
  112. export R_BROWSER="%{_bindir}/xdg-open"
  113. %configure --enable-R-shlib
  114. %{__make} %{?_smp_mflags}
  115. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  116. LANG=C make check-all
  117. %{__make} pdf
  118. #We can only "make info" if we have an up to date version of texinfo
  119. %{?INFO: %{__make} info}
  120. %install
  121. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  122. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  123. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  124. #Install libRmath files
  125. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  126. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  127. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  128. #Fix lication of R_HOME_DIR in shell wrapper
  129. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  130. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  131. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  132. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  133. > ${RPM_BUILD_ROOT}%{_bindir}/R
  134. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  135. # add R into menu
  136. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  137. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons
  138. cp -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
  139. cp -a doc/html/logosm.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  140. %clean
  141. %{__rm} -rf ${RPM_BUILD_ROOT}
  142. %post
  143. %if 0%{?INFO}
  144. # Create directory entries for info files
  145. # (optional doc files, so we must check that they are installed)
  146. for doc in admin data exts FAQ intro lang; do
  147. file=%{_infodir}/R-${doc}.info.gz
  148. if [ -e $file ]; then
  149. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  150. fi
  151. done
  152. %endif
  153. %{_syssbindir}/ldconfig
  154. %preun
  155. %if 0%{?INFO}
  156. if [ $1 = 0 ]; then
  157. # Delete directory entries for info files (if they were installed)
  158. for doc in admin data exts FAQ intro lang; do
  159. file=%{_infodir}/R-${doc}.info.gz
  160. if [ -e ${file} ]; then
  161. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  162. fi
  163. done
  164. fi
  165. %endif
  166. %postun -p %{_syssbindir}/ldconfig
  167. %post -n libRmath -p %{_syssbindir}/ldconfig
  168. %postun -n libRmath -p %{_syssbindir}/ldconfig
  169. %files
  170. %defattr(-, root, root)
  171. %{_bindir}/R
  172. %{_bindir}/Rscript
  173. %{_libdir}/R
  174. %{_datadir}/applications/*
  175. %{_datadir}/icons/*
  176. %{?INFO:%{_infodir}/R-*.info*}
  177. %{_mandir}/man1/*
  178. /etc/ld.so.conf.d/*
  179. %files devel
  180. %defattr(-, root, root)
  181. %doc doc/manual/R-exts.pdf
  182. %files -n libRmath
  183. %defattr(-, root, root)
  184. %{_libdir}/libRmath.so
  185. %files -n libRmath-devel
  186. %defattr(-, root, root)
  187. %{_libdir}/pkgconfig/*.pc
  188. %{_includedir}/Rmath.h
  189. %files -n libRmath-static
  190. %defattr(-, root, root)
  191. %{_libdir}/libRmath.a
  192. %changelog
  193. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  194. - rebuild with icu-54.1
  195. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  196. - Updated to 3.1.2
  197. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  198. - Updated to 3.1.1
  199. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  200. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  201. - add patch (2014-04-26)
  202. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  203. - Updated to 3.1.0
  204. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  205. - Updated to 3.0.3
  206. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  207. - rebuild current VineSeed
  208. - add patch (2014-01-06)
  209. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  210. - add Requires: libicu
  211. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  212. - combine spec files Vine6 and VineSeed
  213. - correct the days of the week in changelog
  214. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  215. - delete BuildRequires: texlive-collection-texinfo
  216. - add BuildRequires: texlive-collection-plainextra
  217. - add BuildRequires: texlive-collection-latexextra
  218. - add BuildRequires: texlive-collection-fontsrecommended
  219. - for VineSeed
  220. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  221. - Updated to 3.0.2
  222. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  223. - Updated to 3.0.1
  224. - add BuildRequires: java-1.6.0-openjdk-devel
  225. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  226. - Updated to 3.0.0
  227. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  228. - Updated to 2.15.3
  229. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  230. - use BuildRequires ncurses-devel instead of libtermcap-devel
  231. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  232. - Updated to 2.15.2
  233. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  234. - changed group to Applications/Edutainment
  235. - added R to menu
  236. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  237. - Updated to 2.15.1
  238. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  239. - Updated to 2.15.0
  240. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  241. - Updated to 2.14.2
  242. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  243. - Updated to 2.14.1
  244. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  245. - Updated to 2.14.0
  246. - add BuildRequires: texlive-collection-fontsextra
  247. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  248. - Updated to 2.13.2
  249. - add BuildRequires: texlive-common
  250. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  251. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  252. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  253. - synchronized to VinePlus/5 package
  254. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  255. - Updated to 2.13.1
  256. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  257. - Updated to 2.13.0
  258. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  259. - Updated to 2.12.2
  260. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  261. - add BuildRequires: libicu-devel
  262. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  263. - synchronized to VinePlus/5 package
  264. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  265. - Updated to 2.12.1
  266. - added --enable-R-shlib option to %%configure
  267. - added static subpackage
  268. - use BR: texlive instead of tetex on VineSeed
  269. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  270. - rebuilt with rpm-4.8.1 for pkg-config
  271. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  272. - recompiled because tcl/tk were not linked
  273. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  274. - Updated to 2.11.0
  275. - added Requires: libgfortran
  276. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  277. - Updated to 2.10.1
  278. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  279. - patched to 2.10.0
  280. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  281. - spec in UTF-8
  282. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  283. - Updated to 2.10.0
  284. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  285. - Updated to 2.9.2
  286. - deleted BuildRequires: lapack-devel blas-devel
  287. - rewrote SPEC file
  288. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  289. - Updated to 2.5.1
  290. - added BuildRequires: gcc-gfortran for VineSeed
  291. - added BuildRequires: lapack-devel blas-devel
  292. v- fixed %preun script
  293. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  294. - Updated to 2.4.1
  295. - Added INFO option
  296. - Exclude Japanese Rprofile.site
  297. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  298. - Updated to 2.4.0
  299. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  300. - Added optimization flags
  301. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  302. - Packaged for VineLinux3.2
  303. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  304. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  305. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  306. - Packaged for VineLinux3.2
  307. - Slipped texinfo
  308. - Fixed preun error
  309. - Preset Japanese fonts
  310. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  311. - Packaged for VineLinux3.2
  312. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  313. - Restored CAPABILITIES file lost in 2.2.1beta
  314. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  315. - Configure uses --without-blas by default.
  316. - Install pdf manuals.
  317. - All toplevel documentation files are installed into _libdir/R
  318. as they may be required by R (qv note on AUTHORS and THANKS below).
  319. - Legacy scripts for rebuilding package indices removed.
  320. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  321. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  322. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  323. - The files AUTHORS and THANKS need to be installed into _libdir/R
  324. as they are required by the function contributors(). Previously
  325. they were installed only as documentation files.
  326. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  327. - Corrected date error in SPEC file.
  328. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  329. - Dropped support for Red Hat boxed set.
  330. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  331. including support for shared R library.
  332. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  333. with the default optimization flags, so there is a temporary work-around.
  334. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  335. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  336. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  337. - Install R-data.info file as well.
  338. - Make info processing conditional on texinfo version, not platform release,
  339. so that if a new enough version is installed, we will build and install info.
  340. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  341. - Built R 2.1.0. R now supports internationalization, so the patch
  342. to set the locale to "C" is now dropped.
  343. - install.packages() exits gracefully with a helpful message if
  344. the file INSTALL is not present, so this is now included in the
  345. R-devel package.
  346. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  347. - Added support for Scientific Linux (http://www.scientificlinux.org)
  348. A distribution based on RHEL. Thanks to Jon Peatfield.
  349. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  350. - Fixed file ownership in R-devel and libRmath packages
  351. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  352. - R-devel package is now a stub package with no files, except a documentation
  353. file (RPM won't accept sub-packages with no files). R now conflicts
  354. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  355. - Created libRmath subpackage with shared library.
  356. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  357. - Created R-devel and libRmath-devel subpackages
  358. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  359. - Built R 2.0.1
  360. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  361. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  362. gives "lpr".
  363. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  364. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  365. - Info support is now conditional on the macro Rinfo, which is only
  366. defined for Fedora 1 and 2.
  367. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  368. - Built R 2.0.0
  369. - There is no longer a BUGS file, so this is not installed as a
  370. documentation file.