ntfs-3g-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2022.5.17
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: https://www.tuxera.com/community/open-source-ntfs-3g/
  12. Source0: https://tuxera.com/opensource/ntfs-3g_ntfsprogs-%{version}.tgz
  13. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: libtool
  16. BuildRequires: libattr-devel
  17. BuildRequires: libconfig-devel
  18. BuildRequires: libgcrypt-devel
  19. BuildRequires: gnutls-devel
  20. BuildRequires: libuuid-devel
  21. %if %{with externalfuse}
  22. BuildRequires: fuse-devel
  23. Requires: fuse
  24. %endif
  25. %description
  26. NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
  27. driver for Linux and many other operating systems. It provides safe
  28. handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
  29. Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
  30. create, remove, rename, move files, directories, hard links, and streams;
  31. it can read and write normal and transparently compressed files, including
  32. streams and sparse files; it can handle special files like symbolic links,
  33. devices, and FIFOs, ACL, extended attributes; moreover it provides full
  34. file access right and ownership support.
  35. %package devel
  36. Summary: Development files and libraries for ntfs-3g
  37. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. Provides: ntfsprogs-devel = %{version}-%{release}
  42. Obsoletes: ntfsprogs-devel < 2.0.0-3
  43. %description devel
  44. Headers and libraries for developing applications that use ntfs-3g
  45. functionality.
  46. %package -n ntfsprogs
  47. Summary: NTFS filesystem libraries and utilities
  48. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  49. Group: system
  50. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  51. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  52. %description -n ntfsprogs
  53. The ntfsprogs package currently consists of a library and utilities
  54. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  55. (for a full list of included utilities see man 8 ntfsprogs after
  56. installation).
  57. %debug_package
  58. %prep
  59. %setup -q -n %{name}_ntfsprogs-%{version}
  60. %patch0 -p1 -b .unsupported
  61. %build
  62. export CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
  63. %configure \
  64. --disable-static \
  65. --disable-ldconfig \
  66. %if %{with externalfuse}
  67. --with-fuse=external \
  68. %endif
  69. --exec-prefix=/ \
  70. --bindir=/bin \
  71. --sbindir=/sbin \
  72. --libdir=/%{_lib} \
  73. --enable-posix-acls \
  74. --enable-xattr-mappings \
  75. --enable-crypto \
  76. --enable-extras \
  77. --enable-quarantined
  78. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  83. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
  84. mkdir -p $RPM_BUILD_ROOT/sbin
  85. # make the symlink an actual copy to avoid confusion
  86. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  87. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  88. # make compatibility symlinks
  89. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  90. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  91. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  92. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  93. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  94. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  95. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  96. # Put the .pc file in the right place.
  97. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  98. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  99. # We get this on our own, thanks.
  100. rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %files
  104. %defattr(-,root,root,-)
  105. %license COPYING
  106. %doc AUTHORS ChangeLog CREDITS NEWS README
  107. /sbin/mount.ntfs
  108. %attr(4754,root,root) /sbin/mount.ntfs-3g
  109. /sbin/mount.ntfs-fuse
  110. /sbin/mount.lowntfs-3g
  111. /bin/lowntfs-3g
  112. /bin/ntfs-3g
  113. /bin/ntfs-3g.probe
  114. /bin/ntfsmount
  115. %{_bindir}/ntfs-3g
  116. %{_bindir}/ntfsmount
  117. /%{_lib}/libntfs-3g.so.*
  118. %{_mandir}/man8/mount.lowntfs-3g.*
  119. %{_mandir}/man8/mount.ntfs-3g.*
  120. %{_mandir}/man8/ntfs-3g*
  121. %files devel
  122. %defattr(-,root,root,-)
  123. %{_includedir}/ntfs-3g/
  124. /%{_lib}/libntfs-3g.so
  125. %{_libdir}/pkgconfig/*.pc
  126. %files -n ntfsprogs
  127. %license COPYING
  128. %doc AUTHORS CREDITS ChangeLog NEWS README
  129. /bin/ntfscat
  130. /bin/ntfscluster
  131. /bin/ntfscmp
  132. /bin/ntfsfix
  133. /bin/ntfsinfo
  134. /bin/ntfsls
  135. /bin/ntfssecaudit
  136. /bin/ntfsusermap
  137. # extras
  138. /bin/ntfsck
  139. /bin/ntfsdecrypt
  140. /bin/ntfsdump_logfile
  141. /bin/ntfsfallocate
  142. /bin/ntfsmftalloc
  143. /bin/ntfsmove
  144. /bin/ntfsrecover
  145. /bin/ntfstruncate
  146. /bin/ntfswipe
  147. /sbin/fsck.ntfs
  148. /sbin/mkfs.ntfs
  149. /sbin/mkntfs
  150. /sbin/ntfsclone
  151. /sbin/ntfscp
  152. /sbin/ntfslabel
  153. /sbin/ntfsresize
  154. /sbin/ntfsundelete
  155. %{_mandir}/man8/mkntfs.8*
  156. %{_mandir}/man8/mkfs.ntfs.8*
  157. %{_mandir}/man8/ntfs[^m][^o]*.8*
  158. %exclude %{_mandir}/man8/ntfs-3g*
  159. %changelog
  160. * Thu Sep 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2021.8.22-1
  161. - new upstream release.
  162. - dropped Patch1-4.
  163. * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2017.3.23-1
  164. - new upstream release.
  165. - imported Patch1-4 from rawhide.
  166. * Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016.2.22-1
  167. - new upstream release.
  168. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
  169. - rebuilt with gnutls-3.4.x.
  170. * Fri May 8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
  171. - reverted file location <Vine Linux:2914>
  172. * Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
  173. - new upstream release
  174. - dropt hal files, since hal is very old
  175. * Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
  176. - new upstream release
  177. * Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
  178. - rebuilt with gnutls-3.2 and libgcrypt-1.6
  179. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
  180. - new upstream release
  181. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  182. - new upstream release
  183. - merge ntfsprogs
  184. - add Obsoletes and Provides ntfsprogs*
  185. - add BR: for ntfsprogs
  186. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  187. - new upstream release
  188. - fix %%files (add lowntfs-3g)
  189. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  190. - new upstream release
  191. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  192. - move binaries to /bin
  193. - move libraries to /%%{_lib}
  194. - add fdi file to enable hal automounting
  195. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  196. - new upstream release
  197. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  198. - new upstream release
  199. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  200. - new upstream release
  201. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  202. - new upstream release
  203. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  204. - initial build for Vine Linux
  205. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  206. - bump to 1.516
  207. - fix bugzilla 232031
  208. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  209. - bump to 1.417
  210. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  211. - bump to 1.416
  212. - drop patch0, upstreamed
  213. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  214. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  215. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  216. - bump to 1.328
  217. - drop patch, use --disable-ldconfig instead
  218. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  219. - 1.0 release!
  220. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  221. - symlink to mount.ntfs
  222. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  223. - bump to 20070118
  224. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  225. - bump to latest version for all active dists
  226. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  227. - bump to latest version (note that upstream fixed their date mistake)
  228. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  229. - add an obsoletes for ntfsprogs-fuse
  230. - make some convenience symlinks
  231. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  232. - add some extra Provides
  233. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  234. - add explicit Requires on fuse
  235. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  236. - fixed versioning (bumped epoch, since it now shows as older)
  237. - change sbin symlink to actual copy to be safe
  238. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  239. - Initial package for Fedora Extras