tzdata-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410
  1. Summary: Timezone data
  2. Summary(ja): タイムゾーンのデータ
  3. Name: tzdata
  4. Version: 2018i
  5. %define tzdata_version 2018i
  6. %define tzcode_version 2018i
  7. Release: 1%{?_dist_release}
  8. License: Public Domain
  9. Group: System Environment/Base
  10. URL: https://www.iana.org/time-zones
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. # These are official upstream.
  14. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  15. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  16. Source2: javazic.tar.gz
  17. Source3: javazic-1.8-37392f2f5d59.tar.xz
  18. Patch002: 0002-Fix-have-snprintf-error.patch
  19. Patch100: javazic-fixup.patch
  20. Patch101: rebase-01.patch
  21. Patch102: rebase-02.patch
  22. Patch103: 7090844.patch
  23. Patch104: 7133138.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. BuildRequires: gawk, glibc, perl
  27. BuildRequires: java-1.8.0-openjdk-devel
  28. BuildRequires: glibc-common >= 2.5.90-7
  29. Conflicts: glibc-common <= 2.3.2-63
  30. %description
  31. This package contains data files with rules for various timezones around
  32. the world.
  33. %description -l ja
  34. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  35. %package java
  36. Summary: Timezone data for Java
  37. Group: System Environment/Base
  38. %description java
  39. This package contains timezone information for use by Java runtimes.
  40. %prep
  41. %setup -q -c -a 1
  42. %patch002 -p1
  43. # tzdata-2018g introduce 25:00 transition times. This breaks OpenJDK.
  44. # Use rearguard for tzdata-2018g java
  45. mkdir rearguard
  46. make VERSION=%{version} tzdata%{version}-rearguard.tar.gz
  47. mv tzdata%{version}-rearguard.tar.gz rearguard
  48. pushd rearguard
  49. tar zxf tzdata%{version}-rearguard.tar.gz
  50. popd
  51. mkdir javazic
  52. tar zxf %{SOURCE2} -C javazic
  53. pushd javazic
  54. %patch100
  55. %patch101
  56. %patch102
  57. %patch103
  58. %patch104
  59. # Hack alert! sun.tools may be defined and installed in the
  60. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  61. # for creating the zoneinfo files, rebase all the packages
  62. # from "sun." to "rht.". Unfortunately, gcj does not support
  63. # any of the -Xclasspath options, so we must go this route
  64. # to ensure the greatest compatibility.
  65. mv sun rht
  66. find . -type f -name '*.java' -print0 \
  67. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  68. -e 's:sun\.util\.:rht.util.:g'
  69. popd
  70. tar xf %{SOURCE3}
  71. echo "%{name}%{tzdata_version}" >> VERSION
  72. %build
  73. # Run make to create the tzdata.zi file
  74. make tzdata.zi
  75. FILES="africa antarctica asia australasia europe northamerica southamerica
  76. pacificnew etcetera backward"
  77. mkdir zoneinfo/{,posix,right}
  78. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  79. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  80. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  81. # tzdata-2018g uses 25:00 which breaks java - use the rearguard files for java
  82. JAVA_FILES="rearguard/africa rearguard/antarctica rearguard/asia \
  83. rearguard/australasia rearguard/europe rearguard/northamerica \
  84. rearguard/southamerica rearguard/pacificnew rearguard/etcetera \
  85. rearguard/backward"
  86. # Java 6/7 tzdata
  87. pushd javazic
  88. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  89. popd
  90. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  91. -d javazi \
  92. $JAVA_FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  93. # Java 8 tzdata
  94. pushd javazic-1.8
  95. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  96. popd
  97. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  98. -srcdir . -dstfile tzdb.dat \
  99. -verbose \
  100. $JAVA_FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  101. %install
  102. rm -fr $RPM_BUILD_ROOT
  103. install -d $RPM_BUILD_ROOT%{_datadir}
  104. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  105. install -p -m 644 zone.tab zone1970.tab iso3166.tab leapseconds tzdata.zi $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  106. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  107. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  108. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  109. %clean
  110. rm -fr $RPM_BUILD_ROOT
  111. %files
  112. %defattr(-,root,root)
  113. %{_datadir}/zoneinfo
  114. %license LICENSE
  115. %doc README
  116. %doc theory.html
  117. %doc tz-link.html
  118. %doc tz-art.html
  119. %files java
  120. %defattr(-,root,root)
  121. %{_datadir}/javazi
  122. %{_datadir}/javazi-1.8
  123. %changelog
  124. * Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2018i-1
  125. - updated to 2018i.
  126. * Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
  127. - update to 2017b
  128. * Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
  129. - updated to 2016j.
  130. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
  131. - fixed changelog.
  132. - added Vendor and Distribution tag.
  133. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
  134. - updated to 2016f.
  135. * Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
  136. - updated to 2016e.
  137. - enabled java18 stuff.
  138. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  139. - updated to 2016d.
  140. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  141. - updated to 2015f.
  142. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  143. - updated to 2015e.
  144. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  145. - update to tzdata-2012c, tzcode-2012b
  146. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  147. - rebuilt with rpm-4.8.1-3
  148. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  149. - update to tzdata-2010l, tzcode-2010l
  150. - added java subpackage
  151. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  152. - update to tzdata-2009d, tzcode-2009d
  153. - spec in utf-8
  154. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  155. - update to tzdata-2008b, tzcode-2008a
  156. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  157. - initial build for VineSeed
  158. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  159. - Upstream 2007d
  160. - Mongolia has abolished DST.
  161. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  162. than 01:00 standard time.
  163. - Cuba observed DST starting Sunday.
  164. - Resolute, Nunavut switched from Central to Eastern time last
  165. November.
  166. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  167. - Upstream 2007c
  168. - Pulaski County, Indiana, switched back to eastern time.
  169. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  170. - Upstream 2007b
  171. - Changes to the commentary in "leapseconds".
  172. - Upstream 2007a
  173. - Updates to Bahamas, they will be in sync with 2007 US DST change
  174. - New zone Australia/Eucla
  175. - Africa/Asmera renamed to Africa/Asmara, link created
  176. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  177. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  178. - Upstream 2006p
  179. - Covers changes from 2006m-2 and 2006m-3
  180. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  181. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  182. - Patch for Western Australia DST trial
  183. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  184. - Proposed upstream patch (#210058)
  185. - Jordan will switch to winter time on October 27, not September 29
  186. - Brazil's DST this year is the first Sunday in November to the last
  187. Sunday in February. (Thanks to Frederico A. C. Neves.)
  188. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  189. - Commentary and past timestamps changes
  190. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  191. - Upstream 2006m:
  192. - Adjustments for Egypt, Palestine, Uruguay
  193. - Better description of `until' field in zic (8) manpage
  194. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  195. - Upstream 2006k, 2006l:
  196. - Adjustments for Egypt, Palestine, Cuba, Honduras
  197. - Documentation changes
  198. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  199. - Upstream 2006j
  200. - Honduras stopped observing DST on Monday at 00:00
  201. - America/Bermuda will follow the US's lead next year
  202. - America/Moncton will use US-style rules next year
  203. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  204. year
  205. - New zone: America/Atikokan instead of America/Coral_Harbour
  206. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  207. - Historical changes
  208. - Commentary updates
  209. - Upstream 2006i
  210. - localtime.c fixes
  211. - Upstream 2006h
  212. - zic leapsecond fix
  213. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  214. - rebuild
  215. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  216. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  217. - Nicaragua updates
  218. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  219. - Upstream 2006f
  220. - America/Guatemala observes DST between Apr/30 and Oct/1
  221. - Historical changes for Nicaragua
  222. - Update of America/Indiana/Vincennes in zone table
  223. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  224. - Upstream 2006d
  225. - Haiti observes DST
  226. - Sri Lanka change actually took effect Apr/15
  227. - All Canada is now scheduled for 2007 US DST rules
  228. - Some historical fixes
  229. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  230. - Upstream 2006c
  231. - Time-related changes:
  232. - dozens of historical and commentary changes
  233. - Iran stopped observing DST
  234. - Sri Lanka switches from UTC+6 to UTC+5:30
  235. - America/Thule and America/Edmonton will adopt new US rules,
  236. starting 2007
  237. - Tunisia is adopting regular DST
  238. - Code:
  239. - asctime.c: Chages in format strings to silent gcc warnings
  240. - removing K&R notation from function signatures
  241. - few fixes across the code
  242. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  243. - Patch for Sri Lanka time zone change (#184514)
  244. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  245. - Upstream 2006b:
  246. - using tz64code version, as 32 is legacy according to tzdata ML
  247. - new manual pages for ctime, strftime, tzset
  248. - some source code reorganizations
  249. - no timezone/dst rule updates
  250. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  251. - Small changes in tst-timezone.c
  252. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  253. - Upstream 2006a:
  254. - private.h(scheck): changing char* to char const*
  255. - Rule changes for Palestine, zone changes for Indiana/US, both
  256. changes for Canada.
  257. - Many related doc changes.
  258. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  259. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  260. - 2005r-3
  261. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  262. so that it won't clash across updates.
  263. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  264. - 2005r
  265. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  266. northamerica to guard against old files with obsolete information
  267. being left in the time zone binary directory.
  268. - Changes for countries that are supposed to join 2007 US DST
  269. change. This includes most of Canada, however entries already in
  270. the database (Alberta, British Columbia, Newfoundland, Northwest
  271. Territories, and Yukon) were left alone for the time being.
  272. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  273. is checked for emptiness.
  274. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  275. - 2005q
  276. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  277. - SystemV timezone changes
  278. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  279. - 2005n
  280. - changes for Kyrgyzstan and Uruguay
  281. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  282. make check), update tst-timezone.c from glibc CVS (#172102)
  283. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  284. - 2005m
  285. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  286. Australia, Kazakhstan
  287. - historical timezone data changes for Japan, Poland, Northern Ireland and
  288. Mali
  289. - timezone name change for East Timor
  290. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  291. - 2005k
  292. - leap seconds update
  293. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  294. - 2005i
  295. - updates for Iran, Haiti and Nicaragua
  296. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  297. - 2005h
  298. - fixes for Kazakhstan
  299. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  300. - 2005g
  301. - fixes for Uruguay
  302. - include README and Theory from tzcode tarball in %{_docdir};
  303. Theory includes a good summary of how the timezone data files
  304. are supposed to be named
  305. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  306. - 2005f
  307. - more updates for Israel, updates for Azerbaijan
  308. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  309. - 2005c
  310. - updates for Israel and Paraguay
  311. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  312. - 2004g (#141107)
  313. - updates for Cuba
  314. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  315. - 2004e (#135194)
  316. - updates for Brazil, Uruguay and Argentina
  317. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  318. - 2004b
  319. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  320. - 2003d
  321. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  322. - 2003c
  323. - updates for Brazil (#104840)
  324. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  325. - rebuilt
  326. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  327. - initial package