rust-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781
  1. %bcond_with bootstrap
  2. %bcond_with test
  3. # Some sub-packages are versioned independently of the rust compiler and runtime itself.
  4. # Also beware that if any of these are not changed in a version bump, then the release
  5. # number should still increase, not be reset to 1!
  6. %global rustc_version 1.30.1
  7. %global cargo_version 1.30.0
  8. %global rustfmt_version 0.99.4
  9. %global rls_version 0.130.5
  10. %global clippy_version 0.0.212
  11. %define _unpackaged_files_terminate_build 1
  12. # Only x86_64 and i686 are Tier 1 platforms at this time.
  13. # https://forge.rust-lang.org/platform-support.html
  14. %global rust_arches x86_64 i686
  15. # The channel can be stable, beta, or nightly
  16. %{!?channel: %global channel stable}
  17. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  18. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  19. # or nightly wants some beta-YYYY-MM-DD
  20. %global bootstrap_rust 1.30.1
  21. %global bootstrap_cargo 1.30.0
  22. %global bootstrap_channel %{bootstrap_rust}
  23. # Only the specified arches will use bootstrap binaries.
  24. %if %{with bootstrap}
  25. %global bootstrap_arches %%{rust_arches}
  26. %endif
  27. # We generally don't want llvm-static present at all, since llvm-config will
  28. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  29. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  30. # *want* static we'll have to force it with "llvm-config --link-static".
  31. # See also https://github.com/rust-lang/rust/issues/36854
  32. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  33. %bcond_with llvm_static
  34. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  35. # is insufficient. Rust currently requires LLVM 3.7+.
  36. %bcond_with bundled_llvm
  37. # LLDB only works on some architectures
  38. %ifarch %{arm} aarch64 %{ix86} x86_64
  39. # LLDB isn't available everywhere...
  40. %bcond_without lldb
  41. %else
  42. %bcond_with lldb
  43. %endif
  44. Name: rust
  45. Version: 1.30.1
  46. Release: 1%{?_dist_release}
  47. Summary: The Rust Programming Language
  48. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  49. # ^ written as: (rust itself) and (bundled libraries)
  50. URL: https://www.rust-lang.org
  51. ExclusiveArch: %{rust_arches}
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. %if "%{channel}" == "stable"
  55. %global rustc_package rustc-%{version}-src
  56. %else
  57. %global rustc_package rustc-%{channel}-src
  58. %endif
  59. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  60. # Get the Rust triple for any arch.
  61. %{lua: function rust_triple(arch)
  62. local abi = "gnu"
  63. if arch == "armv7hl" then
  64. arch = "armv7"
  65. abi = "gnueabihf"
  66. elseif arch == "ppc64" then
  67. arch = "powerpc64"
  68. elseif arch == "ppc64le" then
  69. arch = "powerpc64le"
  70. end
  71. return arch.."-unknown-linux-"..abi
  72. end}
  73. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  74. %if %defined bootstrap_arches
  75. # For each bootstrap arch, add an additional binary Source.
  76. # Also define bootstrap_source just for the current target.
  77. %{lua: do
  78. local bootstrap_arches = {}
  79. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  80. table.insert(bootstrap_arches, arch)
  81. end
  82. local base = rpm.expand("https://static.rust-lang.org/dist"
  83. .."/rust-%{bootstrap_channel}")
  84. local target_arch = rpm.expand("%{_target_cpu}")
  85. for i, arch in ipairs(bootstrap_arches) do
  86. print(string.format("Source%d: %s-%s.tar.gz\n",
  87. i, base, rust_triple(arch)))
  88. if arch == target_arch then
  89. rpm.define("bootstrap_source "..i)
  90. end
  91. end
  92. end}
  93. %endif
  94. %ifarch %{bootstrap_arches}
  95. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  96. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  97. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  98. %else
  99. BuildRequires: cargo >= %{bootstrap_cargo}
  100. BuildRequires: %{name} >= %{bootstrap_rust}
  101. BuildConflicts: %{name} > %{version}
  102. %global local_rust_root %{_prefix}
  103. %endif
  104. BuildRequires: cmake
  105. BuildRequires: make
  106. BuildRequires: gcc
  107. BuildRequires: gcc-c++
  108. BuildRequires: libgit2-devel
  109. BuildRequires: libssh2-devel
  110. BuildRequires: ncurses-devel
  111. BuildRequires: openssl-devel
  112. BuildRequires: zlib-devel
  113. BuildRequires: python
  114. BuildRequires: curl
  115. %if %{with bundled_llvm}
  116. BuildRequires: cmake
  117. Provides: bundled(llvm) = 4.0
  118. %else
  119. %if %defined llvm
  120. %global llvm_root %{_libdir}/%{llvm}
  121. %else
  122. %global llvm llvm
  123. %global llvm_root %{_prefix}
  124. %endif
  125. BuildRequires: %{llvm}-devel >= 7.0.0
  126. %if %{with llvm_static}
  127. BuildRequires: %{llvm}-static
  128. BuildRequires: libffi-devel
  129. %else
  130. # Make sure llvm-config doesn't see it.
  131. BuildConflicts: %{llvm}-static
  132. %endif
  133. %endif
  134. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  135. BuildRequires: procps
  136. # debuginfo-gdb tests need gdb
  137. BuildRequires: gdb
  138. # TODO: work on unbundling these!
  139. Provides: bundled(jquery) = 2.1.4
  140. Provides: bundled(libbacktrace) = 6.1.0
  141. Provides: bundled(miniz) = 1.14
  142. # Virtual provides for folks who attempt "dnf install rustc"
  143. Provides: rustc = %{version}-%{release}
  144. Provides: rustc%{?_isa} = %{version}-%{release}
  145. # Always require our exact standard library
  146. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  147. # The C compiler is needed at runtime just for linking. Someday rustc might
  148. # invoke the linker directly, and then we'll only need binutils.
  149. # https://github.com/rust-lang/rust/issues/11937
  150. Requires: /usr/bin/cc
  151. # ALL Rust libraries are private, because they don't keep an ABI.
  152. %global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
  153. %global __provides_exclude ^(%{_privatelibs})$
  154. %global __requires_exclude ^(%{_privatelibs})$
  155. %global __provides_exclude_from ^%{_docdir}/.*$
  156. %global __requires_exclude_from ^%{_docdir}/.*$
  157. # While we don't want to encourage dynamic linking to Rust shared libraries, as
  158. # there's no stable ABI, we still need the unallocated metadata (.rustc) to
  159. # support custom-derive plugins like #[proc_macro_derive(Foo)]. But eu-strip is
  160. # very eager by default, so we have to limit it to -g, only debugging symbols.
  161. %if 0%{?fedora} >= 27
  162. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  163. %global _find_debuginfo_opts --keep-section .rustc
  164. %else
  165. %global _find_debuginfo_opts -g
  166. %undefine _include_minidebuginfo
  167. %endif
  168. # Use hardening ldflags.
  169. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  170. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  171. # https://github.com/rust-lang/rust/issues/40717
  172. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  173. %endif
  174. %description
  175. Rust is a systems programming language that runs blazingly fast, prevents
  176. segfaults, and guarantees thread safety.
  177. This package includes the Rust compiler and documentation generator.
  178. %package std-static
  179. Summary: Standard library for Rust
  180. %description std-static
  181. This package includes the standard libraries for building applications
  182. written in Rust.
  183. %package debugger-common
  184. Summary: Common debugger pretty printers for Rust
  185. BuildArch: noarch
  186. %description debugger-common
  187. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  188. %package gdb
  189. Summary: GDB pretty printers for Rust
  190. BuildArch: noarch
  191. Requires: gdb
  192. Requires: %{name}-debugger-common = %{version}-%{release}
  193. %description gdb
  194. This package includes the rust-gdb script, which allows easier debugging of Rust
  195. programs.
  196. %if %{with lldb}
  197. %package lldb
  198. Summary: LLDB pretty printers for Rust
  199. # It could be noarch, but lldb has limited availability
  200. #BuildArch: noarch
  201. Requires: lldb
  202. Requires: python-lldb
  203. Requires: %{name}-debugger-common = %{version}-%{release}
  204. %description lldb
  205. This package includes the rust-lldb script, which allows easier debugging of Rust
  206. programs.
  207. %endif
  208. %package doc
  209. Summary: Documentation for Rust
  210. # NOT BuildArch: noarch
  211. # Note, while docs are mostly noarch, some things do vary by target_arch.
  212. # Koji will fail the build in rpmdiff if two architectures build a noarch
  213. # subpackage differently, so instead we have to keep its arch.
  214. %description doc
  215. This package includes HTML documentation for the Rust programming language and
  216. its standard library.
  217. %package -n cargo
  218. Summary: Rust's package manager and build tool
  219. Version: %{cargo_version}
  220. # For tests:
  221. BuildRequires: git
  222. # Cargo is not much use without Rust
  223. Requires: rust
  224. %description -n cargo
  225. Cargo is a tool that allows Rust projects to declare their various dependencies
  226. and ensure that you'll always get a repeatable build.
  227. %package -n cargo-doc
  228. Summary: Documentation for Cargo
  229. Version: %{cargo_version}
  230. BuildArch: noarch
  231. # Cargo no longer builds its own documentation
  232. # https://github.com/rust-lang/cargo/pull/4904
  233. Requires: rust-doc = %{rustc_version}-%{release}
  234. %description -n cargo-doc
  235. This package includes HTML documentation for Cargo.
  236. %package -n rustfmt-preview
  237. Summary: Tool to find and fix Rust formatting issues
  238. Version: %{rustfmt_version}
  239. Requires: cargo
  240. # Despite the lower version, our rustfmt-preview is newer than rustfmt-0.9.
  241. # It's expected to stay "preview" until it's released as 1.0.
  242. Obsoletes: rustfmt <= 0.9.0
  243. Provides: rustfmt = %{rustfmt_version}
  244. %description -n rustfmt-preview
  245. A tool for formatting Rust code according to style guidelines.
  246. %package -n rls-preview
  247. Summary: Rust Language Server for IDE integration
  248. Version: %{rls_version}
  249. Provides: rls = %{rls_version}
  250. Requires: rust-analysis
  251. # /usr/bin/rls is dynamically linked against internal rustc libs
  252. Requires: %{name} = %{rustc_version}-%{release}
  253. %description -n rls-preview
  254. The Rust Language Server provides a server that runs in the background,
  255. providing IDEs, editors, and other tools with information about Rust programs.
  256. It supports functionality such as 'goto definition', symbol search,
  257. reformatting, and code completion, and enables renaming and refactorings.
  258. %package -n clippy-preview
  259. Summary: Lints to catch common mistakes and improve your Rust code
  260. Version: %{clippy_version}
  261. License: MPLv2.0
  262. Provides: clippy = %{clippy_version}
  263. Requires: cargo
  264. # /usr/bin/clippy-driver is dynamically linked against internal rustc libs
  265. Requires: %{name} = %{rustc_version}-%{release}
  266. %description -n clippy-preview
  267. A collection of lints to catch common mistakes and improve your Rust code.
  268. %package src
  269. Summary: Sources for the Rust standard library
  270. BuildArch: noarch
  271. %description src
  272. This package includes source files for the Rust standard library. It may be
  273. useful as a reference for code completion tools in various editors.
  274. %package analysis
  275. Summary: Compiler analysis data for the Rust standard library
  276. Requires: rust-std-static = %{rustc_version}-%{release}
  277. %description analysis
  278. This package contains analysis data files produced with rustc's -Zsave-analysis
  279. feature for the Rust standard library. The RLS (Rust Language Server) uses this
  280. data to provide information about the Rust standard library.
  281. %prep
  282. %ifarch %{bootstrap_arches}
  283. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  284. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  285. --prefix=%{local_rust_root} --disable-ldconfig
  286. test -f '%{local_rust_root}/bin/cargo'
  287. test -f '%{local_rust_root}/bin/rustc'
  288. %endif
  289. %setup -q -n %{rustc_package}
  290. # We're disabling jemalloc, but rust-src still wants it.
  291. # rm -rf src/jemalloc/
  292. %if %without bundled_llvm
  293. rm -rf src/llvm/
  294. %endif
  295. # We never enable emscripten.
  296. rm -rf src/llvm-emscripten/
  297. # We never enable other LLVM tools.
  298. rm -rf src/tools/clang
  299. rm -rf src/tools/lld
  300. rm -rf src/tools/lldb
  301. # extract bundled licenses for packaging
  302. sed -e '/*\//q' src/libbacktrace/backtrace.h \
  303. >src/libbacktrace/LICENSE-libbacktrace
  304. %if %{with bundled_llvm} && 0%{?epel}
  305. mkdir -p cmake-bin
  306. ln -s /usr/bin/cmake cmake-bin/cmake
  307. %global cmake_path $PWD/cmake-bin
  308. %endif
  309. %if %{without bundled_llvm} && %{with llvm_static}
  310. # Static linking to distro LLVM needs to add -lffi
  311. # https://github.com/rust-lang/rust/issues/34486
  312. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  313. src/librustc_llvm/lib.rs
  314. %endif
  315. # The configure macro will modify some autoconf-related files, which upsets
  316. # cargo when it tries to verify checksums in those files. If we just truncate
  317. # that file list, cargo won't have anything to complain about.
  318. find src/vendor -name .cargo-checksum.json \
  319. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  320. %build
  321. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  322. export LIBSSH2_SYS_USE_PKG_CONFIG=1
  323. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  324. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  325. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  326. # We're going to override --libdir when configuring to get rustlib into a
  327. # common path, but we'll fix the shared libraries during install.
  328. %global common_libdir %{_prefix}/lib
  329. %global rustlibdir %{common_libdir}/rustlib
  330. #%ifarch x86_64
  331. %define enable_debuginfo --enable-debuginfo --enable-debuginfo-only-std --disable-debuginfo-tools --disable-debuginfo-lines
  332. #%else
  333. #%define enable_debuginfo --disable-debuginfo --disable-debuginfo-only-std --disable-debuginfo-tools --disable-debuginfo-lines
  334. #%endif
  335. %configure \
  336. --disable-option-checking \
  337. --libdir=%{common_libdir} \
  338. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  339. --enable-local-rust --local-rust-root=%{local_rust_root} \
  340. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
  341. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  342. --disable-jemalloc \
  343. --disable-rpath \
  344. %{enable_debuginfo} \
  345. --enable-extended \
  346. --enable-vendor \
  347. --enable-verbose-tests \
  348. --release-channel=%{channel}
  349. RUST_BACKTRACE=1 ./x.py build
  350. ./x.py doc
  351. %install
  352. rm -rf %{buildroot}
  353. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  354. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  355. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  356. DESTDIR=%{buildroot} ./x.py install
  357. #DESTDIR=%{buildroot} ./x.py install src
  358. # Make sure the shared libraries are in the proper libdir
  359. %if "%{_libdir}" != "%{common_libdir}"
  360. mkdir -p %{buildroot}%{_libdir}
  361. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  362. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  363. %endif
  364. # The shared libraries should be executable for debuginfo extraction.
  365. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  366. -exec chmod -v +x '{}' '+'
  367. # The libdir libraries are identical to those under rustlib/. It's easier on
  368. # library loading if we keep them in libdir, but we do need them in rustlib/
  369. # to support dynamic linking for compiler plugins, so we'll symlink.
  370. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  371. find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
  372. while read lib; do
  373. # make sure they're actually identical!
  374. cmp "$lib" "${lib##*/}"
  375. ln -v -f -s -t . "$lib"
  376. done)
  377. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  378. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  379. # Remove backup files from %%configure munging
  380. find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
  381. # https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
  382. # We don't actually need to ship any of those python scripts in rust-src anyway.
  383. find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
  384. # FIXME: __os_install_post will strip the rlibs
  385. # -- should we find a way to preserve debuginfo?
  386. # Remove unwanted documentation files (we already package them)
  387. # Remove unwanted documentation files (we already package them)
  388. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  389. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  390. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
  391. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  392. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  393. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
  394. rm -f %{buildroot}%{_docdir}/%{name}/*.old
  395. # Sanitize the HTML documentation
  396. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  397. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  398. # Create the path for crate-devel packages
  399. mkdir -p %{buildroot}%{_datadir}/cargo/registry
  400. # Cargo no longer builds its own documentation
  401. # https://github.com/rust-lang/cargo/pull/4904
  402. mkdir -p %{buildroot}%{_docdir}/cargo
  403. ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
  404. %if %{without lldb}
  405. rm -f %{buildroot}%{_bindir}/rust-lldb
  406. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  407. %endif
  408. %check
  409. %if %{with test}
  410. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  411. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  412. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  413. # The results are not stable on koji, so mask errors and just log it.
  414. %{__python} ./x.py test --no-fail-fast || :
  415. %{__python} ./x.py test --no-fail-fast cargo || :
  416. %{__python} ./x.py test --no-fail-fast clippy || :
  417. %{__python} ./x.py test --no-fail-fast rls || :
  418. %{__python} ./x.py test --no-fail-fast rustfmt || :
  419. %endif
  420. %post -p /sbin/ldconfig
  421. %postun -p /sbin/ldconfig
  422. %files
  423. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  424. %license src/libbacktrace/LICENSE-libbacktrace
  425. %doc README.md
  426. %{_bindir}/rustc
  427. %{_bindir}/rustdoc
  428. %{_libdir}/*.so
  429. %{_mandir}/man1/rustc.1*
  430. %{_mandir}/man1/rustdoc.1*
  431. %dir %{rustlibdir}
  432. %dir %{rustlibdir}/%{rust_triple}
  433. %dir %{rustlibdir}/%{rust_triple}/lib
  434. %{rustlibdir}/%{rust_triple}/lib/*.so
  435. %{rustlibdir}/%{rust_triple}/codegen-backends/
  436. %files std-static
  437. %dir %{rustlibdir}
  438. %dir %{rustlibdir}/%{rust_triple}
  439. %dir %{rustlibdir}/%{rust_triple}/lib
  440. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  441. %files debugger-common
  442. %dir %{rustlibdir}
  443. %dir %{rustlibdir}/etc
  444. %{rustlibdir}/etc/debugger_*.py*
  445. %files gdb
  446. %{_bindir}/rust-gdb
  447. %{rustlibdir}/etc/gdb_*.py*
  448. %if %with lldb
  449. %files lldb
  450. %{_bindir}/rust-lldb
  451. %{rustlibdir}/etc/lldb_*.py*
  452. %endif
  453. %files doc
  454. %docdir %{_docdir}/%{name}
  455. %dir %{_docdir}/%{name}
  456. %dir %{_docdir}/%{name}/html
  457. %{_docdir}/%{name}/html/*/
  458. %{_docdir}/%{name}/html/*.html
  459. %{_docdir}/%{name}/html/*.css
  460. %{_docdir}/%{name}/html/*.js
  461. %{_docdir}/%{name}/html/*.svg
  462. %{_docdir}/%{name}/html/*.woff
  463. %license %{_docdir}/%{name}/html/*.txt
  464. %files -n cargo
  465. %license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
  466. %doc src/tools/cargo/README.md
  467. %{_bindir}/cargo
  468. %{_mandir}/man1/cargo*.1*
  469. %dir %{_sysconfdir}/bash_completion.d
  470. %{_sysconfdir}/bash_completion.d/cargo
  471. %dir %{_datadir}/zsh
  472. %dir %{_datadir}/zsh/site-functions
  473. %{_datadir}/zsh/site-functions/_cargo
  474. %dir %{_datadir}/cargo
  475. %dir %{_datadir}/cargo/registry
  476. %files -n cargo-doc
  477. %docdir %{_docdir}/cargo
  478. %dir %{_docdir}/cargo
  479. %{_docdir}/cargo/html
  480. %files -n rustfmt-preview
  481. %{_bindir}/rustfmt
  482. %{_bindir}/cargo-fmt
  483. %doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
  484. %license src/tools/rustfmt/LICENSE-{APACHE,MIT}
  485. %files -n rls-preview
  486. %{_bindir}/rls
  487. %doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
  488. %license src/tools/rls/LICENSE-{APACHE,MIT}
  489. %files -n clippy-preview
  490. %{_bindir}/cargo-clippy
  491. %{_bindir}/clippy-driver
  492. %doc src/tools/clippy/{README.md,CHANGELOG.md}
  493. %license src/tools/clippy/LICENSE
  494. %files src
  495. %dir %{rustlibdir}
  496. %{rustlibdir}/src
  497. %files analysis
  498. %{rustlibdir}/%{rust_triple}/analysis/
  499. %changelog
  500. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
  501. - new upstream release.
  502. - dropped Patch1.
  503. - added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
  504. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  505. - Update to 1.23.0 (stable).
  506. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  507. - initial build for Vine Linux.
  508. - Update to 1.23.0-beta.
  509. - built a bootstrap rpm.
  510. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  511. - Update to 1.22.1.
  512. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  513. - Update to 1.21.0.
  514. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  515. - ABI fixes for ppc64 and s390x.
  516. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  517. - Update to 1.20.0.
  518. - Add a rust-src subpackage.
  519. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  520. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  521. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  522. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  523. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  524. - Use find-debuginfo.sh --keep-section .rustc
  525. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  526. - Update to 1.19.0.
  527. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  528. - Update to 1.18.0.
  529. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  530. - Move shared libraries back to libdir and symlink in rustlib
  531. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  532. - Update to 1.17.0.
  533. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  534. - Make rust-lldb arch-specific to deal with lldb deps
  535. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  536. - Limit rust-lldb arches
  537. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  538. - Update to 1.16.0.
  539. - Use rustbuild instead of the old makefiles.
  540. - Update bootstrapping to include rust-std and cargo.
  541. - Add a rust-lldb subpackage.
  542. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  543. - Update to 1.15.1.
  544. - Require rust-rpm-macros for new crate packaging.
  545. - Keep shared libraries under rustlib/, only debug-stripped.
  546. - Merge and clean up conditionals for epel7.
  547. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  548. - Rebuild without bootstrap binaries.
  549. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  550. - Update to 1.14.0.
  551. - Rewrite bootstrap logic to target specific arches.
  552. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  553. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  554. - Update to 1.13.0.
  555. - Use hardening flags for linking.
  556. - Split the standard library into its own package
  557. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  558. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  559. - Update to 1.12.1.
  560. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  561. - Rebuild with LLVM 3.9.
  562. - Add ncurses-devel for llvm-config's -ltinfo.
  563. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  564. - Rebuild with llvm-static, preparing for 3.9
  565. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  566. - Rebuild with fixed eu-strip (rhbz1380961)
  567. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  568. - Rebuild without bootstrap binaries.
  569. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  570. - Bootstrap aarch64.
  571. - Use jemalloc's MALLOC_CONF to work around #36944.
  572. - Apply pr36933 to really disable armv7hl NEON.
  573. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  574. - Protect .rustc from rpm stripping.
  575. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  576. - Update to 1.12.0.
  577. - Always use --local-rust-root, even for bootstrap binaries.
  578. - Remove the rebuild conditional - the build system now figures it out.
  579. - Let minidebuginfo do its thing, since metadata is no longer a note.
  580. - Let rust build its own compiler-rt builtins again.
  581. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  582. - Rebuild without bootstrap binaries.
  583. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  584. - Bootstrap armv7hl, with backported no-neon patch.
  585. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  586. - Update to 1.11.0.
  587. - Drop the backported patches.
  588. - Patch get-stage0.py to trust existing bootstrap binaries.
  589. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  590. - Use --local-rust-root to make sure the right bootstrap is used.
  591. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  592. - Rebuild without bootstrap binaries.
  593. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  594. - Initial import into Fedora (#1356907), bootstrapped
  595. - Format license text as suggested in review.
  596. - Note how the tests already run in parallel.
  597. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  598. - Don't let checks fail the whole build.
  599. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  600. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  601. - Update -doc directory ownership, and mark its licenses.
  602. - Package and declare licenses for libbacktrace and hoedown.
  603. - Set bootstrap_base as a global.
  604. - Explicitly require python2.
  605. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  606. - Initial package, bootstrapped